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CChhaapptteerr  11  GGeenneerraall  
PPrroocceedduurreess  

This chapter offers an introduction to the MicroStation working environment you’ll find at 
the Maine Department of Transportation. If you are new to MicroStation, you’ll find some 
helpful references about tool locations and document management. If you have previously 
used MicroStation, you’ll also find some helpful hints, since we have customized our user 
interface to increase productivity. 

This manual is to be used in conjunction with the Bridge Plan Development Guide and the 
Highway Design Guide. Please refer to these other documents for standard plan package 
requirements. 



mdot MicroStation 
07/01/07 

General Procedures 

1-2 

 

HHOOWW  TTOO  UUSSEE  TTHHEE  MMAANNUUAALL  



mdot MicroStation 
07/01/07 

General Procedures 

1-3 

 

KEEPING YOUR MANUAL UP TO DATE 
Users Responsibility 
It is the MicroStation user’s responsibility to keep their manuals up-to-date. When an area of 
the manual has been modified, we will recommend replacing the whole chapter affected by 
the change. This may require replacing the Table of Contents also. The MaineDOT internet 
website will contain individual chapters available for downloading.  We will be adjusting 
the dates of the chapters as they are revised and add a note as to what specifically was 
changed within the chapter(s). 

We will be sending the users a pop-up message, via the “Message of the Day”, indicating 
which chapter(s) has been modified.  

Message of the Day 
The “Message of the Day” is a Visual Basic program that we use to send important 
messages to MicroStation users. If a message was sent to you, read it to see if it affects you. 
Please do the recommended action if any is required. Clicking OK will remove the message 
and will not display it again. If you do not have time to read the message, hit Cancel and the 
message will appear again when you enter MicroStation. A typical message might ask you 
to run your Update Utility, let you know if a plotter is working or tell you that the Manual 
has been updated. Try to treat these messages as high importance as we wouldn’t be sending 
them otherwise. 

Website Location 
The updated MicroStation Manual and our configuration files for MicroStation are available 
on the internet for both in-house employees and the consultant community. The address to 
the individual chapters of the manual is as follows: http://www.maine.gov/mdot/cadd-
support/microstation/mstamanualcontents.php . Check the date of your hard copy with the 
chapters on the internet. This is another way to find out if you need to update a chapter. 
Keeping your manual up-to-date will ensure that a reference to another portion of the 
manual is accurate. 

Sending Requests via E-mail 
 A user can print out the new chapter(s) to a local printer or photocopier, however if you 
want it to have 3 hole reinforced paper, you will have to print it by other means. The MDOT 
reproduction room is also going to take requests from individual users or bulk request from 
Programs or Regions. We are providing a link to their general email account so you can tell 
them the chapter(s) that you wish to have printed, the type of stock to print it on (reinforced 
- three hole punch) and a distribution request. Email requests to Repro.Mdot@maine.gov . 

http://www.maine.gov/mdot/cadd-support/microstation/mstamanualcontents.php
http://www.maine.gov/mdot/cadd-support/microstation/mstamanualcontents.php
mailto:Repro.Mdot@maine.gov
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USING THE TABLE OF CONTENTS AS A QUICK 
PUNCH LIST 

We have had requests to make quick To-Do list for some of the Chapters. We have added a 
few here and there, but not throughout the entire manual. This doesn’t mean that you 
shouldn’t read and follow all directions. Once you get familiar with a process, we suggest 
that you use the Table of Contents as a quick punch list for any give chapter. In most cases, 
the important steps are outlined in the table. If a step is unclear, open to the page and read 
more thoroughly. 
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USING THE ON-LINE MANUAL 
Overview 
We have created a PDF document of the entire MicroStation manual and have made it 
available for in-house and consultant use. Many people prefer hard copies of manuals, 
however the PDF document provides more functionality.  

Opening from within MicroStation 
The online manual can be activated from within MicroStation by clicking on the icon that 
looks like a book with a magnifying glass on it (Figure 1-1). 

 
Figure 1-1: MicroStation On-Line Manual Icon 

This will kick off your PDF reader and open the manual. If you can foresee needing the 
manual for offline work, consider doing a “Save As…” and create a local copy on your 
PC/laptop. 

Searching the On-line Manual 
Like with most software, type Ctrl+F, click the binoculars or select Edit>Find (on This 
Page) and it will bring up the Find tool. Enter the topic you are searching for and Adobe 
will show you every occurrence of the word you are searching for, starting with the Table of 
Contents. Select the one that best fits your needs.   

Following Cross References 
In many places in the manual, we refer you to another topic for more information. With a 
hard copy, you have to browse to the chapter and page number. When using the on-line 
manual, you simply click the link to go to the page. 
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HELP WITH MICROSTATION 
Internal Help Program 

Overview 
As with most programs, MicroStation has an internal help program that is very useful and 
detailed. There are many options in using help. Selecting Help from the main menu bar with 
expose these options. 

Contents 
Help>Contents is similar to many Microsoft html Help products. It has a Contents, Index, 
Search and Favorites tabs. 

Tool Index 
This option opens a tool specific dialog and allows a user to search based on a tool selection. 
It still ultimately open the larger help document but helps narrow the search. 

Tool Tips 
With this option checked on, hovering the pointer over a tool icon displays a tool tip, which 
is a yellow rectangle with text that provides the name of the tool. 

Tracking 
Turning on Help>Tracking will display help for whatever tool or view control you pick. 
This is a good option for new users because it will display all possible options for using the 
specific tool. 

CADD Support Personnel 

Phone 
Please feel free to call your support personnel at any time when help is needed. We may 
refer you to a portion of this manual for detailed instructions or guide you through the task at 
hand by using the phone and Microsoft’s Remote Assistance software. We can view the 
problem, take over your mouse and provide help.  

Remote Assistance 
Remote assistance can be kicked off through an email to us or we can Offer Remote 
Assistance to you.  

Send Us an Email 
Go to Start>Programs>Remote Assistance or Start>Help and Support and select Invite 
Somone To Help You. Pick Microsoft Outlook as the way you’d like to contact us and type 
in our email address or use the Address Book to select the name from the list. Follow the 
rest of the promts, and include a password. Place a call in to the person you sent the email to 
and tell them the password. 
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Call and we’ll Offer Assistance 
We can Offer Remote Assistance in the event you need a hand. Give us a call and we’ll do 
the rest. 
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GUI: THE GRAPHICAL USER INTERFACE 
There are a couple of places that MicroStation will offer instructions, read out data, and 
generally try to be helpful. These are the Tool Settings Window, Status Bar and Message 
Center. Make sure you know where these things are and check back with them often. 

 

Figure 1-2: Interface Components 

How do I get back Tool Bars that are missing? 
If any aspect of the GUI has been closed, you’re probably going to need to get it back. Every 
item outlined above can be closed except for the Menus and the Status Bar.  

The Attributes Tools can be opened from the Menus by choosing Tools>Attributes. 

The Primary Tools can be opened from the Menus by choosing Tools > Primary.  

The Standard Tools can be opened from the Menus by choosing Tools > Standard. 

The Main Tool Frame can be opened from the Menus by choosing Tools > Main > Main. 

The Tool Settings Window can be opened by simply activating any command from a 
toolbox or menu. 

The Window Open/Close button bar is used to open and close MicroStation Views. (The 
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words “View” and “Window” are used interchangeably in MicroStation.) This button bar 
can be activated from the Menus by choosing Window > Views > Dialog.  

The Settings Manager can be opened from the Menus by selecting Settings > Manage. 
Task-specific Settings Managers can be opened from Settings > DOT SetMgrs. 

With our in-house customization we have specific settings managers auto loading based on 
file naming convention. 

AccuDraw can be opened by pressing the Toggle AccuDraw button on the Primary Tools 
bar. 

 
Figure 1-3: AccuDraw Button 

How do I retrieve missing tools on a Tool Bar? 
I have my tool bar up but it is not showing all the tools. Well in MicroStation V8 they have 
made the GUI more windows oriented. You can now right click on any tool bar and remove 
from display any of the dockable tools. 
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MOUSEING 
Standard Buttons 
Remember that the three buttons of the mouse are called Data, Tentative, and Reset. Here 
is a brief table of mouse button functions: 

Left Button Middle Button Right Button 

Data Tentative Reset 

Accept Snap Reject 

Yes Maybe No 

Troubleshoot the Middle Button 
It is possible that your Middle Button may not be snapping. From your main menu, select 
Workspace > Button Assignments. This will open the Button Assignments dialog (Figure 
1-4). 

 
Figure 1-4: No Middle Button Assigned 

Highlight the Tentative row. Notice the Invoked by column is not set to Middle Button. 

Put your cursor in the Button Definition Area and hit your middle button. You should see 
the Invoked by column change to Middle Button (Figure 1-5) 

 If you are using a 2 button mouse you can setup the tentative by following this same 
procedure and either holding the Alt button when hitting your Left mouse button or 
hitting your Left and Right mouse buttons simultaneously in the Button Definition 
Area.  
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Figure 1-5: Middle Button Correctly Assigned 

Press the OK button to preserve the assignment. 

Using a Wheel Mouse 
If you are using a wheel mouse you need to establish the wheel as a Middle Button in your 
mouse properties of your Operating System (Start>Settings>Control Panel>Mouse). 

There are some settings that you can set in your preferences for controlling the zoom and 
panning of your wheel mouse. You can find these setting by going to 
Workspace>Preferences… in the main menu. Select Mouse on the left side of your 
Preferences under your Category options. Check the different options out to the right and see what 
best fits your needs. (Figure 1-6) 

 
Figure 1-6: User Preferences 
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MENU OVERVIEW 
Introduction 
Our menu structure lets you run MicroStation from the keyboard. To let you keep one hand 
on the mouse, we've tried to maximize the keystrokes accessible with your left hand only. 

The Principal 
Menu items can be chosen with your mouse or from your keyboard. Notice the underlined 
letters in the menu (File, Element, etc.) Open any menu by typing the Alt key, then typing 
that underlined letter. Then type the underlined letter of a command in the menu.  

Organization: The Top Level 
Commands have been grouped together to make them quick to run and easy to find. Let's 
look at the menu structure, including important modifications we’ve made to existing menus 
as well as menus we've added:  

The File menu has been modified to allow access to custom sheet-creation routines. The 
Reference (DOT) option has also been enhanced to give quick access to common Reference 
commands. 

The Edit and Element menus have only minor changes. 

The Dimension menu has been added to give quick access to some common Dimension 
settings.  

The Group menu helps place and manipulate groups of objects. Using this menu, you can 
control fences and graphic groups and access tools for element selection sets as well. 

The Macro menu is used to launch custom applications and enhancements. 

Use the Measure menu measures distances, angles, areas and volumes.  

The Qualities menu matches and changes color linestyle and other attributes. 

The Settings menu has been modified to give you access to a wide range of MDOT Settings 
Managers, organized by task. 

The Stretch helps you modify, extend, clip and trim elements. 

The Text menu places and modifies text. 

The Tools, Utilities, Window, and Workspace menus have only minor changes. 

The Zip menu helps you place lines, shapes and cells. It also lets you move, copy, and 
modify, as well as hatch and delete. 

Organization: The Next Level 
To keep things simple we've tried to keep the menus similar. The Group and Zip menus 
have some items in common: Copy, Move, Delete, and Scale are in both menus. They also 
have similar entries for Mirror and Rotate.  
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For commands that are unique, we've tried to balance logic with convenience. On the 
convenience side, you can run the "place line" from Zip > Zipline. "Zipline" isn't a familiar 
word, but it's convenient to "place line" with the keystroke Alt+Z, Z. On the logical side, 
there's the "Measure Length" command. Alt+R, L. The Alt+R opens the Measure menu, 
and the L chooses "Length" as an option. 

Organization: Submenus 
Some commands have a lot of options you might want. With "Rotate", you might want to 
rotate by a specific angle. Then again, you might want to eyeball it. The Rotate item under 
both the Group and Zip menus has both of these options. You can "Rotate by Angle" or 
"Rotate by 3 Points".  

Conclusion: The Pros and Cons 
With this system, you can execute virtually every MicroStation command with a two or 
three letter shortcut that can be typed with one hand. If you forget the shortcut, you can 
remind yourself just by browsing through your menus.  
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NETWORK OVERVIEW 
MicroStation Customization files and Drawing Files: 
The master MicroStation customization files are on the network in a blind share. This means 
that they are in a secure location that isn’t normally seen when mapping a drive letter. All 
users have a local copy of the customization on their C: or D: drive. Updates to the 
configuration are handled with an Update Utility. This utility does a date check of your local 
customization and updates files if changes were made to the master copy. There is one 
folder called !msproj in our configuration that requires access to the network. The folder is 
located on the \\dot0dta1fscadd1\pcpin1\msworksp\ and is mapped through the Y: drive. 
This !msproj folder contains project specific information that are used as variables. These 
variables store information such as town name, federal project number, street or route 
number and user names of those who have worked on the project. A copy of this folder is on 
your C: or D: drive for offline work. As new PIN’s are created, you may need to update this 
folder for offline work so your project shows up in the list. 

The master copies of all drawing files are located on the network on 
\\dot0dta1fscadd1\pcpin1\. This folder has been “mapped” to your machine as your Y: 
drive. This folder contains all of your design/detailing (project) information in the form of 
MicroStation files (.dgn).  

Regional Office users create sync copies of their project drawing files to their local hard 
drive because the network speed is diminished due to the geographical location and in some 
cases offline work. In this case, the files are setup in a briefcase “PIN” folder at the root of 
their C: or D: drive. 
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OPENING FILES 
You should always launch MicroStation from either a desktop icon or the Start menu. The 
first dialog to open is the MicroStation Manager. 

At the bottom of this dialog you will notice the Workspace area. 

User should be set to normal.  

Interface should be set to mdot. 

Project should vary depending on what project you are working on. When you click on the 
Project picker, you should see a list of all active PINs. Pick your PIN from this list and 
MicroStation will take you directly to the design file directory for your Project. This is 
important because MicroStation will work smoother if it knows what project directory it 
should look to by default. If this is not working, please contact your CADD Support section. 

Select a file to open from the left side of the MicroStation Manager and press OK.  

 You can open multiple MicroStation sessions while working on a single project (i.e. 
Plan view and Cross Section), however if you open a file having the same name (i.e. 
two highway.dgn’s) in two different  project PINs, you may loose some work. You 
should always close all sessions of MicroStation prior to switching between projects. 
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MAKING NEW FILES 
Setup 
This macro is used to make new design files that meet MDOT standards. It will create them 
only in the same folder as the MicroStation design file that is open when the macro is run. 
To create new files for a specific project, launch the project and open an existing file in the 
project’s folder. 

Launch the Makesheetz macro 
Launch the makesheetz macro from your main menu by selecting File > Makesheetz. This 
will open the File Prefix Dialog (Figure 1-7). 

 
Figure 1-7: File Prefix 

Choose Preliminary Information 
In the File Prefix Dialog, you can choose to make a numbered sheet, a z-file, a c-file or a 
file with no prefix. 

Numbered Sheets contain borders. These are the drawings that comprise the plan set for 
delivery to Contracts. They are the sheets that get plotted. Choose a Sheet Number. 

Z-Files are the files where detailing work gets done. They typically get referenced into 
Numbered Sheets for plotting. 

C-Files are the files where coloring is done for visualization purposes. 

If you do not want a number, a “c” or a “z”, you can also choose “no prefix.” 

 Notice you can choose a different Workgroup here. This option starts with your 
default workgroup. You can change this to create a file that would normally be made 
by another Workgroup. 

When you have set your options, press OK. 

Choose a File Type 
This will bring up the Create File of Type… dialog (Figure 1-8). 
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Figure 1-8: Create File of Type 

Scroll down the list to find the file type that you want to create. Select it and press OK 

Final Filename Editing 
This will bring up the Make File dialog (Figure 1-9). 

 
Figure 1-9: Make File 

You can edit the entry in the Create file called box.  

Choose a number from the pull down for multiple drawings of the same type: (Figure 1-10) 
or type a suffix into the text entry box (Figure 1-11). 

 
Figure 1-10: Index Picker 

 
Figure 1-11: Suffix 

Press OK when you have finished editing your filename. 
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 The macro will automatically enter the underscore character before your suffix. If 
you do not type a suffix in, it will not insert an underscore. 

End Game 
This will create the new file based on appropriate seed files and place the correct border cell, 
where needed. It will then opens up the File Prefix dialog again and prompt you to create 
another file (Figure 1-12) 

 
Figure 1-12: File Prefix Again 

Press Cancel if you are done making files, or repeat these steps to make another file. 

Safety Features 
This macro will not automatically overwrite existing files, if you happen to tell it to create a 
file that already exists. It will first prompt you (Figure 1-13). 

 
Figure 1-13: File Overwrite Alert 

If you press No, the macro will bounce you right back to the File Prefix Dialog to let you 
pick a new sheet number. 
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FILE NAMES 
The file names are important because the automatic sheet numbering capability of 
MicroStation relies on the first three digits of the file name. We all have had plots that came 
out with “XSE” in the “sheet number” box on your cross section plot. This is because the 
filename of your cross section you plotted was something like XSECTMC10_002.dgn. File 
names are also important because MicroStation automatically loads the Settings Manager 
that should be used based on the drawing type. 

 Do not manually edit the sheet numbers on any of your drawings. Allow the 
automated procedure to handle this.  

Consider using the default number that displays, based on your workgroup, when cutting 
plan sheets. This will leave room for sheets that will go before the plans and numbered in 
the beginning of the project, for example: 

001_title.dgn 

002_typical_01.dgn 

003_typical_02.dgn 

004_estimate.dgn 

005_drainage.dgn 

006_notes_general.dgn 

007_notes_construction.dgn 

008_??.dgn 

009_???.dgn 

010_????.dgn 

011_HDPlan1.dgn 

The renumbering utility can be used again and again if necessary. Don’t worry if they aren’t 
in the correct order until final print. 

 Avoid having sheets with the same prefix and suffix in their filename. Add a suffix to 
sheets to differentiate the like drawings (i.e. Typical_01.dgn, Typical_02.dgn). The 
sheet renumbering utility doesn’t like having two drawings with the same prefix or 
root filename and suffix. You can use Windows Explorer to rename any identical root 
filenames to add a suffix or you can let the renumbering utility give you the warning 
and start rebuilding the list to the right. 
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SHEET RENUMBERING UTILITY 
Introduction 
This utility was developed to quickly rename/renumber your plot drawing files in the event 
that a sheet is added or deleted from a plan set. It allows you to prioritize the plan set based 
on the order of files in the list. 

Operating the Utility 
To use this utility click on the icon on your desktop (Figure 1-14) or by selecting 
Start>Programs>MDOT Utilities>MDOT MicroStation Sheet Numbering Utility. 

 
Figure 1-14: The Tao of Renumbering 

Next you will need to click your way to the PIN directory that you are interested in by 
changing the drive letter in the lower left corner, above the Renumber Plot Files button, to 
y:\\dot0dta1fscadd1\Pcpin1. Double click on the pin folder and select the desired project 
identification number (pin). You should keep double clicking on the sub folders to get 
yourself to your workgroups MSTA folder as shown in Figure 1-15. 

 
Figure 1-15: Browsing for Files. 
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Once there, you will see the list of drawings under the heading Available Drawings to the 
left and the utility automatically creates a list of all your numerical prefix drawings to the 
right under the Listing of Sheets category (Figure 1-16). 

 If you have drawings with the same prefix numbers the utility will not populate the 
file names under the Listing Of Sheets beyond the duplication. You can either use 
Windows Explorer to rename individual prefixes or just populate the Listing Of 
Sheets beyond that point. 

 
Figure 1-16: Renumbering Interface 

Prioritizing Plan Set 
Now we are ready to prioritize the drawing list to create the correct numbering of sheets for 
the final plan set. You may have noticed that the list to the right side of the utility shows 
place holders between the original numbered drawings you had created, that's O.K. just 
simply highlight each place holder (015_xxxx) that you don't want and hit the Remove 
button or hit the Clear button and remove all files so that you can rebuild you list of files by 
highlighting and using the arrow in the middle to push the file back to the right. 

 The CLEAR button doesn’t give you a warning! If you hit clear, this will remove all of 
the numbered prefixes from your drawings! You will need to locate and rebuild them.  

You have the ability to add placeholders between drawings to create a gap in your sheet 
numbers in case there are sheets being inserted from other workgroups. You can move a 
selection of files up and down with the arrows to the right of the utility to prioritize your 
plan set. 
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Once you have done this, go ahead and hit the Renumber Plot Files button and you should 
see your file names renumbered and the list to the left renamed as shown in Figure 1-17. 

 
Figure 1-17: Renumbered Files 

Press Done when you are finished. 

Precautions 
This utility is set up to look for files within your folder. It is necessary that all file names are 
unique not only in their root filename and suffix, but in their prefix as well. If this 
requirement isn't met then you will experience problems activating this utility and/or 
renumbering when in the utility. 

The utility reverses the order of files when they are the first files pushed into the “Listing of 
Sheets”. Add a couple of place holders and click on the last place holder prior to pushing a 
large grouping of sequential files into this area. 

 If you get an error when first opening the utility, it may be because a PIN number that 
was previously renumbered no longer exist. To fix this problem, browse to your 
C:\windows directory and open the control.ini file. Delete the InitDirectory line in this 
file and the path to the PIN that it refers to. Reopen the Sheet Renumber Utility: 
(Figure 1-18) 

 
Figure 1-18: Control file 
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PCF EDITING 
Discussion 
PCF Files - “Project Configuration files” are files that contain project specific information 
that will be used by MicroStation and databases that can extract project information from 
lines of text in the file.  

Open one of your prefix numbered drawings.  

Edit PCF File 
Go to Workspace > Edit Project Data (PCF) to revise or add information about this 
project. A list of variables will appear in a dialog. 

 If you get the warning that says “Close MicroStation and choose a project that is 
consistent with your file location”, there are two thing it could be.(Figure 1-19)  

 
Figure 1-19: Information Dialog  

1. You may have entered MicroStation improperly. You must open MicroStation by 
clicking on the MicroStation icon on your desktop and selecting your PIN number in 
the project pull down (this is in the lower portion of your MicroStation Manager 
window. This selects the PCF file that is associated with your PIN number) If you have 
the wrong project specifics on your plot, this is a BIG clue that you selected the wrong 
PCF in the project pull down or that your PCF has bogus information in it.  

2. If the line in your PCF file says “PCF_PINNUMBER = _______”, and does not have a 
value, you will still get this warning. Simply correct this by adding your PIN number 
(i.e. 1234.00), saving the PCF file and restarting MicroStation. 

 Do not enter the word “PIN” in the PCF_PINNUMBER field. 
Verify that the fields crucial to your drawing are filled in. Edit a field by clicking on the 
field and hit OK.  

Another dialog will prompt you for input. Add the information and click OK. Figure 1-20 
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Figure 1-20: PCF Selections 

When done, hit Cancel to Exit. Click Yes to save the changes.  

 In the capture above, you will notice some similar selections. Due to the fact that 
some border drawings may contain different variables, you should enter the primary 
designer in both the PCF_DESIGNER and the PCF_DESIGNER1 fields. The same 
goes for PCF_DETAILER. Additional designer and detailer fields are there for a 
future border that will have the additional fields. 

 If no changes were made and you attempt to save the file anyway, you will get an 
error. Click OK to bypass the error.  

The macro will ask you if you would like to edit the border information. Say Yes to process 
all of the numbered drawings now or No to process them later using Macros > Border 
Information from the Main Menu. Figure 1-21 

 
Figure 1-21: PCF Edit Alert 

 Refer to the Border Information Macro on page 1-27. 
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BORDER INFORMATION MACRO 
Discussion 
The standard border cells contain variables for sheet number, total number of sheets, street 
name, etc. These variables begin and end with a “$” or “@”.  

We have a macro that will substitute your active project information into those variables. 

It will also look for the first three digits of your file name and use those as your current sheet 
number. 

This is called the Borderinfo macro, and you run it from your main menu by selecting 
Macros > Border Information. 

The macro is capable of processing a whole folder-full of files at once. 

 Refer to page 1-30 for information on disabling edited items. 

Sheet Numbering 
Before you run the macro, make sure your file fits naming conventions, i.e., begins with a 3-
digit number and an underline. 

 Check page 1-22 for instructions on using the Sheet Renumbering Utility. 

Process Options 
If you are running the macro from an appropriate file and project setup, you will get the 
Border Info dialog box (Figure 1-22) that offers you two options. 

 
Figure 1-22: Border Info 

Current File 
Process your active file by picking Change Current File.  

Project Files 
Process a whole directory full of files by selecting the Change Project Files option. This 
will select all eligible files in your current directory for processing.  
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You will get a dialog that lists all the files that will be processed. You can browse through 
this list to confirm that only the files you want to process are listed (Figure 1-23). 

 
Figure 1-23: Batch Process 

If you don’t wish to process a certain file in the list, highlight it and press OK. Otherwise, 
press Cancel and MicroStation will open and process each file on the list.  

 Remember that only files in your active directory that begin with a 3-digit number 
(followed by the underscore "_" character) will be processed.  

Error Messages 
When running this macro, you may get one of two error messages.  

1.  If you didn't pick your current project before opening the file, you'll get a prompt to 
"Close MicroStation and choose a project (PIN) that is consistent with your file 
location." This will protect you from substituting incorrect information onto a border. 

2.  If you are working in a file that is not properly named, you will get a prompt that 
explains the file naming criteria. You will get this message if you try to run the macro 
from a file that is not a border file or it has not been run through the Sheet Renumbering 
Routine.  

Side Effects 
The most important side effect of this macro to be aware of is that it will drop all border 
cells in every file processed.  

 The macro may not substitute information if you don’t have a standard border cell. In 
that case, drop the cell manually from Qualities > Drop > Complex.  

Changing Data After the Fact 
If you go back and need to change your project data, select Workspace>Edit Project Data 
(PCF).  

 Refer to page 1-25 for the specific details of editing PCF files. 
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Troubleshooting 
If it seems like the macro is not finishing, it may be because of one of the following reasons. 

1. Someone may have changed or hard coded a variable on the border. 

2. You cannot use a backslash between the month and year in your PCF file. 

3. Your file may be corrupt. (See your CAD administrator) 

4. If there is any multiline text in the border cell the macro can get hung up. 



mdot MicroStation 
07/01/07 

General Procedures 

1-30 

 

DISABLING THE BORDERINFO SUBSTITUTION 
Overview of Droplink.bas 
The downside of using the Borderinfo macro to substitute project information onto the 
border sheets (Macro > Border Information) is that you are limited in your ability to alter 
the results of the substitutions. 

Once the macro has run, you can edit the text as normal. However, every time the 
Borderinfo macro runs, it will re-substitute its text: potentially overwriting your custom text 
entry. 

The DropLink macro has been written to allow you to “hide” your altered text, preventing 
the Borderinfo macro from changing it when it is run. 

A possible good use of this is if you want to maintain a certain designer/technician name of 
a plan sheet then you would droplink these names so that the border information would not 
change them. 

Setup 
There are two ways the Droplink macro can process elements.  

You can place a fence or select a bunch of elements using PowerSelector and then run the 
macro. The macro will process all the indicated elements. 

Or, you can run the macro with no Fence or Selection Set, and the macro will allow you to 
pick elements one at a time to drop. 

Run the DropLink Macro 
From the main menu, select Macro > Droplink.  

If you have a Selection Set or Fence, Datapoint to Accept. 

Otherwise, select each element you’d like to drop the linkage from. 

What Does it Do? 
The DropLink macro removes an invisible tag from the elements you indicate. This tag is 
the only way the Borderinfo macro can find these elements to change them. Without the 
tag, the Borderinfo macro will not further alter the elements. 

 This process is only reversible by using Edit > Undo.  

Quitting 
To exit out of the macro, simply choose another command. 
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MAINEDOT PLOT DRIVERS – REGION 0 
Overview 
The plot driver below are located in the !ms2004conf/standards/plotdrv folder. 

Plots can be sent to any plotter, regardless of its location. Due to network speed, it may be 
more feasible to have someone at the location send the plots. 

The OCETDS600-rm312 has two paper outputs trays available. A “table” which may result 
with plots in reverse order (i.e. MicroStation plots – single or Batch Prints) or an Ascending 
order integrated tray on the top of the machine for plots to be sorted in Ascending order (i.e. 
Print Exec Workgroup or other). We have added the type of output on the plotters described 
below. 

 The recommended printing solution is Batch Printing or plotting with a Fence 
for single copies of a set of drawings. For more than one copy and for better 
management of the order in which they are printed, it is recommended that users 
Batch Print to create a multi-page PDF and print from Adobe directly to a 
plotter. 

 Refer to page 17-13  for instructions on plotting a PDF from Adobe 
software directly to one of the plotter listed below. 

 When plotting a PDF, consider sending it directly from the Adobe PDF viewer 
software to a plotter that is mapped to your computer. You can reverse the order 
(depending on the plotter it goes to) and ask for additional copies. For your 
convenience, we have provided instructions on mapping the various plotters below 
each description. 

 Removing the “US_” from the front end of the drivers description will give you the 
names of the METRIC plot drivers. 

US_ OCETDS860-full-rm126 – Final Full Size Plotting 
This option sends a full size plan sheet, which is 36” wide, to the plotter located in the 
reproduction room at MDOT – Augusta. 

This plotter produces excellent plots and is capable of handling large batch jobs. 

The exit tray is the table that will stack plans based on the order they were printed resulting 
in reverse order. The user is required to adjust the order. When Batch Plotting, click on the 
Name column to sort in decending order. 

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click this link \\Dot0dta1psprt02 and then double click the OceTDS800-Rm126 
plotter in the list. 
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US_ OCETDS860-half-rm126 – Final Half Size Plotting 
This option sends a half size plan sheet, which is 18” wide, to the plotter located in the 
reproduction room at MDOT – Augusta.  

The plotter has an 18” roll; therefore, no trimming is required. 

The exit tray is the table that will stack plans based on the order they were printed resulting 
in reverse order. The user is required to adjust the order. When Batch Plotting, click on the 
Name column to sort in decending order. 

US_ OCETDS860-long-rm126 – Long Plots (5’ – 20’) 
This option sends plots longer than our normal plan sheet is tall (24”+/-). Currently, we have 
4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip 
boundaries of the same size to achieve a plot that is to a desired scale. 

US_PLOT2FILE 
This option is for creating plot files (.plt or .000). This is used in conjunction with the Print 
Exec Workgroup. The Print Exec Workgroup can use the plot files to create full or half size 
plots. Depending on where you send you plots, you may be required to print the job in 
reverse order. 

 For more information on the Print Exec Workgroup, refer to page 1-67 . 

US_ OCETDS600-full-rm312 - Full Size Check Plots 
This option sends a full size plan sheet, which is 36” wide, to the plotter located in Room 
312 on the 3rd level of MDOT in Augusta. 

This plotter is for quick working plots and is not intended to be used for final plots or large 
batch jobs. Please send only 50 plots at a time to this plotter. 

The plots exit on the tray table that will stack plans based on the order they were printed 
resulting in reverse order. When Batch Plotting, click on the Name column to sort in 
decending order.  

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click this link \\Dot0dta1psprt02 and then double click the OceTDS600_Rm312 
plotter in the list. 

US_ OCETDS600-half-rm312 – Half Size Check Plots  
This option sends a half size plan sheet, which is 18” wide, to the plotter.  

It is not intended for large half size batch jobs. Please send only 50 plots at a time to this 
plotter. 

The plots exit on the tray table that will stack plans based on the order they were printed 
resulting in reverse order. When Batch Plotting, click on the Name column to sort in 
decending order.  
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US_ OCETDS600-long-rm312 – Long Plots (5’ – 20’) 
This option sends plots longer than our normal plan sheet is tall (24”+/-). Currently, we have 
4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip 
boundaries of the same size to achieve a plot that is to a desired scale. 

US_OCETCS500-full-rm126 – Full Size Color Plotter 
This option is for sending Full Size color plan sheets to the OCETCS500 Plotter in Room 
126 (reproduction room) at MaineDOT – Augusta. This is a high quality and fastest wide 
format color plotter in the building.  

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click this link \\Dot0dta1psprt02 and then double click the OceTCS500-Rm126 
plotter in the list. 

US_OCETCS500-half-rm126 – Half Size Color Plotter 
This option is for sending Half Size color plan sheets to the OCETCS500 Plotter in Room 
126 (reproduction room) at MaineDOT – Augusta. This is a high quality and fastest wide 
format color plotter in the building. 

US_OCETCS500-long-rm126 – Half Size Color Plotter 
This option sends color plots longer than our normal plan sheet is tall (24”+/-) to the 
OCETCS500 Plotter in Room 126 (reproduction room) at MaineDOT – Augusta. Currently, 
we have 4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction 
with clip boundaries of the same size to achieve a plot that is to a desired scale. This is a 
high quality and fastest wide format color plotter in the building. 

US_HPCOLOR4 
This option is for sending color plots to the HP1055CM Plotter in Room 303 on the 3rd level 
of MDOT in Augusta. This plot driver points to the plotter through the same print server as 
all the printers and photocopiers in the building.  

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click this link \\dot0dta1psprint and then double click the PLOTCHP4 plotter in 
the list. 

US_HPCOLORRoom303 
This option is for sending Full Size plan sheets to scale or larger color plots to the 
HP1055CM Plotter in Room 303 on the 3rd level of MDOT in Augusta. This plotter uses a 
different print server than the US_HPCOLOR4. It should be used when sending for large 
color plots. 

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
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click this link \\Dot0dta1psprt02 and then double click the 
HPCOLORPLOTRM303-HPGL plotter in the list. 

US_HPCOLORRoom303Half 
This option is for sending Half Size plan sheets to scale or other color plots to the 
HP1055CM Plotter in Room 303 on the 3rd level of MDOT in Augusta. This plotter uses a 
different print server than the US_HPCOLOR4. It should be used when sending for large 
color plots. 

US_HPCOLORRoom321 
This option is for sending Full Size plan sheets to scale or larger color plots to the 
HP1055CM Plotter in Room 321 on the 3rd level of MDOT in Augusta. This plotter was 
intended to be used to share the load of the HPCOLORRoom303. It should be used when 
sending for large color plots. 

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click this link \\dot0dta1psprint and then double click the PLOTCHP2 plotter in 
the list. 

US_HPCOLORRoom321Half 
This option is for sending Half Size plan sheets to scale or other color plots to the 
HP1055CM Plotter in Room 321 on the 3rd level of MDOT in Augusta. This plotter was 
intended to be used to share the load of the HPCOLORRoom303. It should be used when 
sending for large color plots. 

US_ pdf-8x11 
This driver will create a black and white 8 1/2 x 11 pdf document provided you are running 
MicroStation version 8.05 or higher.  

US_ pdf-8x11color 
This driver will create a color 8 1/2 x 11 pdf document provided you are running 
MicroStation version 8.05 or higher.  

US_pdf-color-fullsize 
This driver will create a color, full size pdf document provided you are running 
MicroStation version 8.05 or higher. 

Depending on the plotter you are sending to, consider sorting in ascending or decending 
order when using Batch Print to a multi-page PDF to receive the prints in the correct order. 

US_ pdf-color-halfsize 
This driver will create a color, half size pdf document provided you are running 
MicroStation version 8.05 or higher.  
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Depending on the plotter you are sending to, consider sorting in ascending or decending 
order when using Batch Print to a multi-page PDF to receive the prints in the correct order. 

US_ pdf-fullsize 
This driver will create a full size black and white pdf document provided you are running 
MicroStation version 8.05 or higher.  

Depending on the plotter you are sending to, consider sorting in ascending or decending 
order when using Batch Print to a multi-page PDF to receive the prints in the correct order. 

US_ pdf-halfsize 
This driver will create a half size black and white pdf document provided you are running 
MicroStation version 8.05 or higher.   

Depending on the plotter you are sending to, consider sorting in ascending or decending 
order when using Batch Print to a multi-page PDF to receive the prints in the correct order. 

PRINTER_BW 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that 
you have mapped to your computer. If you are sending prints to a color printer, this option 
will print Black and White. If you are using this option and sending to a Black and White 
Printer, all lines (even if you are displaying color) will print black. 

PRINTER_COLOR 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that 
you have mapped to your computer. If you are displaying color in your drawing, this option 
will print color. If you are using this option and sending prints to a Black and White Printer, 
lines other than black will be a gray tone. 

PRINTER_STANDARD_DETAIL 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that 
you have mapped to your computer. This option is intended but not limited to Standard 
Detail printing and will print Black and White. This option produces thicker weights than 
the PRINTER_BW. Compare the results of the two drivers and choose the one that suits 
your needs. 

Hearing_PRINTER 
Drivers with PRINTER in the name sends the plots to your default 8.5” x 11” printer that 
you have mapped to your computer. This driver is used by the Public Hearing Section, 
however can be used by anyone. Test and compare the results of this driver with other 
printer drivers and choose the one that suits your needs. 
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REGIONAL OFFICE PLOTTERS (HP750C AND 
OCE PLOTTER) 

Overview 
All of the Regional offices are equipped with an HP750C color plotter and an OCE Plotter 
in addition to any Laser Jet printers. These plot drivers are located in the 
!msInRoadsconf/standards/plotdrv/divisions/RegionName folder. 

Use the printer and PDF drivers in the plotdrv folder for printing to a Laser Jet (8.5 x 11) 
printer or to PDF. Use the drivers in your specific “divisions” folder for all plots going to 
your HP750C or OCE plotter. 

 Removing the “US_” from the front end of the drivers described will give you the 
names of the METRIC plot drivers. 

US_FULL750C_???_GR 
Default full-size black and white plot driver. Sends plots to the HP750C plotter. 

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click one of the links below depending on the Region.  

Region 1 click here  \\Dot1dts1fsscr01 then double click the scr750c plotter in the list. 

Region 2 click here  \\Dot2dteaqpr001 then double click the HP750C plotter in the list. 

Region 3 click here  \\Dot3dtd4fsdix01 then double click the HP750C plotter in the list. 

Region 4 click here  \\Dot4dtb7fsbgr01 then double click the HP750C plotter in the list. 

Region 5 click here  \\Dot5dtp1fspqi01 then double click the HP750C plotter in the list. 

US_HALF750C_???_GR 
Default half-size black and white plot driver. Sends plots to the HP750C plotter. 

US_Long_750C_???_GR 
This option sends black and white plots longer than our normal plan sheet is tall (24”+/-). 
Currently, we have 4 different lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in 
conjunction with clip boundaries of the same size to achieve a plot that is to a desired scale. 

US_PLOTCHP_??? 
This option is for sending color plots to the HP750C plotter.  

 There may be other drivers in your “divisions” folder that have been created by 
users. Some may work and others may not. If you need assistance with drivers 
contact CADD Support. 

US_OCE9400FULL 
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This is a high speed, full size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 

The plots exit on the tray table that will stack plans based on the order they were printed 
resulting in reverse order. When Batch Plotting, click on the Name column to sort in 
decending order.  

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click here  \\Dot2dteaqpr001 then double click the Region 2 – Oce 9400 plotter 
in the list. 

US_OCE9400HALF 
This is a high speed, half size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 

The plots exit on the tray table that will stack plans based on the order they were printed 
resulting in reverse order. When Batch Plotting, click on the Name column to sort in 
decending order.  

US_OCE9400LONG 
This option sends black and white plots longer than our normal plan sheet is tall (24”+/-) to 
the OCE plotter (if available) in your Regional Office. Currently, we have 4 different 
lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip boundaries of 
the same size to achieve a plot that is to a desired scale. 

US_OCETDS400FULL 
This is a high speed, full size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 

 If you need to map this printer as a Windows Printer for submitting from 
software other than MicroStation (i.e. Adobe, Excel, ESERI, Paint, E-Plans), 
click one of the links below depending on the Region.  

Region 1 click here  \\Dot1dts1fsscr01 then double click the SCR OCE PLOTTER in the 
list. 

Region 3 click here  \\Dot3dtd4fsdix01 then double click the OceTDS450 plotter in the 
list. 

Region 4 click here  \\Dot4dtb7fsbgr01 then double click the OceTDS450 plotter in the 
list. 

Region 5 click here  \\Dot5dtp1fspqi01 then double click the PQI OCE Plotter in the list. 

US_OCETDS400HALF 
This is a high speed, half size, black and white plotter that sends plots to the OCE plotter (if 
available) in your Regional Office. 
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US_OCETDS400LONG 
This option sends black and white plots longer than our normal plan sheet is tall (24”+/-) to 
the OCE plotter (if available) in your Regional Office. Currently, we have 4 different 
lengths available: 5ft, 10ft, 15ft, and 20ft. We use this in conjunction with clip boundaries of 
the same size to achieve a plot that is to a desired scale. 
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PEN TABLES 
Overview 
Pen tables are used in combination with certain Plot Drivers, to accomplish a desired output 
to a printer or plotter. Each pen table does something different to your drawing at plot time. 
Some will require testing with your type of drawing, others have been established for 
specific types of drawings.  

!pentable.tbl 
This is the default pen table for plan production. This is used for all plans being submitted to 
Contracts with the exception for Title sheets for Highway users.  

We have combined four old pen tables into this default pen table. It substitutes certain text 
items (username, division, date, file name, etc.) into standard MDOT borders. 

This pen table lets you print out survey elements in a gray tone. Elements are changed to 
gray if they are in a reference file that has one of the following logical names: 

Topo, Text, Points, Contours, Topoadd1, Topoadd2, and Topoadd3. 

Gray elements, like Cross Section and Profile grids, are prioritized to plot underneath all 
black elements. Elements in these files that are weight 0 are changed to weight 1. 

Amendment.tbl 
This pentable will be used when sending electronic Amendment drawings to the one of the 
color plotters. All existing elements will be grayed, proposed will be black and Amendments 
will be green.  

As-Built.tbl 
This pentable will be used when sending electronic As-Built drawings to the one of the color 
plotters. All existing elements will be grayed, proposed will be black and As-Built elements 
will be red. Any Amendments will appear green.  

BORINGLOG.tbl 
This is used by Geotech to produce desired plots of their Boring Log sheets. 

ENV_PRINTER_COLOR 
This is used by Environment to produce the desired plots for 8 1/2” x 11” color Wetland 
Mitigation plans. 

Graysurvey_wetlands.tbl 
This is used by Environment to produce plans of Wetland delineation. This makes the 
Wetland bold so that they stand out on the plots. 

Heavytopo.tbl 
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This plots out the existing survey in black as opposed to graying it out as does the !pentable.  

MHPC.tbl 
This is used by Environment to produce a color plan set for plans to be submitted to MHPC. 
Use this pentable when sending for plots that utilize Level Symbology Overrides. 

MHPCplan-No Symbology 
This is used by Environment to produce a color plan set for plans to be submitted to MHPC. 
This pentable doesn’t use Level Symbology Overrides.  

Prelim_plan_color.tbl 
This is used by the Bridge Program to produce a colored preliminary plan. 

Title.tbl 
This is used by the Highway Program when printing a Title Sheets that has a Plan Layout. 
This adjusts dashed lines in the topo drawings so that they can still be displayed at the 
smaller scale. 

Hearing_Thicker.tbl 
These were set up for our Hearing Section in order to increase the weights of lines, by one 
stroke, at plot time.  

Hearing_Thinner.tbl 
These were set up for our Hearing Section in order to decrease the weights of lines, by one 
stroke, at plot time. 

PublicHearing.tbl 
These were set up for our Public Hearing Section to speed up the coloring process of metric 
projects. 

usPublicHearing.tbl 
These were set up for our Public Hearing Section to speed up the coloring process of U. S. 
Customary projects. 

Laserjetblack.tbl 
This option will force every color in your drawing to black. This was intended to be used 
with a Laser printer. 

Rowblack.tbl 
This option adjusts the processing order and forces all color to black except for color 46. 
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SINGLE SHEET PLOTTING (FENCE PLOTTING) 
Overview 
This procedure is for sending a single Plan Sheet to a plotter or printer at a desired scale 
using a fence. It requires that you are using a standard border drawing that has predefined 
boundary strings. There are two boundaries for Metric projects, one for an OCE plotter and 
one for HP1055CM or HP750C plotters. In our U.S. Customary projects the borders only 
have one string that will work for all plotters. All printers (8.5 x 11) use the same boundary 
string. 

Step One: Place a fence 

Click on the Place Fence icon and set the Fence Type to Element and the 
Fence Mode to Inside (Figure 1-24). 

 
Figure 1-24: Place Fence Options 

Click on the boundary string. U.S. Customary borders only have one boundary. For Metric 
projects, click on the boundary string that is used for the plotter you are plotting to. Zoom in 
on the top left had porting of your border to determine which shape is right for you (Figure 
1-25). (Outer dotted boundary is used for the OCE plotters; the inner solid boundary is used 
for HP plotters.) 

 
Figure 1-25: Metric border with two boundary strings 

Step Two: Select Print/Plot 
From the main menu select File > Print option. 

On the Print dialog, press the Magnifying Glass button or go to the menu and select 
File>Bentley Driver… (Figure 1-26). 
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Figure 1-26: Plotter Driver on the Print Dialog 

You should see a list of plot driver files pop up for you to select from. If you do not see the 
standard plot drivers, please browse to C:\!msInRoadsconf\standards\plotdrv. Select the 
plot driver that you want to plot to.  

 For a complete list of drivers, refer to page1-32. 

Step Three: Select Pentable (If Necessary) 
Select the pen table if necessary. The default table (!pentable) should be loaded, however if 
you want a different one, select Pentable>Attach from the menu and select the desired pen 
table. If you do not see the standard pen tables, please browse to C:\ 
!msInRoadsconf\standards\tables\pen. 

 Refer to page1-40 for a complete list of Pen Tables. 

Step Four: Modify Attributes (Optional) 
You now have the ability to modify attributes through the Print Dialog. In the past you 
would have to select Settings>View Attributes from MicroStation to turn off Construction 
Elements on single sheet printing. Now you can select Settings>Print Attributes… from 
the Print Dialog menu and toggle things on and off without effecting the display in your 
main view. 

Step Five: Preview Print (Optional) 
From your Print Dialog, you can preview your plot by either selecting from the menu 
File>Preview, clicking on the Preview icon (Figure 1-27) next to the Print icon, or you can 
simply expand the dialog by clicking the Show Preview to the right top of the dialog 
(Figure 1-27). 
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Figure 1-27: Preview Icon 

Step Six: Show More Details 
You can also get more information by selecting the Show Details expansion button in the 
lower right hand corner of the Print Dialog (Figure 1-28).  

 
Figure 1-28: Show Details 

Step Seven: Check Scale 
When you expand the dialog you will see information about your Print Size/Scale and 
Print Position (Figure 1-29). You may notice that the Scale:  shown in this image (3.2808’ 
to 1 M) looks incorrect. It really isn’t, this is the conversion factor of U.S. Customary to 
Metric. If you would like to see the correct scale you can change the settings to read feet to 
feet. This is done by selecting Settings>Units>FT from the Print Dialog menu. Now the 
scale should make more sense (Figure 1-30). 

 If the scale seems to be out of whack when switching the units then you may need to 
reopen the file or close out of MicroStation and come back in to see the correct factor. 
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Figure 1-29: Print Size/Scale & Print Position 

 
Figure 1-30: Print Size/Scale 

The Print Position settings displayed in the prior caption are fine as displayed. 

 When doing a fence plot and picking your plot driver you should not have to worry 
too much about the settings for Print Size/Scale or Print Position. 

Step Eight: Print 
If everything looks fine then hit your Print icon or File > Print… and send your print. 
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PLOTTING SHEET FILES (BATCH PRINTING) 
Overview 
This procedural manual will lead you through some routines involved in plotting sheet files 
(files named in the form of “001_HDPlan1.dgn” that contain standard borders.) 

Step One: Making a Batch Print Job 
The Batch Print utility (File > Batch Print/Plot(DOT)) is MicroStation’s “one-stop 
shopping” for plotting. It’s going to make sure our plots are made to the right scale, to the 
right plotter, and with the right elements showing or not showing. It will also allow us to 
plot out files one by one, in specific groups, or all at once. Naturally, this takes a little bit of 
setup... 

First, select File > Batch Print/Plot (DOT). This brings up the Batch Print dialog (Figure 
1-31).  

 Selecting the DOT option will open a dialog to your PIN directory, giving you the 
option to select a previously saved .job file. Hit Cancel if you would like to setup 
your own at this time. 

 The caption below is for U.S. Customary units, based off the working units of your 
project MicroStation will launch a different Batch Print dialog with changes to the 
Specifications Controlling Printing area. 
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Figure 1-31: Batch Print dialog 

This dialog allows you to create a Batch Print “Job.” A Job has two parts: a list of files and a 
list of specifications. The files are simply the .dgn files that Batch Print is going to plot for 
you, and they’ll be listed at the bottom of the dialog under the Design Files to Print area.  

The Specifications control how these files are going to be plotted, the extents to be plotted, 
which printer they’ll be sent to, which elements will be dithered, etc. There are four specific 
specifications: Printer, Print Area, Layout, and Display.  

Next, select the files you want to include in your Batchplot.  

 
Figure 1-32: Add Design Files 

Step Two: Add Design Files 
Push the Add Design Files button (Figure 1-32) on the Batchplot dialog.  

This brings up the Select Design Files to Add dialog (Figure 1-33).  

 
Figure 1-33: Select Design Files to Add 

Select all of your sheet files from the file list at the left. When they are highlighted, press the 
Add button at the bottom of the dialog. Don’t just select the files that you want to print right 
now. Pick all the sheet files in the job. Batch Print will allow you to print them out one at a 
time if you want. Notice the file names are now displayed in the Selected Files list. When 
you have added all the files, push "Done".  
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 MicroStation V8.5 and higher allows the user to sort their files in asending or 
decending order based on their file name. Click the Name column (acts like a toggle) 
to sort in either direction. Depending on the plotter you are sending it to will 
determine how you want to sort them. 

Step Three: Set Specifications 

Part One: Set Printer 
From the Specifications Controlling Plotting area, select the Printer line. The Printer 
specification chooses a plot output location and a sheet size. Push the Select Specification 
button to see the options (Figure 1-34).  

 
Figure 1-34: Batch Print Dialog 

Notice that there are many selections here (Figure 1-35). The capture only shows seven, 
however, there are many to choose from as outlined previously. Select the plotter you wish 
to plot to.  
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Figure 1-35: Select Printer Specification 

Depending on the printer and sheet size you want, select the printer (i.e. OCETDS860-full-
rm126) from the Select Printer Specification dialog and click OK. 

Part Two: Set Print Area 
The Print Area options determine what element you are looking for in a design file to print 
to. When plotting to a printer (81/2 x 11) select printer, printer_color or Standard Details. 
All other plan sheets should be plotted to the MDOT Standard option. 

 If this was a Metric project then you would leave the Print Area option set to OCE 
for the OCE plotters in Augusta and for Regional users it would be set to divisions 
for their HP plotters or OCE if they have one. 

Part Three: Set Layout (not necessary) 
The Layout specification does not need to be touched. 

Part Four: Set Display 
The Display specification controls which elements are plotted (for example, it can be used 
to turn off the display of all construction elements prior to plotting.) It is also responsible for 
attaching Pen Tables to the plot. We are using Pen Tables for a couple of purposes, 
including automatic sheet numbering and dithering survey information.  

Select the Display selection in the Specifications Controlling Printing dialog and push the 
Select Specifications button (Figure 1-34). 

 
Figure 1-36: Select Display Specification 

The default option is “oce” for Metric projects and “MDOT Standard” for U.S. Customary 
projects (Figure 1-36). This utilizes the !pentable and will make sure that sheet 
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numbering happens correctly, survey files dither in our plot, and that grid lines are plotted 
underneath the proposed design. For explanation of additional pen tables, refer to their 
breakdown previously outlined in this Chapter. 

Part Five: Save Job File 
Now that we have our file list and specifications set, it’s time to save this Batch Print Job. 
On the Batch Print dialog, select File > Save. This brings up the Save Job Set File dialog 
(Figure 1-37).  

 
Figure 1-37: Save Job Set File Dialog 

To make it easier to use this .job for the duration of the project type in a name that reflects 
both the sheet size and the plot location. For convenience, keep the .job file in your 
workgroups \msta directory of your project folder (this should be the default option.) When 
you’ve named the .job file, press OK. You have now successfully created a Batch Print Job. 

Step Four: Printing with Batch Print 
 MicroStation V8.5 and higher allows the user to sort their files in asending or 
decending order based on their file name. Click the Name column (acts like a toggle) 
to sort in either direction. Depending on the plotter you are sending it to will 
determine how you want to sort them. 

 Refer to the plotter listing to determine whether or not the plots will come out in 
asending or decending order. 

Now you can select one or more sheets to be plotted (using Ctrl key to pick and choose or 
Shift key to select a range). If you want to print all files, push print without selecting any 
files. 

Click the Print icon or select File>Print… 

The Print Batch dialog will open (Figure 1-38). If you made a selection, you will be 
prompted as such or if you did nothing, the all button will be defaulted. If you meant to 
select all, you can pick it now. After you make a selection, press OK. 
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Figure 1-38: Print Batch Dialog 

As the plots are being sent to the plotter, the progress will be displayed in another dialog. 
Wait until this is complete before trying to do anything else in your drawing. 

Batch Print Troubleshooting 
Batch Print also generates a Log File for troubleshooting purposes called batchplt.log. This 
file gets written to the same directory you are plotting from. Open Windows Explorer and 
browse to this location (i.e. Y:\pin\11146\00\Bridge\MSTA\). Open this file and look for an 
error statement or for the last file that was actually plotted. 

Some common problems are, the file does not contain the clip boundaries necessary to 
define the plot area, or a small filled shape exists on one of your drawings. An example of a 
small filled shape could be a radius of a side road that is shaded on a Title Sheet. In this 
case, select the whole drawing and scale it up 100 times. Now the shape should be able to be 
plotted. If this doesn’t work, consider hatching this area with close line spacing. 
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PRINTING FROM AN EXISTING BATCH PRINT 
JOB 

Once a Batch Print Job has been created for a project, printing is much more streamlined. 

To print a file (or a group of files) that is part of a Batch Print Job, first open the Batch 
Print dialog from File > Batch Print/Plot (DOT). This option will also automatically 
browse to your active PIN folder. 

Choose the existing .job file (Figure 1-39) you want to print from and press OK. 

 
Figure 1-39: Open Job Set Dialog 

On the Batch Print dialog, select the file or files you want to plot (Figure 1-40).  

 
Figure 1-40: Pick Files to Batchplot 

If you want to print all files, push print without selecting any files.  

From the Print dialog, you have the option of printing All files, or just the Selection of files 
you made in the previous step (Figure 1-41).  
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Figure 1-41: Batchplot Selection 

Once you make a selection, push the OK button. As the plots are being sent to the plotter, 
the progress will be displayed in another dialog. Wait until this is complete before trying to 
do anything else in your drawing. 
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CREATING LONG PLOTS 
Step One 
Make sure you have the Plan Settings Manager by choosing Settings > DOTSetMgrs > 
Plan Sheet Settings. This should be autoloaded for you. 

Right Click anywhere on the Settings Manager and choose Category > Scale and pick the 
scale you want to plot to (i.e. 1 in.=25 ft. or 1 in.=50 ft.). From the USPlan Settings 
Manager choose Long Plots > [5 foot/ 10 foot/ 15 foot/ 20 foot/Plan Sheet HP 
Plotter/Plan Sheet OCE Plotter] 

 It is important that you remember which border size you used in order to set your 
paper size when you print. 

Step Two: Placing the Cell 
You should see the plot boundary on your cursor. You will place it with two clicks. The first 
places the origin of the cell. The second allows you to spin the cell around the origin point 
(Figure 1-42).  

 
Figure 1-42: Long Plot Boundary 

Step Three: Rotate View 
Before we can print, we have to rotate our view. Select the Rotate View button in the lower 
left hand corner of window 1 (Figure 1-43).  
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Figure 1-43: Rotate View Button 

Select the 3 Points method from the Tool Settings Window (Figure 1-44).  

 
Figure 1-44: 3 Points Method 

The “three points” specify the x origin, positive x direction and positive y direction of your 
view. Choose your first two points by snapping to the two corners of the boundary.  

 Always define the two points in a left to right motion. 

Your third point defines the positive y direction. Snap to an area of the screen that would be 
above the left to right selection of the two previous points. 

 Picking these points in the wrong order can result in flipping your design upside 
down. Correct this by Rotating the view again, setting your Method to Top (Figure 
1-42). 

It is recommended to rotate your view horizontally as shown in (Figure 1-45). 

 
Figure 1-45: Vertical Long Plot View 

Step Four: Printing 
Place a fence on the boundary you just rotated. 

From the main menu select the File > Print option. 
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In the Print dialog select File> Bentley Driver… or the Magnifying button (Figure 1-46).  

 
Figure 1-46: Plot Driver on the Print Dialog 

You should see a list of plot driver’s display for you. Select a driver that matches the type of 
plot you are sending. Use a driver with “LONG” in the name for 5, 10, 15 or 20 foot long 
plots, or use a driver with “FULL or HALF” in the name for “Plan Sheet” size clips.   

The possible plot boundary shapes allow for a maximum plot size of 20 feet. There is no 
reason to change your Paper: size in the Printer and Paper Size area of the dialog (Figure 
1-47). Leave it set to the defaulted 20FTPLOT for any size. 

 
Figure 1-47: Page Setup on the Plot Dialog 

 Based on the rotation you used in your view, it may be necessary to toggle the 
Rotate 90 on or off to plot correctly (Figure 1-48). 
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Figure 1-48: Print Rotate 90 

 The processing time for long plots will be a little longer than a normal plot but we still 
need to be prompt in retrieving our plots so that they don't jam the plotter and also 
doesn't end up all over the floor. 
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FENCE PLOTTING TO SCALE 
It is easy to create a scaled print by placing a fence in the area you want. In the following 
example we are going to print an area to 1 in. = 25 ft. 

Step One: Place Fence 
Place a fence around the area you would like to print (Figure 1-49). 

 
Figure 1-49: Place Fence 

Step Two: Setting Scale 
Select File>Print from the Main Menu. Expand the Print dialog so you can see the Print 
Size/Scale area, in the lower left hand corner of the dialog. In (Figure 1-50) we have our 
Scale: options set to “’:” to 1 FT”, this means we need to apply an absolute scale of “300” 
(12 in. x 25 = 300) to get a 25 scale plot (Figure 1-51). You could change this option to “’:” 
to 1 IN.” by selecting Settings>Units>IN from the Print menu. This would allow you to set 
the Scale: to “25” (Figure 1-52). 

 You are only allowed to change the scale option to a larger number than what is 
displayed when opening the Print Dialog. If you can not get the desired scaled print 
you want then consider either making the fence smaller or changing paper size. 

If you have set your desired scale then select either the Print icon or File>Print… from the 
menu. 
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Figure 1-50: Scaled Printing by Fence 

 
Figure 1-51: Scale Change Master Units 

 
Figure 1-52: Scale Change Sub Units 
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COLOR PLOTTING 
Using a combination of file referencing techniques it's possible to make plans that will print 
out in full color. It requires that you put all of your color-filled areas in a single file, then 
reference that file to your border along with your line drawings. Use a color plotter (i.e. 
US_HPCOLORRoom303.plt) plot driver to make your final printout. 

File Setup 
Start by making a new file to put your coloring in. It's probably quickest to start by opening 
the file you want to color, then from the menu, select File > Save As or by selecting 
File>Make Sheetz. Name your file beginning with a "c_" prefix to point out that the file is 
color. 
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PLOTTING TO PDF 
Create MicroStation PDFs 

 A .pdf file is only a “snapshot” of the file at its present state. Any changes made to the 
MicroStation file will not be represented in the .pdf without recreating it. Without the 
PDF writer software, you can’t add and remove .pdf sheets as they change, you would 
have to re-create the whole multi-page .pdf or send them as single sheets. 

Option One: Creating a single PDF 
Creating a .pdf is as easy as printing to a plotter. A single file can be created as a .pdf by 
placing a fence around the drawings plot boundary and picking the plot driver pdf-fullsize 
(select the US version for US Customary project) from the plotdrv folder. The file will be 
created in your active MSTA directory. Print Exec Workgroup can use the .pdf to print full 
size or scale the .pdf to halfsize if that’s your desired hardcopy size. It is recommended that 
a user create a separate folder for the single .pdfs and replace older ones as changes to the 
drawings are made. 

Option Two: Batch Printing to a Multi-page PDF 
When Batch Printing, select the pdf-fullsize printer from available printers. Add the files 
you want to print, select pdf_bw-Fullsize from the available printers and select print. When 
the Print Batch dialog opens (Figure 1-53), add a file name and .pdf extension (i.e. 
FinalPlans.pdf) in the filename portion of the dialog. Do not remove the MS_DEF: variable. 

Depending on the plotter you are sending to, and it’s output orientation, consider sorting in 
ascending or decending order when using Batch Print to a multi-page PDF to receive the 
prints in the correct order. 

 
Figure 1-53 Print Batch dialog. Add the filename with the .pdf extension. 

The file will be created in your active MSTA folder. Print Exec Workgroup can use the .pdf 
to print full size or scale the .plt to halfsize if that’s your desired hardcopy size. 
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Printing PDF 
A user can print a PDF document as Full Size or Half Size, in reverse order and request 
multiple copies. When there are vertical sheet internally to the PDF, these sheets will need to 
be rotated 180 degrees in the hard copy plan set. To bypass this issue, the sheets can be 
rotated electronically to appear as landscape sheets along with the rest of the internal pages. 
This can only be done by someone with PDF Writer software. Either the Reproduction staff 
or someone with this Adobe Professional software can finalize the PDF for printing or 
simply rotate the stack of sections manually. 

Rotate Vertical Pages with Adobe Professional (Optional) 
Vertical Cross Section pages need to be rotated 90 degrees counter-clockwise so that they 
are printed correctly with the binding edges matching all the other pages in the plan set. 

Select the Pages tab and locate the vertical pages (if any exist). Select the first sheet that 
requires rotating. While holding the Shift key, scroll to the last vertical page. Release the 
Shift key. Right-click on the selected pages and select Rotate Pages… (Figure 1-54). 

 
Figure 1-54: Right-click and select Rotate Pages 

In the Rotate Pages dialog (Figure 1-55), adjust the Direction to Counterclickwise 90 
degrees. Verify that the Page Range is set to Selection. Click OK. 
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Figure 1-55: Rotate Pages dialog 

Save the PDF Document 
Select File>Save from the main menu. 

Print to OCETDS600 or OCETDS800 

Adding a Printer 
Printing the PDF will require that the OCETDS600 or OCETDS800 has been added as one 
of your available printers. If it isn’t, open Windows Explorer and browse to the 
\\Dot0dta1psprt02\ folder (or click the underlined link in the electronic document). Double 
click the OceTDS600-Rm312 or OceTDS800-Rm126 printer in the list (Figure 1-56). 

 
Figure 1-56: Double click the OceTDS800-Rm126 to add the printer 

Printing the PDF Document 
Open the PDF document. Select File>Print. Select the printer from the Printer Name pull 
down. Set the Print Range to All. Place a check mark in the Reverse pages box. In the Page 
Handling portion of the dialog, set the number of copies desired (if more than one, place 
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a check mark in the collate box), set the Page Scaling to None,  place a check mark in the 
Auto-Rotate and Center box and place a check mark in the Choose Paper Source by PDF 
page size box (Figure 1-57).  

 
Figure 1-57: Print dialog with adjustment made for a Full Size US Customary project 

Select Properties. Depending on whether you want a Full Size or Half size plot or whether 
it’s a metric or U.S. Customary project, will depend on the settings you choose. Select the 
Refresh button on the Basic tab to refresh the list of page sizes available and make the 
adjustments necessary. 

o Full Size U.S. Customary Project – Set the page size to Oce D 22x34 in. 

o Full Size Metric Project – Set the page size to Oce D+ 24x36 in. 

o Half Size U.S. Customary Project – Set the page size to Oce B 11x17 in. 

o Half Size Metric Project - Set the page size to Oce B+ 12x18 in. 

In addition to these setting, the OCETDS600 (only) will need one more 
adjustment for half size plots. Select the Layout tab (Figure 1-58). In the Custom 
Scale portion of the dialog, place a check mark in the Keep Aspect Ratio box. 
Adjust the Custom Scale to 50%. Click OK. 
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Figure 1-58: Adjusting the Custom Scale for Half size plots 

 The Preview portion of the Print dialog will not display the correct dimensions for a half 
size plot, however, the 50% scale will happen when it reaches the plotter. 

Select OK to start printing the PDF. A progress bar will appear displaying the printing 
progress. 
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PLOTTING TO PLT 
Create MicroStation PLTs 

 A plot file is only a “snapshot” of the file at its present state. Any changes made to the 
MicroStation file will not be represented in the plot file without recreating it. It is 
recommended that a user create a separate folder for the plot files and replace older ones 
as changes to the drawings are made. 

Option One: Single Sheet Printing to .plt 
Creating a plot file is as easy as printing to a plotter. A single file can be created as a plot 
file by placing a fence around the drawings plot boundary and picking the plot driver 
PLOT2FILE (select the US version for US Customary project) from the plotdrv folder. The 
file will be created in your active MSTA folder. This is a full size plot .plt(.000), however 
the Print Exec Workgroup can scale the image to halfsize if that’s your desired hardcopy 
size. 

Option Two: Batch Printing to .plt 
When Batch Printing, select the PLOT2FILE printer from available printers. The files will 
be created in your active MSTA folder. Print Exec Workgroup can use the .plt to print full 
size or scale the .plt to halfsize if that’s your desired hardcopy size. 
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USING PRINT EXEC WORKGROUP 
Overview 
This program is used to submit up to 100 files (per job) at once to the black and white 
OCETDS860 (Reproduction Room 126) & OCETDS600 plotter (RM312) at MaineDOT in 
Augusta. You can create multiple jobs when a project is over 100 sheets or create a multi-
page .pdf. The user can save and retrieve jobs when additional prints are necessary. The 
Print Exec Workgroup application is a replacement for the Oce Job Director that some 
people may have used in the past to send CADD plot files (.plt) or .tif images from a CD 
archive.It will not handle .dgn files directly. You must create one or the other to take 
advantage of the job capability in Print Exec Workgroup.  

Help 
This document is not intended to cover all options within Print Exec Workgroup. A PDF 
help document provided by OCE on their product fully describes everything you need to 
know about Print Exec Workgroup and more. A HELP menu is also available internal to the 
application. To review the PDF document, click this link  OCEPrintExecWorkgroup or 
browse to 
\\dot0dta1fscadd1\pcpin1\msworksp\documentation\mdot\OCEPrintExecWorkgroup.pdf . 

Plotters Available 

OCETDS860-rm126 
This plotter only has a table output delivery system which will print your jobs in reverse 
order unless you place a check make in the Reverse Order box. 

If sending a multi-page PDF, Batch Print in reverse order and do not place a check mark in 
the Reverse Order box. 

OCETDS600-rm 312 
The OCETDS600-rm312 has two paper outputs trays available. The “table” option where 
plots exit in reverse order or an “Ascending order” option using the intregated tray on the 
top of the machine for plots to be sorted in Ascending order. 

If sending a multi-page PDF, select the Ascending Order option as the preset configuration. 

Step One: Adding Files to Print Exec Workgroup 

Part One: Open Print Exec Workgroup 
Click here http://10.10.18.101 (OCETDS860-rm126) http://10.10.18.235 (OCETDS600-
rm 312) or open a webpage and type the IP in the address bar, or pick it from your favorites 
menu. Click on the page to activate the controls. The opening page displays the plotter 
information. Click the Submission tab (Figure 1-59). 

http://10.10.18.101/
http://10.10.18.235/
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Figure 1-59 Print Exec Workgroup Dialog 

Part Two: Select Add 
In the Documents portion of the dialog, click the Add button (Figure 1-59). Click cancel to 
any warnings pop up saying that a link can’t be found. 

Part Three: Browse to File Location 
Browse to your file location. Select them and click OK when finished adding files or Add to 
Job if you need to pick and choose files and/or browse elsewhere (Figure 1-60).  
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Figure 1-60 Add files dialog 

Part Four: Check “Reverse Order/Collate” 
Place a check in the Reverse Order button (Figure 1-59) so that the plots come out of the 
plotter with the last sheet first placing the first sheet on top (OCETDS860 or Table option on 
the OCETDS600). The OceTDS600 has a second paper handler for printing to Asending 
Order that doesn’t require Reverse Order sorting. Make a selection based on this 
information. 

Place a check in Collate (Figure 1-59) if printing multiple copies. 

Part Five: Select the number of Copies 
Change the number of copies if more that one is required (Figure 1-59). 

Part Six: Select Preset Plot Configuration 
Highlight your files or click the folder above them to select them all. Click the 
Configurations button (Figure 1-59). Change the radio button to All (Figure 1-61). For full 
size plots, select MicroStation_Fullsize. For half size plots, select MicroStation_Halfsize. 
Click Apply. Click OK. 
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Figure 1-61 Select the appropriate MicroStation size. 

Part Seven: Save Job with Documents (Optional) 
Supply a name to your “job” file if you will need to recall it in the future. Saving the job 
with documents makes the job very portable and the job file larger (Figure 1-62). Using this 
option isn’t necessary in most situations. 

 
Figure 1-62 Save Job Options 
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Part Eight: Save Job with Links Only (Preferred Method) 
Supply a name to your “job” file if you will need to recall it in the future. “Saving the job 
with links only” (Figure 1-62) makes the job file smaller and requires that your files (.pdf or 
.plt) are on the network. Make multiple job files for project with more than 100 pages in 
your plan set. 

Part Nine: Print 
Select the Print button. 

Recalling a Previous Job 
Click the Load button. Browse to your project location. 

 For more information on Print Exec Workgroup, please refer to the internal help file or 
click this link  OCEPrintExecWorkgroup to open OCE’s user manual.
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ELEMENT ATTRIBUTES 
Setting Attributes 
Every element placed in your MicroStation design file is placed with Attributes, including 
color, level, style, and weight. These are reflected in your Attributes Tools Box (Figure 
2-1). 

 
Figure 2-1: Attributes Tool Box 

When you go to change an Element’s Attributes, you can see these Active Attributes, along 
with another setting for your Active Class (Figure 2-2). 

 
Figure 2-2: Change Element Attributes Setting 

 Element Attributes can be matched by changing the Method to Match/Change. 
Making elements Class-Construction is a way of marking “junk” lines in 
MicroStation as. This makes it easy to avoid plotting them. You can turn off the 
display of Construction elements from the View Attributes dialog (Settings > View 
Attributes).  

Settings Manager 
You can let the Settings Manager take care of all these Element Attributes for you.  

For example, choose Exist. Roadway Lines > Sidewalks from the plan.stg Settings 
Manager (Figure 2-3). 
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Figure 2-3: Pick a Component 

This not only launches the Smartline command, it also sets your active color, style, weight 
and level for proper placement of existing sidewalk lines (Figure 2-4). 

 
Figure 2-4: Sidewalk Setting 

Level Display 
The Level Display (Figure 2-5) can be launched from the main menu by selecting Settings > 
Level > Display, Ctrl+E or click the Level Display on the Primary Tools tool box. 

 
Figure 2-5: Level Display Dialog 
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This is a simple overview of some of the management options using the Level Display.  

If the Reference Files or the active file is not displayed, Click on the + before the file, the 
Show Target Tree icon or Right Click and select Expand All from the menu to expand the 
file tree.  

To toggle the display of levels in a file, Click a level if being used (white on black with a 
dot in the Used column) it will turn the level off and changes the white to black. If the level 
is off when clicked the change will be from black to white and turned on. All levels can be 
toggled by Right Clicking on a level and selecting All On or All Off from the menu. To 
turn off levels graphically, select the Change Level tool (Figure 2-5), in the Level Display 
dialog box, select the Change Level icon, choose Level: Display Off from the Change Level 
Dialog (Figure 2-6) and Data Hit the Element on the screen. 

 
Figure 2-6: Change Level Dialog 

The whole Reference File can be toggled by Right Clicking on the file and selecting 
Reference On or Reference Off from the menu. 

Level Manager 
The Level Symbology is now manipulated with the Level Manager (Figure 2-7). The Level 
Manager shown below does not display all of the columns available. By Right Clicking on 
the Used column header a menu appears showing other unchecked columns available. The 
Level Manager is displayed by clicking on the Active Level on the Status Bar, Ctrl+L or 
the Level Manager icon on the Primary Tool Box.  

 
Figure 2-7: Level Manager Dialog 
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Most of our element symbology is set using the Settings Manager dialog. On occasion for 
viewing or plotting color, weight, or style needs to be manipulated without make actual 
changes to the element symbology. If necessary the File Tree can be expanded by clicking 
on the + beside the Active File in the Level Manager Dialog. Elements Symbology on every 
levels of each file can be changed by selecting the file on the left and the level from the right 
of the Display Manager. By clicking the checkmark in the Global Display column the 
graphic display of that level will be toggled on or off. 

To use symbology by level switch the Symbology option to ByLevel. Click the desired 
Level Name, change the Color, Style and/or Weight and click OK to accept the change. 

To override the symbology of a level switch the Symbology options to Override. Right 
Click on a level will bring up a menu with other options.  

To view the symbology changes Check on Level Symbology and Apply in the View 
Attributes dialog (Settings>View Attributes or Ctrl+B). When the Level Symbology is 
uncheck the element attributes will return to normal. 
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SNAPS 
Most of the elements placed are connected to previously placed elements. Snaps are use to 
accurately place points on a drawing. To tentative hit on an element Snap Lock has to be 
toggle on. To view the Locks (Figure 2-8) from the main menu Settings>Locks>Full or 
click the Lock on the Status Bar and select Full.  

 
Figure 2-8: Locks Dialog 

A Snap Mode can be locked by changing the Mode: in the Snap field of the Locks Dialog or 
by holding down the Shift key and selecting the Snap Mode from the Status Bar. To use the 
snaps for one snap, use AccuDraw shortcuts for some or select the snap from the Status Bar. 
For a complete list of AccuDraw shortcuts, click in the AccuDraw and type “?” (Shift+?). 
To view all the available Snap Modes: Settings>Snaps>Button Bar or click the Snap Mode 
on the Status Bar and select Button Bar. Right Click on one of the icons on the Snap Mode 
Dialog (Figure 2-9) and a menu of all the snap mode which can be toggled will appear. 

 
Figure 2-9: Snap Mode Dialog 

Below is view and brief description of the available snap modes. 
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AccuSnap 
By hovering near a Keypoint of an element with the curser AccuSnap will display that 
point, the element, the type, level name and allow a Data Point to be placed at that point 
without a Tentative Snap (Figure 2-10).  
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Figure 2-10: AccuSnap 

AccuSnap can be toggled from the Snap Mode Dialog or the AccuSnap Setting Dialog. More 
settings are available with the AccuSnap Setting Dialog Element and Feel tabs.  

Keypoint 
Keypoint is used to snap to point on arcs or lines. The number of Keypoint on an element is 
set in the Keypoint Snap Divisor Dialog (Figure 2-11). The dialog can be open by typing K 
in your AccuDraw Window. The division can also be set from the main menu Settings > 
Design File>Snaps. 

 
Figure 2-11: Keypoint Snap Divisor 3 

Intersection  
The Intersection Snap is used to locate the intersection of two elements. Locate one of the 
elements with a tentative snap which will highlight the element and just hover over the 
intersecting element with the curser and accept with a data snap when the AccuSnap appears 
on the screen. If AccuSnap is toggled off two tentative snaps, one on each element and a data 
snap to accept the point will be needed. You can continue snapping until the desired 
intersection is found; the last two tentative snaps define where the intersection point lies. 

If the two elements do not actually intersect a point will be a projection where of one or both 
elements would intersect.  

Center 
The center snap can be used to snap to the center of a line, shape, circle, cell, etc. It requires 
one tentative. The tentative has to be placed on the outside of the shape – do not try to 
eyeball it and snap near the middle. (Eyeballing actually will work with circles, but not 
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with other shapes.) If AccuSnap is on, hover near the element and data hit when the 
AccuSnap appears. 

Nearest 
The nearest snap is used when you absolutely, positively have to get a point on an element, 
but you don’t care (or don’t know) exactly which point. 
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VIEW CONTROL 
Overview 
There are a number of view controls that you will use on a daily basis. You might want to 
edit your Function Keys to give you quick access to them. They include Zooming, Fit View, 
View Previous and View Next.  

More Advanced view controls deserve another look. 

Rotate View 
Choosing the Rotate View (Figure 2-12) command gives you a number of choices.  

 
Figure 2-12: View Rotation Methods 

The majority of these Methods relate to 3D view control. Remember that Top view is the 
default and always a safe starting point. 

3 Points is the method of choice for rotating a view to something other than the default. The 
3 points that you enter correspond to an xy axis. The first point is xy of zero (the coordinate 
origin). The second point defines the direction of the positive x-axis. The final point defines 
the direction of the positive y-axis.  

 It is beneficial to have depth lock turned on for this operation.  

3D Troubleshooting 
Sometimes you will get unexpected results when you are working with 3D files. There are a 
couple of tricks that you can try out.  

Flattening is always a good start.  

Also make sure to rotate your view to “top.”  
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COMPLEX CHAINS AND SHAPES 
Overview 
Adjacent lines and arcs can be grouped together into Complex Chains and Shapes. 

Creating Complex Chains 
Use the Create Complex Chain tool to combine adjacent lines and/or arcs into a linear 
(non-closed) element. 

 This allows you to measure length and construct distances along the combined 
element. It also speeds up modification and manipulation. 

Activate the Create Complex Chain tool either from your Main Tool Frame (Figure 2-13) 
or from your main menu by selecting Group > Groupings > Create Chain. 

 
Figure 2-13: Create Chain 

Using the Manual option, MicroStation prompts you to “Create Complex Chain > Identify 
Element.” Pick each element you’d like to add to the chain, in order, until you have selected 
the entire chain.  

 Make sure to Accept the final element in the chain. 
Reset to complete the chain. 

Using the Automatic option, MicroStation will prompt you to “Automatic Create Complex 
Chain > Identify Element.” Once you have picked that element, just Data Point to Accept it 
and MicroStation will automatically highlight the next element in the chain.  

 MicroStation will jump gaps to complete these chains. Set the Max Gap value to tell 
it how far to look. 

Keep Accepting until MicroStation completes the Chain.  

If there is a fork in the path, MicroStation will highlight one possible path and prompt you 
with the statement “FORK – Accept or reset to See Alternative.” Send a Reset if you don’t 
like the path MicroStation has chosen. 
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Creating Complex Shapes 
Use Create Complex Shape to combine adjacent lines and/or arcs into a closed (non-linear) 
shape. 

 This allows you to measure length and area and construct distances along the 
element. You can also fill, pattern, or hatch the resultant area. It also speeds up 
manipulation and modification of the element. 

Choose Create Complex Shape from the Main Tool Frame (Figure 2-14) or choose 
Group > Groupings > Create Shape from your main menu. 

 
Figure 2-14: Create Complex Shape 

Note that you have some of the same options here that you had in the Create Complex 
Chain Tool Settings Window.  

Manual and Automatic creation procedures are much the same for Shapes as they are for 
Chains.  

One notable difference is the fact that Shapes are only complete when they are closed. As 
soon as a Shape is closed by Manual or Automatic creation, the creation is immediately 
completed.  

 If the end of the final segment does not correspond to the beginning of the first 
segment, MicroStation will draw a line that makes that connection. 

Area 
There are two choices for Area when you are creating a Complex Shape. They are Solid 
and Hole.  

 This property is only relevant to Hatching. Hole elements cannot contain Hatching 
or Patterning elements.  

It is strongly recommended that you do not ever place Hole elements in your drawing. It 
only leads to unnecessary confusion. 
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Fill Type 
If you would like your resultant Shape to be either Outlined or Opaque you can make that 
selection here before you create the Shape. 

Troubleshooting 
Creating Complex Chains and Shapes is a fussy business: sometimes just a slight error can 
lead to unexpected results. 

Extra Elements 
Probably the most common mistake in creating Complex elements happens when the user 
Resets before the element is entirely finished. They realize they haven’t created the entire 
Chain, and they go back to the beginning and re-create it.  

The problem with this is that even though the first chain wasn’t complete, it is still a 
legitimate element and MicroStation doesn’t know that the user doesn’t want it. 

This ends up leaving all kinds of partial chains kicking around in your file. 

 As a rule of thumb, don’t forget to Undo your aborted efforts at creating Chains and 
Shapes before you go back and do it again. 
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COMPLEX REGIONS 
Overview 
While Complex Chains and Shapes are created by combining single, entire, simple elements, 
Complex Regions are Closed elements created through a more complicated interaction of 
multiple and potentially complex elements. 

Launching the Tool 
Choose Create Complex Region from you Main Tool Frame (Figure 2-15) or from your 
menu by choosing Group > Groupings > Create Region. 

 
Figure 2-15: Create Complex Region 

Complex Region Methods 
In your Tool Settings Window you have four Methods to choose from. Starting from the 
circles and line in Figure 2-16, these four methods have the following effect: 
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Figure 2-16: Starting Point 

Intersection 
Intersection creates a Complex Region out of the area where the two shapes overlap. 

Choosing the two circles, the Intersection looks like Figure 2-17. 

 
Figure 2-17: Intersection 
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Union 
Union creates a Complex Region out of the outermost boundary of the shapes chosen. 

Choosing the two circles, the Union looks like Figure 2-18. 

 
Figure 2-18: Union 

Difference 
Difference creates a Region that is the outside of the first chosen element, minus the outline 
of the subsequently chosen shapes.  

Choosing first the top circle, then the bottom, the Difference looks like Figure 2-19. 
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Figure 2-19: Difference 

Flood 
Flood defines an area by searching for enclosing elements around a Data Point sent by the 
user.  

Sending a Data Point into the right side of the area where the two circles overlap looks like 
Figure 2-20. 

 
Figure 2-20: Flood 

Fill 
Note you have the same Fill options with Create Complex Region that you had with Create 
Complex Shape. 

Keep Original 
The examples above show the behavior of Create Complex Region with Keep Original 
disabled. Every element that contributes a piece to the resultant Region is deleted. 

If you do not want these elements deleted, enable Keep Original from the Tool Settings 
Window (Figure 2-21). 
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Figure 2-21: Keep Original 

Tips and Tricks for Flood 
In congested areas on the drawing, it is sometimes difficult to use the Flood Method. Often, 
MicroStation will not find the correct Enclosing Region.  

PowerSelector  
To simplify matters, start by using the PowerSelector to pick only the elements that make up 
the outline you want to create a region from. Now use Flood and data point somewhere in 
this area. Flood will look only for highlighted elements when it looks for an enclosing 
region. 

Adjust Max Gap 
If MicroStation can’t find an enclosing region, you may have some slight gaps between 
elements. Try changing your Max Gap value to a higher number (Figure 2-22). If you have 
to set it higher than .1, you may need to make sure that your file is flat and that you have 
selected all of the elements that make up your boundary. 

 
Figure 2-22: Create Region dialog – Max Gap 

 Check Flattening your Active File on page 2-87. 

Set/Lock Z to Zero 
Another macro that will help make sure that you are measuring on the same plane and get 
the correct area measurement is called ZLOCKANY. This macro is kicked off by selecting 
Macros>Set/Lock Z from the Main Menu and setting the active depth to “0” in the 3D 
file.  
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IINNTTRROODDUUCCTTIIOONN  TTOO  TTHHEE  
SSEETTTTIINNGGSS  MMAANNAAGGEERR  

The Settings Manager is our one-stop-shopping for establishing standard MicroStation 
procedures and properties. We are going to use it to develop everything from standardizing 
text height to launching macros.  
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STRUCTURE OF THE SETTINGS MANAGER 
The Settings Manager works kind of like a menu structure: it has Groups and Components. 
Groups are like menus and Components are like the items on the menus. Picking a Group 
without picking a Component is kind of like opening up a menu without selecting an item: 
nothing happens. Think of the Components as buttons that need to be pushed to make 
something happen. When you haven’t picked a Component, you haven’t really done 
anything. Settings Managers are used to place elements on the proper level with correct 
weight, style and scale.  

The Many Faces of the Settings Manager 
One of the most confusing aspects of the Settings Manager is that it can take on a couple of 
very distinct appearances. Figure 2-23 shows what the Settings Manager looks like as a 
Large Dialog.  

 
Figure 2-23: Settings Manager Options 

This Large Dialog can be resized into the Small Dialog by choosing Options > Small 
Dialog from the Select Settings dialog. This will transform the Settings Manager to look 
like Figure 2-24.  

 
Figure 2-24: Small Settings Manager Dialog 

From here, we can choose Options > Large Dialog to return to the large dialog, or we can 
pick Options > Hide Menu Bar to make the dialog even smaller (Figure 2-25). 
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Figure 2-25: Even Smaller Settings Manager Dialog 

When the menu bars have been hidden, the only way to used item on the menu is by right 
clicking on the Settings Manager. This gives you the same options that were previously 
available from the Select Settings dialog’s menu (Figure 2-26). 

 
Figure 2-26: Right-click for Menus 

The Settings Manager can be docked when in Small Dialog mode (Figure 2-27). The usual 
location for the Settings Manager is at the bottom. It is a user preference and is reloaded to 
the same location as when MicroStation is closed. 

 
Figure 2-27: Docked Settings Manager 

Opening the Settings Manager 
The Settings Manager is autoloaded depending on the work group and the working units of 
the file, if the file is opened using the MicroStation Manager and a PIN is selected. Task-
specific Settings Managers can be launched from your main menu by selecting Settings > 
DOTSetMgrs > [Task] or File>Open from the Settings Manager Dialog and selecting the 
.stg from Open Existing Settings File Dialog. 
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SETTINGS MANAGER SCALE 
One of the primary functions of the Settings Manager is to help us standardize text and 
dimension size. It can also help us make sure that our symbols and cells all come into our 
drawings at the right size. This is accomplished through careful manipulation of the Settings 
Manager Scale.  

Real World Size Vs. Paper Size 
There is some confusion over the concept of drawing “One to one” or “Full Size” and how 
that impacts the scale of the drawing. If you’re drawing one to one, how could you possibly 
have a scale applied? Isn’t everything full size?  

The answer is “yes -- but there is more than one kind of full size.” 

How is that possible?  

The AutoCAD terminology for this calls the two sizes “Paper Space” and “Model Space.”  

When you’re detailing up an abutment, you want to make sure that a 6 meter wing measures 
6 meters on the drawing -- that’s “Model Space” -- your “Model” of the abutment measures 
the same size in your file that it will measure out in the field. 

But what about when you want to annotate the abutment? You know that when you get your 
finished plot back from the printer you want your annotation text to be 3 millimeters high. 
But what does that 3 millimeters mean to your 6-meter wing? Nothing -- because those 3 
millimeters are in “Paper Space” instead of “Model Space.” 

So how do you reconcile the two? That’s where the Setting Manager Scale comes in.  

Selecting a Scale 
Right-click on your Settings Manager to open your options menu and select Category > 
Scale (Figure 2-28). 

 
Figure 2-28: Right-click on the Settings Manager 

This opens up the Select Scale Dialog (Figure 2-29). 
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Figure 2-29: Select Scale Dialog 

Let’s say we select 1in. = 25 ft. (1:300) as our scale.  

What does this change? 
What does this do for us? All this does is alert the Settings Manager to our intended plot 
scale. From here on out, anything that we launch from the Settings Manager is going to 
know that it needs to be at the selected scale. We’ll see the impact of this when we use the 
Settings Manager to place text and dimensions, as well as certain cells, linestyles and 
borders. It does this by changing the text height or by setting the Active Scale. It does not 
change the size of elements in your drawing. 

 Note again that this has no impact on items already placed in the drawing.  

This is not at all like changing our Working Units. Settings Manager uses its internal scale 
settings only to help you place new text and cells at the right size. Once your text has been 
placed, you can do whatever you want to your Settings Manager scale and it will not impact 
the text on your drawing (however, as soon as you place more text by selecting Text > Text 
Note from the Settings Manager, it will set your text size to reflect your current Settings 
Manager Scale.)  
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SETTINGS MANAGER WORKING UNITS 
Another thing that we are going to use Settings Manager for is to control our Working Units 
settings. This is going to help us to draw imperial details on a Metric sheet and vice versa. 

 A better way to accomplish this is to pick Macros>Unit Swap (m<->’). This toggles you 
from one set of working units to another (Feet to Meters).  

Choosing a Working Units Setup 
From the Settings Manager choose Category > Working Units...(Figure 2-30) 

 
Figure 2-30: Category > Working Units 

This will open up the Select Working Units dialog (Figure 2-31). 

 
Figure 2-31: Select Working Units 

The Defaults 
All metric work should be done in meters. 

All imperial work should be done in imperial. 

All the other options are maintained only for backward compatibility.  

Switching to U S Custom 
If you are working in meters and you need to draw up an existing detail that is dimensioned 
in U S Custom units, you can switch your Working Units temporarily to imperial. Make 
sure to switch back to meters when you’re done. 
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FFEENNCCEESS  &&  GGRROOUUPPSS  
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SELECTION SETS 
Select All 
From your main menu, choose Edit > Select All. MicroStation will pick every element in 
your file. 

 Even elements that are not currently displayed will be selected. This includes 
construction elements and elements on levels that have been turned off. 

Select None 
To clear a Selection Set, you can always choose Edit > Select None from your main menu. 

Element Selection 
The Element Selection tool (Figure 2-32) can be used to pick single or multiple elements for 
processing.  

 
Figure 2-32: Element Selection 

 Use of Element Selection changes the order in which you pick commands. Generally 
you pick your command first, then the element you want to affect. Using any 
element selection tool, you pick your elements first, then the command to alter them. 

To select more than one element, hold down the Ctrl key when you click on new elements. 
If you select the wrong element, hold down the Ctrl key and click on it again to remove it 
from the Selection Set.  

 Notice that when you add elements to a Selection Set, MicroStation displays the 
number of elements you have selected. This number is displayed in the right corner 
of your Status Bar as shown in Figure 2-33. 

 
Figure 2-33: Count of Elements 

To select elements over a wide area, click in empty space and drag. This will create a box. 
Elements entirely inside this box will be added to the Selection Set. 

If you hold down Ctrl + Shift and drag the same box, it will add all elements overlapping 
the box to the Selection Set.  
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PowerSelector 
The PowerSelector (Figure 2-34) is a more powerful way of quickly assembling Selection 
Sets.  

                    
Figure 2-34: PowerSelector   Figure 2-35: PowerSelector Tool Settings Window 

The PowerSelector has a number of Methods and Modes of operation (Figure 2-35). 

By changing Methods and Modes, elements can be added, subtracted, or inverted to a 
Selection Set. 

Methods 
By changing your Method, you can identify items singly, by block, shape or line.  

Individual: selects graphically one element at a time  

Block Inside:  elements inside the block are selected 

Block Overlap: overlapping elements plus those inside the block are selected 

Shape Inside:  elements inside a shape are selected  

Shape Overlap: overlapping elements plus those inside a shape are selected  

Line: selects elements that intersect a line  

Modes  
Add: adds elements to a selection set 

Subtract: subtracts elements from a selection set 

Invert: toggles the selection status of an element  

New: clears the current selection set and starts a new set. 

Clear/Select All: deselects all selected elements, or selects all elements if no elements are 
currently selected. 

 Block and Shape Methods can be switched from Overlap to Inside just by clicking 
again on the respective icon in the Tool Settings Window.  

“Permanent” Grouping 
Once you have elements gathered together into a Selection Set, you might want to “cement” 
them together. 

With the elements selected, pick Edit > Group.  
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Notice that once you have grouped elements together, the number of elements in your 
Selection Set drops to “1”.  

These elements have been joined together the same way elements of a cell are joined 
together. The only difference is that these “cells” don’t have cell names. MicroStation refers 
to them as Orphan Cells. They can be modified and manipulated exactly the same way cells 
are. To drop these Orphan Cells back to their original independent state, use the Drop 
Complex tool.  
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ADVANCED POWERSELECTOR 
Setup 
There is a little arrow in the lower right-hand corner of the PowerSelector Dialog (Figure 
2-36). 

        
Figure 2-36: Show Selection Information     Figure 2-37: Expanded PowerSelector 

To expand the PowerSelector click on the Show Selection Information arrow to reveal the 
Attribute tabs (Figure 2-37). 

Tabs 
Lv (Level): select levels from a list  

Co (Color): select the required colors from a list (plus By Level). 

Lc (Style): select the required line styles from a list (0–7 plus custom line styles present) 

Wt (Weight): select the required line weights from a list (0–31 plus By Level). 

Ty (Type): select the required element types from a list. 

Cl (Class): select the required element classes from a list. 

Adding Elements 
Say you want to add all elements in a level to your Selection Set.  

Start by choosing Lv tab from your Tool Settings Window. 
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Now Click the Level Name from the list of level names. Notice that the elements are 
highlighted and the level name moves to the top of the Lv list (Figure 2-38). 

         
Figure 2-38: PowerSelector Lv Dialog   Figure 2-39: PowerSelector Co Dialog 

All elements on PAY TREES level have been added to your Selection Set.  

Now add all elements of color 2 to the set by choosing Co tab from the PowerSelector. 
Notice that Color 3 is at the top of the list (Figure 2-39). 

The Color 3 is the color of elements already selected (elements on the PAY TREES level 
that was selected above from the Lv tab). To add color 2 to this list, Click the cursor in the 
“color 2”. Notice in (Figure 2-40) number 2 moved to the top with 3. All the elements with 
the color 2 have been added to the Selection Set. 

 
Figure 2-40: PowerSelector Co 2,3 

 This does not mean that all elements of color 2 and 3 are selected: it only means that 
there are elements of these colors in this Selection Set. 
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Subtracting Elements 
You can also use this feature to remove specific colors, levels, styles and weights from your 
selection set. Start by selecting all Levels that have elements, either by choosing Edit > 
Select All or by Clicking on the first level that is not high lighted and dragging to display 
all of the levels and release. Now check out the Lv tab, all the levels that are present in the 
Selection Set (Figure 2-41) have elements. 

 
Figure 2-41: All Levels Picked 

Clicking on the level name will remove all the elements on that level from the Selection Set.  

Color, Style, Weight, Type and Class 
By Clicking on the list from Color, Style, Weight, Type and Class tabs the elements can be 
manipulated the same way as the Levels. 
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SELECT BY ATTRIBUTES 
Overview 
Select By Attributes is an extremely useful tool for making focused alterations to a design 
file. You could use it to help accomplish any of the following: 

Move all text to MINOR. 

Delete all lines that are Color 5 and Weight 4. 

Change all elements on PBSUPER to be Construction elements. 

The Select By Attributes tool allows you to specify certain Element Criteria. It then searches 
through the file and selects elements that match those search criteria. 

The Select By Attributes Dialog (Figure 2-42) can be opened from the main menu by 
selecting Edit > Select By Attributes. 

 
Figure 2-42: Select By Attributes 

Standard Methods 
The simplest application of the Select By Attributes tool uses the default settings. 

In the Levels, Symbology and Types areas of the Select By Attributes dialog pick your 
search criteria. The example in (Figure 2-43) shows what the dialog would look like if you 
wanted to pick all text in levels PRPTY ENVRN and RIGHT OF WAY that is also of 
color 5. 
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Figure 2-43: Select By Attributes Dialog 

 Note that since Style and Weight are not selected, this process will identify elements 
of any style or weight. 

Push the Execute button and MicroStation will add all elements that match these criteria to a 
Selection Set. 

Element Type Hints 
The Types are of the Select By Attributes Dialog is not always straight forward. Here are a 

few hints that should make it easier to select the elements you want. 

Multi-line text is Text Node type. Single-line text is the Text type. Typically, if you want 
one, you want both of them. 

For circles, the Type you want to choose is Ellipse. 

To pick Smartlines with arcs in them, choose the Complex String type. 

Similarly, any closed area with arcs would be the Compels Shape type. 

Smartlines without arcs are Line Strings.  

All closed polygons (squares, triangles, rectangles, etc.) are Shapes.  

Leaders placed by the Place Multi-Line Note tool are Dimension types. 

Right Clicking in the Levels and Types fields Select By Attributes Dialog gives the option 
to Select All, Select None or Invert Selection. 

Elements grouped together by selecting Edit > Group are Cells. 
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ADVANCED SELECT BY ATTRIBUTES 
Overview 
Up until now, we have only used the default Mode settings of the Select by Attributes tool. 
These are good enough to get you where you need to go 90% of the time. But there are a few 
things you might want to do that you’ll need some extra help with. For example, you might 
want to: 

Pick all elements except text. 

Delete all color 5 lines from one part of your drawing. 

Move all filled elements to level CENTERLINE. 

Delete all text of font 24. 

Modes 
The first thing to look at is the Modes section of the Select By Dialog. There are two areas 
we’ll focus on. The first allows you to select either Inclusive or Exclusive modes (Figure 
2-44). 

 
Figure 2-44: Inclusive/Exclusive  

Inclusive, the default setting, means that all elements that match your criteria will be 
affected. 

Exclusive means that all elements except those that mach your element criteria will be 
selected.  

 Therefore, to pick all elements except text, set your Type field to Text and Text 
Node, set your Mode to Exclusive and push Execute. 

The other parts of the Mode allow you to choose how you want to act on the elements you 
have selected (Figure 2-45). 

 
Figure 2-45: Selection/Location/Display 
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Selection, the default settings, adds the identified elements to a Selection Set.  

Location allows you to “lock down” elements other than your identified elements. Only 
elements that match your criteria will be accessible to MicroStation commands. This will 
prevent you from copying, matching, or deleting any but your identified elements. 

Display makes all other elements invisible. Only elements that match your criteria will show 
up on your window. 

 Using the Display mode will have minor adverse effects on “dynamic” displays. This 
means fences, selection sets and other “rubber-banding” affects may not display as 
you’d expect. All the tools still work as normal, though. 

Properties 
At the bottom of the Select By Attributes Dialog you will find the Properties button 
(Figure 2-46). 

 
Figure 2-46: Properties 

Pushing this button gives you access to more element selection criteria via the Select By 
Properties Dialog (Figure 2-47). 

 
Figure 2-47: Select by Properties Dialog 

Two parts of this dialog are likely to be useful to you. 

From the Properties portion, you can place a Check next to the Non-Filled option and 
choose to select by whether or not an element is Filled. 

From the Class area, you can select whether you want to pick Construction or Dimension 
elements. 
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 Even after you drop Dimensions into their component elements, those elements are 
still in the Dimension Class and can be selected together by the Class portion of the 
Select By Properties Dialog.  

More Properties 
From the Select By Attributes Dialog, you can open up four more dialogs that control 
settings for specific kinds of elements under the Settings Menu (Figure 2-48). 

 
Figure 2-48: Settings Menu Properties 

These options allow you to select cells and text by very specific element attributes. 

Set Select By From Element 
If you don’t know exactly what attributes you want to select by, but you know of an element 
on your drawing that is an example of those criteria, you can choose Tools > Set Select By 
From Element from the Select By Attributes Dialog Main Menu.  

This brings up the Set Select By Dialog (Figure 2-49). 

 
Figure 2-49: Set Select By 
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Toggle on or off each item on the dialog depending on whether you want to select based on 
that criteria, then identify the element in your file to match.  



mdot MicroStation 
07/01/07 

General Tools 

2-39 

 

FENCES 
Discussion 
With all the capability of the Element Selection tools, you could ask if there is really any 
need for another way of grouping elements. 

Fences are more of an old-fashioned way of working in MicroStation, and they are not as 
necessary for day-to-day drawing as they used to be. 

There are, however, some important reasons to keep fences in your arsenal. 

One is processing time. If you have to move a lot of elements, it is usually quicker to fence 
them than to select them. This is because the selection tools require more redrawing of the 
elements to the views. 

Another reason to use fences is to clip elements by setting your Fence Mode to either Clip or 
Void-Clip. 

A less common application would be to use the Void mode to process all elements outside 
the fence boundary. 

Fence Types 
When you choose the Place Fence tool (Figure 2-50) you have a number of options of what 
kind of Fence you would like to place (Figure 2-51). 

                
Figure 2-50: Place Fence       Figure 2-51: Fence Types 

Block allows you to define two corner of a rectangle. 

Shape allows you to define up to 101 vertices of a polygon. 

Circle allows you to define a center and radius for a multi-vertex polygonal approximation 
of a circle. 

 This is not really a circle, but it’s pretty close. Use it accordingly. 
Element allows you to pick an element. MicroStation will approximately overlap the 

Element’s outline with a fence. 

From View will place a fence that matches the view outline. 

From Design File will pick all elements in the design file. 

Fence Modes 
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Once you have placed a fence, you can change your Fence Mode to affect elements that are 
either Inside or outside your fence, Overlapping it or not, or even Clipping elements at the 
point that the fence crosses them (Figure 2-52). 

 
Figure 2-52: Fence Modes 

Inside affects only elements entirely inside the fence. 

Overlap affects elements with any part in the fence. 

Clip affects all elements inside the fence, cutting elements where they cross the fence 
boundary. 

Void affects all elements entirely outside the fence. 

Void-Overlap affects all elements with any part outside the fence. 

Void-Clip affects of all elements outside the fence, cutting elements where they cross the 
fence boundary. 

Points to Ponder 

Area of Influence 
Selection Sets specifically identify particular elements. No matter how you process them, 
you never will process elements other than the ones you initially selected. This is not the 
way Fences work.  

Fences always affect the elements that lie within their selection area (bearing in mind your 
active Fence Mode.) Every time you move or copy a fence from one location to another, you 
are defining a new area of influence, and can potentially be picking up new elements to 
process. 

3D Windowing 
Fences in 3D files are view-specific. 

 Fences must be in your view at all times or they will be deactivated and you will need 
to place them again. Be careful when you zoom and pan. 

Deactivating Fences 
The way to deactivate a fence is to choose the Place Fence tool. This immediately clears 
your active fence. 
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GRAPHIC GROUPS 
Overview 

 Graphic Groups are common even if you don’t create them yourself: they are often the 
by-product of translations or custom applications. Be aware of their functionality. 

Graphic Groups are yet another way to bunch elements together for quick processing. They 
are more like Selection Sets than fences, since they single out specific elements rather than 
affecting all elements in a specific are the way fences do. 

Graphic Groups have one special capability: elements in Graphic Groups can be moved 
independently or simultaneously depending on the current status of your Graphic Group 
Lock. 

Graphic Group Lock 
Graphic Groups rely on the Graphic Group Lock. This can be toggled on and off from the 
Locks portion of your Status Bar (Figure 2-53). 

 
Figure 2-53: Locks in the Status Bar 

When the Graphic Group Lock is turned on, all elements in the same Graphic Group are 
grouped together much like a single cell or Selection Set: they can be copied, rotated, moved 
or deleted as one. 

However, when the Graphic Group lock is turned off, the elements are all affected 
completely independently of each other.  

Adding Elements to a Graphic Group 
Elements can be added to a graphic group either singly or by Selection Set.  

To add elements one at a time, choose Group > Groupings > Add to Graphic Group from 



mdot MicroStation 
07/01/07 

General Tools 

2-42 

 

your main menu, or pick the Add to Graphic Group tool from your Main Tool Frame 
(Figure 2-54). 

 
Figure 2-54: Add to Graphic Group 

Once the tool is activated, pick all the elements you’d like to add to the group.  

To add a bunch of elements to a Graphic Group, add them to a Selection Set (by 
PowerSelector, for instance). Then choose the Add to Graphic Group command and Data 
Point to Accept the action. 

Removing Elements from a Graphic Group 
Graphic Groups can be dropped either singly or all at once. To drop elements from a 
Graphic Group one-at-a-time, make sure your Graphic Group Lock is turned off. Pick the 
Drop from Graphic Group command from your Main Tool Frame (Figure 2-55) or select 
Group > Groupings > Drop from Graphic Group from your menu. 

 
Figure 2-55: Drop from Graphic Group 

Once you have chosen the tool, pick the elements you’d like to remove from the Graphic 
Group. 

To drop an entire Graphic Group, follow the same routine as above, making sure that 
Graphic Group Lock is turned on instead of off. 

Adding Elements to an Existing Graphic Group 
You may want to add a couple of elements to an existing Graphic Group.  

Choose the Add to Graphic Group tool. When it prompts you to “Add to Graphic Group > 
Identify Element” start by picking an element that is already in the Graphic Group you want 
to add to. Then go on to select the elements you would like to add to the Graphic Group.  
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AACCCCUUDDRRAAWW  
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FUNDAMENTALS OF ACCUDRAW 
 See page 2-51for a detailed example of using AccuDraw. 

Introduction 
Launch AccuDraw from the Primary Tools toolbox by pressing the Start AccuDraw 
Button (Figure 2-56). 

     
Figure 2-56: AccuDraw Start  Figure 2-57: Rectangular AccuDraw Window 

Somewhere on your screen you’ll see the AccuDraw window (Figure 2-57). 

The window may be in its Distance/Angle format as well (Figure 2-58). 

 
Figure 2-58: Polar AccuDraw Window 

It’s also possible that the AccuDraw window will be docked (Figure 2-59). 

 
Figure 2-59: Docked AccuDraw Window 

When you place a data point in the drawing, it will bring up the AccuDraw Compass. In 
Figure 2-60, you can see AccuDraw in Rectangular mode.  

 
Figure 2-60: Accudraw's Rectangular Compass 

 Use the Rectangular mode to draw xyz distances as well as slopes expressed as xy. 

In Figure 2-61 you can see AccuDraw in its Polar mode.  
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Figure 2-61: Accudraw's Polar Compass 

 Use Polar mode to draw lines at a fixed angle or bearing. 

Press your [Spacebar] key to toggle back and forth between distance and angle mode. 

Shortcut Keys for Construction 
O allows you to place the AccuDraw Compass at a specific point without placing a 
Datapoint.  

RQ allows you to spin the AccuDraw Compass. 

V rotates the AccuDraw Compass to be aligned with the view. 

A locks the angle in  

X, Y and Z lock the corresponding AccuDraw Axis.  

[Enter] locks the AccuDraw Axis along whatever axis the user is gesturing. 
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ACCUDRAW SETTINGS 
You can access Accudraw’s settings by typing GS into your AccuDraw Window or from the 
Main Menu Settings>AccuDraw. This will bring up the AccuDraw Settings Dialog 
(Figure 2-62). 

 
Figure 2-62: AccuDraw Settings Dialog 

Operation Tab  

Auto Load: If on (the default), when MicroStation is started loads AccuDraw automatically 

Floating Origin: If on (the default), the origin moves to the last point placed  

Context Sensitivity: If on (the default), enables tools to provide “hints” to AccuDraw to 
override its default behavior for smoother operation  

 Context Sensitivity won’t do anything without Floating Origin turned on. 

Smart Key-ins: If on (the default), AccuDraw interprets a number as positive or negative, 
depending on the direction of the pointer from the compass. In rectangular mode only, 
causes AccuDraw to move the focus to either the x or the y field depending on pointer 
position. 

Auto Point Placement: When on, places data points automatically when they have been 
fully constrained (default is off) 

Sticky Z Lock: If on (default is off), when you lock the Z axis, for example, where you 
want to draw on the one plane (that is, you want to lock Z=0), while snapping to elements 
that are on another plane  the Z value will remain locked until you turn it off. 

Always Show Compass: If on (default is off), when is activate AccuDraw, the compass 
displays before placing a data point for the current operation. 

Default Origin: Lets you choose the default origin. When a tool starts AccuDraw and there 
is no origin currently defined, then this setting specifies the default location of the 
AccuDraw drawing plane origin. Options are: 

 View Center on active Z: The AccuDraw's origin is centered in the view, at the  
           Active Z depth 

 Global origin: The  AccuDraw's origin at the Global Origin of the file 
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 Global origin on active Z: The  AccuDraw's origin at the Global Origin of the file 
             and at the Active Z depth] 

Display Tab  

 
Figure 2-63: AccuDraw Settings Display Tab Dialog 

X axis, Y axis, Hilite & Frame: The colors on the AccuDraw compass, via an option menu 
can be changes for the X axis, Y axis, negative X and Y axis and compass frame 

 
Delayed Update: If on (default is off), the coordinates are updated in the AccuDraw 
window when pointer is at rest. If off the coordinates are continuously updated, as the 
pointer move. 

Show Negative Angles: If on (default), AccuDraw displays negative angles (+/-180°) 

Pop-up Confirmation: If on (default), AccuDraw displays shortcut popups.  

Shortcut Key-ins: Opens dialog that lists AccuDraw shortcut keys. 

Coordinates Tab 

 
Figure 2-64: AccuDraw Settings Coordinates Dialog 

Rotation: The AccuDraw compass can be rotated: Top, Front, Side, View, Auxiliary and    
      Complex. Context lasts only for the current drawing tool 
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Type: Sets AccuDraw Compass to Rectangular or Polar 

Unit Roundoff: This works like a grid, that helps place “freehand” drawings to a specific 
    Distance and Angle. 

 

Indexing: The Distance required to move the pointer from the indexed Axis is controlled by 
      the Tolerance setting. 

 Tolerance is measured in screen pixels, 1-99 allowed 
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ACCUDRAW SHORTCUT COMMANDS 
AccuDraw shortcut commands are invoked by typing either the single letter or combination 
of two letters as outlined in the AccuDraw Shortcuts dialog (Figure 2-65).  

 
Figure 2-65: AccuDraw Shortcuts Dialog 

 Note that these shortcuts will only run if AccuDraw has focus. For a complete list of 
shortcuts, type (Shift+?). 

 
Figure 2-66: AccudrawDocked - Focus OFF 

Note also that the Tool Settings Window has Focus (like the Place SmartLine window in 
Figure 2-66) and AccuDraw is grayed. The Esc key toggles focus back and forth between 
AccuDraw and the Tool Settings Window. If I were to hit the Esc key (located in the upper 
left of my keyboard), the Focus will change to the AccuDraw (Figure 2-67) and the Place 
SmartLine window is grayed. 
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Figure 2-67: AccuDraw Docked - Focus ON 

Some Important Shortcut Keys 
Try to get used to using the K, N, C, O and I shortcuts to activate your Keypoint, Nearest, 
Center Origin and Intersection snap modes. 
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ACCUDRAW EXAMPLE: ROADWAY 
TEMPLATES 

Calculating Slope 
AccuDraw can be used to calculate your cross slopes easily. The basic theory is to figure the 
“drop” for the distance and slope of your lane. Mathematically, to know how far a 3.3 m 
lane will “drop” at a -2% slope, you would multiply 3.3 * .02. This results in a .066 m drop. 
AccuDraw can do this for you in one easy step. 

First select the SmartLine and place the first point. 

Move your cursor in the X direction so that AccuDraw sets its focus in the X field. Input 
your lane width 3.3 meters as a horizontal distance (Figure 2-68).  

 
Figure 2-68: Enter Width in AccuDraw 

Move the cursor in the Y direction, shifting the “focus” of the AccuDraw window 
accordingly. (For a negative slope move the cursor down or up for a positive slope.)  

Enter the horizontal distance again, 3.3m. Then, using [SHIFT 8], evoke the multiplication 
function of AccuDraw and enter .02. By entering your slope in decimal form, you will be 
multiplying the lane width by the slope to calculating the drop (Figure 2-69). 

 
Figure 2-69: Calculate Vertical Drop Based on Slope 

By accepting this position, you have just placed a line that extends the width of your lane 
and drops according to your decimal slope. If you then hit the “V” on your keyboard, the 
AccuDraw compass will rotate parallel to the view and you can continue placing a shoulder 
without quitting the SmartLine command. 

Placing Accudraw’s Origin 
You can change the origin of your line and make it relative to a position on the screen. This 
comes in handy when drawing typicals from scratch. For instance, if you drew the finished 
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grade using the distance/slope method described earlier, you could use the Origin function 
of AccuDraw to lay your pavement lines. 

First, snap to the place that you want to move your origin from. 

In this example, you would start with the smart line command and then snap on the 
centerline position of the finished grade (Figure 2-70). 

   
Figure 2-70: Tentative on the Centerline  Figure 2-71: AccuDraw Origin 

Without accepting that position, hit the “O” on your keyboard to invoke the Set Origin 
function of AccuDraw (Figure 2-71). 

This will allow you to move your cursor without actually drawing a line. If you move your 
cursor in the Y direction, you can then input the exact distance you want to move away from 
your snap point and begin drawing. So if you wanted to move down 50 mm and start 
drawing again, you would move your cursor down and then type in .05. By accepting that 
position with a data point you can begin to draw again (Figure 2-72). 

 
Figure 2-72: Free to Draw 

Likewise, you can use multiple Origins to move first in one direction, and then another. 
With this functionality, you will hardly ever have to use construction lines. The AccuDraw 
Origin will allow you to move around and position your cursor almost anywhere in relation 
to other elements in your design file. 
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DRAWING IN SUB-UNITS 
Sometimes, it is easier to draw in sub-units. With the introduction of the metric system, the 
conversion to master units is made quite easy.  

1000 mm = 1m  

500 mm = 0.5m  

30 mm = 0.03m  

…and so on and so on. But still, there will be times when you will want to draw in sub units, 
especially for U. S. Customary jobs. 

This is done easily and simply with AccuDraw. All you need to do is choose your starting 
point for your line and then input the distances using a colon or semicolon (: or ;) before the 
numbers (Figure 2-73).  

 
Figure 2-73: Subunits in AccuDraw 

This tells AccuDraw that you will be using the sub-units. For instance, if you were working 
in an U. S. Custom job (ft, in) and wanted to draw a line that is 6.25 inches long; all you 
would have to do is input that distance in your AccuDraw window with :6.25 (Using the 
proper X,Y, Z depending on what direction you want to move in).  
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DRAWING BY COORDINATES 
Using the Data Point Keyin 
Sometime you may want to draw a line, place a cell or other type of element at certain 
coordinates in a drawing. Some files are at their intended State Plane Coordinate System 
(i.e. topo, contours, highway, bridge, alignment, etc.) and others are not dependent on the 
coordinate system (i.e. 3 digit prefix plan sheets and z files). 

Start  a command that will utilize a point placement method (i.e. Place Line, Place Active 
Cell, etc). When ready to enter a coordinate position, verify that you have focus in 
AccuDraw and type “P” to activate the Data Point Keyin dialog.  

 
Select Absolute (xy=) from the pull down. Enter the coordinates points for the X, Y and Z 
values separating them by commas. If you need the dialog for multiple points, type “MI” for 
multiple keyin points. 

 Please refer to MicroStation’s HELP menu for more information about the different 
methods of the Data Point Keyin. 

Locking AccuDraws Compass at 0,0 
By default, your AccuDraw compass is setup to reside at the the last point that is selected in 
a file by clicking a data point. If a line is drawn, the AccuDraw compass is at the end of the 
line, rotated along the line so that a user can draw easily draw a perpendicular line from the 
last point or an arc that is tangent to the line just drawn.  

At times you may want to set AccuDraw at 0,0 so that the lines, arcs, cells or text placement 
can be relative to 0,0 in your file. You can adjust your AccuDraw settings so that the 
compass is loced at 0,0 and doesn’t follow (Float) or move to the last data point or to the end 
of a  line. To lock your AccuDraw compass at (0,0) in your drawing, goto 
Settings>AccuDraw and while displaying the Operation tab, uncheck Floating Origin. 
Now goto Utilities>Keyin and type in AccuDraw Setorigin 0,0,0. This keyin can be added 
to a Function Key for quick activation. Sometimes you may want to temporarily move your 
origin to the end of a line so that you can draw lines based on an angle or bearing. You can 
still move this origin by using the AccuDraw shortcut key “o” (origin) and the “RQ” (rotate 
quick) functionality or “T” (top rotation) to rotate the compass to a top view (+Y = north). 
Reset your origin to 0,0 in the file by typing the keyin again. 

 Refer to previous pages in this chapter for more information about AccuDraws shortcut 
keys, setting its origin and floating origin. 
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MMEEAASSUURRIINNGG  
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COORDINATE READOUT 
Control the display of your working units from your main menu by selecting Settings > 
Design File>Coordinate Readout (Figure 2-74). 

 
Figure 2-74: Design File Coordinate Readout 

This area is going to control how MicroStation displays linear and angular measurements to 
you.  

Linear Units, Accuracy 
In the Coordinates area of this dialog, choose Format (Figure 2-75) and Accuracy (Figure 
2-22).  

                    
Figure 2-75: Coordinate Format                                Figure 2-76: Coordinate Accuracy 
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The Format should be set to Master Units for working in metric drawings. 

 The only time you would set Format to other than Master Units would be for U S 
Custom work. You might set it to Sub Units to display Imperial projects in feet and 
inches (whereas keeping it set to Master Units in Imperial will display data in 
decimal feet.) 

Set your Accuracy to reflect how many decimal places you want your measurements 
displayed to. 

Angle Accuracy and Mode 
From the Angles portion of the Design File Settings Dialog you can control the Format 
(Figure 2-77), Mode (Figure 2-78), and Accuracy (Figure 2-79) of MicroStation’s angular 
display. 

                 
Figure 2-77: Angle Format             Figure 2-78: Angle Mode 

Choose whether you want the Format of your angular display to be in decimal degrees or in 
degrees, minutes and seconds. 

Choose whether you want your Mode to be Conventional, Azimuth, or Bearing. 
Conventional angles start with 0° at 3:00 (on a clock) and increasing counter-clockwise 
(90° would be 12:00). Azimuth angles start with 0° at 12:00, increasing clockwise (90° 
would be at 3:00). Bearing angles are expressed in terms of North/South X° East/West. 

 
Figure 2-79:Angle Accuracy 

Set your angular accuracy to as many decimal places as you want. 

 Note that if your Format is DD MM SS, then your Accuracy is the number of 
decimal Seconds you want displayed. 
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MEASURING PART 1 
You can access all measuring commands from your main menu by selecting Measure 
(Figure 2-80). 

 
Figure 2-80: Measure Menu 

Circle Radius, Length, Area, and Volume require that you simply identify one element.  

 Circle Radius can be used to measure the radius of arcs and ellipses as well. 

Angle and Distance > Minimum require that you identify two elements.  

 Perpendicular measuring sometimes gives unexpected results in 3D files. If you 
encounter this, flatten your file and try again or try the Measure Distance Between 
Points command while using AccuDraw to get the Perpendicular distance. 
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MEASURING PART 2 
Measuring Areas 
With a basic understanding of Region Creation, measuring areas becomes straightforward. 

From your Main Tool Frame, select Measure Area (Figure 2-81) or choose Measure > 
Area from the main menu. 

   
Figure 2-81:Measure Area   Figure 2-82:Measure Area Methods 

A brief look in the Tool Settings Window should reveal some familiar Methods (Figure 
2-82). 

Element: measures the area of a single closed element 

Fence: measures the area of a fenced area. 

Intersection: measures the area where two or more closed elements overlap. 

Union: measures the total area encompassed by two or more closed elements. 

Difference: measures the area of a single closed element with “bites” taken out by other   
         closed elements. 

Flood: finds an enclosing region around a data point. 

Points: measures the area of a polygon entered by the user. 

Look at Measure > Area Tools for measuring and labeling areas in one fell swoop. 
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MEASURING AREAS AND PLACING TEXT 
Step One: Lock “Z” to Zero 
From the Main Menu select Macros>Set/Lock Z to force MicroStation to place all elements 
at “0.00” elevation in the file. Click OK for the defaulted “0”. 

 This will prevent MicroStation from jumping to elements at different depths in the 
file. 

Step Two: Set the Category Scale 
Right Click on your Settings Manager and select Category>Scale.  From the list of 
available scales, select the scale that you intend on plotting your sheets.  

 If you use the Settings Manager for almost any activity, it is required that you set the 
Category Scale first. This has to be set once in every file. 

Step Three: Set the Text Attributes 
Using the Settings Manager, select Prop. Text and Dims>Text Note or Standard Text 
(Normal). This will set your text to the correct height, width, color, level, style and weight. 

Step Four: Open Measure Area Tools 
Select Measure>Area Tools from the Main Menu. A new set of tools should open. 

In the rightmost tool in the Tool Box (Figure 11-12), set some Parameter Settings. 

 
Figure 2-83: Area Parameter Settings 

Part One: Set the Default Text Font 
While in the Text tab, set the Font to 123 dotitalics (Figure 11-13). This is the only setting 
necessary on the tab. 
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Figure 2-84: Adjust Text Font to 123 dotitalics 

Part Two: Set the Default Prefix 
Click on the Prefix tab (Figure 11-14). Add a prefix that you would like to use. (i.e. 
Wetlands = ). You’re limited to ten characters. 

 
Figure 2-85: Add a prefix 

Part Three: Set the Default Suffix 
Click on the Suffix tab (Figure 11-15). Add a suffix that you would like to use. (i.e. s.f. or 
m\178 for metric). You’re limited to ten characters. 

 
Figure 2-86: Add Suffixes 

Step Five: Select Measure Area Tool 
From the Area Tools toolbox (Figure 11-16), select Measure Area. 
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Figure 2-87: Measure Area Tool 

Configure area tool for the method, prefix and suffix. Select one of the methods available. If 
using the Flood method, use the PowerSelector and select all bounding elements. If there is 
a gap in any of the connections, correct it or use the Flood method in the Measure Toolbox 
as it allows the jumping of gaps. Click inside the area or on the element (based on the 
method you picked). 

This should label your area. The orientation of the text will be horizontal to your current 
view window which means you will have to rotate and possibly move text. Use the Rotate 
Element tool and set method to either 2 points or 3 points. Follow the prompts. 

 If you cannot see the text for your areas, check that you have done all the steps in this 
section. 

Step Six: Select None 
Select Edit>Select None to unselect any elements that may be currently selected.  
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TIPS AND TRICKS 
We have a number of tools and tips to make the measurement of areas easier. 

Measuring with Flood Method  

PowerSelector  
If you are working in a crowded area, you will have a hard time using the Flood method to 
pick exactly the area you want to measure. This is because Flood is confused by lots of 
crossing lines. To simplify matters, start by using the PowerSelector to pick only the 
elements that make up the outline you want to measure. Now use Flood and data point 
somewhere in this area. Flood will look only for highlighted elements when it looks for an 
enclosing region. 

 
Figure 2-88: Measure Area by Flood Options 

Adjust Max Gap 
If MicroStation can’t find an enclosing region, you may have some slight gaps between 
elements. Try changing your Max Gap value to a higher number (Figure 2-88). If you have 
to set it higher than .1, you may need to make sure that your file is flat and that you have 
selected all of the elements that make up your boundary. 

 Check Flattening your Active File on page 2-87. 

Set/Lock Z to Zero 
Another macro that will help make sure that you are measuring on the same plane and get 
the correct area measurement is called ZLOCKANY. This macro is kicked off by selecting 
Macros>Set/Lock Z from the Main Menu and setting the active depth to “0” in the 3D file.  

Converting Metric Measurements to English 
We have a macro that will convert your metric measurements directly into English units.  

All you have to do is measure your area in Metric, then run the acre.bas macro. ROW users 
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press Alt+F2 or Utilities>Macro>MicroStation BASIC>acre. This will bring up the Area 
dialog (Figure 2-89).  

 
Figure 2-89: Area Macro Options 

Press the unit that you want to label and the macro will stick text right on your pointer. 
Make sure to have your text height and font (229 verdana) set up right beforehand.  

 If you find, in the middle of the macro, that your text height is wrong, just Reset and 
pick the right text height. Then re-run the macro. You do not have to re-measure the 
area. MicroStation remembers the last area that you measured. 
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REFERENCES DIALOG 
Select: File > Reference (DOT)>Dialog. This will open the Reference Dialog (Figure 
2-90).  

 
Figure 2-90:Reference Dialog 

List box 
Slot: The a number of a File referenced 

 

File Name: The name of the DGN being attached 

 

Model: The name of the Model that contains the elements diaplayed 

 

Description: A description of the file reference 

 

Logical: A name assign to the file being referenced 

 

Presentation: The Display Mode of the graphics 

 

Display: By clicking the checkmark turns the graphics in the file On or Off 

 

Snap: When checked On snapping to an element is possible 

 

Locate: When ckecked On allows elements to be copied into the Active File 
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You must first select a reference file in the List Box before you can change a setting or select 
a tool. However, you can change the Display, Snap, and Locate settings for DGN files 
simply by clicking in that column. 

 

Icons  

Attach Reference: Used to attach a reference to the active file 

 

Clip Reference: Used to display only graphic inside a fence boundary 

 

Delete Clip: Deletes the clip boundary of a reference 

 

Set Ref Back Clip Z: Sets the back clipping plane for a 3D reference 

 

Set Ref Front Clip Z: Sets the front clipping plane for a 3D reference 

 

Reload Reference: Reloads all references, allowing you to see changes made since being 
          loaded 

 
Move Reference: Moves a reference 

 
Copy Reference: Copies a reference 

 

Scale Reference: Scales a reference 

 

Rotate Reference: Rotates a reference 

 

Mirror Reference: Mirrors a reference 

 

Set Reference Presentation: Changes the display: Wireframe, wiremesh, etc.  

 

Detaches Reference: Detaches a reference 

Hilite Mode 
Highlighted and/or surrounded a reference by a border when placed in the active file. 
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None: Does not place a dashed border or highlight the select reference. 

 

Boundaries: Places a dashed border around the select reference. 

 
Hilite: Highlights the selected reference. 

 
Both: Places a dashed border and highlights the selected reference. 

Main Menu (Tools) 
Attach: Used to attach a reference to the active file 

 
Attach URL: Opens the Select Remote Design File to Attach dialog box, which is used to 
            attach a remote referenced model 

 
Detach: Detaches a selected reference  

 

Detach All: Detaches all references 

 

Reload: Reloads a references, allowing you to see changes made since being loaded 
      

 

Reload All: Reloads all references 

 
Ref Agent: Opens the Reference File Agent dialog box, which enables you to automatically 
        maintain local copies of remote references 

 

Exchange: Toggles from the master file to an attached reference 

 

Move: Moves a reference 

 

Copy: Copies a reference 

 
Scale: Scales a reference 
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Rotate: Rotates a reference 

 

Merge Into Master: Merges reference models to the active file. 

 
Make Direct Attachment: Promotes the nested attachment to a direct attachment so it can 
           be modified. The nested attachment becomes redundant with the 
           newly created direct attachment. Quotation marks under Display, 
           Snap, and Locate indicate a redundant attachment. 

 
Mirror Horizontal: Mirrors a reference about the horizontal axis. 

 
Mirror Vertical: Mirrors a reference about the vertical axis. 

 
Clip Boundary: Used to display only graphic inside a fence boundary 

 

Clip Mask: Masks a part of a reference that is inside a fence boundary 

 
Delete Clip: Deletes the clip boundary of a reference 

 

Clip Front: Sets the front clipping plane for a 3D reference 

 
Clip Back: Sets the back clipping plane for a 3D reference 

Main Menu (Settings) 
Settings: Opens the an Attachment Settings Dialog that is used to set attachment     
     information for references 

 

Presentations: Opens the Set Presentation Dialog used to set presentation for   
              references 

 
Update Sequence: Opens the Update Sequence Dialog used to change the order of display 
         for references 

 

Adjust Colors: Opens the Adjust Reference Color  Dialog used to modify or change colors 
    of references 
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REFERENCES ATTACH 
Most of the file will already be attached. From time to time files will need to be attached. To 
attach a reference from the same PIN without Browsing: File>Reference (DOT)>Attach. 
This will open up the Attach Reference dialog (Figure 2-91). This is an automated routine 
to look at where you entered MicroStation thru the projects list and place you into the proper 
directory tree. 

 
Figure 2-91: Attach Reference 

Browse to the SURVEY\MSTA directory and select the file and Click OK. If 
File>Reference (DOT)>Attach is not used be sure that you are browsing in the proper 
directory because MicroStation remembers the last place you went to attach a reference file.  

This brings up the Attach Reference Settings Dialog (Figure 2-92). 
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Figure 2-92: Attach Reference Settings Dialog 

For now work is done in the Default Model. Type in a Logical Name (topo), select 
Orientation (Coincidental-World  Global Origin align with Master File), Scale (Master:Ref) 
1:1 and True Scale Checked. Push the OK button. Push Fit View (on the lower left of the 
window border) to see all your reference files. Nested Attachments (Figure 2-93) will be 
grayed if no files are attached to the file being referenced. 

 
Figure 2-93: Nested Attachments 

Nested Attachments 
Nesting describes how nesting of references is handled. 

No Nesting: References attached to the file being referenced will not be displayed 

 

Live Nesting and Copy Attachments: References attached to the file being referenced will 
        be displayed and appear in the list of reference 
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Depth 
0: References only the file being attached 

 

1: References the file and any files being reference to it 

 

2: References the file, any files being reference to it and references any files attatched to 

    those and so on 

 

For example, Live Nesting: File B is attached to file A. Further, file B also has file C 
attached. If you detach file C from B, file C will no longer appear as attached to file A. 

Where Copy Attachments:  File A has an attachment, file B which also has an attachment, 
file C, if file C is detached from B, file C will still appear as attached to A unless C has been 
explicitly removed. 

Display Raster References 
When a rastered image is attached to a file a Checkmark can be placed in the box with a 
data click to display the image. If there is no image attached to the file the area on the Attach 
Reference Settings Dialog will be grayed. 
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REFERENCE FILE MOVING 
Everyone likes to have some control on how the plan appearance looks. You have the ability 
to move your reference files around in your border. 

Select: File > Reference to open the References Dialog box (Figure 2-94). 

 
Figure 2-94: Reference Dialog 

Highlight the reference file or files that you want to move. From the Reference Dialog box, 
select Tools>Move.  

MicroStation will prompt you (in your Status Bar) to “Move Reference File > Enter Point 
to move from.” Enter a data point. MicroStation will now prompt you to “Move Reference 
File > Enter point to move to.” Enter another data point. MicroStation will move all the 
reference files you selected from the first point to the second point. 
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REFERENCE FILE ROTATION 
MicroStation 3D files allow for reference file rotation in the X, Y, and Z-axis. When 
working in a plan view, reference file attachments will only need to be rotated around the Z-
axis.  

Select: File > Reference. This will open the References Dialog box (Figure 2-95). 

 
Figure 2-95: Reference Dialog 

Let’s begin by selecting the file or files you want to rotate. From the Reference Files dialog, 
select Tools>Rotate. This will open up the Rotate Reference File Dialog. Set the angle to 
rotate around the Z-axis and send a data point to your screen. After rotating you may want 
to move the reference files to a more precise location on your border. 

 Refer to Reference File Moving, page2-73. 
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ATTACHING A RASTER IMAGE TO SCALE 
Determine Image Size 
Before the image is placed in MicroStation, create a rectangle the same dimensions as the 
1:1 paper image multiplied by the original scale of the image. Doing this will insure that the 
Image will be to scale. To do this, open Windows Explorer and browse to the image. Next, 
Rt+click the image and select Properties. Select the Summary tab and click the Advanced 
button. You should see the width and height in pixels and the horiz. and vert. resolution 
(should be the same) (Figure 2-96).  

 
Figure 2-96: Windows Explorer 

Divide the dimensions by the resolution to get the image size in inches. Using the numbers 
in the expamle above (Figure 2-96), divide 6906 by 200 & 4450 by 200 to get the width and 
height in inches (34.53 x 22.25). Now we have to multiply these dimensions by the original 
scale of the image. If the scale is 1”=25’, the dimensions, both width and height, will need to 
be multiplied by the absolute scale which is 300 (12”x25’). You can calculate these 
dimensions now or use AccuDraw’s built in calculator to calculate the dimensions on the fly. 
In this example, the retangle will have to be 10,359’ x 6,675’ to be 1:1 (actual size) in 
MicroStation (i.e. 34.53 x 300 = 10,359’ & 22.25 x 300 = 6,675’). 

 If the image will open with Paint, check Image>Attributes for size in inches. 

 The TDS860 is in the Reproduction Room which scans images at 300 dpi’s (dots 
per inch). 

Place Block 
Start  MicroStation, select the Place Block and place the first point. Move your cursor in 
the X direction so that AccuDraw sets its focus in the X field. Input colon :34.53 (subunits) 
using [SHIFT 8], evoke the multiplication function and enter 300 for the horizontal 
distance. Move the cursor down in the Y direction, shifting the “focus” of the AccuDraw 
window accordingly. Enter the horizontal distance :22.25 * 300 for the Vertical distance and 
enter a data point to finish the rectangle.  
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Attach Raster Image 
To attach a Raster Image, select File>Raster Manager. This will open up the Raster 
Manager Dialog (Figure 2-97). 

 
Figure 2-97: Raster Manager Dialog 

From the main menu of the Raster Manager Dialog select File>Attach. When the Attach 
Raster Reference Dialog (Figure 2-96) opens browse to select the Image File and hit OK. 

 
Figure 2-98: Attach Raster Reference 

MicroStation will ask for Enter Origin, see Status Bar. Place a Data Point at the upper left 
corner of the rectangle previously created for the Enter Origin point. Next place a Data 
Point, in the lower right corner of the rectangle to enter the Enter Corner point. The scale 
of the image can be changed by Scaling the rectangle and detaching and reattaching the 
image: File> Detach and File> Attach.  
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Figure 2-99:Raster Manager Attachment 

In the Raster Manager (Figure 2-99) from the Settings submenu select Attachment…. To 
print the image white with black details the color may need to be changed. Open the Color 
tab (Figure 2-100) and check for a white Foreground and a black Background. 

 
Figure 2-100: Attachment Settings 
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GEOREFERENCED IMAGES 
Overview 
MicroStation has the ability to attach Raster Images that have spatial extents. This means 
that the image has a “world” or a “sister” file that contains the X and Y coordinates of where 
the image should sit on the face of the earth. Because of many different potential coordinate 
systems, it is very important that you know what coordinate system your project is based on.  

Browse to your projects directory on the Y: drive (\\dot0dta1fscadd1\pcpin1). Your project’s 
Survey\MX folder contains a Status.doc or Status.rpt file. The Status file indicates what 
the units are for your project and the coordinate system used. Any images will have to be 
“projected” to this same coordinate system for the MicroStation graphic and the image to 
line up. 

Preferences 
Some of the “out of the box” preference will need to be adjusted also for the image to 
display properly and in the correct location. Go to Workspace>Preferences… and select 
Raster Manager from the Category list (Figure 2-101). Adjust your settings to look like the 
settings in the dialog box. This will allow images to be placed in your drawing based on its 
World File or Sister File. The units may have to be adjusted base on the the image units. 

 
Figure 2-101 User Preference dialog – Raster Manager Preferences 
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PLOTTING BY STATION AND OFFSET 
Plotting elements along a centerline is fairly simple when your on a straight portion of the 
alignment. AccuDraw performs this task very easily. Drawing a perpendicular line off a 
centerline on a radius is fairly easy, however plotting a point or placing a cell at a specific 
“odd” station along the curved alignment is a cumbersome task. We have created a macro 
that make this easy… once you get the hang of it. The Pointalong macro is going to make it 
possible for us to construct points at a specific distance along an existing alignment. From 
these points, we’ll be able to draw a line perpendicular to the alignment at a specific 
distance. 

Starting Point 
Run the Pointalong macro by selecting Graduate>Distance and Offset from the most 
Settings Managers (ROW workgroup users have global Function Key menus in which by 
selecting the F12 key will start the macro). You will be prompted to “Identify Point to 
Construct Distance From.” (Figure 9-1)  

 
Figure 2-102: StartPoint Along Status Prompts 

The Macro is expecting a data point on your “alignment.” Using the Keypoint snap, 
Intersection snap or AccuSnap, snap to the middle of a station tick mark. Once this point is 
selected, either the tick mark or the centerline may be highlighted. You want the centerline 
highlighted. Right-click until it is highlighted and click your left mouse button to Accept. 

Entering the Distance and Direction 
Once you’ve entered a data point telling the macro the start point, it will prompt you to 
“Enter Distance Along Element.” (Figure 9-2)  

 
Figure 2-103: Input Distance 

If you were trying to construct Station 1+35.240 from a tick mark at Station 1+20.000, the 
distance to construct would be 15.240. Enter in your desired value and press the OK button. 
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Choosing the Direction 
This next step is very important. The macro isn’t smart enough to know whether or not you 
want to construct a point to the left or to the right of the point that you just chose. Look 
down in your Status Bar to see that the macro is now prompting you to “Identify Direction 
for Construction.” (Figure 9-3)  

 
Figure 2-104: Status Bar Message 

What it is asking for is a data point either to the left or to the right, or, in the case of a 
vertical line, above or below the first point you entered. Put your cursor on the baseline near 
the first point, but clearly to one side or the other (Figure 9-4) and enter in a data point (left 
button). There is no need to snap to enter this point.  

 
Figure 2-105: Identify Direction for Construction 

When you enter a data point, MicroStation will start drawing a line at the specified offset 
and direction from the first point you entered (Figure 9-5).  

 
Figure 2-106: Point Constructed 

It will also put the AccuDraw compass on the line, rotated to make it easy for you to 
construct a line perpendicular to your centerline. 

Choosing the Offset Distance 
Now that we are drawing a line, we can choose to go either to the right or to the left of the 
centerline. Just put your cursor graphically near where you want the line to go. Keep your 
cursor near the axes of AccuDraw and it will ensure that you are drawing perpendicular to 
the baseline. 
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Enter your Offset into the Distance field of your AccuDraw window (Figure 9-6).  

 
Figure 2-107: Constructing a Distance off the Baseline 

Notice that the angle is 90°. Enter a Data Point to complete the command. Reset to stop 
drawing lines. 

Troubleshooting 
There is a Warning Dialog (Figure 9-7) that you will get from time to time when you 
construct distances using this macro.  

 
Figure 2-108: Pointalong Warning Dialog 

It lets you know that the point you are trying to construct cannot be constructed because 
your Element is too short. This could happen for a couple of reasons. 

1) You may have just chosen the wrong direction to construct from. Your baseline may run 
16 kilometers to the right and only 16 centimeters to the left of your offset point. You can’t 
construct a point 10 meters to the left of that first point. 

2) You may have picked the wrong element to construct the distance along (i.e. tick mark). 
Choose the point again and make sure that you Accept only the element you want to 
construct along.  

3) You may have used the Drop Element tool to drop Complex Status of the baseline. This 
would have broken up the lines and arcs that are joined together in a “complex chain” of 
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a baseline, leaving only individual lines and arcs. The resulting elements are much shorter 
than a typical baseline.  

You can put dropped baselines back together using the Create Complex Chain tool. Set your 
method in the Tool Settings Window to Automatic. 

 Refer to 2-12 for using the Complex Chain Tool  

4) You may be confusing Metric and English units. Make sure you’re not trying to go 75 
feet along a 40-meter line. MicroStation reads that “75” distance as 75 meters if you’re 
working in a metric drawing.  
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HOTSWAP 
Overview 
This macro helps you navigate to specific elements in reference files.  

Launch the Macro 
From the main menu, select File > Reference (DOT) > HotSwap. 

Identify the Element 
MicroStation will prompt “Hotswap > Identify Element.” Chick on the element with a 
Datapoint. 

 MicroStation will not allow you to identify Dimensions to swap to the reference file. 
Pick a line, arc, circle, text, or some other basic element type.  

 MicroStation will also not allow you to identify elements in your active file. 
Once you have picked an element, MicroStation will hilite the element and prompt you 
“Hotswap > Follow Element? (Accept/Reject).” Datapoint to Accept and MicroStation will 
open up the file of the indicated element. 

Set Zoom Level 
Once MicroStation has opened the target file, it will center your view window on the 
indicated element and open the HotSwap Zoom Dialog (Figure 2-109). 

 
Figure 2-109:HotSwap Zoom Dialog 

This dialog allows you to Zoom In or Zoom Out centered on the indicated element. 

Press the Done button when you are finished zooming. 

Tips 
The easiest way to get back to your previous file is from your File menu.  

At the bottom of the menu, right below Protection there should be a list of files. File 
number 1 is your active file. File number 2 is your previous file.  

Open your previous file from the main menu by choosing File > 2 [Filename…] form the 
list of files. 
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LABEL SLOPE BY POINTS 
Overview 
This macro was created to make it easier to label roadway lines with the appropriate slope 
value. 

Setup 
Set your text up to the proper style and scale by using your Settings Manager. 

 Refer to page 2-20 for more information on the Settings Manager. 

Run the Macro 
From your Settings Manager, choose Prop. Text and Dims > Slope %. MicroStation will 
prompt you in the status bar “SlopeByPoints > Enter First Point.” Snap and Accept to a point 
on the slope you wish to define. 

MicroStation will prompt you in the status bar “SlopeByPoints > Enter Second Point.” Snap 
and Accept to another point on the slope you wish to define. 

You will get a positive slope if your first point is below your second point. You will get a 
negative slope if your first point is above your second point. 

 For roadway slopes, snap to an inner point before an outer point. 

Once you have defined your points, MicroStation will bring up the text dialog with your 
slope all typed in.  

 You can edit the text at this point, if you desire. You could change the sign, degrees 
of accuracy, etc. 

MicroStation will prompt you to “Place Text Above Element > Identify Element.” 

Datapoint on the line you want to label, near the point you would like the text to be. The text 
will appear, highlighted, above the element you selected. Datapoint to Accept, or Reset to 
choose another point for text placement. 
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FLATTENING YOUR ACTIVE FILE 
Flatten.bas is a BASIC macro that was designed to help you squash a 3D file down to a 
single elevation. It’s like pressing a leaf in a book: it takes all of the peaks and valleys and 
presses them down. 

When to Flatten 
There are a couple of symptoms that may occur in your file to lead you to believe that you 
have a 3D problem. If you measure the distance between two points and find that it is much 
greater than you were expecting, perhaps those points are at different elevations. If you 
measure the length of a short line and find that it is hundreds of meters long, the line may be 
spanning two elevations. 

How to Flatten 
From the Main Menu, select Macros > Flatten. This will open the Flatten File dialog 
(Figure 2-110). Type in a target elevation for your elements and press OK.  

 
Figure 2-110: Flatten File Elevation 

The Status Bar will prompt you to “Flatten Elements? (Accept in Plan View/Reject)”. Enter 
a Data Point in your plan view. 

How to Undo The Flatten 
If you change your mind about flat elements, you are going to have to take a special course 
to undo what you have done: namely, go to the Main Menu and choose Edit > Undo Other 
> To Mark. 

 This is necessary because the Macro issues the scale command about ten times. If 
you were to undo singly, it would only undo one of those scales. The Macro sets a 
Mark in the file before it starts to scale though, so you can undo all of its impact in 
one fell swoop. 

Other Options When Flattening 
If you don’t want to scale all the elements in your file, the Macro will allow you to scale 
only the contents of a Selection Set or a Fence. Pick a bunch of elements with the Element 
Selection Tool or the Powerselector or place a Fence before you run the Macro. The Macro 
will then only impact the elements you have selected. 
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Just What Exactly Does the Flatten Macro Do? 
Flatten.bas starts by checking to see if you have an active Fence or Selection Set. If you 
don’t, it executes the “Select All” command, picking all elements in the file. Then it prompts 
you to enter in an elevation for elements to be scaled to. Then it runs the “Scale” command, 
setting your active (xyz) scale to (1,1,0.00001). This scales in the xy direction by 1 (no 
change) and the z scale by 0 (flattening the elements.)  

Next, the Macro turns off AccuDraw (because the scale command tries to read Accudraw’s 
orientation, which could really screw up the automation.) Now the Macro gets a Data Point 
and changes the z-value of that point to equal the z-value entered by the user. The Macro 
then briefly turns off the display of elements to the screen (this saves processing time.) Next, 
the Macro runs the scale command ten times (just once doesn’t seem to do it.)  

Finally, the Macro turns element display back on (you shouldn’t even notice a difference) 
and activates AccuDraw. Even if you didn’t have it on before, you’ll have it on afterwards. 
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STEEL MACRO 
Overview 
The Steel macro draws standard steel shapes for the user. Selection is made in a graphic 
dialog box based on shape type. The user has the option of placing shapes by any of nine 
points of origin, i.e. top left, bottom right, etc. 

Step Zero: Preparation for the Macro 
This macro is not going to set any appropriate level, color, style or weight. Before you 
launch the macro, use your Settings Manager and pick the most appropriate setting (i.e. 
Structural Detailing > Superstructure.) 

Step One: Launch the Macro 
Launch the macro from the main menu by selecting Macros > Steel. This will bring up the 
Steel Selector Dialog (Figure 2-111).  

 
Figure 2-111: Steel Selector Dialog 

Step Two: Pick Your Shape 
On the right side of the Steel Selector Dialog, notice the section labeled Shape Picker. 
Each button in this area is labeled with a type of steel shape: W, M, S, etc. Find the steel 
type you want to place and click the button. 

This will bring up the Shape Picker Dialog (Figure 2-112). 
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Figure 2-112: Shape Picker Dialog 

This dialog is a scrolling list of all the available shapes of the type you selected. Scroll down 
the list until you find the shape you want to place, and then press OK.  

 
Figure 2-113: Steel Label 

 If you have a hard time decoding the steel designations here, take a look at the text at 
the top of the dialog (Figure 2-113). These items correspond to the columns of text in 
the body of the Shape Picker, and should help you find the shape you’re looking for. 

Once you have picked your shape, the Steel macro will drop you back into the Steel 
Selector Dialog (Figure 2-114). 

 
Figure 2-114: Steel Selector Take Two 
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 Notice that the shape you chose in the previous step is now highlighted in the Enter 
New box, and the Selection Button next to it is Checked.  

Step Three: Choose an Origin 
Now you need to make a decision about how you want to place this shape. On the Steel 
Selector Dialog, press the Origin button. This will bring up the Placement Dialog (Figure 
2-115). 

 
Figure 2-115: Placement Dialog 

In the Origin Justification section of this dialog, there are nine buttons that you can press to 
set the justification. Your choice will depend on the detail you are working on. For this 
example, I’ll choose CT, which is “Center Top.” We’ll see the impact of this when I place 
the shape. 

Pressing any of those nine buttons will dismiss the dialog and bring up the Steel Selector 
Dialog again (Figure 2-116). 
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Figure 2-116: Steel Selector Take Three 

Notice the Origin you selected in this step is displayed next to the Origin button. Press OK 
to place the steel shape. 

Step Four: Place the Shape 
Check your Status Bar for the prompt. It should say “Steel > Enter Origin of Shape (Reset to 
Exit.)” Datapoint to place your shape, Reset to abort. (You can also Snap to choose the 
origin point more specifically.) 

The shape should appear where you Datapoint (Figure 2-117). 
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Figure 2-117: Placed Shape 

 Notice the circle at the center of the top flange in Figure 2-117. This is the Origin 
point that I selected in Step Three.  

Option One: More of the Same 
If you want to keep placing more shapes like the one you just placed, just keep 
Datapointing. Until you Reset, MicroStation will continue to drop a shape wherever you 
Datapoint.  

Option Two: Undo 
If you have placed a shape in the wrong place, you can Undo the placement. From your 
main menu, select Edit > Undo Other > To Mark.  

 This uses built-in MicroStation functionality related to setting Marks in your drawing 
– kind of like bookmarks – that allow you to Undo back to a specific point. You can 
set your own marks by choosing Edit > Set Mark.  

Option Three: Using Previous Shapes 
As you run the Steel macro a number of times to place different shapes, you should notice 
that it remembers shapes you’ve already placed. The most recent shape you’ve used is still 
in the Enter New box of the Steel Selector Dialog. 



mdot MicroStation 
07/01/07 

General Tools 

2-94 

 

The four shapes you’ve used previously are stored in the Previous Shapes box in the Steel 
Selector Dialog (Figure 2-118). 

 
Figure 2-118: Steel Selector Previous Shapes 

To place any one of these stores shapes, just Check the button next to the shape description, 
set your Origin and press OK. 

Option Four: Angle Legs 
L Shapes are drawn with Leg 1 as vertical and Leg 2 as horizontal. The resulting shape 
looks like an “L”.  

There are two ways to change the way Ls are placed by this macro. 

1. Push the Swap Angle Legs button. This reverses the placement of Leg 1 and Leg 2. 
This essentially mirrors the default L over a 45° mirror line. 

2. Set the Rotate Shape By angle to a non-zero value. This spins the L counterclockwise 
by the angle specified. 
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WELD MACRO 
Overview 
The Weld macro was written to make it easier to place consistent weld symbols on 
structural details. It prompts you to enter two Datapoints: one for the location of the weld, 
the second for the location of the symbol. Then you fill out a dialog box full of options and 
the macro places the weld symbol for you! 

Step One: Launch the Macro 
Run the Weld macro from your main menu by choosing Macros > Weld. 

Step Two: Enter Points 
Look in your Status Bar. MicroStation should be prompting you to “Select Weld Location to 
Be Labeled (This is where the arrow points.) 

Datapoint or Snap to the location of the weld. 

Once you have Accepted, MicroStation will prompt you to “Select Location of Weld 
Symbol (This is the end of the arrow.)”  

 If you snapped to the first point, you have to snap to define the second point as well. 
Place a tentative point (away from any element) in the approximate location you want 
the weld symbol to be drawn, and then Accept. 

Step Three: Fill out the Dialog 
Now that you have Accepted the location for the weld and the symbol, the macro will open 
up the Select Weld dialog (Figure 2-119). 
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Figure 2-119: Select Weld 

Weld Type 
At the top of the dialog, you can select a Near Side and a Far Side weld. Near Side 
symbols will be placed under the line, Far Side symbols above the line. The various kinds 
of symbols are illustrated in Figure 2-120. 
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Figure 2-120: Weld Symbols 

Choose whatever Near Side and Far Side welds you would like to show by Toggling the 
button next to the symbol type (Figure 2-121). 

 
Figure 2-121: Pick Weld Type 

 If you accidentally pick a weld type for the Far Side when you actually don’t want 
to show a Far Side weld, pick None from bottom of the Select Weld Dialog. 

Weld Size 
Also in the Near and Far Side boxes you can make your Size selection (Figure 2-122). 
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Figure 2-122: Weld Size 

Place a Check in the box and type a size into the text field. 

Field Weld, All Around, Notes, Labeling 
Directly under the Near Side and Far Side boxes, you’ll find more weld placement options 
(Figure 2-123). 

 
Figure 2-123: Weld Options 

These options are illustrated by Figure 2-124. 

 
Figure 2-124: Weld Anatomy 

Place Checks in the appropriate boxes to enable or disable these features and provide text in 
the text boxes. 

Direction 
The Weld macro is capable of automatically deciding whether the weld symbol should 
extend to the left or to the right of the arrow. If you want to override the default settings, 
select a Direction from the Direction Box (Figure 2-125). 
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Figure 2-125: Weld Direction 

Contour 
Near the bottom of the Select Weld Dialog there is a Contour Box (Figure 2-126). 

 
Figure 2-126: Weld Contour 

The two options, Flush and Convex are illustrated in Figure 2-127 on a Square weld. 

 
Figure 2-127: Weld Contour Appearance 

Step Four: Apply Settings 
Press the OK button to let the macro draw your weld. Or press Cancel to abort the symbol. 

Undo It 
Similar to the Steel Macro, the Weld Macro sets a Mark before it begins to draw. If you 
want to Undo the creation of a Weld symbol, simply choose Edit > Undo Other > To 
Mark from your main menu. 
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MOVE FILLED SHAPES BACK 
Launch the Macro 
From your menu, select Macros > Send Fill Back.  

What Does it Do? 
This Macro re-orders the display of elements. It selects all non-filled elements and uses a 
simple command to re-write them to the end of the design file. This makes them "newer" 
than the filled elements. New elements display on top of old elements. So by making all 
non-filled elements "new", we move the filled elements to the "back" of the picture.  
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BATCH PROCESSOR 
Overview 
MicroStation has the ability to run commands from a text file and apply the commands to a 
file or multiple files. 

Keyin Commands 
To run MicroStation commands, you must first figure out what the valid keyin command is. 
Select Utilities>Key-in. 
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MMXX  DDEELLIIVVEERRAABBLLEESS  AANNDD  
UUPPDDAATTEESS  

This section is not intended to replace the MX Editors procedure defined in the MX manual. 
It is described here for the purpose of informing a MicroStation user on the process and the 
evolution of the file naming.  
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GENERAL INFORMATION 
Standard Naming 
The department has a standard naming convention for all drawing files. The main reason for 
this is that many of our standard plan view type drawings for the department have the 
existing topography information referenced into them by default. This default reference only 
works when the files are named correctly and when they exist in the correct location.  

Please follow procedures outlined below to adhere to these standards. Click this link for a 
complete list of MDOT Standard File Names or visit our website at 
www.maine.gov/mdot/cadd-support/microstation/std_filename.php.  

Preserving Original Files 
The Survey Folder is where the “Original” Survey files are stored. The folder is Read-Only 
to everyone except for the Survey Editors. MicroStation Survey clean up will be done in the 
Topo folder, unless network speed is an issue, and at which point, it can be copied locally. 

 Refer to page 12-1 Regional Workflow documentation for working with files locally. 
Please consult CADD Support for assistance. 

http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
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INITIAL TOPOGRAPHY 
Step One: MX Editing 

After an initial survey is completed, the Survey Editors will do the necessary MX 
editing. This editing will consist of the same editing done prior to this document.  

Step Two: Create MicroStation Drawings 
Create the following drawings and place them in the y:\pin\####\##\Survey\Msta folder. 
Please be positive that you have the latest MX configuration that utilizes the most up-to-date 
MicroStation seed files. 

 3DtopoMMDDYY.dgn 
This is the 3D topography file that has only been MX edited. 

 Please use a 6-digit date without separators. (i.e. 3Dtopo021402.dgn)  

3DmappingMMDDYY.dgn 
This is the 3D Aerial Mapping file that has only been MX edited. 

 Please use a 6-digit date without separators. (i.e. 3Dtopo021402.dgn)  

Origtext.dgn 
This is the raw text that describes the topographical features. This will include both ground 
survey and Aerial Mapping text (if there is any). 

 The drawing resides at elevation 0.1000, slightly above elevation 0.0000. 

 Points.dgn 
This is all of the points for the topographical features.  

 The drawing resides at elevation 0.0000. It will be regenerated with all additional 
surveys. 

Contours.dgn 
This drawing is the 3D contour model that includes both the ground survey and Aerial 
Mapping.  

 It will be regenerated with all additional surveys.  

Triangles.dgn 
This drawing is the 3D triangles model that includes both the ground survey and Aerial 
Mapping.  

 It will be regenerated with all additional surveys. 
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OrigWetlands.dgn 
This drawing is the 3D wetland drawing. It includes all wetland strings identified by a 
Biologist and flag text associated with them. 

Step Three: Update Status Report 
Add notes to the Status.rpt file located in your PIN’s Survey\MX folder. 

Step Four: Communication 
At this point, send your correspondence to the proper contact in the desired MDOT Program 
division (i.e. Urban Arterial Program, Bridge Program, etc) to notify them that the survey 
files are available, however need to be cleaned-up in MicroStation. 
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TOPOGRAPHY UPDATES 
Step One: MX Editing 

After the additional survey is completed, the Survey Editors will do the necessary 
MX editing. This editing will consist of the same editing done prior to this document.  

Step Two: Create New MicroStation Drawings (Adds) 
Create the following drawings and place them in the y:\pin\####\##\Survey\Msta folder. 
Please be positive that you have the latest MX configuration that utilizes the most up-to-date 
MicroStation seed files. 

Origtopoadd#.dgn 
This file will consist of the updated 3D topographical features and a boundary string if this 
project utilizes Areial Mapping. 

Origtextadd#.dgn 
This is the updated text that describes the updated topographical features and/or Areial 
Mapping.  

 The text drawing resides at elevation 0.1000 m, slightly above elevation “0.0000”. 

Wetlandsadd#.dgn 
This drawing is the additional 3D wetland drawing. It includes all wetland strings identified 
by a Biologist and flag text associated with them.  

Step Three: Regenerate Points, Contours & Triangles 
The following drawings require editing and regeneration in MX to update and display the 
latest information. This editing work will consist of the same procedures done prior to this 
document. All files will reside in the Survey\Msta folder.  

 Points.dgn 
This will consist of all the original points and all additional points for all of the 
topographical features. 

Contours.dgn 
This drawing is the 3D Contour model. This will incorporate the original Contour model 
with the new Contour model (both ground survey and Aerial Mapping), providing one 
complete, seamless model. 

Triangles.dgn 
This drawing is the 3D Triangle model. This will incorporate the original Triangle model 
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with the new Triangle model (both ground survey and Aerial Mapping), providing one 
complete, seamless model. 

Step Four: Regenerate Topo Model 
In MX, combine the old ground model with the new ground model and create a file called 
3DtopoMMDDYY.dgn (supplying current date in place of MMDDYY) and place it in the 
Survey\Msta folder. Leave the ZZ string in the file to help identify the area that has been 
updated.  

 This file contains the most complete ground topographical features as of the date in 
the filename. 

 Use a 6-digit date without separators. (i.e. 3Dtopo021402.dgn)  

Step Five: Recreate Mapping Model 
If this is a mapping project, and additional ground survey was completed, remove the 
portion of the mapping model defined by the boundary string and create a new file called 
3DmappingMMDDYY.dgn (supplying current date in place of MMDDYY) and place it in 
the Survey\Msta folder. Leave the boundary in the file to help identify the area that has been 
updated. 

 Use a 6-digit date without separators. (i.e. 3Dtopo021402.dgn)  

Step Six: Update Status Report 
Add notes to the Status.rpt file located in your PIN’s Survey\MX folder. 

Step Seven: Communication 
At this point, send your correspondence to the proper contact in the desired MDOT Program 
division (i.e. Urban Arterial Program, Bridge Program, etc) to notify them that the updated 
survey files are available, however they need to be cleaned-up in MicroStation. 

 The end product, in the Survey\Msta folder, is to have all individual topographical 
files preserved as historical data, enabling someone to track what was done and when. 
This folder also contains a combined, topographical drawing called 
3DtopoMMDDYY.dgn, which contains the complete ground topography (old and new) 
as of the date indicated in the filename. It also may contain the latest 
3DmappingMMDDYY.dgn, which contains only the mapping data with a hole(s) 
indicating where ground survey was supplied.  

Step Eight: Create Zip Files For A Design Consultant (If 
Necessary) 
If this project is going to be done by a design consultant, create a zip file and place it in the 
Survey\Consultant folder. Use the PIN number and Town Name in the filename (i.e. 
8467Topsham.zip).  
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Breakdown of files sent to a consultant 
MX files:  
Traverse.inp file(s) contains the adjusted Traverse & generates the Traverse Model. 

Ground01.inp file(s) contains the topographic features from the field survey. 

Ground01.out file(s) contains the resulting X, Y, Z coordinates & associated point number 
above data. 

Ground01.inc file(s) generates the topographic features with associated text. 

Ground01.rep file(s) shows the labels X, Y, Z coordinates with associated text. 

Contours.inp generates the Triangles & Contour Models.  

Points01.str & Points01.txt file(s) generates the Point Numbers as surveyed from the field. 

 MX users may need to process multiple sets of numbered files (i.e. ground01.inp 
through ground10.inp) as opposed to running the highest numbered file.                                                        

MicroStation files: 
Topo.dgn is the Survey (cleaned-up and flattened). This file, if cleaned-up, is located in the 
topo folder of the PIN number.  

Text.dgn is the text associated with Survey data (cleaned-up and flattened). This file, if 
cleaned-up, is located in the topo folder of the PIN number. 

Points.dgn are the field Survey point numbers. This file resides in the Survey\MSTA folder. 

Wetlands.dgn is the name of the cleaned up version of the wetlands drawing. It is located in 
the topo folder. If the file has not been cleaned up, the file will reside in the Survey/MSTA 
folder and is called origwetlands.dgn.  

Contours.dgn is the 3D contours drawing. This would also include Aerial Mapping 
Contours. The file resides in the Survey\MSTA folder. 

 There is a contours drawing in the topo folder also, but it has been flattened. 

3DtopoMMDDYY.dgn is the 3D MicroStation design file (.dgn) of the Survey. This file 
resides in the Survey\MSTA folder. 

3DMappingMMDDYY.dgn is the 3D MicroStation design file of the Aerial Mapping (only 
on Photogrammetric Mapping projects). This file resides in the Survey\MSTA folder. 

origtext.dgn is the 3D MicroStation design file of the text associated with ground survey 
data and Aerial Mapping. This file resides in the Survey\MSTA folder. 

Triangles.dgn is the 3D triangulation file for the project. This would also include Aerial 
Mapping Triangles. This file resides in the Survey\MSTA folder. 

 When a design consultant requests survey information for a project, the 
3DtopoMMDDYY with the most recent date is the one file containing all the latest 3D 
topographical data. It will not be necessary to send any of the Origtopoadd#.dgn files. 
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Step Nine: Communication to Consultant Coordinator (if 
necessary) 
Send usual correspondence to the Consultant Coordinators in the Programs. 
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MMIICCRROOSSTTAATTIIOONN  CCLLEEAANNUUPP  
PPRROOCCEEDDUURREESS  
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GENERAL INFORMATION 
Standard Naming 
The department has a standard naming convention for drawing files. The main reason for 
this is that many of our standard plan view type drawings for the department have the 
existing topography information referenced into them by default. This default reference only 
works when the files are named correctly and when they exist in the correct location.  

Please follow procedures outlined below to adhere to these standards. The standard file 
names for existing Survey information residing in the Topo folder are Topo, Text, Contours, 
Points and Wetlands. These are the only five files that should permanently live in the Topo 
folder. Click this link for a complete list of MDOT Standard File Names or visit the website 
at www.maine.gov/mdot/cadd-support/microstation/std_filename.php. 

Preserving Original Files 
The Survey\Msta Folder is where the “Original” Survey files are stored. The folder will act 
as the topographical history for any given project. A user can open the folder and tell what 
was done for original survey, and all subsequent topoadds. The folder is Read-Only to 
everyone except for the Survey Editors, therefore, MicroStation Survey clean up will be 
done in the Topo folder. If network speed is an issue because of proximity to the server, 
then copy the necessary files locally.  

 Regional Office users should refer to page12-1:    Regional Workflow documentation for 
working with files locally. Please consult CADD Support for assistance. 

The End Result 
The end result is to make the Topo and Text drawings, which exist in the Topo folder, a 
combination of all Survey topography and text for the project (including Aerial Mapping 
data). This would leave no question as to which drawings need to be referenced to display 
all of the existing, cleaned up topography for the project. 

http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
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INITIAL TOPOGRAPHY CLEANUP 
Quick Punch List 

• Copy files from Survey/MSTA to Topo folder 
• Rename files 
• Cleanup Files 
• Flatten Files 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with original survey files. 
If the topography is needed prior to the cleanup, copy the files to the topo folder and 
rename them.   

Determine Direction of Proposed Alignment 
This step is very important. If you haven’t already, take necessary steps to determine who 
the Project Manager is for the project. Ask which direction that they anticipate the alignment 
to be laid out. If this is unknown, do not cleanup this drawing until it’s been established. 

Step One: Open Windows Explorer 
Open Windows Explorer (Start>Programs>Accessories>Windows Explorer) and browse 
to your project on the y: drive. 

 Regional Offices: Copy the project folder to your local C:\PIN or D:\PIN folder and 
continue with the steps in this document, substituting your C: or D: drive where the 
document says Y: drive.  

 
Figure 3-1: Browse with Windows Explorer 
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Step Two: Open the Topo Folder 
In the example above (Figure 3-1), double click the Topo folder to display its contents. This 
folder should be empty. If it is, proceed to the next step.  

 If this folder already contains files, someone may have started Survey cleanup on this 
project. Do not overwrite these files with the next step. Open the Cleanlog.txt file to see 
if there are any “cleanup” notes. Skip to Step Four: Open MicroStation. 

Step Three: Copy Files from Survey\Msta to Topo Folder 

Part One: Browse to Survey\Msta 
With Windows Explorer still open, browse to the Survey\Msta folder, displaying its contents 
in the rightmost window. 

Part Two: Select Files 
Select the following files (Hold Ctrl to select more than one at a time): 
3DtopoMMDDYY.dgn, 3DmappingMMDDYY.dgn (if one exists), Origtext.dgn, 
Contours.dgn and Points.dgn.  

 If there are more than one 3DtopoMMDDYY.dgn files, this indicates that there has 
been topoadd’s done for this project. Select the most recent file based on its date. If no 
cleanup has been done, cleanup up the latest dated file and you will be taking care of 
every topoadd, including the original topo. All topography is displayed in the latest 
3DtopoMMDDYY.dgn file. Always check the Cleanlog.txt file to see what has been 
cleaned up. 

Part Three: Copy 
From the Main Menu, select Edit>Copy (Figure 3-2). 
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Figure 3-2: Select and Copy files from Survey\MSTA folder 

Part Four: Paste 
Click on the Topo folder. From the Main Menu select Edit>Paste (Figure 3-3). 

 
Figure 3-3: Paste files from Survey\MSTA folder to Topo folder 
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Part Five: Rename Topo, Text and Mapping 
Select 3DtopoMMDDYY.dgn. From the Main Manu, select File>Rename. Begin typing 
the new name, which is Topo.dgn. Hit Enter to accept this name. 

Select Origtext.dgn. From the Main Menu select Files>Rename. Begin typing the new 
name, which is Text.dgn. Hit Enter to accept this name. 

Select 3DmappingMMDDYY.dgn. From the Main Menu select Files>Rename. Begin 
typing the new name, which is Mapping.dgn. Hit Enter to accept this name.  

Part Six: Add Notes to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started Topo.dgn cleanup. 

03/04/02 John Doe - Started Mapping.dgn cleanup. 

03/07/02 John Doe - Finished Topo.dgn cleanup. 

03/07/02 John Doe - Started/Finished Text.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt file so 
that other employees can check the status of the project. If you make the comments 
to your local Cleanlog.txt file, no one else can see this but you. 

Step Four: Open MicroStation 
Open MicroStation by clicking the Icon on your desktop. When the MicroStation Manager 
window appears, pick your project from the Project pull down. Browse to the Topo 
directory by double clicking your project number’s decimal folder (i.e. pin\9045\”00” 
folder), then double clicking the “Topo” folder.  

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.  
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Figure 3-4: Select the topo.dgn and click OK 

You should see four or five drawings on the left. Select topo.dgn (Figure 3-4) and click OK. 
Once the file is open, click Fit View  from Window 1’s view control toolbar. Close 
Window 2, Window 3and Window 4 if necessary and maximize Window 1. 

 If the Topo directory is empty, go back to Step Three and copy files. 

Step Five: Attach Reference Files 
The topo and text drawings do not have any reference files attached by default. Even though 
you can only edit one file at a time, it is helpful to have both drawing displayed. Select 
File>Reference(DOT)>Attach from the Main Menu. Select the Text.dgn, browsing to the 
Topo folder if necessary. Click OK. It is not necessary to enter a Logical or Description. 
Attach by Coincident World method. Repeat this process for the Points.dgn and 
Contours.dgn drawings. To shut off the display of these two reference files, open the 
Reference File dialog (File>Reference from the Main Menu), click the “checkmark” in the 
Display column of the reference files you wish to shut off. 
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Step Six: Turn Off Line Weights (Optional) 
Some users prefer to have line weights shut off. To do this, select Settings>View Attributes 
(Ctrl+B) from the Main Menu. Uncheck Line Weights. Hit Apply. Close View Attributes 
Window. 

Step Seven: Adjust Level Display (Optional) 
You may want to shut off levels 8 (H_V CONTROLS) and 12 (GROUND) in the topo.dgn. 
These are the Traverse Points and the Ground Elevation strings. No Cleanup is required on 
these elements, and shutting them off reduces the clutter on the drawings. This is done by 
selecting Settings>Level>Display (Ctrl+E) and deselecting the levels you don’t want to be 
displayed (Figure 3-5).  

 
Figure 3-5: Deselected Levels in the Level Display  

Refresh the view if necessary. Close this dialog box. 

Step Eight: Load Clean-up Tools (Optional) 
From the Main Menu, select Tools>Tool Boxes… 
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Figure 3-6: Tool Boxes dialog 

Scroll down the list and click to place an “X” in the Survey Editing box (Figure 3-6). Click 
OK. A new set of tools should appear. 

 
Figure 3-7: Survey Editing Tool Box 

These Survey Editing tools (Figure 3-7) are dockable and will auto-load next time you enter 
MicroStation.  

 If you do not have these tools as an option, contact your CADD Support. 

 Element Selection Tool: Can be used to select individual elements or multiple 
elements by holding the Ctrl key. (Also located in the Main Tool Box.) 

Change Element Direction Tool: Use this to reverse a custom linestyle direction. (i.e. 
Trees and Bushes). (Also located in the Modify Tool Box.) 

Edit Text: Says it all. (Also located in the Text tool box.) 

Change Text Attributes: Used to change the text to the MDOT standard height and 
width. (Also located in the Text tool box.) 

Partial Delete: Used to delete part of an element. (Also located in the Modify Tool 
Box.) 

Extend Element to Intersection: Used to extend an element. (Also located in the 
Modify Tool Box.) 
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Rotate: Used to rotate individual elements (i. e. text and cells) around a user-defined 
point or origin point. (Also located in the Manipulate Tool box) 

 For a detailed description of any tool, select Help>Contents and then Help>Tracking. 
Click on each tool, one at a time, and look to the Help window for a description. 

Step Nine: Adjust Ditch Arrows (May be Necessary) 

General Information 
Adjusting the direction of existing ditches (as of  December 2002) is now a responsibility of 
the MX editor. They are supposed to make the adjustments in MX and the direction should 
be correct when the drawings are translated into MicroStation. Older projects may still 
require editing in MicroStation. 

Part One: Adjust Display Of Topo.dgn to Isolate Ditch and Culverts 
(Optional) 
All ditch lines must be checked to see that the arrows point in the direction of the flow of 
water. To isolate the ditch lines, open the Level Display by selecting 
Settings>Level>Display (Ctrl+E). With topo levels displayed, Right Click anywhere in the 
Levels area and select All Except Element (Figure 3-8).  

 
Figure 3-8: Right Click and Select All Except Element 

Click on any ditch line or culvert pipe. Click to select the element, then, click to accept it. 
Only the “Open Drainage” items will be displayed. Close the dialog. 

Part Two – Option A: Using Elevation to Determine Direction 
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An accurate way to determine flow direction is to check the elevation at both ends of the 
ditch line while it is still 3 dimensional.  

Shut off Depth Lock by selecting Settings>Locks>Depth from the Main Menu.  Use a 
Keypoint snap (default snap) with your middle mouse button and click on one end of ditch 
line. Look to the Status bar located in MicroStation’s status bar (Figure 3-9). 

 
Figure 3-9: X, Y and Z coordinate displayed in MicroStation Status bar 

The elevation (Z) is the rightmost set of numbers (or look in the Z field of AccuDraw). Click 
on another vertices of the line to determine which direction the ditch is flowing. Use the 
Reverse Directions tool to change directions if necessary. An example of using the tool is 
in the next step. 

Part Two – Option B: Using Contours to Determine Direction 
Turn on the display of your Contours.dgn (File>Reference from the Main Menu) to 
quickly determine flow direction. Place a “check mark” in the display area for contours.  

 
Figure 3-10: Example of ditch arrow in wrong direction 

In the Example above (Figure 3-10), the ditch arrow is pointing from the 27.00 +/- to 29.00 
+/-, which is uphill and therefore wrong. 

Part Three: Click the Reverse Direction Tool  
Click the tool and follow the prompts in the bottom left status bar.  

Part Four: Select the Line (Identify the Element) 
Click on the line with a left mouse button. An arrowhead will appear (Figure 3-11) 
displaying the current direction of the line. 



mdot MicroStation 

07/01/07 

Survey Clean-up 
Procedures 

3-21 

 

 
Figure 3-11: Reverse Direction tool in action 

Part Five: Define Start of the Line 
The prompt is telling you to click anywhere near the opposite end of the line. This will make 
the other end the starting point (Figure 3-12). As long as the click on the screen is beyond 
the midpoint of the line, it will reverse directions.   

 
Figure 3-12: Reverse Direction results 

Part Six: Adjust Level Display (If You Adjusted it to Isolate 
Drainage) 
Turn on the levels that you shut off. From the Main Menu, select Settings>Level>Display 
(Ctrl+E). With the topo levels displayed, Right Click anywhere in the levels area and select 
All On. Click on the 8 (H_V CONTROLS) and 12 (GROUND) to shut off these two levels. 
Close Window. 

Step Ten: Flatten Your Drawing 
From the Main Menu, select Macros>Flatten. Click OK to accept “0.000” as the desired 
elevation to flatten to. Click anywhere in the view window to accept the command. Fit your 
view. 

Step Eleven: Determine Direction of Proposed Alignment 
This step is very important. Take necessary steps to determine who the Project Manager is 
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for the project. Ask which direction that they anticipate the alignment to be laid out. If this is 
unknown, do not cleanup this drawing until it’s been established. 

Step Twelve: Adjust View and Save Settings (Optional) 

Rotate the View Window 
If your project is not running from left (West) to right (East), you may want to rotate your 
view window so that the majority of the project is horizontal across your screen. Select 
Rotate View from Window 1’s View Controls (Figure 3-13). 

  
Figure 3-13: Rotete View Tool 

When the Rotate View dialog appears, set method to 3 points. First point (0/0), click on 
screen where you want the lower left corner of the new window to be. Second point (+X 
direction), click where you’d like the bottom right corner of the view window to be. Third 
point (+Y direction), click to define the top left corner of the view window (Figure 3-14). 

 
Figure 3-14: Rotating your View 

 Rotate View as often as necessary to get the majority of elements horizontal in your 
view. It is best not to snap to elements in your file while performing this command, 
unless you lock your “Z” prior to doing so (Macros>Set/Lock Z). A slightly skewed 
view may result if the 3 elements snapped to are at different elevations.  
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Graphic Group Unlock 
Disable Graphic Groups by selecting Settings>Locks>Graphic Groups from the Main 
Menu or click the padlock on the status bar and click Graphic Groups to remove the 
checkmark.  

Save Settings 
To save these settings as your default view for the file, select File>Save Settings.  

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Thirteen: Reverse Element Direction 
There are many other directional elements (like ditches) that may require reversing in the 
Topo.dgn. Use the Reverse Directions Tool to reverse tree lines, bush lines, house lines, 
curbing lines, guardrail strings, wetland lines, river and water lines and other underground 
utility lines, to correctly display each element. 

Tree lines, Bush lines and Gardens should have the “rounded” side towards road. The 
rounded cell in the line is representing the canopy or outer edge of the wooded area. 

The heavier line of a house and river line style represents the outer edge of that object. 
House lines may have two or more segments to reverse.  

Underground utility lines and wetland lines have text imbedded in them that may require 
reversing. Water lines, for example, may need to be reversed to show the ‘W’ symbol 
aligned correctly with the centerline or plan sheet.  

Curbing lines may need to be reversed so that the symbol will fall closest to the edge of 
pavement or dashed edge of concrete, gravel or planting.  

Guardrail lines may need to be reversed so that the posts are away from the roadway. 

Click on Change Element Direction Tool and reverse the string(s) (may have more than one 
segments to reverse). 

Part One: Click the Reverse Direction Tool  
Click the tool and follow the prompts in the bottom left status bar.  

Part Two: Select the Line (Identify the Element) 
Click on the line with a left mouse button. An arrowhead will appear displaying the current 
direction of the line. 

Part Three: Define Start of the Line 
The prompt is telling you to click anywhere near the opposite end of the line. This will make 
the other end the starting point. As long as the click on the screen is beyond the midpoint of 
the line, it will reverse directions. 
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 You may have trouble reversing closed elements (shapes, blocks, etc.) and elements 
that go in both directions. Try deleting a small portion of the element using the 

Delete Partial tool.  Click on the Partial Delete Tool. Click anywhere on the 
string, then without moving the cursor away from the center of AccuDraw’s 
compass, click where you originally clicked forming a partial deletion of the line that 
is unnoticeable.  

Step Fourteen: Rotating Topography Cells 

General Information : What to Rotate 
Iron Pins - Rotate so that the text in the cell runs parallel with the roadway. Iron pin rotation 
will vary from pin to pin, so it’s better to rotate these individually. 

Power, Telephone and light poles - Poles that have a line through them should be rotated 
so that the line is perpendicular to the centerline of the roadway. A light pole would have its 
mast over parking lots or the roadway. 

 The point that a Pole is picked up in the field is its face closest to the centerline of the 
roadway. While cleaning up the poles, consider moving the pole so that the 
intersection of the line and circle is represented as the face of the pole closest the 
roadway. Make a note in the CleanLog.txt file. 

Single Post Street signs - The flat side of the sign should be facing the oncoming lane of 
traffic, unless it is a ‘No Parking’ sign or an entrance to a business. These will be facing the 
street (as seen in real life). 

Double Post Signs - Double posted signs are created with a linestyle. This linestyle is 
directional and may need to be reversed to face traffic or the roadway. 

Mailboxes - The short, flat side of mail box cell should be parallel to centerline, with the 
two pointed ends away from the road. 

Catch basins & Drop Inlets - The “grate lines” should be perpendicular to curb / edge of 
pavement (so a bicycle wheel won’t drop into them). 

Hydrants - Rotate so that the spout is facing the roadway (as seen in real life). 

Sill Elevations on buildings - The letters  “Sill El” should generally be perpendicular to the 
building wall.  If on the front face of building, rotate them so they are perpendicular and 
inside the building. 

Global vs. Individual Rotation Introduction 
Most cells will come in from the cell library at the same orientation (with the exception of 
Iron Pins and sill shots) and will need to be rotated around their individual origins to align 
with the centerline at that specific location on the project. 

One pass Globally, using selection sets through the entire project will align the majority of 
cells correctly. The cells that it doesn’t correct will most likely be an even 90-degree 
increment away from being correct. 
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 This method works best on the straight portions of your project. Areas on a curve can 
be dealt with by using smaller selection sets or simply by using individual rotation 
methods.  

Utilize the Individual rotate command for Iron Pins, signs and other item that need final 
tweaking. Intersections of Side Roads require a bit more attention in this respect. 

Global Rotation: Select Multiple Cells to Rotate 
Identify a portion of your project that is fairly straight. If your project is one big curve use 
small selection sets so that global rotation will be effective. 

To set your editing filter to only cells in your file, go to Edit>Select By Attributes. 

 
Figure 3-15: Select By Attributes set to locate cells only 

In the Types portion of the dialog, select Cell. In the Modes section of the dialog, change 
Selection to Location (Figure 3-15). Hit Execute. Now you are only able to edit (rotate) cells 
in your file for the time being. If the dialog gets in the way, you can close it and click OK to 
keep the edit filtering “on” (Figure 3-16). When done editing cells, open Select By 
Attributes again and hit cancel to stop filtering. 

 
Figure 3-16: Select By Attributes Alert Message 
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Using the Power Selector - The power selector works well for selecting single or multiple 
cells because of the various selection methods. You can also add and subtract from your 
selection set easily. Choose Shape method and choose the “+” in the mode field (Figure 
3-17). 

  
Figure 3-17: Power Selector set to shape 

Left click to form a shape around the cells you want to rotate, returning back to the 
beginning point to close the shape. You should see them highlight.  

 To create new selection sets, hit your “spacebar” to clear the current selection set 
(while focus is in Power Selector dialog) and place a shape around the new set of 
cells. 

 Refer to page 2-28 for more information on the Power Selector tool. 

Click the Rotate tool from the Survey Editors tool box or the Main tool frame. In the Tools 
Setting box, click the down arrow (Figure 3-18) to Show Extended Information. Place a 
checkmark in the About Element Center box (Figure 3-19) of the dialog box. 

 
Figure 3-18: Rotate Element’s Show Extended Information button 

 
Figure 3-19: Rotate Element’s About Element Center box 

Active Angle method: Take a rough guess of what the angle would be between the cell and 
the roadway. In the angle field, type in the angle. If you don’t have any idea what the angle 
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might be, try using a 5-degree rotation and click multiple times on the screen to continue 
rotating this amount. (Type in a “-“ for a clockwise rotation.) 

2 Points method: Click on the screen and you are dynamically rotating the cells around 
their origins. Move your cursor around the AccuDraw’s compass until the majority is rotated 
correctly. Click to Accept this rotation. Right Click to stop rotating. 

Individual Rotation 
To perform individual rotations, rotate the cells around the point established by the Survey 
Crew, which is also the center/origin point of most cells.  

 Click the Rotate tool from the Survey Editors tool box or Main tool box. In 
the Tools Setting box, click the down arrow to Show Extended Information. Place a 
checkmark in the About Element Center box of the dialog box. Click near the cell 
(the actual pivot is set to the cells origin based on the tool setting). The cell will 
rotate dynamically as you move the mouse around AccuDraw’s compass. Left click 
again to define the amount of rotation. Right Click to stop rotating the cell. 

Step Fifteen: Moving Vertices 
You may need to connect any storm sewer pipes, sanitary pipes, water lines and other 
underground utilities. Do this only if absolutely certain that the like-sized pipes that point 
towards each other actually connect underground. A field inspection or correspondence with 
town or city utility companies by the Project Manager may be necessary in an urban 
situation.  

Use the Modify Element tool to move one end of the line to the center of the desired utility 
manhole, catch basin or water gate. 

Delete duplicate lines. 

Step Sixteen: Adjust and Save Changes (Courtesy To 
Others) 
Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation. Select File>Save Settings. 

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Seventeen: Add Note to Cleanlog.txt File! 
Make a comment to the Cleanlog.txt to let people know that the topo has been cleaned up. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt so that 
other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you. 



mdot MicroStation 

07/01/07 

Survey Clean-up 
Procedures 

3-28 

 

Step Eighteen: Open and Flatten Contours and Points 
Open the Contour.dgn file located in the \topo folder, select Macros>Flatten from the Main 
Menu. Follow promts. Close MicroStation. Repeat for the Points.dgn file. 

Step Ninteen: Repeat for Mapping.dgn (Projects that 
Utilizes Aerial Mapping) 

Cleanup Mapping.dgn 
If the Survey/MSTA folder has a 3DmappingMMDDYY.dgn, you must clean up this file 
as well. Follow the same steps as outlined in the “Initial Topography Cleanup” section. 
Substitute mapping.dgn where it asks for the topo.dgn.  

 Some older projects may have mapping in a separate folder. Files may not follow the 
naming described in this manual. Contact CADD Support for assistance. 

Merge Mapping.dgn into Topo.dgn 
Once the Mapping.dgn cleanup has been completed, open the topo.dgn file from the Topo 
folder. Select File>Reference (DOT)>Attach from the Main Menu and select the 
Mapping.dgn, browsing to the Topo folder if necessary. Click OK. It is not necessary to 
enter a Logical or Description. Attach by Coincident World method. 

From the Reference File dialog, select the Mapping.dgn file. Then select Tools>Merge 
Into Master. Following the prompts, click in your view window. This dialog will come up 
(Figure 3-20) warning you that you are about to merge the Reference file into your current 
file.  

 
Figure 3-20: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 
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INITIAL TEXT CLEANUP 
Determine Direction of Proposed Alignment 
This step is very important. If you haven’t already, take necessary steps to determine who 
the Project Manager is for the project. Ask which direction that they anticipate the alignment 
to be laid out. If this is unknown, do not cleanup this drawing until it’s been established. 

Step One: Open the Text.dgn (From the Topo Folder) 
Open MicroStation by clicking the Icon on your desktop. When the MicroStation Manager 
window appears, pick your project from the Project pull down. Browse to the Topo 
directory by double clicking your project number’s decimal folder (i.e. pin\9045\”00” 
folder), then double clicking the “Topo” folder.  

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.  

 
Figure 3-21: Select Text in the MicroStation Manager dialog 

You should see four or five drawings on the left. Select text.dgn and click OK (Figure 
3-21). Once the file is open, click Fit View  from Window1’s view control toolbar. Close 
Window2, Window3and Window4 if necessary and maximize Window1. 

 If the Topo directory is empty, go back to Step Three and copy files. 
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Step Two: Reference Topo.dgn and Mapping.dgn (If 
exists) 
Select File > Reference(DOT)>Attach. Browse to the Topo folder if necessary and select 
topo.dgn. It’s not necessary to enter a Logical or Description. Attach by Coincident World 
method. Repeat for Mapping.dgn. 

Step Three: Flatten the Drawing 
From the Main Menu, select Macros>Flatten. Follow prompts. 

Step Four: Adjusting Text Height, Width and Line Spacing 

Introduction 
Depending on whether or not you project is metric or U.S. Customary or when the PIN was 
created, you may or may not have to adjust the height, width and line spacing. Go through 
the following steps to see if your text requires adjusting.  

 Experienced users can use the Analyze Element tool and click on the Details tab to 
compare text sizes from to the Nominal Text sizes below. 

Part One: Select Text 
From the Main Menu select Edit>Select All. All of the text should highlight.  

Part Two: Set the Scale 
Right Click the Settings Manager and select Category Scale. Pick the plot scale that was 
intended for the project (i.e. 1 in. = 25 ft. or 1 in. = 50 ft. (1:250 or 1:500 metric)). 

Part Three: Select Text from Settings Manager 
From the Survey Settings Manager select Text(Misc)>Standard Text (Normal).  

Part Four: Change Text Attributes 
From the Main Menu, select Text>Update Text. Uncheck Justification in the list of 
attributes.  

 It may be necessary to expand the list by clicking on the “Expand” down arrow in 
the Tool Settings window. 

Part Five: Click to Accept the Command 
Zoom in on a piece of text. Click in Window 1 to accept the command and the current 
selection set. All of the text will change size if the change is necessary. If the text doesn’t 
change size, a change wasn’t needed. Use Undo and Re-do to look at the difference if there 
is any. 

 The Line Spacing is an attribute that cannot be preset. If a user wants to stack text 
(multi-line) this setting must be adjusted.  
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Part Six: Select None 
From the Main Menu, select Edit>Select None. 

Step Five: Rotating Text 

General Information 
Most text should be rotated to read from west to east (parallel to centerline), and/or from 
south to north (perpendicular to centerline). In tight situations, a 45-degree rotation is 
acceptable. 

All rotated text, if perpendicular to the centerline, should be legible from the right side of the 
plan sheet. This enables a person to read the text from a stapled set of plans with the most 
ease. 

Text on buildings should be rotated either parallel or perpendicular with the building face. 

Text for drives should run parallel to the drive unless it identifies a wide parking area/lot. 

Global vs. Individual Rotation Introduction 
All text in the text.dgn comes in at the same angle. 

One pass Globally, using selection sets through the entire project will align the majority of 
text elements correctly. The text that it doesn’t correct will most likely be an even 90-degree 
increment away from being correct. 

 This method works best on the straight portions of your project. Areas on a curve can 
be dealt with by using smaller selection sets or simply by using individual rotation 
methods.  

Utilize the Individual rotate command for text blocks that need final tweaking. 
Intersections of Side Roads require a bit more attention in this respect. 

Global Rotation: Select Text Blocks to Rotate 
Identify a portion of your project that is fairly straight. If your project is one big curve use 
small selection sets so that global rotation will be effective. 

Using the Power Selector - The power selector works well for selecting single or multiple 
text blocks because of the various selection methods. You can also add and subtract from 
your selection set easily. Choose Shape method and choose the “+” in the mode field 
(Figure 3-22). 

  
Figure 3-22: Power Selector set to shape 
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Left click to form a shape around the text blocks you want to rotate, returning back to the 
beginning point to close the shape. You should see them highlight.  

Click the Rotate tool from the Survey Editors tool box or the Main tool frame. In the Tools 
Setting box, click the down arrow to Show Extended Information (Figure 3-23). Place a 
checkmark in the About Element Center box of the dialog box (Figure 3-24). 

 
Figure 3-23: Rotate Element’s Show Extended Information button 

 
Figure 3-24: Rotate Element’s About Element Center box 

Active Angle method: Take a rough guess of what the angle would be between the text 
block and the roadway. In the angle field, type in the angle. If you don’t have any idea what 
the angle might be, try using a 5-degree rotation and click multiple times on the screen to 
continue rotating this amount. (Type in a “-“ for a clockwise rotation.) 

2 Points method: Click on the screen and you are dynamically rotating the text blocks 
around their origins. Move your cursor around the AccuDraw’s compass until the majority is 
rotated correctly. Click to Accept this rotation. Right Click to stop rotating. 

 To create new selection sets, hit your “spacebar” to clear the current selection set 
(while focus is in Power Selector dialog) and place a shape around the new set of 
text blocks. 

 Refer to page 2-28 for more information on the Power Selector tool. 

Individual Rotation 
To perform individual rotations, rotate the text block around the point established by the 
Survey Crew, which is also the center/origin point of the cell it identifies. 
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 Click the Rotate tool from the Survey Editors tool box or Main tool frame. In 
the Tools Setting dialog, click the down arrow to Show Extended Information. Place 
a checkmark in the About Element Center box of the dialog box. Click near the text 
block (the actual pivot is set to the text block’s origin based on the tool setting). The 
text block will rotate dynamically as you move the mouse around AccuDraw’s 
compass. Left click again to define the amount of rotation. Right Click to stop 
rotating the text block. 

Step Six: Moving Text 
After text is rotated, it may also require moving. Text should be kept out of and away from 
roadway as much as possible. Use common sense when moving items nearest the cell that 
they describe so the plan “looks good”. Use the Move Element tool to move single text 
blocks. 

 Snapping to text (middle mouse) will show you what the text is describing. This 
works well in areas where text is on top of text making it difficult to distinguish. 
Identify what the text is describing and move it to a better location until all elements 
are clearly identified. 

Step Seven: Editing Text (Optional) 
Text for similar elements should be consistent. Examples of inconsistent labels are 
GRAV.DR., GR.DRIVE, GRAVEL DR.. Adjust these to read GRAVEL DRIVE. (If in a 
tight area, abbreviations may be unavoidable.) Use the Edit Text tool to do this. Click the 
tool and then identify the text. Click once more to Accept and the text will appear in the 
Text Editor window. Make your changes and hit Apply. Right click to stop editing that text 
block.  

Abbreviations or making the text appear on two lines may be necessary in order to squeeze 
long descriptions in highly congested areas. Like items close to each other, may be labeled 
once. To do this, edit the text using the Edit Text tool. Click on the text, once more to Accept 
and it should appear in the Text Editor window. Make your changes and hit Apply (i.e. 5 – 
400 to 500 mm CEDAR SHRUBS). 

Step Eight: Labeling With Arrows (Optional) 
It may be necessary to create an arrow line pointing to the cell it represents. Here are a few 
steps to accomplish this. 

Part One: Select Arrow Line 
Select Text (Misc)>Arrow Lines from the Settings Manager.  

Part Two: Make Lines 
Click to the left of the text block with the left mouse button. Type RQ (Rotate Quick) and 
align your AccuDraw axis along the text block and click your left mouse button. Enter the 
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distance that you want your line to be from the text, 3 feet (1.0 m) is usually good and click 
your left mouse button to Accept. Point to the cell that you are annotating (Figure 3-25). Do 
the same for the other side if necessary. 

 
Figure 3-25: Example of annotating with arrows 

Step Nine: Find and Replace Text (Metric Projects Only)  
Change the units from displaying an upper case ‘MM’ to a lower case ‘mm’ as suggested by 
current Metric standards. Open the Edit > Find And Replace Text dialog box. By using 
certain combinations of strings, you can change all of them globally. Find “0MM”. Replace 
with “0 mm” (gets all numbers ending with a zero). Find “_MM”. Replace with “_mm”. In 
this example, the “_” symbol represents a space. This should change them all. Do the same 
process to change from “M” (meters) to “m”.  

 Some words will have two ‘M’s in them. Commercial is one. Using the above 
combinations will not affect these type words. 

Step Ten: Adjust and Save Changes (Courtesy To Others) 
Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation. Select File>Save Settings. 

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Eleven: Add Note to Cleanlog.txt File! (Courtesy To 
Others) 
Make a comment to the Cleanlog.txt to let people know that the text has been cleaned up. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt so that 
other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you. 
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ADDITIONAL TOPOGRAPHY CLEANUP 
Quick Punch List 

• Copy topoadd# files from Survey/MSTA to Topo folder 
• Rename files (remove the “Orig”) 
• Cleanup Files 
• Flatten Files 
• Blend the two Files 
• Merge file into topo.dgn 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with additional 
topograph files. If the topoadds are needed prior to the cleanup, copy the files to the 
topo folder temporarily. 

 Supply your topoadd number where you see a “#” sign. 

Step One: Copy/Rename Origtopoadd#, Origtextadd#, 
Contours and Points 
Copy Origtopoadd#, Origtextadd#, Contours and Points from the Survey\Msta folder into 
the Topo folder using Windows Explorer. You will be prompted to overwrite Contours and 
Points. Say Yes.   

Select Origtextadd#.dgn. From the Explorers Menu, select File>Rename. Remove the Orig 
from the file name. Repeat for Origtopoadd#.dgn (i.e. topoadd1.dgn and textadd1.dgn.)  

 Refer to Step Three: Copy Files from Survey\Msta to Topo Folder in the Initial 
Topography Cleanup portion of this manual for more detailed instruction if necessary. 

 If there are more than one 3DtopoMMDDYY.dgn files, this indicates that there has 
been topoadd’s done for this project. If no cleanup has been done on the whole 
project, cleanup up the latest dated file and you will be taking care of every topoadd, 
including the original topo. All “ground survey” topography is displayed in the latest 
3DtopoMMDDYY.dgn file. Always check the Cleanlog.txt file to see what has been 
cleaned up. 

 The original 3DmappingMMDDYY.dgn file contains all Aerial Mapping data. No 
additional Aerial mapping is ever done. If there is more than one 
3DmappingMMDDYY.dgn, it means that additional ground survey has been taken in 
the form of a Origtopoadd#.dgn. Survey re-creates a 3DmappingMMDDYY.dgn to 
indicate where the ground survey fits in. This area(s) is encompassed by a boundary 
string. 

Step Two: Add Note to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
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directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started Topoadd#.dgn cleanup. 

03/07/02 John Doe - Finished Topoadd#.dgn cleanup. 

03/07/02 John Doe - Started/Finished Textadd#.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt so that 
other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you. 

Step Three: Open Topoadd# 
Click the MicroStation icon on your desktop and pick your Project from the pull down. 
Browse to the Topo folder. Select Topoadd#.dgn and click OK. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.   

Step Four: Attach Reference Files 
Select File>Reference(DOT)>Attach from the Main Menu. Select the Textadd#.dgn, 
browsing to the Topo folder if necessary. Click OK. It is not necessary to enter a Logical 
name or description for any attachments to this file. Attach by Coincident World method. 
Repeat this process for the Topo.dgn and Text.dgn drawings. Shut off the display of Topo 
and Text unless you need to see the “big” picture. 

Step Five: Refer to Step 6 through Step 18 in the “Initial 
Topo Cleanup” portion of this manual 
Follow the same steps that were followed when doing an Initial topo cleanup. Many steps 
may be skipped depending on the type of information in the Topoadd# file. 
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ADDITIONAL TEXT CLEANUP 
Determine Direction of Proposed Alignment 
It should be apparent which way alignment is going to be laid out from the current Topo and 
Text drawings. Rotate accordingly. 

Step One: Open the Textadd#.dgn (From the Topo Folder) 

Step Two: Reference Topoadd#.dgn 
Select File > Reference(DOT)>Attach. Browse to the Topo folder if necessary and select 
Topoadd#.dgn. It’s not necessary to enter a Logical or Description. Attach by Coincident 
World method. Repeat this process for the Topo.dgn and Text.dgn drawings. Shut off the 
display of Topo and Text unless you need to see the “big” picture. 

Step Three: Refer to Step 3 through Step 11 in the “Initial 
Text Cleanup” portion of this manual 
Follow the same steps that were followed when doing an Initial text cleanup. 
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BLENDING NEW TOPO AND TEXT WITH OLD 
General Information – Blending Tips 
Topoadd1 and Textadd1 features take precedence in the Topo file, therefore, most of the 
work will be done in the topo.dgn file. Edit topo.dgn and text.dgn to accommodate the new 
topography (topoadd1.dgn and textadd1.dgn) to be merged. 

Use a combination of MicroStation’s tools to accomplish the task of “blending” the updated 
Topography with the Topo.dgn and the Text.dgn file. The areas of additional survey should 
stand out from the previous surveys if you use Level Symbology. 

Aerial Mapping Projects 

Part One: Open Topo.dgn – Attach Topoadd# 
Open the Topo.dgn. Select File>Reference (DOT)>Attach from the Main Menu. Browse 
to the Topo folder if necessary and select Topoadd#.dgn. It’s not necessary to enter a 
Logical or Description. Attach by Coincident World method.The Topoadd#.dgn takes 
precedence in the drawing. This will replace any Mapping Survey elements that exist in the 
topo.dgn. There should be a boundary element around the additional ground survey 
elements. 

Part Two: Place Fence By Element 
Select the Place Fence tool. Change Fence Type to Element. Set Fence Mode to Clip. Click 
on the boundary element. The element will highlight indicating the fence was placed. 

Part Three: Delete fence Contents 
Select the Delete Fence Contents tool. Set the Fence Mode to Clip. Click in your view to 
Accept the command. This should remove the old elements that were picked up through 
Aerial Mapping methods to make room for the newly surveyed information. 

Adjust Colors for Easy Editing - Level Symbology 
(Optional) 
Adjusting colors of the drawings will make it easier to distinguish the old Topography and 
the updated Topography. Adjust colors to your personal preference. You may want to follow 
the same steps outlined below for the topo.dgn, text.dgn, and the Topoadd#.dgn, so while in 
that drawing, your colors are the same throughout all of the files you need to edit. The 
example below is adjustments to make while in the topo.dgn. 

Part One: Open Topo.dgn and Attach Topoadd#.dgn and 
Textadd#.dgn 
Open topo.dgn from the \topo folder. Select File > Reference(DOT)>Attach. Browse to 
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the Topo folder if necessary and select Topoadd#.dgn. It’s not necessary to enter a Logical 
or Description. Attach by Coincident World method. Repeat this process for the 
Textadd#.dgn drawing. 

Part Two: Open Topo and Turn On Level Symbology 
From the Main Menu, select Settings>View Attributes (Ctrl + B).  

 
Figure 3-26: View Attributes using Level Symbology 

Place a checkmark in the Level Symbology box (Figure 3-26). Hit Apply. 

Part Three: Assign Colors to the Active Design File (i.e. Topo) 
Open the Settings>Level>Manager dialog from the Main Menu. 
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Figure 3-27: Level Manager dialog 

In the leftmost window, click to highlight Topo (Figure 3-27) which is the active file you are 
in. Right-Click in the rightmost window and pick Select All (Figure 3-28). All Levels will 
highlight (Figure 3-29). 

 
Figure 3-28: Right Click and select Select All 
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Right-Click again and select Properties (Figure 3-29). 

 
Figure 3-29: Right Click and select Properties 

In the Level Properties dialog, adjust the Symbology Overrides to look like the dialog in 
Figure 3-30. (Ignore the Symbology: By Level area.) Hit OK. 
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Figure 3-30: Symbology Overrides section of Level Properties 

Part Four: Repeat for Text.dgn 
Repeat the same process for the text.dgn. Be sure to select the text.dgn on the left side of the 
dialog to display its levels. If you don’t see the text drawing, expand the tree by clicking the 
“+” sign next to topo.dgn. Use the same color you used for topo. 

Part Five: Assign Colors to the Topoadd# 
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Figure 3-31: Right Click and pick Select All 

In the leftmost window, click to highlight Topoadd1.dgn. Right-Click in the rightmost 
window and pick select all (Figure 3-31). All Levels will highlight. 

Right-Click again and select Properties. 

In the Level Properties dialog, adjust the Symbology Overrides to look like the dialog in 
Figure 3-32. (Ignore the Symbology: By Level area.) Hit OK. 
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Figure 3-32: Symbology Overrides section of Level Properties 

Part Six: Repeat for Textadd#.dgn 

Part Seven: Refresh View 
Click on the paintbrush in the View Controls tools to Refresh the view. 

Part Eight: Save Settings 
From the Main Menu, select File>Save Settings. 

 File Swapping (Handy Tip - Optional) 
While editing the Topo file, you may need to swap back and forth between it and the 
Text.dgn and/or the Topoadd1.dgn. Try using File>Reference(DOT)>HotSwap. Follow 
prompts as the macro takes you to the element you select in any of the reference files you 
have attached. This gives you the capability to edit it. Also, use File>2 (Alt+F+2) to swap to 
the file you just came from. 

Highlite Display of Reference Files (Optional) 
In the Reference File dialog, set your Hilte Mode to Hilite. Select a reference file to hilite 
it. 
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Update the Reference File Sequence (Optional) 
Some people may want to change which file is displayed on top of which file. In the 
Reference File dialog, select Settings>Update Sequence. This determines which file is 
displayed first.  
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MERGING NEW TOPO AND TEXT WITH OLD 
Step One: Open Topo.dgn and Attach Topoadd#.dgn 
Open topo.dgn from the \topo folder. Select File > Reference(DOT)>Attach. Browse to 
the Topo folder if necessary and select Topoadd#.dgn. It’s not necessary to enter a Logical 
or Description. Attach by Coincident World method. 

Step Two: Merging Topoadd# File 

Part One: Select Reference File to Merge 
Once the Topo file has been edited to allow for incorporation of the new topography, open 
the File>Reference(DOT)>Dialog. 

From the Reference File dialog, select the Topoadd#.dgn file. Then select Tools>Merge 
Into Master. Following the prompts, click in your view window. This dialog will come up 
(Figure 3-33) warning you that you are about to merge the Reference file into your current 
file. 

  
Figure 3-33: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 

Part Two: Adjust and Save Changes 
Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation.  

If Level Symbology was used, select Settings>View Attributes and uncheck Level 
Symbology. Hit Apply. Close View Attributes Window. 

Select File>Save Settings. Exit MicroStation. 

Step Three: Open Text.dgn and Attach Textadd#.dgn 
Open text.dgn from the topo folder. Select File > Reference(DOT)>Attach. Browse to the 



mdot MicroStation 

07/01/07 

Survey Clean-up 
Procedures 

3-47 

 

Topo folder if necessary and select Textadd#.dgn. It’s not necessary to enter a Logical or 
Description. Attach by Coincident World method. 

Step Four: Merging Textadd# Files 

Part One: Select Reference File to Merge 
Once the Text file has been edited to allow for incorporation of the new text, open the 
File>Reference(DOT)>Dialog. 
From the Reference File dialog, select the Textadd#.dgn file. Then select Tools>Merge 
Into Master. Following the prompts, click in your view window. This dialog will come up 
(Figure 3-34) warning you that you are about to merge the Reference file into your current 
file. 

  
Figure 3-34: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh.  

Part Two: Adjust and Save Changes 
Rotate Window 1 back to a top view. Click on Rotate View and set the Method to Top. Click 
in the view to accept the new rotation.  

If Level Symbology was used, select Settings>View Attributes and uncheck Level 
Symbology. Hit Apply. Close View Attributes Window. 

Select File>Save Settings. Exit MicroStation. 

Step Five: Moving Topoadd# and Textadd# 
Using Windows Explorer, move the Topoadd#.dgn and the Textadd#.dgn files you just 
edited and merged from the Topo folder to the ADDSDONE folder located in your project’s 
Topo folder. 

 If Topoadd and Textadd drawings still exist in the Topo folder, this should tell a user 
that the clean up and merging is not yet complete. 

Step Six: Add Note to Cleanlog.txt File! 
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Follow steps previously outlined in this document. Add a note saying that the two files have 
been merged. 

 Regional employees make changes to this file on the Y: drive.  

Step Seven: Copy Contents of Topo folder to Y:drive 
(Regional Employees) 
If you are a Regional Employee or did the cleanup on your C: or D: drive, copy the contents 
of the Topo folder on your hard drive to the Y: drive Topo folder of your PIN number. As in 
similar procedures outlined in this manual, use the Edit>Copy and the Edit>Paste 
commands in Windows Explore. 
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WWEETTLLAANNDD  SSUURRVVEEYY  CCLLEEAANNUUPP  
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GENERAL INFORMATION 
Standard Naming 
The department has a standard naming convention for drawing files. The main reason for 
this is that many of our standard plan view type drawings for the department have the 
existing topography information referenced into them by default. This default reference only 
works when the files are named correctly and when they exist in the correct location.  

Please follow procedures outlined below to adhere to these standards. The standard file 
names for existing Survey information residing in the Topo folder are Topo, Text, Contours, 
Points and Wetlands. These are the only five files that should permanently live in the Topo 
folder. Click this link for a complete list of MDOT Standard File Names or visit the website 
at www.maine.gov/mdot/cadd-support/microstation/std_filename.php. 

Preserving Original Files 
The Survey\Msta Folder is where the “Original” Survey files are stored. The folder will act 
as the topographical history for any given project. A user can open the folder and tell what 
was done for original survey, and all subsequent “survey adds”. The folder is Read-Only to 
everyone except for the Survey Editors, therefore, MicroStation Survey clean up will be 
done in the Topo folder. If network speed is an issue because of proximity to the server, 
then copy the necessary files locally.  

 Regional Office users should refer to page12-1:    Regional Workflow documentation for 
working with files locally. Please consult CADD Support for assistance. 

The End Result 
The end result is to make the wetlands.dgn, which exist in the Topo folder, a combination 
of all wetlands lines and text for the project. This would leave no question as to which 
drawing needs to be referenced to display all of the cleaned up wetlands for the project. 

http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
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INITIAL WETLANDS CLEANUP 
Quick Punch List 

• Copy files from Survey/MSTA to Topo folder 
• Rename files 
• Cleanup Files 
• Flatten Files 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with original wetlands 
file. If the wetlands are needed prior to the cleanup, copy the file to the Topo folder 
and rename it.   

Step One: Open Windows Explorer 
Open Windows Explorer (Start>Programs>Accessories>Windows Explorer) and browse 
to your project on the y: drive. 

 Regional Offices: Copy the project folder to your local C:\PIN or D:\PIN folder and 
continue with the steps in this document, substituting your C: or D: drive where the 
document says Y: drive.  

 
Figure 3-35: Browse to your PIN’s topo folder 

Step Two: Open the Topo Folder 
In the example Figure 3-35, double click the Topo folder to display its contents. This folder 
should not have a wetlands.dgn file in it. If it does, skip the next step.  
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 If this folder already contains files, someone may have started Wetlands cleanup on 
this project. Do not overwrite this file with the next step. Open the Cleanlog.txt file to 
see if there are any “cleanup” notes. Skip to Step Four: Open MicroStation. 

Step Three: Open the Survey\MSTA Folder - Copy Files to 
Topo Folder 

Part One: Browse to Survey\MSTA 
With Windows Explorer still open, browse to the Survey\MSTA folder, displaying its 
contents in the rightmost window. 

Part Two: Select Files 
Select the origwetlands.dgn. If there have been additional wetland areas added to this 
project (i.e. wetlandsadd1.dgn) and no cleanup has been done on any of it, select these also. 

Part Three: Copy 
From the Main Menu, select Edit>Copy (Figure 3-36). 

 
Figure 3-36: Copy origwetlands.dgn from the Survey\MSTA folder 

Part Four: Paste 
Click on the Topo folder. From the Main Menu select Edit>Paste (Figure 3-37). 
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Figure 3-37: Paste origwetlands.dgn into the Topo folder 

Part Five: Rename Origwetlands 
Select Origwetlands.dgn. From the Main Manu, select File>Rename. Begin typing the 
new name, which is wetlands.dgn. Hit Enter to accept this name. 

Part Six: Add Notes to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started wetlands.dgn cleanup. 

03/07/02 John Doe - Finished wetlands.dgn cleanup. 

03/07/02 John Doe - Started/Finished wetlands.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt so that 
other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you unless you have your 
project Briefcased. In this case, be sure to synchronize this file also. 

Step Four: Open MicroStation 
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Open MicroStation by clicking the Icon on your desktop. When the MicroStation Manager 
window appears, pick your project from the Project pull down. Browse to the Topo 
directory by double clicking your project number’s decimal folder (i.e. pin\9045\”00” 
folder), then double clicking the “Topo” folder.  

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.  

 
Figure 3-38: Select wetlands.dgn from your list of available files 

You should see your drawing on the left. Select wetlands.dgn (Figure 3-38) and click OK. 
Once the file is open, click Fit View  from Window1’s view control toolbar. Close 
Window2, Window3and Window4 if necessary and maximize Window1. 

 If the Topo directory is empty, go back to Step Three and copy the file(s). 

Step Five: Attach Reference Files 
The wetlands drawing doesn’t have any reference files attached by default. Even though you 
can only edit one file at a time, it is helpful to have other drawings displayed. Select 
File>Reference(DOT)>Attach from the Main Menu. Select the alignments.dgn, browsing 
to the Highway or Bridge\MSTA folder if necessary. Click OK. It is not necessary to enter 
a Logical or Description. Attach by Coincident World method. 

 If an alignments.dgn file is not found, take necessary steps to determine who the 
Project Manager is for the project. Ask which direction that they anticipate the 
alignment to be laid out. If this is unknown, do not cleanup this drawing until it’s 
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been established. This will determine which direction you adjust the linestyles for 
readability. 

Step Six: Flatten Your Drawing 
From the Main Menu, select Macros>Flatten. Click OK to accept “0.000” as the desired 
elevation to flatten to. Click anywhere in the view window to accept the command. Fit your 
view. 

Step Seven: Adjust View and Save Settings (Optional) 

Rotate the View Window 
If your project is not running from left (West) to right (East), you may want to rotate your 
view window so that the majority of the project is horizontal across your screen. Select 
Rotate View from Window 1’s View Controls (Figure 3-39). 

  
Figure 3-39: Rotate View tool 

When the Rotate View dialog appears, set method to 3 points. First point (0/0), click on 
screen where you want the lower left corner of the new window to be. Second point (+X 
direction), click where you’d like the bottom right corner of the view window to be. Third 
point (+Y direction), click to define the top left corner of the view window (Figure 3-40). 

 
Figure 3-40: Rotating View with 3 point method 
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 Rotate View as often as necessary to get the majority of elements horizontal in your 
view. It is best not to snap to elements in your file while performing this command, 
unless you lock your “Z” prior to doing so (Macros>Set/Lock Z). A slightly skewed 
view may result if the 3 elements snapped to are at different elevations.  

Graphic Group Unlock 
Disable Graphic Groups by selecting Settings>Locks>Graphic Groups from the Main 
Menu or click the padlock on the status bar and click Graphic Groups to remove the 
checkmark.  

Save Settings 
Select File>Save Settings to save these settings as your default view for the file. 

 If Save Settings is grayed out, this means that your current preferences are to save 
settings on exit. It will accomplish what this step is intended to do.  

Step Eight: Reverse Wetland Linestyle Direction 

Objective 
Wetland lines have text imbedded in the linestyle. Ultimately, we want the text to be legible 
when the plans are cut into sheets. The text should be readable from left to right in 
accordance to the direction of the alignment. 

Part One: Click the Reverse Direction Tool  
The Reverse Element Directions tool is located in the Modify toolbox or from the Main 
Menu select Qualities>Change>Directions. Click the tool and follow the prompts in the 
bottom left status bar.  

Part Two: Select the Line (Identify the Element) 
Click on the line with a left mouse button. An arrowhead will appear displaying the current 
direction of the line. 

Here is an example of a wetland line before clean up (Figure 3-41). Notice only part of the 
line reads correctly. 
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Figure 3-41: Example before reversing elements 

Part Three: Define Start of the Line 
The prompt is telling you to click anywhere near the opposite end of the line that needs 
reversing. This will make the other end the starting point. As long as the click on the screen 
is beyond the midpoint of the line, it will reverse directions. 

Here is an example of a wetland line after clean up (Figure 3-42). Notice that all portions of 
the line read correctly. A partial delete had to be done to get accomplish this.  

 
Figure 3-42: Example of a cleaned up wetland line 

 You may have trouble reversing closed elements (shapes, blocks, etc.) and elements 
that go in both directions. Try deleting a small portion of the element using the 

Delete Partial tool which is located in the Modify toolbox.  Click on the Partial 
Delete Tool. Click on a vertex of the string, then without moving the cursor away 
from the center of AccuDraw’s compass, click where you originally clicked forming 
a partial deletion of the line that is unnoticeable.  

Step Nine: Moving Vertices 
You may need to adjust wetland lines because the line may not have been drawn correctly. 
Use the Modify Element tool to move a vertex from one location to another. 
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Step Ten: Changing Linestyle (if necessary) 
If the wetland Linestyle is incorrect, select the line and select Wetland/Rare 
Vegetation>?New Type? from the Settings Manager. Select Quality>Change>Symbology 
from the main menu and click in the view window. 

Step Eleven: Add Wetland Lines (if necessary) 
Use the Settings Manager to place new wetland lines if necessary. Select Wetland/Rare 
Vegetation>?Type? from the Settings Manager. Draw the line using AccuDraws abilities. 
If there are Station and offsets available, consider using the the Point Along macro. 

 Refer to page 2-81 for instructions for entering  station and offset values for plotting 
wetland lines manually.  

Step Ten: Adjusting Text Height, Width and Line Spacing 

Introduction 
Depending on whether or not you project is metric or U.S. Customary or when the PIN was 
created, you may or may not have to adjust the height, width and line spacing. Go through 
the following steps to see if your text requires adjusting.  

 Experienced users can use the Analyze Element tool and click on the Details tab to 
compare text sizes from to the Nominal Text sizes below. 

Part One: Select Text 
From the Main Menu select Edit>Select All. All of the text should highlight.  

Part Two: Set the Scale 
Right Click the Settings Manager and select Category Scale. Pick the plot scale that was 
intended for the project (i.e. 1 in. = 25 ft. or 1 in. = 50 ft. (1:250 or 1:500 metric)). 

Part Three: Select Text from Settings Manager 
From the Survey Settings Manager select Text(Misc)>Standard Text (Normal).  

Part Four: Change Text Attributes 
From the Main Menu, select Text>Update Text. Uncheck Justification in the list of 
attributes.  

 It may be necessary to expand the list by clicking on the “Expand” down arrow in 
the Tool Settings window. 

Part Five: Click to Accept the Command 
Zoom in on a piece of text. Click in Window 1 to accept the command and the current 
selection set. All of the text will change size if the change is necessary. If the text doesn’t 
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change size, a change wasn’t needed. Use Undo and Re-do to look at the difference if there 
is any. 

 The Line Spacing is an attribute that cannot be preset. If a user wants to stack text 
(multi-line) this setting must be adjusted.  

Part Six: Select None 
From the Main Menu, select Edit>Select None. 

Step Eleven: Rotating Text 

General Information 
It is up to the discretion of the individual or their unit as to rotate the wetland flags or not. 
Since other units will most likely shut off the wetland “flag” text, it’s important to know that 
you are doing this for your biologist’s checking purposes only. 

Most text should be rotated to read from west to east across your screen (parallel to 
centerline), and/or from south to north (perpendicular to centerline). In tight situations, a 45-
degree rotation is acceptable. 

All rotated text, if perpendicular to the centerline, should be legible from the right side of the 
plan sheet. This enables a person to read the text from a stapled set of plans with the most 
ease. 

Global vs. Individual Rotation Introduction 
All text in the wetlands.dgn comes in at the same angle. 

One pass Globally, using selection sets through the entire project will align the majority of 
text elements correctly. The text that it doesn’t correct will most likely be an even 90-degree 
increment away from being correct. 

 This method works best on the straight portions of your project. Areas on a curve can 
be dealt with by using smaller selection sets or simply by using individual rotation 
methods.  

Utilize the Individual rotate command for text blocks that need final tweaking. 
Intersections of Side Roads require a bit more attention in this respect. 

Global Rotation: Select Text Blocks to Rotate 
Identify a portion of your project that is fairly straight. If your project is one big curve use 
small selection sets so that global rotation will be effective. 

Using the Power Selector - The Power Selector works well for selecting single or multiple 
text blocks because of the various selection methods. You can also add and subtract from 
your selection set easily. Choose Shape method and choose the “+” in the mode field 
(Figure 3-43). 
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Figure 3-43: Power Selector set to shape 

Left click to form a shape around the text blocks you want to rotate, returning back to the 
beginning point to close the shape. You should see them highlight.  

Click the Rotate tool from Main tool frame. In the Tools Setting box, click the down arrow 
to Show Extended Information (Figure 3-44). Place a checkmark in the About Element 
Center box of the dialog box (Figure 3-45). 

 
Figure 3-44: Rotate Element’s Show Extended Information button 

 
Figure 3-45: Rotate Element’s About Element Center box 

Set Method to 2 Points. Click on the screen and you are dynamically rotating the text blocks 
around their origins. Move your cursor around the AccuDraw’s compass until the majority is 
rotated correctly. Click to Accept this rotation. Right Click to stop rotating. 

 To create new selection sets, hit your “spacebar” to clear the current selection set 
(while focus is in Power Selector dialog) and place a shape around the new set of 
text blocks. 

 Refer page2-28 for more information on the Power Selector tool. 

Individual Rotation 
To perform individual rotations, rotate the text block around the point established by the 
Survey Crew, which is also the center/origin point of the cell it identifies. 



mdot MicroStation 

07/01/07 

Survey Clean-up 
Procedures 

3-61 

 

 Click the Rotate tool from the Main tool frame. In the Tools Setting dialog, 
click the down arrow to Show Extended Information. Place a checkmark in the About 
Element Center box of the dialog box. Click near the text block (the actual pivot is 
set to the text block’s origin based on the tool setting). The text block will rotate 
dynamically as you move the mouse around AccuDraw’s compass. Left click again 
to define the amount of rotation. Right Click to stop rotating the text block. 

Step Twelve: Moving Text 
After text is rotated, it may also require moving. Use common sense when moving items 
nearest the vertex that they describe so the plan “looks good”. Use the Move Element tool to 
move single text blocks. 

 Snapping to text (middle mouse) will show you what the text is describing. This 
works well in areas where text is on top of text making it difficult to distinguish. 
Identify what the text is describing and move it to a better location until all elements 
are clearly identified. 

Step Thirteen: Add Note to Cleanlog.txt File! 
Make a comment to the Cleanlog.txt to let people know that the wetlands have been cleaned 
up. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt so that 
other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you. 
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ADDITIONAL WETLANDS CLEANUP 
Quick Punch List 

• Copy wetlandsadd# file(s) from Survey/MSTA to Topo folder 
• Cleanup Files 
• Flatten Files 
• Blend the two Files 
• Merge file into wetlands.dgn 
• Add note to Cleanlog.txt file 

 This punch list is to give an overview of what is to be done with additional wetland 
files. If the wetlandsadds are needed prior to the cleanup, copy the files to the topo 
folder temporarily. 

 Supply your wetlandsadd number where you see a “#” sign. 

Step One: Copy Wetlandsadd# 
Copy wetlandsadd#.dgn from the Survey\Msta folder into the Topo folder using Windows 
Explorer. 

 Refer to page 3-52 to see how it was done in the Initial Wetlands Cleanup portion of 
this manual. 

Step Two: Add Note to Cleanlog.txt File! 
As a courtesy to others, always add a note to the Cleanlog.txt file located in the Topo 
directory as progress is made during the cleanup process. Here are a few examples of 
informative cleanup notes.  

03/04/02 John Doe - Started Wetlandsadd#.dgn cleanup. 

03/07/02 John Doe - Finished Wetlandsadd#.dgn cleanup. 

03/07/02 John Doe - Started/Finished Wetlandsadd#.dgn cleanup. 

 Regional Office employees that copy the project locally should browse to the 
Y:drive PIN folder and make the edits to the network copy of the Cleanlog.txt so that 
other employees can check the status of the project. If you make the comments to 
your local Cleanlog.txt file, no one else can see this but you. 

Step Three: Open Wetlandsadd# 
Click Bentley (MicroStation) icon and pick your Project from the pull down. Browse to the 
Topo folder. Select Wetlandsadd#.dgn and click OK. 

 If the project pull down does not take you to your project, contact your CADD 
Support personnel.   

Step Four: Attach Reference Files 
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Select File>Reference(DOT)>Attach from the Main Menu. Select the Wetlands.dgn, 
browsing to the Topo folder if necessary. Click OK. It is not necessary to enter a Logical 
name or description for any attachments to this file. Attach by Coincident World method. 
Select the alignments.dgn, browsing to the Highway or Bridge\MSTA folder if necessary. 
Click OK. Attach by Coincident World method. 

Step Five: Refer to Step 6 through Step 13 in the “Initial 
Wetlands Cleanup” portion of this manual 
Follow the same steps that were followed when doing an Initial wetlands cleanup. 
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MERGING NEW WETLANDS WITH OLD 
Step One: Open Wetlands.dgn and Attach 
Wetlandsadd#.dgn 
Open wetlands.dgn from the \topo folder. Select File > Reference(DOT)>Attach. Browse 
to the Topo folder if necessary and select Wetlandsadd#.dgn. It’s not necessary to enter a 
Logical or Description. Attach by Coincident World method. 

Step Two: Merging Wetlandsadd# Files 
Once the Wetlands file has been edited to allow for incorporation of the new wetlands, open 
the File>Reference(DOT)>Dialog. 

From the Reference File dialog, select the Wetlandsadd#.dgn file. Then select 
Tools>Merge Into Master. Following the prompts, click in your view window. This dialog 
will come up (Figure 3-46) warning you that you are about to merge the Reference file into 
your current file. 

  
Figure 3-46: Merging Reference File Alert 

If everything looks good, click OK to proceed. 

Hit Refresh. 

Step Three: Moving Wetlandsadd# 
Using Windows Explorer, move the Wetlandsadd#.dgn file(s) you just edited and merged 
from the Topo folder to the ADDSDONE folder located in your project’s Topo folder. 

 If Wetlandsadd drawings still exist in the Topo folder, this should tell a user that the 
clean up and merging is not yet complete. 

Step Four: Add Note to Cleanlog.txt File! 
Follow steps previously outlined in this document. Add a note saying that the two files have 
been merged. 

 Regional employees make changes to this file on the Y: drive.  
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Step Five: Copy Contents of Topo folder to Y:drive 
(Regional Employees) 
If you are a Regional Employee or did the cleanup on your C: or D: drive, synchronize your 
files in the briefcase (if one was used) or copy the contents of the Topo folder on your hard 
drive to the Y: drive Topo folder of your PIN number. As in similar procedures outlined in 
this manual, use the Edit>Copy and the Edit>Paste commands in Windows Explorer.
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TTIITTLLEE  SSHHEEEETT  DDEEVVEELLOOPPMMEENNTT  
Quick Punch List 
• Create a Title Sheet Using Make Sheetz 

• Edit Headings Using Border Macro 

• Create a Location Map  

• Create a Layout Drawing (If Necessary) 
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CREATE A TITLE SHEET 
Step One: Open MicroStation 
To begin, double click on your MicroStation icon and select your project from the project 
pull down. Open any file. 

Step Two: Create Title Sheet 
Select File>Make Sheetz from the Main Menu. 

Use a numbered prefix. The default is 001_ which makes this the first sheet in your final 
plan set. 

 If for some reason you will need two title sheets for this project, add the suffix “1” to 
avoid having two files with the same root file name. 

 Refer to page 1-18 for help making sheets. 

Step Three: Editing Text Headings 
Do not manually edit the text in your title sheet. Use Workspace>Edit Project Data(PCF) 
to change all of the variables in your drawing. Variables are any text in your drawing that 
has a “$” or “@” symbol in it. The text that remains can be edited by using the Edit Text tool 
or by selecting Text>Edit Text from the Main Menu. 

 To learn more about editing variables in your PCF file, refer to PCF Editing on page1-
25. 
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CREATING LOCATION MAPS 
Step One: Open Location Map 
From the Main Menu, select File > Open Location Map. Select the file called “Statemap-
local.dgn”. This should be pointing to your C: or D: drive if you have the Location Map files 
copied locally. You can open the files over the network, however they are large are will 
open very slowly. Contact CADD Support if you are pointing to the network for the 
Statemap#.dgn files.  

Step Two: Locate the Project Area 
Find the area of the state that your project is located. Once you have located this area, run 
the location map macro from your Main Menu by selecting Macro > Location Map. 

Step Three: Place the Square 
Once the macro has been activated a square boundary element will appear on your cursor. 
(If it doesn’t, you may be zoomed in too close.) Place the square around the project area 
trying to encompass any text that you want to appear in your map. 

 The size of the square can be modified to cover a larger area by adjusting the X, Y 
and scale (i.e. X=2, Y=2, Z=2 to double the area of the map) before placing it on the 
map. Contact CADD Support for assistance if necessary. 

Step Four: Save the Locmap.dgn 
A dialog will appear stating the directory path and a default file name of Locmap.dgn.  

 If this is not the right directory, hit Cancel. You will need to start back at Step No. 1 of 
the “Create a Title Sheet”, selecting the correct PIN from the “Project Pull-down” in 
the MicroStation Manager dialog. 

If all looks good, Hit OK to let the macro create the file. It will then open the file it just 
created. 

Step Five: Copy Map to Clipboard 
After the macro opens the file it just created, it will select all elements and copy them to the 
clipboard. It will show you the Information dialog (Figure 4-1). 

 
Figure 4-1: Map copied to clipboard 
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 This step doesn’t always work. What the macro intends to automate is selecting all of 
the elements in the file, snapping (without accepting) to a corner of your box and 
activating the Edit>Copy command. Do this manually if the automation doesn’t work. 

Step Six: Paste Map 
Select Edit>Paste from the Main Menu.  

Set the scale in the Tool Settings dialog. Here are some scales to use when pasting the 
location map into certain files: 

1:1 border drawing, (i.e. 001_Title.dgn) set the scale to .00000789 for U. S. Customary 
projects (.00001 for metric projects).  

1:250 border drawings, (i.e. 003_Plan1.dgn) set the scale to .0025. This is used for the 
Bridge Programs metric “Preliminary Plan” drawings. 

1:300 (1” = 25’) border drawings, (i.e. 003_Plan1.dgn) set the scale to .00234. This is used 
for the Bridge Programs U.S. Customary “Preliminary Plan” drawings. 

Snap to the corner of the location map box on your title sheet. Left Click to accept. 

Once you have pasted the map into the title sheet you can clean it up as necessary. 

 If you adjusted the size of your map to cover a larger area (i.e. 2 times larger) enter 
one of the scales above depending on the application. Use AccuDraw’s calculating 
ability to divide (“/”) the X, Y and Z by 2 to get the map to fit the standard map 
border. Adjust the scale as necessary. 
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CREATING A LAYOUT (HIGHWAY PROJECTS 
WITH A SURVEY & DESIGN) 

Introduction 
Once the proposed design file (i.e. highway.dgn or bridge.dgn) has been created and 
flattened to zero, follow these steps to create a layout drawing to be placed on the title sheet. 

Step One: Create a Layout Drawing 
Open any drawing in your PIN directory if you’re not already in one. From the Main Menu, 
select File>Make Sheetz. Create a drawing called z_layout.dgn.  

 Check page 1-18 for more about creating drawings using the Makesheetz macro. 

Step Two: Place a North Arrow 
Do a Fit View. The default View orientation should be Top which means North is up. Using 
the Plan Sheet Settings Manager, select Symbols & Linestyles > North Arrow True. In 
the Tool Settings dialog, enter 90 degrees in the Active Angle field, click on the padlock to 
lock the X, Y, and Z fields. (Figure 4-2)  

 
Figure 4-2: Adjust Active Angle, Padlock locked 

Type 300 (250 metric) in the X field, followed by a (Shift+8), then, enter the total number of 
clip boundaries on the main line for your project (your referenced hdplan.dgn boundaries) in 
the layout drawing. This will size the cell appropriately for the title sheet. (Figure 4-3) 

 
Figure 4-3: Using AccuDraw’s Calculator  

Set the cell down close to the boundaries in your layout drawing, with a Datapoint. 

Step Three: Rotate Your View 
Rotate your view using the 3 points method until the graphics in your view are aligned the 
way you want to see them on your title sheet. 
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 To make clip boundary horizontal: snap and accept to the lower left and lower right 
corners of your boundary. These two points define the X-axis. Snap and accept to the 
upper left corner of the boundary to provide the final point (positive Y direction 
according to your first point).  

Step Four: Create a Saved View 
Using the Plan sheet Settings Manager, select Create Plan Sheets > Create Saved View. 
Now define the rectangle for your saved view. Be sure to encompass all clip boundaries and 
your north arrow. Read the dialog and follow the prompts.  

A dialog will appear asking for a name of your saved view. Name it “layout.” A description 
is not necessary.  

Leave the Add Shape box unchecked.  

Click Make. (Figure 4-4) 

 
Figure 4-4: Saved View Dialog Settings 

Step Five: Reference the view into the Title Sheet 
Open the title sheet (i.e.001_title.dgn). 

Go to File > Reference (Dot)>Attach. 

Select z_layout and hit OK. 

In the Attach Reference Settings dialog, select the named view called “layout”.  

Determine how many clip boundaries (plan sheets) on the main line for your project (your 
referenced hdplan.dgn boundaries) in the layout drawing. Multiply this number by the scale 
in which the sheets were cut (i.e. 300 (250 metric)). Enter this number in the right most field 
of the scale (Master:Ref) portion of this dialog to scale your layout file appropriately. (i.e. 
12 sheets x 300 = 3600) See Figure 4-5. 

 If after attaching you decide that you want to the area is too large to fit on the title 
sheet, you can adjust the attachment with a series of commands or simply detach and 
reattach adding a one to your number of sheets. (i.e. 1 + 12 sheets (13) x 300 = 3900) 
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Figure 4-5: Sample Setting for Attaching Layout 

Set the Nested Attachments: to Copy Attachments with a Depth set to “1”. This will attach 
the layout drawing and everything it has attached with it. 

 Check page 2-71 for an explanation of Reference Nesting. 

Click OK and you should see a rectangle on your cursor. Left click to place it down on the 
title sheet. You can move it if necessary in the next step. 

Fit View.  

 If you aren’t seeing the same thing you saw in your layout.dgn, place a fence around 
the border and select File>Reference (DOT)>Clip>Boundary>All. Set the Method 
to Fence, place a check in the Use References Dialog List and click in the view 
window (Figure 4-6). 

 
Figure 4-6: Set the Clip Boundary Tool Settings dialog 

Step Six: Tweaking the Layout Placement 
Once the layout is placed, you can still manipulate the reference files.  

Go to File > Reference (Dot) > Dialog. Select all reference files in the dialog. 

In the Reference Dialog, choose Tools > Move or Tools > Scale or Tools > Rotate if 
things need to be moved, rotated or scaled again. You can repeat this function as many 
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times as you want, being sure that all reference files are selected before manipulating. You 
may need to move other things around in your Title sheet to make room for it (i.e. scales, 
location map box, etc).  

 When rotating the referenced saved view, rotate it in the “Z” value only. 

Step Seven: Stationing the Layout 

Introduction 
The alignment drawing that is attached is most likely too small to read on your Title sheet. It 
is also centered in your roadway which is going to be filled in, identifying the new pavement 
area. The alignment is a temporary attachment to be used as a guide for the next step and can 
be shut off eventually. 

Part One: Open z_layout.dgn 
Open your z_layout drawing and turn off your graphic group lock 
(Settings>Locks>Graphic Groups). 

 Refer to page 2-41 for a description of working with graphic groups. 

Part Two: Copy Alignment String 
Copy your alignment element into the z_layout file using the copy tool. It isn’t necessary to 
copy in the station or tick marks.  

Part Three: Graduate – Create New Tick Marks 
Measure a rough distance from the centerline to a point just outside of the proposed 
pavement area to determine how long the tick mark will have to be to still be visible once 
the pavement is filled in. 

Use the Plan Sheet Settings Manager to place station lines by selecting Graduate from the 
left side, and depending on the proposed pavement widths, select a tick mark that will be 
long enough to be visible outside of the shaded pavement area. Current options are 20’, 25’, 
40’ 50’ and 60’ for US Customary projects (5 m, 10 m and 15 m for metric projects). 

A new toolbox should be on your screen. (Figure 4-7) Click on the Place cell along tool.  

 
Figure 4-7: Pace Cell Along Tool 

When the dialog opens, enter the desired spacing for the tick marks. Defaults are 100’ or (10 
meters). (Figure 4-8) 
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Figure 4-8: Place Cell Along Dialog 

Snap to the beginning of your centerline to see how your ticks are going to be placed. Click 
to accept or reject the placement. If your alignment does not start at an even station, delete a 
portion of the “copied” center line to force it to start at an even station.  

 The normal text for stationing is 100 feet (20 meters), but if you have a really long 
job, maybe you might want to space them at 1000 feet (100 meters) or another even 
increment. Be sure that the Offset and Angle are both set to “0”. (Figure 4-8) 

Part Four: Adding Text for Stations 
Open your 001_title.dgn. It’s best to station the alignment in the Title Sheet to produce 
standard size text. 

Right Click on the Settings Manager. Set the Category Scale to 12” = 1 ft. (1:1 metric) 
(Figure 4-9).  

 
Figure 4-9: Right Click, Category Scale 

Using your Plan Sheet Settings Manager, select Proposed Text and Dims>Standard Text 
(Normal). Start placing your station text. For long jobs, it may make sense to place your 
stations every 1000 feet (100 meters). 

 Use AccuDraw’s functionality of  “o” (origin) and “rq” (rotate quick) to place the 
text at different angles along your project’s centerline. 

Step Eight: Shading the Layout Drawing 

Introduction 
This step will shade all proposed pavement areas. Due to certain limitations, you will have 
to do this in sections as opposed to one large filled shape. Shading should be done in the 
z_layout drawing. It is important that your proposed design (Highway.dgn) has been 
flattened to “0” along with the z_layout drawing. 

 On large projects, shading may not be necessary because the layout is scaled down 
so small that when printed, the proposed pavement lines themselves are so close 
together that they appear to be one solid line. Print out a test plot of the Title Sheet to 
determine if shading is necessary. 
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Part One: Open z_layout 

Part Two: Create Temporary Lines 
Use the Smartline tool to create lines across (perpendicular) the roadway every 1000 to 2000 
feet (100 to 200 meters) or so to break the shading into manageable areas. Straight portions 
of the alignment may allow you to shade larger sections at a time. 

 The highway.dgn typically needs to have lines draw on it to signify the match points 
on the beginning and ending of the main line and the limit of work on the side roads. 
Do this work in the highway.dgn by Smart Matching the shoulder or travelway line 
then drawing a line connecting the opposite shoulders at the beginning and ending of 
the project. 

Part Three: Flatten 
Flatten the drawing by selecting Macros>Flatten from the Main Menu. 

Part Four: Select Boundary Lines of Area to be Shaded 
Using your Power Selector or similar means, select the lines that define the boundaries of 
area to be shaded (i.e. edge of pavements, and 2 junk lines you created earlier).   

Part Five: Create Regions 
Select Group>Groupings>Create Regions from the Main Menu or pick the Create 
Regions tool from the Groups tool box. Set the dialog to look like Figure 4-10. 

 
Figure 4-10: Create Region Settings 

The color you select is optional. All colors, with the exceptions of 10-16, will print black. 
Colors 10-16 will print a shade of gray. 

The Level that you place the shading is optional. It is a good idea to select a Level that is not 
being used. 

Part Six: Flood Area 
Click anywhere inside of the area you Power Selected. Click again to Accept. This should 
fill the area.  

 If you get a warning that says “No Enclosing Region Found”, you can adjust the Max 
Gap to a larger number so the tool will jump gaps in the lines. 
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 If you get a warning that says “Shapes are not coplanar”, it could mean that the 
Highway.dgn or possibly the z_layout.dgn isn’t flattened. Re-flatten both drawings 
and try again. 

If all else fails, change your Method to Points and use data points to create the filled shape, 
however, this doesn’t work so well around curves. 

Contact your CADD Support for assistance.  

Step Nine: Adjusting the Layout Scale 

U.S. Customary Projects 
To adjust the scale, you will need to take in account what scale you placed the Layout into 
your title sheet. In Step 5, we counted the number of clip boundaries (12) and multiplied that 
by 300 to get 3600. Divide this number by 12 to get the scale per inch of your Layout 
drawing. In this example your scale per inch would be 300.  

You can also find out what scale factor you used by opening the File>Reference dialog and 
double clicking on one of the attachments and looking to the Scale (Master:Ref) portion of 
the dialog. Divide the reference scale by 12.  

Use Text>Edit Text from the Main Menu to edit the text in the bar scale Figure 4-11.  

 
Figure 4-11: U.S. Customary Layout Scale Example 

Metric Projects 
To adjust the scale, you will need to take in account what scale you placed the Layout into 
your Title Sheet. In Step 5, we counted the number of clip boundaries (12) and multiplied 
that by 250 to get 3000. Multiply this number by .02 and the result is the scale used in the 
Layout bar scale (i.e.3000 X .02(constant) = 60 meters).  

You can also find out what scale factor you used by opening the File>Reference dialog and 
double clicking on one of the attachments and looking to the Scale (Master:Ref) portion of 
the dialog. Multiply the reference scale by .02. 

Use Text>Edit Text from the Main Menu to edit the text in the bar scale Figure 4-12. 
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Figure 4-12: Metric Layout Scale Example 

Step Ten: Place Text on the Title Sheet 
Use the Settings Manager (Prop. Text and Dims>Standard Text (Normal) to enter text 
labels for Side Roads, Town Lines, Sheet Numbers, etc.  
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CREATING A LAYOUT (NO SURVEY) 
Introduction 
This section is intended for projects with no survey. We will use a portion of the Location 
Map to create a rough drawing as your layout. 

Step One: Place Temporary North Arrow 
Before you clip out an area from the Location Map for your layout, place a small vertical 
line near the project area. This will represent north. North is up in the map. 

Step Two: Place a Fence 
Use the Place Fence command and set the Fence Type to Shape and the Fence Mode to 
Clip(Figure 4-13) (Group>Fence>Shape).  

 
Figure 4-13: Place Fence – Clip Mode 

Place your fence around the project area, as close to your project as possible, encompassing 
only the beginning of side roads and your temporary north arrow Figure 4-14. 

  
Figure 4-14: Fence Encompassing Project Area with Temporary North Arrow  

Step Three: Copy Fence 
From the Main Menu, select Group>Copy Fence or use the Manipulate Fence Contents 
tool. Verify that the Fence Mode is set to Clip (Figure 4-15). 

 
Figure 4-15: Manipulate Fence Contents Settings 
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Place a datapoint to define where you want to copy from and click another datapoint in the 
middle of your title sheet to place the contents of the fence. 

Step Four: Scale and Rotate 
Use Power Selector and select your new layout elements. Use a combination of Scale 
Element (Zip>Scale) and Rotate Element (Zip>Rotate>Rotate By 3 Points) to adjust the 
layout to fit within your Title Sheet. 

Step Five: Adjust Scale 
The scale of the layout drawing pulled from the location map will be somewhat rough. It 
may be a good idea to simply remove the scale for the layout and add a note stating it is 
“Not to Scale”. 

Step Six: Place North Arrow 
Using the Plan Sheet Settings Manager, select Symbols & Linestyles > North Arrow 
True. In the Tool Settings dialog, set the active angle to “0” and set the X, Y, Z scales to 1. 
Snap to the middle of the line you placed in the location map to represent the temporary 
north arrow. Before Accepting, type “O” for origin, then follow it by “RQ” on your 
keyboard. Snap to the end of the line that should point to north, Accept the AccuDraw 
rotation. Now move the arrow to wherever it fits well on your title sheet. Use a datapoint to 
place the arrow. Delete the “temporary line representing your North Arrow. 

Step Seven: Place Text on the Title Sheet 
Use the Settings Manager (Prop. Text and Dims>Standard Text (Normal) to enter text 
labels for Side Roads, Town Lines, Sheet Numbers, etc.  
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TTYYPPIICCAALL  SSEECCTTIIOONN  SSHHEEEETT  
DDEEVVEELLOOPPMMEENNTT  

Quick Punch List 
• Create a Typical Sheet Using Make Sheetz 

• Run “Template” Macro 

• Edit and add cells  

• Add Dimensions and text 

• Edit Border Using Border Macro 

Things to Remember 
Whether you use the typical section program to draw your lines or not, there is a certain 
strategy to keep in mind when you are drawing such things.  

First of all, you should draw all your lines first, as the program would have you do.  

Then you should trim up all the lines, adding cells if necessary.  

Then you should add the dimension, text and notes. 

 Use the Cross-Sections Setting Manager to draw new lines.  

 Draw the typical completely before you move on to labeling and dimensions. This 
will help you keep the elements in the right levels without needing to Match Element 
Attributes all the time. 

Freehand Template Techniques 
 Refer to page 2-51 for an example of using AccuDraw to draw roadway sections. 
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CREATING A TYPICAL SECTION DRAWING FILE 
Step One: Open MicroStation 
Open MicroStation and use the project pull-down list to move to your project directory. 
Open any drawing file in your PIN directory. 

Step Two: Create a New Drawing(s) 
Select File > Make Sheetz to create a new file for every typical sheet you will need. If there 
will be more than one, be sure to add a suffix in the make sheets dialog (Figure 4-16). 

 
Figure 4-16: Selecting a Suffix for Multiple Drawings of the Same Type 

  Refer to page 1-18 for help creating files. 
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CREATING TYPICALS USING THE TEMPLATE 
MACRO 

This macro was created for the Bridge Program to make drawing templates on Cross 
Sections easier. This can be used for Typical Sections as well. It allows you to place 
guardrail and curbing, and remembers your setting should you need to make more than one. 

 
Figure 4-17: Typical U.S. Customary Template Information Dialog 

The Guardrail and Curb placement requires that you give the offset from the centerline to 
the cell. Look to the Standard Details for the proper offsets or ask your designer. 
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DIMENSIONS, TEXT, AND NOTES 
 Always use the Settings Manager when placing dimensions and text. This is especially 
helpful in keeping your elements on the correct levels.  

 Check page 2-20 for a complete introduction to the Settings Manager. 

Why are levels so important? These files may need to be archived, translated to different 
CAD systems, or they may be used in the creation of As-Builts. If elements are on the right 
level, these processes will be much easier. 
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EESSTTIIMMAATTEE  SSHHEEEETT  
DDEEVVEELLOOPPMMEENNTT  

Quick Punch List 
• Add Items To Estimator (If Necessary) 

• Export Items from “Estimator” 

• Make Estimate Sheet Using Make Sheetz 

• Import Items from CSV file 

• Adjust Lump Sum Items (If Necessary) 
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EXPORTING QUANTITY ITEMS FROM THE 
ESTIMATOR  

Introduction 
This is a description of how to export a list of Quantities for the purpose of filling out the 
Estimated Quantities sheet. This assumes that all or most of the items have been previously 
entered into the Estimator program. 

 For information on using the Estimator program, refer to page15-2. 

Step One: Getting into Estimator 
First you will need to double click on the icon on your desktop. 

 Contact CADD Support if you do not have an icon. Experienced users: Map any drive 
letter to \\dot0dta1fsaug01\$Com-ProgMan\Highest\  folder. Right click the 
Highest.exe and select Send To>Desktop (create shortcut). 

Now log in (Figure 4-18) 

 
Figure 4-18: Log In to Estimator 

“Beta” is the user name and “User” is the password.  

 Usernames and passwords are case-sensitive: you must capitalize the first letter of 
each word. 

Step Two: Exporting (*.he) File 
Once you are in the Estimator program you must select the appropriate file that was created 
by either you or the Designer and open that file. 

Now that you have selected the file, go to File > Export. 

Here is the important part, you must select the Export File Format: and change this to: 
Lotus (Category Items) even though we do not use Lotus products (Figure 4-19).  
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Figure 4-19: Export Dialog 

Next you will need to change the directory to the appropriate PIN directory that you are 
working in. To do this you need to select the drive letter that the PIN is sitting in. In this 
case MDOT standards is the Y drive. 

Once there, double click on the Pin folder, your PIN number and to your workgroups 
\MSTA folder. This is where the macro looks for this file (i.e. 
y:\pin\9009\00\highway\msta\). 
Now that everything is set, hit the O.K. button and the Estimator will go through its process 
of exporting the document into the MSTA folder in your pin directory. 
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IMPORTING LOTUS.CSV FILE INTO ESTIMATED 
QUANTITIES SHEET 

Step One: Open MicroStation 
To begin, double click on your MicroStation icon and select your project from the project 
pull down. Open your ###_Estimate.dgn if it exists, otherwise, open any file. 

 Some older projects have an estimate.dgn in the MSTA directory. This file doesn’t 
have any grid lines in it and should be deleted. Make a new sheet.  

Step Two: Make an Estimate Sheet 
If you don’t have an estimate sheet (i.e. ###_Estimate.dgn), go to File > Make Sheetz and 
create one. 

 Check out page 1-18 for more information about making sheets. 

Step Three: Run Estimate Macro 
Once you are in the drawing, you need to activate the macro to begin importing your 
estimate items. To do this, go to Macros > Estimate. You will be prompted to “snap to the 
upper left corner of first table” (Figure 4-20). Accept with a left click. 

 
Figure 4-20: Example of Snap Point “Upper Left Corner of First Table” 

Step Four: Adjust Quantities 
This should have filled out your Estimated Quantity sheet. It will be necessary to edit text on 
a couple of the items that are supposed to be L.S., but because the Estimator requires actual 
quantities for the item, it will require that you change the value to “1”. Use the Edit Text 
tool.  

The Contract Section would rather not see decimals in the quantities. Edit the text and round 
all decimal number up to the nearest whole number.  

 If you would rather use a different justification on certain text, use Text>Rejustify 
(Macro) and select the text you want to change. When the dialog comes up, pick the 
new justification. 



mdot MicroStation 
07/01/07 

Plan Development 

4-24 

 

 If there are changes to the Estimator (*.he) file, you will need to export another 
Lotus.csv file and overwrite the existing one. Then go into the file, delete the 
existing list, and re-run the macro. 

Additional Sheet Needed? 
Occasionally you may have more items than one Estimate Sheet will hold. In this case, the 
macro writes the additional information off to the right of the border. If your original border 
hasn’t been dropped, copy it and place it with the additional items. (If it has been dropped, 
get a copy from the USBorder/Border cell library.)  

Place a fence around the new border and select Utilities>Development Tools>Fence File 
from the Main Menu. When the new dialog appears, supply the name of an additional 
Estimate Sheet (i.e. 004_Estimate2.dgn) being sure to increment the prefix and suffix. Click 
OK. Click on the screen to Accept the command. Open the new sheet. If all looks good, 
delete the extra border and contents from the original file. Contact CADD Support for 
assistance. 
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DDRRAAIINNAAGGEE  SSHHEEEETT  
DDEEVVEELLOOPPMMEENNTT  

Quick Punch List 
• Copy Drainage Spreadsheet into PIN directory 

• Enter drainage data into drainage.xls. 

• Save drainage.xls as a tab-delimited text file. 

• Create a Drainage Sheet using Make Sheetz 

• Run the Drainage Macro 
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USING THE DRAINAGE SPREADSHEET 
Introduction 
This macro merges data from an excel spreadsheet into MicroStation. There are a couple of 
steps involved. Follow them exactly.  

 Do not attempt to be creative in the naming of your file or create multiple files to 
somehow trick the program. It won’t work. 

Step One: Copy the Spreadsheet 
The drainage.xls spreadsheet is a standard form. The drainage.xls template is located in the 
Y:\msworksp\MDOT MicroStation Utilities\Spreadsheets & Notes folder. Make a copy 
of this file and place it in your workgroup’s MSTA folder before entering your project data. 

 Do not edit the spreadsheet on the Y: drive! 

Step Two: Enter Drainage Data 
Enter your drainage data into the spreadsheet. Do not attempt to reformat the spreadsheet in 
any way. Add all the information to this one spreadsheet even if there isn’t any grid lines 
present in the rows or columns. Save your file. 

 Make sure you save your changes by choosing File > Save. 

Step Three: Save as TXT file 
Our macro cannot access excel data when it is saved in workbook (xls) format. From Excel, 
choose File > Save As… This will open the Save As dialog (Figure 4-21). 
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Figure 4-21: Save As Txt 

From the bottom of this dialog, choose Text (Tab delimited) (*.txt) in the Save as type 
field.  

Check that the file name is DRAINAGE.TXT and push the Save button. This will bring up 
a Microsoft Excel dialog warning you about the limitations of tab delimited text (Figure 
4-22). 

 
Figure 4-22: Save As Warning  

Tab delimited text files aren’t capable of handling all the formatting options of Microsoft 
Excel. This is not going to be a problem for us.  

Dismiss this dialog by pushing the Yes button. 



mdot MicroStation 
07/01/07 

Plan Development 

4-28 

 

 Notice that you are now editing a file called “Drainage.txt”. This filename is a must 
for the macro to work Figure 4-23). 

 
Figure 4-23: New File Name 

You are now finished with Excel. Choose File > Exit. You will get a warning dialog like 
Figure 4-24. 

 
Figure 4-24:Save Changes? 

You do not need to save this file again. Dismiss this dialog by pressing the No button.  
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IMPORTING DRAINAGE INFORMATION 
Step One: Open MicroStation 
To begin, double click on your MicroStation icon and select your project from the project 
pull down. Open your ###_Drainage.dgn if it exists, otherwise, open any file. 

 Some older projects have a drainage.dgn in the MSTA directory. This file doesn’t 
have any grid lines in it and should be deleted. Make a new sheet.  

Step Two: Make an Drainage Sheet 
If you don’t have a drainage sheet (i.e. ###_Drainage.dgn), go to File > Make Sheetz and 
create a numbered sheet, with Highway workgroup. Choose Drainage as the file type. 

 Check out page 1-18 for more information about making sheets. 

Step Three: Run the Macro 
From the Main Menu select Macros>Drainage. 

MicroStation will prompt you “Drainage > Snap to upper left corner of first table” Snap to 
the point marked with an “X” in Figure 4-25, and Accept. 

 
Figure 4-25: Upper Left Corner 

MicroStation will place a column of text in every column of the table has information. 

 If you would rather used a different justification on certain text, use Text>Rejustify 
(Macro) and select the text you want to change. When the dialog comes up, pick the 
new justification. 

Multiple Drainage Sheets 
If you have more than 78 lines of drainage information, the macro will start placing another 
column of text to the right of the first table and place an additional border. 

Place a fence around the new border and select Utilities>Development Tools>Fence File 
from the Main Menu. When the new dialog appears, supply the name of an additional 
Drainage Sheet (i.e. 004_Drainage2.dgn) being sure to increment the prefix and suffix. 
Click OK. Click on the screen to Accept the command. Open the new sheet. If all 
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looks good, delete the extra border and contents from the original file. Contact CADD 
Support for assistance. 
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NNOOTTEESS  SSHHEEEETT  DDEEVVEELLOOPPMMEENNTT  
Quick Punch List 
• Copy Template from Y: drive to your PIN on the Y: drive 

• Open and Edit the Template in Microsoft Office (i.e. Word or Excel) 

• Save as new Format (according to specific instructions) 

• Open new file, select range of text and Copy to Clipboard 

• Open MicroStation, Make Sheetz and set text Style  

• Paste (according to specific instructions) 

• Edit Sheet Type in title box 

• Run Macros>Border Information 
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LOCATION AND EXPLANATION OF TEMPLATE 
FILES 

Introduction 
We are using Microsoft Word for all text arranged in paragraph form, to be pasted into 
MicroStation. Text that is intended to be in columns should be produced in Microsoft Excel. 
We have placed template files in the following directory - Y:\msworksp\MDOT 
MicroStation Utilities\Spreadsheets & Notes. Please copy files from this location into 
your projects PIN directory under your workgroups MSTA folder. Do not edit the files in 
their original location. 

General Notes 
There are a few template files available to be used for generating your General Construction 
Notes. They require editing for every project and should be checked for accuracy.  

Imperial General Notes.doc - This file has a listing of the most common General Notes 
used on U.S. Customary projects. 

Metric General Notes.doc - This file has a listing of the most common General Notes used 
on metric projects. 

Metric Expanded General Notes.doc - This file includes all of the General Notes in the 
Metric General Notes.doc file, plus, an additional 50+ notes that may pertain to more 
complex projects. Check both of these files and decide which one suits your projects needs. 

Summary of Excavation and Borrow 
The Summary of Excavation and Borrow is an Excel spreadsheet. It can be easily pasted 
into a MicroStation drawing for your final plans. The file is called Summary-Excavation-
Borrow.xls. This form is sometimes confusing to do by hand on complicated projects. Just 
enter the figures and the formulas will take it from there. It also allows you to delete the 
lines (rows) that aren’t needed. When doing this, the user must also delete out any lines with 
an “ERR” in them, starting from top of the sheet to the bottom.  

Use the same instructions used when pasting Construction Notes into MicroStation. 

Estimating US Customary Projects 
We have a spreadsheet to help do one of the most tedious tasks of Estimating which is 
calculating your Cuts and Fills. Once you supply the stations, without the (+) symbol, the 
sheet will automatically fill in the distances between stations. (Do not enter numbers in the 
shaded cells) After you enter areas or lengths, it will automatically average them and give 
you totals. Each sheet will give you totals that are summarized on the Index of the 
spreadsheet. Right now there are only five pages for the calculations and an index. If more 
pages are needed, ask your support staff to create them and revise the master. Here is a 
listing of files available for English projects. 

ENGLISH-ESTIMATE-CUYDS.xls - This is for estimating items requiring a cubic yard 
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measurement (i.e. Common Excavation, Gravel, etc.). 

ENGLISH-ESTIMATE-SQYDS.xls - This is for estimating items requiring a square yard 
measurement (i.e. Loam, Sod, etc.).  

ENGLISH-INDEX.xls - This is for indexing your estimate book that you turn in with your 
project. Many people are not including this with their comps, but if you are, this will make it 
easier. Also you can experiment with exporting a text file from Highest (Estimator) with out 
the prices. 

Estimating Metric Projects 
We have a spreadsheet to help do one of the most tedious tasks of Estimating which is 
calculating your Cuts and Fills. Once you supply the stations, without the (+) symbol, the 
sheet will automatically fill in the distances between stations. (Do not enter numbers in the 
shaded cells) After you enter areas or lengths, it will automatically average them and give 
you totals. Each sheet will give you totals that are summarized on the Index of the 
spreadsheet. Right now there are only five pages for the calculations and an index. If more 
pages are needed, ask your support staff to create them and revise the master. Here is a 
listing of files available for Metric projects. 

METRIC-ESTIMATE-CUMETERS.xls - This is for estimating items requiring a cubic 
meter measurement (Common Excavation, Gravel, etc.).  

METRIC-ESTIMATE-SQMETERS.xls - This is for estimating items requiring a square 
meter measurement (Loam, Sod, etc.).  

METRIC-INDEX.xls - This is for indexing your estimate book that you turn in with your 
project. Many people are not including this with their comps, but if you are, this will make it 
easier. Also you can experiment with exporting a text file from Highest (Estimator) with out 
the prices. 
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GENERAL NOTES SHEETS 
Step One: Copy the Template File 
Using Windows Explorer, browse to the Y:\msworksp\MDOT MicroStation 
Utilities\Spreadsheets & Notes folder. Select the General Notes file that best pertains to your 
project. Copy the file from this location into your projects PIN directory, under your 
workgroups MSTA folder. 

Step Two: Open and Edit Using WORD 
Open and edit the Microsoft Word file, supplying your project specific information. Save the 
file in its native format (.doc). 

Step Three: Save As .txt File 
From the Main Menu, go to File > Save As., Select “Plain Text (*.txt)” in the Save as Type 
pull down (Figure 4-26). Verify that the path of the new file name is pointing to your PIN 
directory. 

 
Figure 4-26: Save as type- Plain Text (*.txt) 

A new dialog will open. Place a check mark in the “Insert Line Breaks” box (Figure 4-27) 
and leave the other defaults as is. Click OK. 
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Figure 4-27: Select Insert Line Breaks 

Close the Word document. 

Step Four: Open and Copy the Text from the New File 
Using Windows Explorer, browse to your projects PIN directory and open the file that you 
just saved with the .txt extension. Select the range of text you wish to paste into 
MicroStation. From the Main Menu, select Edit>Copy. 

 You can select all of your text and manipulate it prior to placing it in the 
MicroStation Text Editor dialog. The Text Editor has the same capabilities as the 
Notepad text editor. You can Copy, Paste and Cut by either Right clicking in the 
dialog or using shortcut keys Ctrl+C (Copy), Ctrl+V (Paste) or Ctrl+X (Cut).  

 If you are familiar with PFE Editor, Right Click the file and select “Open With…” 
then select “Choose Program” and select PFE Editor. You can select up to 100 lines 
of text and still fit it within your border. Notepad doesn’t give you this information.  

Step Five: Open MicroStation 
Open MicroStation by double clicking the MicroStation icon on your Desktop and pick your 
PIN number from the project pull down. Open the MicroStation file that you wish to place 
the General Notes in. If necessary, create a new file from the Main Menu using File > 
Makesheetz. Use a numbered drawing, selecting Notes from the drawing type dialog. 
Consider adding “General” in the suffix to better specify the sheet type.   

 See the Make Sheetz documentation on page 1-18. 

Step Six: Set Your Text Size and Font 
Right click on the Settings Manager and select Category > Scale. Normally, General Notes 
are placed on a border that hasn’t been scaled. Select 12in. = 1 ft. for U.S. Customary 
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projects (1:1 for metric projects). From the Settings Manager, select Proposed Text and 
Dims > Standard Text (Normal). This sets your text attributes. 

Step Seven: Paste the Selected Text 
While your Text Editor has focus (active), type Ctrl+V to paste the notes into the window 
or Right Click to bring up the “Right-Click Menu” and select Paste (Figure 4-28). 

 
Figure 4-28: Right Click with mouse - Paste Option 

Step Eight: Placing Text in the File 
Place the text as you would any other text (Datapoint) utilizing AccuDraw and/or tentative 
snaps to place it accurately. 

If the text you pasted will not fit inside of your border, use the Edit Text tool and click on the 
text. In the Text Editor dialog, select the extra text that isn’t fitting within the border starting 
from the bottom up and type Ctrl+X. This will “cut” the extra text to the Clipboard. Click 
Apply to accept the changes. Click on the Place Text tool. With your cursor in the Text 
Editor dialog, type Ctrl+V to paste the remaining text. Place it down using AccuDraw to 
place it accurately. Continue until all of the text fits within the border. Create a second sheet 
if necessary. 

 If you have over 200 lines of text, the text block may not display when you do a fit 
view. This is normal due to the limitations of multi-line text (text nodes). Zoom in to 
see the text. 

Step Nine: Editing Text 
Edit text like you would any other text by selecting the Edit Text tool from the Main tool 
frame. 
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CONSTRUCTION NOTE SHEETS 
Introduction 
Depending on who generated the construction notes, you may be working with an Excel 
Spreadsheet, reports generated from MX software or hand written hard copies. 

These instructions are not intended to explain how to use Excel, but instead, it explains how 
to take a construction note file and paste it in to MicroStation.  

If you are using reports generated from MX, these files are in a .prn format. These files can 
be opened directly using Notepad or the PFE editor. You can select the text and copy it 
directly into a Text Editor dialog for placement. These come in well, but may need 
adjustments to columns. You can also importing the reports into Excel to provide better 
formatting abilities. 

Importing Reports into Excel (Informational/Optional) 
If you are building the spreadsheet from .prn reports, select Data>Import External 
Data>Import Data from Excel’s main menu. Browse to your workgroups MSTA folder 
and select the .prn file. Click OK. A text import dialog will open. Select Delimited. (Figure 
4-29) Click Next. 

 
Figure 4-29: Text Import Wizard 

In the next dialog, make an additional selection for “Space” as your delimiter (Figure 4-30). 
The other selections by default do not need changing. Click Next. 
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Figure 4-30: Select “space” as your delimiter 

 In the final dialog of importing text you have the opportunity to format cells in the 
spreadsheet. “General” is normally good for this setting. If you wish to omit a column, click 
on the column header and click on the “Do not import column (skip)” button. Click Finish 
(Figure 4-31). 

 
Figure 4-31: Import Wizard column formating 

Step One: Open Spreadsheet 
Locate and open the spreadsheet (.xls file) in your PIN directory that has the Construction 
Notes in them.  
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 Right click in your MSTA folder and select New>Microsoft Excel Worksheet if 
you need to create one. Name it appropriately and add in your information. 

Step Two: Save as FormattedText (Space delimited) 
If you have to make any changes to the spreadsheet, make the changes and save them.  

Select File>Save As… from Excel’s main menu. Change the File As Type pull down to 
FormattedText (Space delimited) (*.prn)(Figure 4-32). Notice that your file name now 
has a new extension. Click Save. 

 
Figure 4-32: Save as Type Text (Tab delimited)(*.txt) 

 If you have multiple sheets in one Excel Spreadsheet, you will need to go into each 
sheet and save them individually as a different file name (i.e. Construction-
Note1.prn, Construction-Note2.prn). The .prn format cannot handle multiple pages 
all at once. 

 The .prn extension will allow the user to adjust the widths of the columns in Excel 
and carry over the changes into the text document (.prn).  

Step Three: Warnings 
You will get a series of warnings. First one saying the format doesn’t support multiple 
sheets. Click OK. (Figure 4-33) 

 
Figure 4-33: Warning One – Click OK 

At the next warning click Yes. (Figure 4-34) 
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Figure 4-34: Warning Two – Click Yes 

Close the Excel session. When asked to save the document, click NO (Figure 4-35). You 
have already created the .prn documents as a separate file and do not need to save the 
changes in the Excel workbook.  

 If you had made changes after saving it as a .prn file, do a Save As… and change the 
“Save as type” back to .xls 

 
Figure 4-35: Warning when closing the file – Click NO! 

Step Four: Open MicroStation 
Open MicroStation by double clicking the MicroStation icon on your Desktop and pick your 
PIN number from the project pull down. Open the MicroStation file that you wish to place 
the Construction Notes in. If necessary, create a new file from the Main Menu using File > 
Makesheetz. Use a numbered drawing, selecting Notes from the drawing type dialog. 
Consider adding “Construction” in the suffix to better specify the sheet type.   

Step Five: Set Your Text Size and Font 
Right click on the Settings Manager and select Category > Scale. Normally, Construction 
Notes are placed on a border that hasn’t been scaled. Select 12in. = 1 ft. for U.S. Customary 
projects (1:1 for metric projects). From the Settings Manager, select Proposed Text and 
Dims > Monospaced Text. This sets your text attributes. 

Step Six: File Import>Text 
Go to File>Import>Text from the Main Menu. Select the file that you created with the .prn 
extension. Place the text with a data point, utilizing AccuDraw to place it accurately 
amongst other notes on your sheet. 

Step Eight: Editing the Text 
After placement, you will notice that there may be some adjustment necessary. Use the Edit 
Text tool in your Main Tool Frame or use the Main Menu and select Text>Edit Text. Click 
the text and adjust as necessary. 

 The original .xls file is a handy document because it can be used to generate item lists 
in your Estimate Book that we turn in to Contracts. It’s up to the team as to whether 
or not you keep the master .xls file up to date or edit the changes within MicroStation 
only. 
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CLEAN-UP THE GEOMETRY 
Introduction 
Once the geometry file has been created in MX and is placed in your PIN directory, there is 
some cleanup required. In the future, we hope this process will be automated by using a 
macro and/or mapping tables. This section describes how to adjust the line styles of the 
original drawing to the appropriate style desired in MicroStation. 

Step One: Opening and Editing the Geometry 
To begin, double click on your MicroStation icon and select your project from the project 
pull down. Open your design file (geometry.dgn) and Fit View.  

 If design changes are made to curb placement, entrance widths, or other elements in 
the geometry.dgn, it may be necessary to adjust the in the Highway.dgn file to reflect 
the same changes to your normal plan sheets. Consider only using certain parts of the 
geometry file that are unique from the actual proposed design. You could attach the 
proposed design file (i.e. Highway) to the geometry.dgn and shut off levels that your 
don’t need so that any changes made are reflected on both plan sheets and geometric 
sheets. 

Part One: MX Enquire 
 Turn the Graphic Group lock off (Settings>Locks>Graphic Groups). 

Under the Macro menu, choose MX String Info. An Enquire button should pop up (Figure 
4-36). 

 
Figure 4-36: Moss Enquire 

Press the Enquire button.  

Click an element to find out what it is called. The attributes of the element you picked will 
be displayed in a new dialog window.  

The Element Name is what you are interested in most. If you don’t know what the element 
name is referring to, select Macros>MX String Search and type in the name. If the name is 
recognized, it will display the description.  

Go to Macros > Select By MX Attributes. Under the Model pull down, select the model 
listed.  

 There may be multiple models in your drawing, but normally, there is only one 
called geometry. If there are multiple models, you will have to do this same routine 
for each and every one. 

In the Name field, type in the name of the object you wish to have selected. If this element 
name has numbers in it, supply the characters then use the wildcard “**” after these 
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characters. This will select all MX elements in your drawing that have the same name. Do 
not enter a value in the Object pull down. 

Hit Select to pick the elements. 

Part 2: Setting the Attributes 
The quickest way to set the attributes of an element is to utilize our Plan Sheet Settings 
Manager. Right click on the Settings Manager and pick Category>Scale. Select desired 
scale of your geometric plans normally 1 in. = 25 ft. (1:250 for metric). If what you 
Enquired on represents proposed curb, choose Proposed Curb, Ret. Wall, GR from the 
left side, then choose the type of curb on your project to set the attributes.  

Part 3: Changing the Attributes 
Click on the Change Element Attribute tool in the Main Toolbar. Place a check in the Use 
Active Attributes and all of the attributes boxes except for Class and Use Fence (Figure 
4-37). By using the Settings Manager in Part 2, Level, Color, Style and Weight should be 
set for you. Click on the screen to change the attributes.  

 
Figure 4-37: Use Active Attributes 

Repeat the steps above on all elements that require a custom line style in MicroStation (i.e. 
retaining walls, curbing, and sometimes, proposed underdrain). 

Part 4: Finishing Up 
Once all custom line styles are changed to the proper style, all that remains in the active 
drawing are lines and circles for the geometry.  

These lines should be selected and changed to a weight 3. Using the Edit > Select By 
Attributes, check the box to select attributes by weight of “0”. Hit Execute. Only these 
should highlight. Now, use the Change Element Attributes tool and select only the weight 
and set the number value to 3. Click on the screen to make the change. Close the Select By 
Attributes and click Cancel to stop filtering elements. If you have elements in your file with 
heavier weights, select them using the Select By Attributes and change them to weight 3 
also. 

Step 2: Placing Notes from MX Reports 
The MX designer can export station and offset reports from MX of the curb locations, 
curve data, control points and Catch Basin locations. These reports usually have a .prn 
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extension. They can be read with Notepad or PFE editor or imported into Excel. You have a 
couple of options for importing them into MicroStation, but it’s up to user discretion on 
which option is best.  

 It is a good idea to place them into the individual geometric plan sheets as opposed 
to the geometry drawing. 

Option 1 - Leave these as .prn files and copy and paste them directly into your Text Editor 
after selecting Proposed Text and Dims>Monospaced Text.  

Option 2 - Open/Import them into Excel as to better enable a user to use this information for 
generating estimate computations for items that will be used in the Engineer’s Estimate 
book, then save them as a tab delimited *.txt file and import them through MicroStation’s 
Main Menu (File>Import>Import Text).  

 Refer to page 4-37 for the documentation on creating Construction Notes. 

We have a couple of grid boxes available that can be used to group your data. From the Plan 
Sheet Settings Manager, select Geometric Plans>Control Point Box and/or Curve Data 
Box. 

 Open each individual geometric plan sheet (i.e. 021_geometry.dgn) and paste your 
notes directly into the border drawing.  

Step 3: Annotating Point Numbers 
Use the Plan Sheet Settings Manager and select Proposed Text and Dims>Standard Text 
Normal to place text for the point numbers. If the circle for the points weren’t added to the 
geometry.dgn, you can place them manually from the Settings Manager by selecting 
Geometric Plans>Control Points. Drop the cell and edit the text using the Edit Text tool. 
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CREATING GEOMETRIC PLANS 
Geometric plans are required if you have granite curb (Type 1 Curb) or concrete curb (Type 
2 curb) on your project.  

Step One: Open the geometry.dgn 
To begin, double click on your MicroStation icon and select your project from the project 
pull down. Locate the geometry.dgn that is in your groups MSTA directory. This file is 
produced from MX so if it doesn’t exist, asks your designer to create one and place the file 
into your PIN directory. 

Flatten this file because it is still 3D. Select Macros>Flatten from the Main Menu. 

Step Two: Reference hdplan.dgn and Alignments.dgn  
To reference the files needed for your geometric plan sheets, select File > Reference (DOT) 
> Attach.  

Select hdplan.dgn. Click OK.  

This brings up the Attach Reference File dialog. Add a Logical Name of hdplan.dgn for 
the file.  

Attach your file by Coincident - World (Global Origin Aligned with Master File). 

Select True Scale. Set the Nested Attachments to No Nesting. Click OK. 

Repeat this process for the alignments.dgn. 

 Check page 2-71 for an explanation of Reference File Nesting. 

Click Fit View (Figure 4-38) to see your reference files.  

 
Figure 4-38: The Fit View Button 

Step Three: Merging the Clip Boundaries into the 
Geometry File 
In order for the next procedure to work, we need to merge the clip boundaries into the active 
file. This will produce the geometric plans that look identical in orientation to your normal 
plans sheets. This procedure is assuming that you want a geometric plan for every plan 
sheet. If you only need a geometric plan for specific areas on your project, place clip 
boundaries manually in your active file as you would when creating the normal plan 
drawings. 

 Refer to the procedure on page 5-3 to place clip boundaries manually. 

In the Reference File dialog, highlight the reference file (hdplan.dgn) then select 
Tools>Merge Into Master from the Menu Bar. Now you will be prompted to select a view. 
Click a datapoint in your view. An informational dialog will open telling you that you are 
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about to merge one reference file into the current design file. This is what you want to do. 
Select OK to start the procedure. Refresh your window to update the view. 

Step Four: Make Geometric Plan Files 
From the Plan Sheet Settings Manager select Create Plan Sheets > Create Cut Sheets. 
This macro is doing a number of things. First off, it is creating saved views in geometry.dgn 
that are aligned with the clip boundaries you just merged in or just placed. It asks you what 
number you want to use for the starting number of the geometric plan sheets. If you know 
where the sheets will fall in your plan set, enter this number here. The default will be eleven. 
(Figure 4-39) If you don’t know yet where they will fall, use the default and we will utilize 
the Sheet Renumbering routine to organize the files outside of MicroStation. 

 
Figure 4-39: Start Numbering At? 

When the program finishes, it will drop you back into geometry.dgn. Open up the files 
you’ve just created and see how they look! 

Troubleshooting 
If you open a geometry plan sheet drawing and the graphics within the sheet are not correct, 
it could mean a couple of things. Try re-cutting the sheets. It won’t be necessary to place 
new clip boundaries, simply select Create Plan Sheets > Create Cut Sheets and run 
through the process of attaching the saved views again. This will correct the problems most 
of the time. 

It could also mean that a drawing that is referenced is not at the same Global Origin as the 
other drawings. See CADD Support for assistance if needed or read the documentation on 
Flattening drawing and shifting the global origins.  

Adjusting Saved Views 
You can adjust the area of a reference file on your plan sheet by using the reference file 
dialog Tools in combination with Move, Scale or Rotate commands. Be sure to highlight all 
of your reference files prior to adjusting. 

To expand the area of your original saved view, place a fence around your sheet frame and 
highlight all of the reference files. Choose Tools > Clip Boundary.  

Place a fence and use the Tools > Clip Mask to remove parts of the reference files that may 
be in your Title Box area. 
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Re-sheeting 
It is possible to use the macro to recreate these sheeted drawings. The macro will prompt 
you to overwrite duplicate files.  

However, it is not capable of only sheeting up one or two sheets—it’s all or nothing. If you 
need to make a change to geometry.dgn (move a clip boundary, add a clip boundary, etc.) 
you’re going to have to go through the process of sheeting again. 

Just a reminder, it can only sheet up files in the order that the clip boundaries were placed in 
the file. If you need to add sheets at the beginning of the project, it might be easiest to delete 
all your clip boundary cells that you placed and start again from scratch (using Settings 
Manager Create Plan Sheets > Place Clip Boundary).
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CREATING ROADWAY PLAN SHEET 
DRAWINGS 

Step One: Open your group’s ??plan.dgn 
Open MicroStation and choose your PIN. 

 Refer to page 1-17 for more information on opening files. 

Locate the ??plan.dgn that is in your groups MSTA directory (i.e. hdplan.dgn, bdplan, 
geoplan envplan, etc). 

Step Two: Reference in Survey Data 
From the main menu, choose File > Reference to open the Reference dialog.  

Check to see that the appropriate files are attached to this drawing (i.e. contours, topo, 
points, and text). Wetland data will eventually be in a file called wetlands.dgn. If it exists in 
the topo directory, attach it. 

By default, all Survey files should be attached. If these files are not attached, you will have 
to attach them manually. To reference all files needed for you plan sheets into this file, 
select File > Reference (DOT) > Attach. Browse to the Topo directory of your current 
project (Figure 5-1). 

 
Figure 5-1: The Topo Directory 

 It is important that you attach files from the topo directory and not the survey 
directory. The files in the survey directory are to be used as backups for the survey 
section only.  

Pick any one of these files from the Topo directory and push OK. 



mdot MicroStation 
07/01/07 

Roadway Sheets 

5-4 

 

This brings up the Attach Reference Settings dialog. Below file name and path is the 
Model drawing that you will be attaching. Typically this will show the attachment of the 
Default model. 

Next, type in a Logical Name (either “topo”, “contours”, “text”, “wetlands” or “points”) for 
the file.  

Now pick Coincident – World as your Orientation. This will always line up your drawings 
based on the coordinates of those files. 

Leave the Scale (Master:Ref) set to 1:1 and True Scale checked on.  

If the Nested Attachments area grays out on you then that is a good indication that there is 
no files attached to the file you are currently attaching. If this portion does not gray out then 
you will need to set this to No Nesting or change the Copy Attachment Depth value to 0 
(Figure 5-2). 

 
Figure 5-2: Reference Settings 

 Check page 2-70 for an explanation of Reference File Attachment settings. 

Push the OK button.  

Now repeat these steps until you have attached all the survey files you need to attach.  

Step Three: Attach Proposed Design and Alignment  
If the plans you are creating require the proposed design and alignment, attach them using 
the same method as above. Depending on type of project, bridge or highway, browse to the 
necessary workgroups \MSTA folder and attach the two files. 

Push Fit View (Figure 5-3) to see all your reference files.  
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Figure 5-3: The Fit View Button 

 If you fit view and the graphics zoom way out and does not maximize in your view 
window, there may be some problems with a file or files that you have attached. 
Attempt to correct this before you continue. One common problem is that maybe you 
attached the file base on Coincident instead of Coincident – World. Shut off the 
display of your reference files one at a time, fitting view after each one is shut off to 
try and isolate which file is causing the problem. Once you have isolated the file in 
question, detach and try reattaching based on the method described previously.  

Step Four: Place Clip Boundaries 
At this stage we are going to be placing rectangles along the alignment that will correspond 
to our sheets. We will be using the Plan Sheet Settings Manager to accomplish this. If it 
isn’t loaded already, go to Setting > DOT SetMgrs > Plan Sheet Settings. 

 Check page2-20 for an introduction to the Settings Manager. 

Part One: Set the Category Scale 
Right Click the Settings Manager, choose Category > Scale and set your scale (i.e. 1 
in.=25 ft. or 1 in.=50 ft. for U.S. Customary projects or 1:250 or 1:500 for metric projects). 

Part Two: Place the Cells 
From the Settings Manager, select Create Plan Sheets > Place Clip Boundary.  

This selects our sheet boundary cell and activates a cell placement command that will make 
it easy to place a bunch of these rectangles along the alignment.  

Notice the box on the end of your cursor. When you send a Datapoint to MicroStation, the 
box will be placed at that location.  

 It’s best not to snap to elements in your file. If the two elements you snap to are at 
different elevations, you might end up with a slightly skewed view. 

The box you just placed will immediately begin to rotate by the origin point (the point you 
just entered.) Move your mouse around and notice how it spins. When it is aligned with the 
roadway, enter another datapoint and it will immediately prompt you to place the next 
boundary.  

 Don’t worry if they’re not in exactly the right place. You can go back and clean up 
any placement later by using the move and rotate tools.  

 It is important that you place these boundaries in the order that you want your sheets 
to be numbered. We have a routine that automatically creates the plan files for us, and 
it will number them in the same order that you place these clip boundaries. 

Step Five: Placing North Arrows 
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Start by rotating the view to “top” if not already in a top view.  

 Refer to page 2-11 for help with view controls. 

From the Settings Manager, select Symbols and Linestyles> North Arrow True.  

North is up in your view. It may be necessary to enter 90 degrees in the Place Active Cell 
dialog to orientate the North Arrow to a vertical position. Place the north arrows inside of 
your clip boundaries in a place that is out of the busy area of your plan (preferably the top 
center of each sheet). 

Step Six: Create Cut Sheets 
Now that you have placed all your sheet boundaries, we are going to run a macro that will 
create new plan files for us. From the Settings Manager select Create Plan Sheets > Create 
Cut Sheets. This macro is going to create saved views in ??plan.dgn that are aligned with 
the clip boundaries we just placed then create new drawings and attach the saved view from 
the ??plan.dgn. 

The macro asks you what number you want to use for the starting number of the plan sheets 
(Figure 5-4). 

 
Figure 5-4: Start Numbering At? 

 Depending on your workgroup, you may have a different starting numbers by 
default. The number you see is set based on the estimated number of plan sheets that 
will be placed before these sheets in your plan package. You do have the option to 
change this number at this point in the macro if you have a good feel for your plan 
package set. We will go back later and re-number all the sheets once the complete 
plan package is ready. 

When the program is finished, it will drop you back into ??plan.dgn and fit the view in a top 
rotation. Open up the files you’ve just created and see how they look! 

Live Nesting 
What is Live Nesting? This is a new method in MicroStation V8 of attaching a file with 
references to another file like our border sheets. By using Live Nesting you no longer need 
to use the old methods of Batch>Attach and Batch>Settings to manipulate the way you 
want your cut sheets to appear for plotting purposes. Now if you want to turn off certain 
levels, adjust displays of reference files or attach/detach additional reference files, you can 
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simply do this in your source drawing (i.e. HDPlan, BDPlan, etc.) and all of your border 
files will be displayed in the same manner.  

Troubleshooting 
If you open a plan sheet drawing and the graphics within the sheet are not correct, it could 
mean a couple of things.  

It could mean that some of the drawings that are referenced in are not at the same Global 
Origin as the rest of your drawings. See your Support Staff for assistance if needed or read 
the documentation on Flattening drawings and shifting the global origins.  

Or, it could mean that the clip boundary was placed incorrectly. You can fix this without 
rerunning the “Create Cut Sheets” part of the plan sheet process by following these steps.  

1) Open the incorrect plan sheet. Go to File > Reference - to open reference dialog. 

2) Tools > Detach All to detach the existing reference files.  

3) Now Tools > Attach and be sure to browse to your PIN and select ??PLAN.  

4) When the Reference File Settings dialog comes up, select the “Saved View” from the 
Orientation area you need (i.e.. 011) and set Nested Attachments method to Live Nesting. 
Now the saved view will be on your cursor.  

5) Set it down as close to being in the center of your border as possible. 

 It is not necessary to give a description or logical name. 

Adjusting Saved Views 
You can adjust (re-define) the area of the reference files on your plan sheet by using the 
reference file dialog Tools in combination with the Place Fence command.  

Place a fence around your sheet frame and highlight all of the reference files. Choose Tools 
> Clip Boundary. This will expand the area of your original saved view to the extents of 
your fence. 

Also, use the Tools > Clip Mask to remove parts of a reference file or files. 

Re-sheeting 
It is possible to use the macro to recreate these sheeted drawings. The macro will prompt 
you to overwrite duplicate files.  

However, it is not capable of only sheeting up one or two sheets—it’s all or nothing. If you 
need to make a change to ??plan.dgn (move a clip boundary, add a clip boundary, etc.) 
you’re going to have to go through the process of sheeting again. 

Just a reminder, it can only sheet up files in the order that the clip boundaries were placed in 
the file. If you need to add sheets at the beginning of the project, it might be easier to delete 
all your clip boundary cells that you placed and start again from scratch (using Settings 
Manager Create Plan Sheets > Place Clip Boundary). 
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CLEAN-UP THE PROPOSED ALIGNMENT FILE 
Overview 
Once the proposed alignment has been created in MX and are placed in your PIN directory, 
there is some cleanup required.  

We will be using a macro to draw the centerline in MicroStation. This will produce true 
curves and a complex chain that will facilitate measurement. 

The MX designer must place the dab-alignments.prn file into your projects PIN directory 
under the MSTA folder. This is the default directory that the macro points to. 

Step 1: Open the Alignment Drawing 
Open your alignments.dgn design file and Fit View. 

Step 2: Run the Macro 
On the Settings Manager, select Category > Scale and pick the scale in which you will be 
printing your drawings. U. S. Customary projects; this is typically one of two scales, 1 in. = 
25 ft. or 1 in. = 50 ft. (1:250 or 1:500 for metric projects).  

Using the Plan Sheet Settings Manager, which should have automatically loaded, select 
Proposed Alignment>Create Alignment String.  

This opens a dialog that prompts the user to select the dab-alignments.prn file for your 
project.  

 Verify that the default directory is indeed your projects directory. If the path is 
pointing to a project other than yours, exit MicroStation. Open MicroStation by 
clicking on the icon and select your project from the Project pull down. 

If your directory is OK, select the file and press OK to have the macro draw your centerline 
string. 

Step 3: Adjusting “Flag” Text 
The PC’s and PT’s may need to be rotated 180 degrees so that they are easy to read if 
looking from the rightmost edge of your plan sheet and may need to be moved.  

To do this, use the Rotate tool in the main toolbox, set the mode to active angle and set 
your angle to 180 degrees. Move into position using the Move Element tool.  

If the flag line requires trimming, use the Extend Element tool. 

Step 4: Placing Curve Data 

Open dab-alignments.prn  
The curve data exists in the same file that the macro used to run to generate the centerline 
string. Using Windows Explorer, browse to your PIN directory. Open the dab-
alignments.prn file.  
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 You may get a dialog that asks you what program you would like to use to open this 
file. Choose either PFE32, or Notepad. Check the box to “Always use this program 
to open this file”. 

Place and Edit the Curve Data Cell 
From the Settings Manager, select Proposed Alignment>Curve Data Cell. 

Place it between your PC and your PT with a Datapoint. Now the cell is dynamically 
rotating around your cursor. Click again to finish rotating it correctly. 

Depending on what text editor you are using you may or may not need to drop the cell to 
edit the text. We will assume you are using the standard text editor. 

Once you drop the cell Qualities>Drop>Complex), use your Edit Text tool and either type 
or copy and paste the information into the text editor dialog from the dab-alignment.prn 
file. 

Step 5: Placing Bearings 
To place your bearings, choose Proposed Alignment > Centerline Bearings from the 
Settings Manager. Datapoint on a tangent line.  

 Be sure that your proposed centerline highlights, as opposed to the existing centerline 
string located in the topo.dgn. 

The resulting label shows both distance and bearing. All we want to display is the bearing. 
Remove the distance by using the Edit Text tool. Datapoint on the distance/bearing label to 
open the Dimension Text dialog (Figure 5-5). 

 
Figure 5-5: Edit Dimension Text 

Replace the “*” in the Upper field with a space. 

 You can’t just delete the “*”. 
Hit OK to apply the change. 

Verify that the bearing matches the bearing in your dab-alignments file. If it doesn’t, edit 
the text and supply the value from the dab-alignments report. This is the correct bearing for 
the centerline. 
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 Due to the current working units of the drawing cube in MicroStation, there is not 
enough precision to accurately formulate the bearings. 

 If the bearing you placed is upside down compared to the centerline text, drop the 
dimension (Qualities>Drop>Dimension) then rotate the text 180 degrees.   

Step 6: Flatten the Drawing 
Go to Macros>Flatten. Click OK to accept 0 as the desired elevation. Click a data point 
anywhere in the view window to initiate the command. 
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EDITING THE PROPOSED DESIGN (I.E. 
HIGHWAY.DGN OR BRIDGE.DGN) 

MX produces most of our proposed design files (i.e. highway.dgn or bridge.dgn). The file is 
in a very raw format. There are a handful of elements that require adjustment to their 
linestyle. Some of them are cut lines, fill lines, ditch lines, curbing, retaining walls, 
guardrail and possibly drainage lines. This section describes how to select like lines and 
make adjustments “Globally” to set the appropriate symbology of the elements in 
MicroStation.  

Step 1: Identify Elements Using MX Enquire 
Under the Macro menu, choose MX String Info. An Enquire button should pop up (Figure 
5-6). 

 
Figure 5-6: Mx Enquire 

Press the Enquire button.  

 Turn the Graphic Group lock off.  
Click an element to find out what it is called. The attributes of the element you picked will 
be displayed in a new dialog window (Figure 5-7).  

 
Figure 5-7: MX Enquire Message display 

The Element Name is what you are interested in most; however, the name may not be clear 
as to what it represents. Go to Macros>MX String Search and enter the “Name” of the 
element. If this element name has numbers in it, supply the characters then use the wildcard 
“**” in place of the numbers. If the Designer used standard naming convention for the MX 
elements, the Name of the element should be displayed in the dialog giving you a better idea 
what the element might be. The designer may also be able to give you some insight on what 
he or she named the elements. 

Go to Macros > Select By MX Attributes (Figure 5-8). 
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Figure 5-8:Select by MOSS Attributes 

Under the Model pull down, select the model.  

 There may be multiple models in your drawing, but normally, there is only one 
called Design. 

In the Name field, type in the name of the object you wish to have selected. If this element 
name has numbers in it, supply the characters then use the wildcard “**” in place of the 
numbers.  

Hit Select to pick the elements. This will select all MX elements in your drawing that have 
the same name. 

Step 2: Setting the Attributes 
The quickest way to set the attributes of an element is to utilize our Plan Sheet Settings 
Manager.  

On the Settings Manager, select Category > Scale and pick the scale in which you will be 
printing your drawings. U. S. Customary projects; this is typically one of two scales, 1 in. = 
25 ft. or 1 in. = 50 ft. (1:250 or 1:500 for metric projects). 

For example, if what you Enquired appears to be a proposed slope line, choose Proposed 
Slope Lines>Cut Line or Fill Line to set the attributes. 

 If you find that the cut and fill lines are not sized correctly then you should verify you 
Category>Scales is set correctly from the Settings Manager prior to selecting any 
thing in the Settings Manager. 

 All of your slope lines may be named the same; therefore they will all be selected 
and changed to the attributes of a cut line or a fill line. Select the slope line type 
based on what the majority is for your project.  

The name “IC” means interface cut. The name “IF” means interface fill. If proper naming 
was used, you should be able to pick them individually.  

Step 3: Changing the Attributes 
Click on the Change Element Attribute tool in the main toolbar. Make sure Method is set 
to Change and place a check in all of the other attributes boxes except for Class and Use 
Fence. By using the Settings Manager, Level, Color, Style and Weight should be set for 
you. Click on the screen to change the attributes.  

Repeat the steps above on all elements that require a custom line style in MicroStation (i.e. 
Ditch arrows, slope lines, retaining walls, curbing, and sometimes, proposed underdrain). 

Step 4: Finishing Up 
Once all custom line styles are changed to the proper style, all that remains in the active 
drawing are lines that represent the travel way, edge of shoulder, back of sidewalks and 
boundaries of entrances, etc.  

These lines should be selected and changed to a weight 3. Using the Edit > Select By 
Attributes, check the box to select attributes by weight of “0”. Hit Execute. Only these 
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should highlight. Now, use the Change Element Attributes tool and select only the weight 
and set the number value to 3. Click on the screen to make the change. Close the Select By 
Attributes and click Cancel to stop filtering elements. 

Step 5: Flatten the Drawing 
Go to Macros>Flatten. Click OK to accept 0 as the desired elevation. Click a data point 
anywhere in the view window to initiate the command. 
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PROFILE DRAWING GENERATION 
Discussion 
To work on the Profile drawings, they must first be generated from Mx and placed in your 
projects PIN directory on the Y: drive. Typically, there are two standard scales for profiles, 
1”=25’ scale and 1”=50’ scale (1:250 or 1:500 metric). Find out which scale was used to 
generate the profiles. 

Rename file to look alike (Optional) 
Use your Windows Explorer to browse to your PIN directory and browse to your 
workgroups MSTA folder. The majority of the files should have names like PROF-
DESIGN-MC10_dr_002.dgn. When MX creates these files using the wizard, it doesn’t add 
part of the filename to the first file.  

Rename this file (File>Rename) in Windows Explorer, adding _dr_001 to the end of the 
file name.  

Step One: Symbology Correction 
Drawings that have been processed from Mx to MicroStation are now full-size and the 
standard border is already placed. The only issue is the symbology of our borders comes 
over as gray. 

 All Profile drawings need to be processed, if you see that the borders are gray, 
process these files by selecting Macros>Fix Borders (XS/PROF) from the main 
menu. 

 If you did receive Profile drawings from your designer (Mx user) and there were no 
borders in the files, then please ask the designer to redisplay the drawings in Mx with 
the appropriate settings for translation. 

When the macro finishes processing the files, it will open the first file. 

Step Two: Rename the Drawings 
Close out of MicroStation. Using the “Sheet Renumbering Utility”, organize the sheets, 
using placeholders if necessary, so that the profiles are after the plan sheet. This will add the 
number prefix to the drawings. If you do not do this, you will not be able to take advantage 
of automatically filling in the variables in the drawings (Editing the PCF). 

 Check page 1-22 for instructions for using the Sheet Renumbering Utility. 

Step Three: Edit the PCF File 
“Project Configuration files” are files that contain project specific information that will be 
used by a macro to substitute project information for variables into your Border. Any text on 
the border that has a “$” is a variable. Examples of variables are Town or City, Street or Rte, 
PIN, Project Number. 

 Refer to page 1-25 for complete instructions on Editing the PCF file.  
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Step Four: Border Information 
If you would like to replace the variables in your border, run the Border Information Macro. 
This is kicked off after editing the PCF file, but it can be run as a separate step. 

 Refer to page1-27  for complete instructions on running the Border Information macro. 

More Cleanup 
Using the profile Settings Manager, place all dimensions; text and symbols required on your 
profile drawings using the Profile Settings Manager. Refer to a sample set of profiles, your 
Plan Development Guide or Highway Design Guide for what is required and to see how they 
should look. For additional information, contact CADD Support. 
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WORKING WITH CROSS-SECTIONS 
Discussion 
To work on the Cross Section drawings, they must first be generated from MX and placed in 
your projects PIN directory on the Y: drive. Currently, there are only two scales for Cross 
Sections: 1 in.=5ft. and 1 in.=10ft (1:50, 1:75 or 1:100 metric). Find out which scale was 
used to generate the Cross Sections. 

Bridge Program users only use MX to produce Cross Sections with old ground on them, you 
can use the Template macro to produce the proposed lines on your sections. The macro can 
be found in the main menu under Macros>Template. 

 For detailed instructions on using the template macro, refer to page 4-18.   

Rename file to Look alike (Optional) 
Use your Windows Explorer to browse to your PIN directory and browse to your 
workgroups MSTA folder. The majority of the files should have names like 
XSMC10_dr_002.dgn. When MX creates these files, it doesn’t add part of the filename to 
the first file.  

Rename this file (File>Rename) in Windows Explorer, adding _dr_001 to the end of the 
file name. 

Step One: Symbology Correction 
Drawings that have been processed from Mx to MicroStation are now full-size and the 
standard border is already placed. The only issue is the symbology of our borders comes 
over as gray. 

 All Cross Section drawings need to be processed, if you see that the borders are gray, 
process these files by selecting Macros>Fix Borders (XS/PROF) from the main 
menu. 

 If you did receive Cross Section drawings from your designer (Mx user) and there 
were no borders in the files, then please ask the designer to redisplay the drawings in 
Mx with the appropriate settings for translation. 

Step Two: Rename the Drawings 
Close out of MicroStation. Using the “Sheet Renumbering Utility”, organize the sheets, 
using placeholders if necessary, so that the Cross Sections are after the Profile sheets. This 
will add the number prefix to the drawings. If you do not do this, you will not be able to take 
advantage of automatically filling in the variables in the drawings (Editing the PCF). 

 Check page 1-22 for instructions for using the Sheet Renumbering Utility. 

Step Three: Edit the PCF File 
“Project Configuration files” are files that contain project specific information that will be 
used by a macro to substitute project information for variables into your Border. Any text 
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on the border that has a “$” is a variable. Examples of variables are Town or City, Street or 
Rte, PIN, Project Number. 

 Refer to page1-25  for complete instructions on Editing the PCF file.  

Step Four: Border Information 
If you would like to replace the variables in your border, run the Border Information Macro. 
Usually this is kicked off after editing the PCF file, but it can be as separate steps. 

 Refer to page1-27 for complete instructions on running the Border Information macro. 

More Cleanup 

Step One: Clean up the file 
Using the Edit Text tool or selecting Text>Edit Text from the Main Menu, replace the 
X+XXX and the Y+YYY with the first and last station numbers on your sheet. 

 Complete this procedure to all of your Cross Sections before you start plotting 
singles. 

Step Two: Plotting Existing & Proposed “Singles” 
There are many items that need to be plotted on the Cross Sections. Trees, Poles, Buildings, 
Drainage Features, Underground Utilities and Text associated to each of them. We have a 
Cross Section Setting Manager designed specifically for this task that will help keep our 
files standard. It should be automatically loaded. 

 Remember to place these items on the closest possible section. 

Right click on the Settings Manager, choose Category > Scale and select the scale of your 
Cross Sections (i.e. 1 in.=5ft. and 1 in.=10ft (1:50, 1:75 or 1:00 metric)). 

Step Three: Plotting Cells 
Some cells are created with origins for the Left and for the Right side of the centerline and 
some have the origin located in the center of the cell. The trees, for instance, have a bottom 
center origin, but need to be plotted to the face of the tree, depending on whether it is on the 
left or the right.  

The following is the procedure for plotting singles that have a proper origin. 

Go to the left pull down of your Settings Manager and choose the category of singles you 
are plotting. In the right pull down, select the specific cell you want to plot. 

You will find that the cell you selected is now on your pointer. With your focus in 
AccuDraw, tentative to one of the centerline tick marks and type an “O” to set your 
AccuDraw Compass to this point. 

Move the cell horizontally in the X direction, either left or right, and type in the offset. This 
offset will be locked for the time being. Move the cell up or down until you have it 
positioned on the old ground.  

 Snap to the ground using your Nearest snap (type N into AccuDraw).  
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Some items, drainage and utilities, have their own level for text placement, use the 
appropriate text associated to these cells from the settings manager (i.e. Exist. 
Utilities>Utility Text). For all other text associated to existing cells, select Existing Text 
(Misc)>Standard Text (Normal) from the Settings Manager. 

A Text Editor window opens and waits for your entry. Enter your text in this field and it will 
be attached to your pointer, waiting for the user to provide a position on your screen.  

If you are cutting and pasting from another program, go to this program, select the text and 
select Edit>Copy or Ctrl+C on your keyboard and go back to MicroStation and select 
Edit>Paste or Ctrl+V into the Text Editor window. 

Because the tree cell’s origin is at the bottom center of the cell, the user needs to take notice 
of where the temporary dashed line crosses the existing ground string during placement of 
the cell. At this point, hit the “L” key twice and it will release the lock in the X direction 
allowing the user to move the cell horizontally until the face of the tree is aligned where the 
temporary line that was crossing the existing ground. Datapoint to place it.  

 Please note that the Survey Section defines the face of the tree closest to the 
centerline of the road. 

Step Four: Manipulating The Template 
The Template (proposed design) most likely needs some editing, or at the least, additions. 
For an example, all cross section on each sheet need offsets to the toe of slope, and cut and 
fill quantities. There are many ways to do one thing in MicroStation, so we will describe the 
method we found easiest and fastest. 

Part One: Adjusting slopes 
When adjusting or modifying a line, set your snap mode to Keypoint. 

Use the Modify tool (Stretch > Modify).  

Snap to the end of the line, and (using your AccuDraw shortcut keys) snap to the new 
location with a I for intersection or provide an offset value by snapping to the centerline and 
type O for origin and slide in the X direction and enter a value. Move in the Y direction until 
you are near the old ground and hit the N on your keyboard then Snap to the old ground. 

Step Two: Creating slopes. 
AccuDraw makes it very easy to create lines at a slope or percentage.  

Use the Cross-Sections Settings Manager to control the appearance of new lines. From the 
Settings Manager, choose Template Lines and Symbols > Finished Grade and Slope. 
This will set the proper Level, Color, Style and Weight as well as launching the Smartline 
command. 

To place a slope specified as “rise / run”, snap and Datapoint to begin the line. Gesture left 
or right and type the “run” value of your slope into AccuDraw. Gesture up or down and 
enter the “rise” value of your slope into AccuDraw. Type “A”, while focus is in AccuDraw, 
to lock the angle of the line. Use a Nearest snap and click on the old ground. 
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 Refer to page 2-51 for a description of using AccuDraw to place lines at a percent slope. 

If you need to trim a slope line to the old ground, use the Extend Element to Intersection tool 
and hit the line you want to extend, and then hit the line that you want it to extend to.  

Use the Construct Circular Fillet command to place rounded ditch slopes (Zip > Fillet > 
Fillet). In the Construct Circular Fillet Tool Settings Window (Figure 5-9) make a guess 
on the Radius of the fillet and set the Truncate value to First. 

 
Figure 5-9: Fillet Tool Settings Window 

This command requires two Datapoints. The first point indicates the element that is going to 
be cut (“truncated”). Pick your proposed slope line. The second point identifies the line to 
trim the first line to. Pick the existing ground to the outside of the slope. 

 If you don’t like the results, try a different radius. 

Step Three: Labeling Slopes 
Labeling slopes have been made easier by using the Settings Manager. Select Proposed 
Text and Dims>Slope% and snap and Accept on both ends of the line you are labeling. The 
slope will appear in your Text Editor. It is ready for placement. Snap to the middle of the 
line and Accept to finish the placement. 

 For more detailed information about the Slope% macro, refer to page 2-86. 

Step Four: Subgrade and Driveway Cleanup 
The rest of the cleanup may consist of drawing subgrade lines for your main line and your 
drives. Be sure to use your Settings Manager (Template Lines and Symbols) to control the 
Level, Style, Color and Weight of these lines. Refer to the Standard Details when adjusting 
driveways. Use the Proposed Text and Dims>Slope% macro to label the driveway slopes.
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DETAILING TO SCALE 
Introduction 
We’d like to make it as easy as possible to draw our structural details. The biggest problem 
we face in doing this is the issue of controlling text and dimension size relative to plot scale. 
To make sure we’re always drawing 1:1 (full size), we’ve adopted a workflow that relies on 
MicroStation’s built-in use of reference files, as well as a heavily customized Settings 
Manager. 

File Segregation 
Let’s look at an abutment as an example of how we’re going to segregate files. Say we have 
three sheets for abutment one: a footing sheet, an abutment sheet and a wing sheet. In our 
bridge\msta\ folder for this project, we will have one .dgn file that corresponds to each of 
these sheets. They might be named “016_abutment1.dgn” “017_pier_1.dgn” and 
“018_framing.dgn.” These files would be empty except for a border that contains the title 
block, signature block, etc. All of the detailing work that we’ve done for this abutment will 
be other files, which might be called “z_abut_1.dgn”, “z_pier_1.dgn” and “z_framing.dgn.” 
These files contain the lines, text and dimensions that make up our details.  

Creating A Detailed Drawing 
The first step in detailing our abutment is to create the drawing file that is going to contain 
our lines, text and dimensions. 

 Refer to page 1-18 for Creating Drawing Files. 

Now we are ready to do our detailing work. We will discuss this in detail elsewhere, but for 
now, note that we will be using the Settings Manager to control our level, color, style and 
weight. From the Settings Manager, select Structural Detailing > Abutments and draw up 
your abutment plan.  

Now it’s time to decide what scale we’re going to want to plot this plan. Until we have 
placed text or dimensions on this plan, we can plot it out at any scale. It is the size of text 
and dimensions that lock us down to a fixed plot scale. 

If your Settings Manager is docked at the bottom or top of your screen, right-click on it to 
pop up the menu choices (Figure 7-1). 

 
Figure 7-1: Right Click on your Settings Manager 

From the menus, select Category > Scale to select the working scale for your detail. This 
brings up the Select Scale dialog (Figure 7-2). 
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Figure 7-2: Select Scale 

Let’s select a scale of ¼ in. = 1 ft. and push OK.  

 Check page 2-23 for more information on the Settings Manager Scale. 

Once you have selected your scale, it is time to annotate your detail. Using the Prop. Text 
and Dims > Dimension Ft./In. (1/4 accuracy) (Figure 7-3), this will setup your dimension 
sizes and your text size. Finish up your detailing work. 

 
Figure 7-3: The Prop. Text and Dims Group 

Once you have finished your annotation, we are going to set up a Saved View that contains 
our detail. From the Settings Manager, choose Tools > Saved View Maker.  

This will run a macro to quickly create a saved view for you. It will prompt you to enter the 
lower left and upper right hand corners of a box that contains all of the lines and text that 
make up your detail (Figure 7-4).  
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Figure 7-4: Define the Extents of your Saved View 

Once you enter in both of these points, the macro will then resize your open window to the 
aspect ratio of your detail and open up a Saved View dialog to ask you for a name and a 
description of your view (Figure 7-5).  

 
Figure 7-5: Naming a Saved View 

 In the description field, make sure to include a reference to the scale of the detail, as 
you will need that information later. 

This completes the work that needs to be done in this file. Now we are going to create a 
Sheet File and attach our detail to it. 

Creating a Numbered Border File 
 Refer to page 1-18 for creating your Border File  
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Fill in the information in the border by selecting Macros > Border Information from your 
main menu. 

 If you find the information on your border to be incorrect then it will be necessary to 
edit your “Project Configuration File”. This can be accomplished by going to the 
main menu and selecting Workspace>Edit Project Data (PCF). 

 Refer to page 1-25 for more information about PCF Editing. 

Now it’s time to attach our detail to this drawing. Select File > Reference (DOT) > Attach. 

This will bring up the Preview Reference dialog (Figure 7-6).  

Select your drawing file and push OK. 

 Using this selection instead of the out-of-the-box File > Reference allows us to go 
directly to the project directory that we are working in and keeps us from having to 
browse to the directory. 

 
Figure 7-6: The Preview Reference Dialog 

This will bring up the Attach Reference File dialog (Figure 7-7).  
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Figure 7-7: The Attach Reference File Dialog 

We will need to make a number of selections here. First off, pick your saved view from the 
Orientation portion of the dialog. When picking a Saved View you will notice that the 
Logical Name and the Description will fill in automatically. Finally, set your Scale 
(Master:Ref) to be equivalent to the Settings Manager scale that you used when annotating 
your detail. (In this case, our ¼ in.=1 ft. Settings Manager scale translates to a 1:48 
Master:Ref scale.) Push OK. 

 Refer to page16-2 for the table of U.S. Customary detailing scales. 

This will dump you back into your file with a box hovering on the end of your cursor 
(Figure 7-8). 
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Figure 7-8: Reference Placement by Saved View 

Datapoint somewhere on your border to place your detail in an acceptable location. 

Adding Further Details, Different Scales 
To continue with the previous example, you might go back into your z_abut_1.dgn and 
create an abutment elevation. Since the abutment plan and elevation may be at the same 
scale, you should have no trouble working on both of those details in the same file for the 
life of the project. You would set up a saved view for the elevation and attach that saved 
view to your 017_abutment1.dgn. Then any changes that needed to be made to those two 
sections would be made by opening up z_abut_1.dgn drawing file. 

However, the abutment section is often at a different scale than the plan and elevation. There 
are two choices for detailing this section. One method would be to create a new design file 
(“z_abut1_sect.dgn”) and choose something like “1/2in.=1 ft.” for the scale. Then draw and 
annotate as we just explained, creating a saved view and attaching that file to 
017_abut1_plan.dgn. 

The other method would be to draw the abutment section in the same file as the abutment 
plan and elevation. Then, when you wanted to place text on the section, you would choose 
“1/2in.=1 ft.” as you Settings Manager Scale and reselect Prop. Text and Dims > 
Dimension Ft./In. (1/4 accuracy) to establish the correct dimension and text size for 
annotating your section detail.  
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 Remember, this won’t affect the text that we’ve already placed on the ¼ in=1 ft. 
details. It only impacts text that we are going to place from here on out. 

The only drawback to this method arises when you want to add more annotation to the ¼ 
in.=1 ft. details. You MUST select the proper Settings Manager Scale before using the 
Settings Manager to place additional text, dimensions, custom linestyles, or cells. This 
means that as you work on this drawing you will need to continually flop back and forth 
between scales.  

To check your current Settings Manager scale, go to the Settings Manager and choose Tools 
> Plot Scale? (Figure 7-9)  

 
Figure 7-9: Settings Manager Scale Information 
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TOOLS IN THE SETTINGS MANAGER 
The Tools section of the Settings Manager (Figure 7-10) has a couple useful automation 
routines.  

 
Figure 7-10: Settings Manager > Tools 

The File Making Macros 
File creation has been removed from the Structural Settings Manager. Cut sheets will be 
created from the USPlan Settings Manager and all other file creation will be handled 
through the makesheetz.bas macro (File > Makesheetz). 

 Check page 1-18 for a description of the makesheetz macro. 

 There is a file creating process within the Tools group that allows for developing 8.5 
x 11 detail sheets for the purpose of developing Coast Guard permit plans. This 
works very similar to creating plan sheets. You would use the option Place 8.5x11 
Clip Boundary around your specific details and then process them to sheet drawings 
by using the option Create 8.5x11 Plan Sheets. 

Plot Scale 
The Plot Scale? Component reminds you of your current Settings Manager Plot Scale 
(Figure 7-11).  

 
Figure 7-11: Settings Manager Scale Information 

Make Saved Views 
The Saved View Maker is a way of automatically creating a Saved View of a specific size 
and aspect ratio.  

Saved Views are a little bit like bookmarks in a MicroStation .dgn file. They help you get 
back to a specific location in your file by storing the coordinates in a utility called Saved 
Views.  
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The default way of accessing Saved Views is by opening the dialog from the Menus under 
Utilities > Saved Views (Figure 7-12).  

 
Figure 7-12: Saved View Dialog 

Structural Detail Settings Manager 
When selecting Structural Details Stg. Mgr. you will launch another Settings Manager that 
will allow you to place structural detail cells that have been built into a cell library for you. 
They are categorized by bridge components. 

 If there are any details that you develop while detailing that would be pertinent to be 
created as cells please contact your support staff to develop and make them 
accessible to all others. 
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DIMENSIONS AND THE SETTINGS MANAGER 

 
Figure 7-13: Dimensions 

Dimensions With Arrows 
There are currently four options for placing Dimensions with Arrows. 

• Dimension Decimal Feet lays out dimensions to hundredths of inch accuracy. 

• Dimension Ft/In (1/16 accuracy) lays out dimensions to a 1/16” accuracy. 

• Dimension Ft/In (1/4 accuracy) lays out dimensions to a 1/4” accuracy. 

• Dimension Ft/In (1/8 accuracy) lays out dimensions to a 1/8” accuracy. 

Selection of any of these options will setup your active level, color, style and weight, as well 
as setting an appropriate dimension text height for your active Settings Manager Scale. It 
will also launch the appropriate tool for dimensioning (in this case, the Dimension Size 
Arrow tool (Figure 7-14).)  
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Figure 7-14: Dimension Size Arrows Command 

Angle (Text Above) & Angle (Text Horiz.) 
These Components set us up for dimensioning the angle between two lines. The Text Above 
option places the text in-line with the dimension arc. The Text Horizontal option cuts the 
dimension arc and always draws in text horizontal (Figure 7-15). 

 
Figure 7-15: Angular Dimension Examples 

 This command can be used to dimension obtuse as well as acute angles, depending 
on the order in which you identify the lines. In the pictorial, I identified the 
horizontal line first, and then the slanted line and I got the angle that was less than 
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180°. This is because MicroStation always dimensions angles in a counter-clockwise 
direction, if I had identified the slanted line first, I would have gotten the angle that 
was greater than 180°. 

Dimension Arc Length 
This tool allows for dimensioning an arcs length with a radial dimension (Figure 7-16). 

 
Figure 7-16: Dimension Arc Length 
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STRUCTURAL DETAILING AND THE SETTINGS 
MANAGER 

The Structural Detailing component of the Settings Manager (Figure 7-17) is set up to 
help us control level, style, color, and weight of elements that we place on our drawings as 
we draw details. 

 
Figure 7-17: Structural Detailing Settings Manager 

Nuts and Bolts 
Selecting any component from the Structural Detailing portion of the Settings Manager 
does a number of things. 

Most of the components set you active color, level, style and weight. You can watch these 
attributes change on your Attributes tool box (Figure 7-18).  

 
Figure 7-18: The Primary Tool Box 

The only exception to this is the Hidden component, which only changes your style to 
dotted and weight to thin. (This allows you to draw a Hidden line of any of the other types: 
Abutment, Framing, etc.) 

Some Typical Uses 

New Elements: 
Probably the most common workflow will be simple. Decide what kind of detail you’re 
working on. See which Component best corresponds to the work you’re going to be doing, 
and pick that item from the Settings Manager. This will set up the proper Symbology and 
level for you.  

 Symbology is MicroStation’s collective term for color, style and weight.  
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Now choose your drawing commands (place circle, place Smartline, etc.,) and start drawing. 

Changing Existing Elements: 
You’ll also use the Structural Detailing Group for cleaning up elements that may have 
been drawn wrong. Maybe you constructed lines parallel to a centerline, and now you need 
to change them to an Abutment style.  

From the Settings Manager, choose Structural Detailing > Abutments to set the 
appropriate level, color, style and weight.  

Then, choose the Change Attributes tool either from the Main Tool Frame or from the 
Menus (Qualities > Change > All). This will prompt you to Identify Element. Pick the 
element that you want to change. (Make sure to Accept the change by entering a Datapoint.) 

Adding New Detailing Types 
If there is a detail type that you think needs to be added, please bring it to the attention of 
your support group. 
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CHANGING DETAIL SCALE 
So you’ve finished drawing up your detail. You’ve got it all dimensioned. You’ve got it all 
annotated. Now you’ve changed your mind about what scale you need to use, and all your 
text, dimensions, and linestyles look wrong.  

No Quick Solution 
There’s no one-step program to fixing this problem. It’s going to take some work. But here 
are the things you need to do: 

Scale 
First off, let’s make sure you pick your new scale. From the Settings Manager, choose 
Category > Scale and pick your new scale (Figure 7-19). 

 
Figure 7-19: Pick a Settings Manager Scale 

 Check page 2-23 for more information on the Settings Manager Scale. 

Text 
Now let’s get the text out of the way. You’ve already got a lot of text on the drawing; you 
just need to change it. We’re still going to start by going to the Settings Manager and 
choosing Prop. Text and Dims > Text Note (Figure 7-20). 

 
Figure 7-20: Structural Settings Manager 
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This will open up the Text Editor (Figure 7-21). 

 
Figure 7-21: The Text Editor 

It opens up because that Component launched the Place Text command. We’re not going to 
use the Place Text command, however. Go to your Main Menu and choose Text > Update 
Text. (This is the same as the Change Text Attributes command (Figure 7-22) from the 
Text tool box.). 

 
Figure 7-22: Change Text Attributes 

This tool is used to change the Text Attributes of an existing text item. The status bar will 
prompt you to “Identify Element.” Go around your detailing, picking on all the text that 
needs to be changed. Or, if you prefer, place a fence that encompasses all of the text items 
that you want to change and check off the Use Fence option in your Tool Settings Window. 
This will let you change a whole bunch of text items at once.  

Once that’s done, you’re going to notice that some of the text doesn’t fit into spaces where it 
used to fit, or text will overlap other text or parts of the detail. This is going to require some 
cleanup. I recommend the Main Menu Zip > Move to move text items back into place. 
Make sure to use AccuDraw to keep them in proper horizontal and vertical alignment. 

Dimensions 
We’re going to use a similar procedure for all the dimensions that need to be changed. First, 
go to the Settings Manager and choose the dimension Component that corresponds to the 
dimension that you need to change.  

Once you have selected a Component, MicroStation is going to launch a Place Dimension 
command. We’re going to ignore that command and go on to select Update Dimension 
either from the Dimension toolbox (Figure 7-23) or from the Main Menu Dimension > 
Update.  

 
Figure 7-23: The Dimension Toolbox 

This command works very similar to the Change Text Attributes command. It will prompt 
you to identify a dimension to change. Go around your detail, picking on every dimension 
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that needs to be updated to your current settings. Note that there is no way to change a fence 
full of dimensions at once. However, you can use the Element Selection tool or the 
Powerselector to pick a whole bunch of dimensions, and then issue the Update Dimension 
command to change the whole lot of them. 

Linestyles 
The last thing that needs to be changed may not be obvious at first. Your Arrow and Bullet 
linestyles should always be the same size relative to your text. So if your text size changes, 
you should make sure to change your linestyles as well.  

Do this by going to the Structural Linestyles Group from the Settings Manager and 
picking the linestyle that you want to update (Figure 7-24). 

 
Figure 7-24: Structural Linestyles 

This will set your active settings appropriately. It will also issue the Place Smartline 
command. Again, we’re going to ignore the command launched by the Settings Manager 
and go on to select Change Element Attributes.  

This can be selected from the Main Tool Frame or from the Main Menu Qualities > 
Change > All. Now identify each line that needs to be changed. 

Speeding up the Process 
It is possible to use the Select By Attributes command from the Edit menu (Figure 7-25) to 
speed up the process of selecting elements that need to be changed.  
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Figure 7-25:Select By Attributes 

This utility allows you to select elements by Level, Symbology, and Type (Line, Arc, etc.)  

 Refer to page 2-33 for a thorough discussion of Selecting by Attributes. 
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TEXT AND THE SETTINGS MANAGER 
One of the primary functions of the Settings Manager is to help us control text size on 
details of various scale. We have programmed a number of text settings into the Settings 
Manager. They are accessed through the Prop. Text and Dims Group. 

A Word on Scale 
Before you place text on a detail, make sure that you have determined what scale you want 
that detail plotted at. Make sure you have selected that scale from the Settings Manager by 
choosing Category > Scale.  

 Check page 2-23 for more information on the Settings Manager Scale. 

Text Components 
There are basically four different types of text we’ll be placing on our drawing. All of our 
annotation will be done with the Text Note option. This sets up our standard normal text 
size and activates the text placement command. The other text size options are the Title 
Text options: Title Text and Title Text (Underlined) and the Sub-Title Text.  

 It is no longer necessary to underline text by drawing a line underneath it. 
MicroStation will automatically underline text for you. If you are going to place a 
detail label, make sure to use the Underlined option.  

There may be cases where you want larger text that is not underlined, and that is where the 
Title Text Component comes in, also you may find an instance where you want a text size 
that falls between our standard normal size and the title text size. This is when the Sub-Title 
Text option would be handy. 

Behind the Scenes: The Long Way Around 
What are these Components really doing for you? They are setting up text attributes like 
font, height and width. To see the changes that are made when you select the text 
Components, open up the Text Dialog by choosing Element > Textstyles from the Main 
Menu (Figure 7-26). 
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Figure 7-26: The Text Styles Dialog 

Placing Text Annotation 
Much of the text that we’re going to be placing on our drawings is going to be in the form of 
annotation: a label with an arrow or bullet that extends to a detail. We have decided to 
approach this matter as simply as possible. First, place your text around your detail. Then, 
from the Settings Manager, select one of the Text Note linestyles (like Text Note Arrow). 

 Selecting the Note/Linestyle component does two things. First off, it sets your active 
color, style, weight and level -- just like the Structural Detailing Component. 
Second, it runs the Place Smartline command. 

MicroStation is now ready to help you draw a leader line from your text to your detail. Use 
AccuDraw and your snaps to control the geometry of the leader line (Figure 7-27).  

 
Figure 7-27: Sample Leader Line 
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Some Difficulties 
First off, you can’t snap to text in a very useful way for placing notes. The only points you 
can snap to on text are the origin, the center, and the midpoint. These probably aren’t going 
to help you locate the perfect spot to start placing your leader lines. This means eyeballing is 
the answer. 

Changing Your Mind About Scale 
If you change your mind about the scale that a detail is going to be, it’s going to screw up 
your text. There’s no way around it.
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PIN CREATION 
This process is to develop project identifiers for Accident Record Diagrams. 

Step One: Opening the Command Prompt Screen 
Double click on the Command Prompt Icon on your Desktop (Figure 8-1). If you don’t have 
one, select Start>Programs>Accessories>Command Prompt. 

 
Figure 8-1: Command Prompt Icon 

Step Two: Changing Directory 
You will need to type Y: in the Command Prompt window to change your directory (Figure 
8-2). 

 
Figure 8-2: Changing directory to Y:\> 

Step Three: Creating the Project Identifier 
The following steps will need to be done in order to create Project Identifier on the network. 

Type: Makeaccid 05 0123456789 as and press enter (Figure 8-3). 
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Figure 8-3: Example of an Accid PIN 

After pressing enter you will see the following prompt (Figure 8-4), if this is your intention 
then press enter again. 

 
Figure 8-4: Press any key to continue [Ctrl]-C to Cancel 

The next prompt below (Figure 8-5) shows you the directory that is being created and 
verifies that this is correct. If so press enter. 

 
Figure 8-5: Press any key to continue [Ctrl]-C to Cancel 

The next prompt just verifies you are sure of your location (Figure 8-6) and if so then enter 
Y in the question statement and press enter. 
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Figure 8-6: Processing the privileges 

The next prompt (Figure 8-7) when pressing enter creates a PCF file (Project Configuration 
File) for MicroStation. 

 
Figure 8-7: PCF File Creation 

This next prompt (Figure 8-8) tells you that the file has been created and when you press 
enter the PCF file will open for editing in Notepad. 

 
Figure 8-8: Information about PCF file 

Step Four: Editing Your Project Configuration File 
Below is the PCF file for MicroStation (Figure 8-9). The most important thing for you to do 
in this file would be to fill in the Project Identifier in the line labeled PCF_PINNUMBER = 
05.123456789. It is important to use a decimal in this number between the 05 and 
123456789 for purposes of locating the Project Identifier through your MicroStation 
Manager dialog. Once edited do a File>Save and File>Exit. 
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Figure 8-9: Example of PCF file in NOTEPAD 

Step Five: Closing Command Prompt Window 
You will now need to close out your Command Prompt window by typing Exit (Figure 

8-10) and pressing enter. 

 
Figure 8-10: Type Exit to Close Command Prompt 
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CONSTRUCT STATION AND OFFSET 
The F12 key runs a customized macro that is going to make it possible for us to construct 
points at a specific distance along an existing alignment. From these points, we’ll be able to 
draw a line perpendicular to the alignment at a specific distance. 

Starting Point 
Run the Pointalong macro by hitting your F12 key. You will be prompted to “Identify Point 
to Construct Distance From.” (Figure 9-1)  

 
Figure 9-1: StartPoint Along Status Prompts 

The Macro is expecting a data point on your “alignment.” Note that you can construct 
distances along many different kinds of elements: arcs, lines, line strings and complex 
chains and shapes are all legitimate elements to construct a distance along. This will let you 
construct distances along baselines, ROW lines, property lines, etc. 

You are quite possibly going to be entering this start point based on an intersection of 
another line with your alignment. For instance, you may want to construct a Plus and Offset 
starting at the intersection of a tick mark with a baseline.  

Entering the Distance and Direction 
Once you’ve entered a data point telling the macro the start point, it will prompt you to 
“Enter Distance Along Element.” (Figure 9-2)  

 
Figure 9-2: Input Distance 

If you were trying to construct Station 1+35.240 from a tick mark at Station 1+20.000, the 
distance to construct would be 15.240. Enter in your desired value and press the OK button. 

Choosing the Direction 
This next step is very important. The macro isn’t smart enough to know whether or not you 
want to construct a point to the left or to the right of the point that you just chose. Look 
down in your Status Bar to see that the macro is now prompting you to “Identify Direction 
for Construction.” (Figure 9-3)  
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Figure 9-3: Status Bar Message 

What it is asking for is a data point either to the left or to the right, or, in the case of a 
vertical line, above or below the first point you entered. Put your cursor on the baseline near 
the first point, but clearly to one side or the other (Figure 9-4) and enter in a data point (left 
button). There is no need to snap to enter this point.  

 
Figure 9-4: Identify Direction for Construction 

When you enter a data point, MicroStation will start drawing a line at the specified offset 
and direction from the first point you entered (Figure 9-5).  

 
Figure 9-5: Point Constructed 

It will also put the AccuDraw compass on the line, rotated to make it easy for you to 
construct a line perpendicular to your baseline. 

Choosing the Offset Distance 
Now that we are drawing a line, we can choose to go either to the right or to the left of the 
baseline. Just put your cursor graphically near where you want the line to go. Keep your 
cursor near the axes of AccuDraw and it will ensure that you are drawing perpendicular to 
the baseline. 

Enter your Offset into the Distance field of your AccuDraw window (Figure 9-6).  
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Figure 9-6: Constructing a Distance off the Baseline 

Notice that the angle is 90°. Enter a Data Point to complete the command. Reset to stop 
drawing lines and press F12 to start again! 

Troubleshooting 
There is a Warning Dialog (Figure 9-7) that you will get from time to time when you 
construct distances using this macro.  

 
Figure 9-7: Pointalong Warning Dialog 

It lets you know that the point you are trying to construct cannot be constructed because 
your Element is too short. This could happen for a couple of reasons. 

1) You may have just chosen the wrong direction to construct from. Your baseline may run 
16 kilometers to the right and only 16 centimeters to the left of your offset point. You can’t 
construct a point 10 meters to the left of that first point. 

2) You may have picked the wrong element to construct the distance along. Choose the 
point again and make sure that you Accept only the element you want to construct along.  

3) You may have used the Drop Element tool to drop Complex Status of the baseline. This 
would have broken up the lines and arcs that are joined together in a “complex chain” of a 
baseline, leaving only individual lines and arcs. The resulting elements are much shorter 
than a typical baseline.  
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You can put dropped baselines back together using the Create Complex Chain tool. Set your 
method in the Tool Settings Window to Automatic. 

 Refer to 2-12 for using the Complex Chain Tool  

4) You may be confusing Metric and English units. Make sure you’re not trying to go 75 
feet along a 40-meter line. MicroStation reads that “75” distance as 75 meters if you’re 
working in a metric drawing.  
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CREATING ROW PLAN SHEETS 
Step One: Open RWPLAN-clips.dgn 
Select your project from the list of projects in the Project pulldown at the bottom of the 
MicroStation Manager.  

Select RWPLAN-clips.dgn from the list of files on the left and press OK. If the 
RWPLAN-clip.dgn does not exist the file will have to be created. Open the RWplan.dgn. 

Select: > File > Make Sheetz > click on no prefix (Figure 9-8) and click OK. 

 
Figure 9-8: File Prefix Dialog  

Choose RWplan-Clips (Figure 9-9) and click OK in the Create File Of Type… Dialog. 

 
Figure 9-9: Create File Of Type Dialog 

Click OK in the Make File Dialog (Figure 9-10). 

 
Figure 9-10: Make File Dialog 



mdot MicroStation 
07/01/07 

ROW Sheets 

9-9 

 

Click Cancel in the File Prefix Dialog to exit the Make Sheetz program. 

In the RWplan-clips.dgn look in the Reference Dialog  (Figure 9-11) to confirm the 
attached Reference Files. 

Select: Files > Reference(DOT) > Dialog  

 
Figure 9-11: Reference File Dialog 

 This dialog already shows that you have topo, text, bridge, highway, etc. files 
attached. If these files are not attached or other files are needed, refer to page 2-70 
for Reference Attach Methods.  

Step Two: Cut Sheets 

Introduction 
At this stage we are going to be placing rectangles along the alignment that will correspond 
to our sheets. We will be using the Settings Manager to accomplish this. The Settings 
Manager is docked at the bottom or top of your screen. If the Settings Manager is not 
displayed, it can be launched from the menus by Settings >DOTSetMgrs > Right-of-Way. 
Based on the file name, the correct Settings Manager should be automatically loaded. 

Part One: Set Category Scale 
Right Click anywhere on the Settings Manager and select Category>Scale. Select the 
intended plot scale for the plan sheets (i.e. 1 in. = 25 ft. or 1 in. = 50 ft. (1:250 or 1:500 for 
metric projects)). 

 You should be the same scale that other programs are using for the project. When 
Survey Editors create the topo and text for the projects, this governs the scale.  

Part Two: Place Clip Boundaries 
From the Settings Manager select Borders >Clip Boundary. This selects our sheet 
boundary cell and activates a cell placement command that will make it easy to place a 
bunch of these rectangles along the alignment.  

Notice the box on the end of your cursor. When you send a Datapoint to MicroStation, the 
box will be placed at that location. (You might want to set your snap mode to Nearest and 
snap to the centerline of road.) The box you just placed will immediately begin to rotate 
by the origin point (the point you just entered.) Move your mouse around and notice how 
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it spins. When it is aligned with the roadway, enter another Datapoint (again, you might 
want to Nearest snap to the centerline) and it will immediately prompt you to place the next 
boundary.  

Don’t worry if they’re not in exactly the right place -- you can go back and clean up any 
mess later by using the move and rotate tools. It is important, however, that you place these 
boundaries in the order that you want your sheets to be numbered. We have a routine that 
automatically creates plot drawing files for us, and it will number them in the same order 
that you place these clip boundaries. 

Step Three: Make new Plan Files 
From the Settings Manager select Tools > Plan File Maker. This macro is doing a number 
of things. First off, it is creating saved views in RWPlan-clip.dgn that are aligned with the 
clip boundaries we just placed. It asks you what number you want to use for the starting 
number of the ROW plan sheets. If you know where the sheets will fall in your plan set, 
enter this number here. The default will be “1”. If you don’t know yet where they will fall, 
use the default and we will utilize the Sheet Renumbering routine to organize the files 
outside of MicroStation. 

When you have finished, the program will drop you back into rwplan-clips.dgn. Open up the 
files you’ve just created and see how they look! 

 Refer to page 1-22 about the Sheet Renumbering Utility. 

 Refer to page 1-25 about PCF editing. 

 Refer to page 1-27 about the Border information macro. 

 Refer to page 1-30 about disabling the Borderinfo Substitution. 

Troubleshooting 
This macro has very specific expectations, and anything different about your input has the 
potential of giving you bad output.  

It can only sheet up files in the order that the clip boundaries were placed in the file. If you 
need to add sheets at the beginning of the project, it might be easier to delete all your clip 
boundary cells that you placed and start again from scratch. 
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CREATING ROW INFORMATION PLAN 
Overview 
As a new requirement Right-of-Way Mappers will be required to generate a 
001_RWCoordinates.dgn file which contains control information for a project. This will 
require communication with the Project Designer/Technician to receive the necessary file 
to read into the dgn. 

Step One: Creating 001_RWCoordinates.dgn 
From the main menu select File>Makesheetz. Leave the dialog toggled to Sheet Number 
and select OK (Figure 9-12). 

 
Figure 9-12: File Prefix Dialog 

Choose RWCoordinates (Figure 9-13) and click OK in the Create File of Type… Dialog. 

 
Figure 9-13: Create File of Type… Dialog 

Click OK in the Make File Dialog (Figure 9-14). 

 
Figure 9-14: Make File Dialog 

Now that the file is created select Cancel to end the process of creating files. 
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Step Two: Placing Coordinate Information 
In the Right-of-Way Settings Manager select Tools>Create ROW Coordinate Info. 
(Figure 9-15). 

 
Figure 9-15: Right-of-Way Settings Manager 

The information will be developed on the sheet drawing automatically if the file is found. 
The program also looks for any overrun of information and will create, if necessary, a 
second drawing to finish the process. 

 This program was created to look for a RWInformation.txt file created in the 
Mx/Reports folder of the specific work group. (Ie. Bridge or Highway) If the 
program can not locate the file you will receive a message stating you need to talk to 
the Project Designer. They are required to run a program within Mx called 
MaineDOT Right of Way Sheet to generate this file. 

 Refer to page 1-22 about the Sheet Renumbering Utility. 

 Refer to page 1-25 about PCF editing. 

 Refer to page 1-27 about the Border information macro. 

 Refer to page 1-30 about disabling the Borderinfo Substitution. 

 Refer to page 4-4 about creating your Location Map. 
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CONSTRUCT A METES AND BOUNDS 
DESCRIPTION 

You will use this routine to construct county layouts and surveys. When you need to 
construct a Metes and Bounds, there are only a couple of things you're going to need to bear 
in mind. 

Tools 
You're going to be using Smartline and AccuDraw. Make sure that you are in Bearing mode 
by hitting your F9 function key. 

Setup 
First off, make sure you're in a Top View.  

Choose Rotate View icon from the tools at the bottom of your View 1 - Top Window 
(Figure 9-16).  

 
Figure 9-16: Rotate View Dialog 

Look at your Tool Settings Dialog and make sure you have Top selected as your rotation 
Method (Figure 9-17).  

 
Figure 9-17: View Rotation Top Dialog 

Enter a Data Point to begin your line, then type your bearing and distance into the 
AccuDraw Dialog. Make sure you are in Distance/Angle mode. Hit your Spacebar if you 
aren't (Figure 9-18). 
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Figure 9-18: Toggle AccuDraw Mode Dialog 

Placing Lines 
As you go, your AccuDraw Compass is going to rotate to align with line that is being 
placed.  

 You have to make sure that it is always rotated back to horizontal between every 
segment: type V with active AccuDraw to rotate the Compass to the view (Figure 
9-19). 

 
Figure 9-19: Rotate AccuDraw to the View 

For More Information 
 Check page 9-17 for more information on working with Baselines. 

Offset Using Copy Parallel 
Once your line is constructed, you're going to want to offset the line by some distance. Use 
the Move Parallel tool from the Manipulate toolbox (Figure 9-20). 
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Figure 9-20: Move/Copy Parallel Dialog 

In your Tool Settings Window, make sure that Distance and Make Copy are turned on. 
Type the offset distance into the Distance field and identify the element you want to copy 
by Data Pointing on it. Move your mouse and watch the line pop back and forth to either 
side of your original line. Once it is displaying on the proper side, Data Point again to 
accept the final location. Reset to complete. 

Fitting the Layout 
Once the layout has been constructed, you're going to need to rotate and move it into place 
over the survey information. There are only a couple steps to this process. 

First, use the Element Selection tool or PowerSelector to pick all the elements in your layout 
(Figure 9-21).  

 
Figure 9-21: Pick the Elements in your Layout 

Snap (but do not Accept) to your layout at the point you want to pick it up from.  

Second, choose Edit > Cut (Ctrl+X) from your Main Menu. 
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Now, choose Edit > Paste (Ctrl+V) from your Main Menu. You should see your layout 
hovering over your drawing, hanging off your cursor from the point you gave it in step one 
(Figure 9-22). 

 
Figure 9-22: Paste your Layout Down 

Look at your Tool Settings Window and be sure that your Scales are all set to 1 (otherwise, 
your layout will be made bigger or smaller.) Change the Angle field and move your layout 
around your drawing until you get a good fit. Data Point to place the layout in your 
drawing. 

Fine Tuning 
If you want to make changes to individual components of your layout after you've got it into 
place, use the Modify command from the Manipulate toolbox (Figure 9-23). 

 
Figure 9-23: The Modify Command 

With this command you can flatten or sharpen angles and shorten or lengthen lines. It 
basically will allow you to move any vertex to any other point. AccuDraw sometimes 
interferes with these kinds of “eyeball” commands -- press your F7 key until you see your 
AccuDraw Window disappear. When you’re done, press F7 and it will come back again. 

It’s going to be tough to use Modify to make your second line be parallel to a Modified line. 
Use Delete to get rid of your second line entirely, and then use Copy Parallel to create 
another parallel copy of your Modified line. 
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BASELINE OVERVIEW 
As with most things in MicroStation, there is more than one possible approach to 
constructing a baseline. What we are presenting here is the method that is going to minimize 
the amount of hand calculating required. 

Baseline Geometry: 
First we're going to construct the baseline using Smartline and AccuDraw. We're only going 
to need a few pieces of information to complete a Baseline. For starters, we're going to need 
a Bearing and Distance of a tangent. After that, all we need is the Radius and Delta Angle 
for each curve and a distance for further tangents.  

Checking and Cleaning Up Geometry: 
After we have constructed a Baseline, we're going to drop it into its components to make 
sure we've drawn it correctly. If we've made any mistakes, we'll correct them with the 
Modify and Rotate tools. Then we'll group the Baseline back together as a Complex Chain.  

Stationing and Annotating: 
Next we'll place PC and PT lines. We'll label them from the Settings Manager.  

 Check page 2-20 for an overview of the Settings Manager. 

From those we'll find a beginning station and we'll put station marks along the length of the 
baseline. Then we'll edit the text of our Station Marks and place Curve Data. 
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BASELINE TOOLS 
There are a number of tools that we’re going to be using to construct our Baseline. Some of 
them have some very specific capabilities that we should review and clarify before you get 
started working with them. 

Smartline 
We’re going to be relying on Smartline to create our baselines. Smartline is capable of 
creating a series of lines and arcs (Figure 9-24). We are going to be constructing lines based 
on Distance and Bearing and constructing arcs based on Radius and Delta. With a little help 
from AccuDraw, it’s going to be simple to build “on the fly” lines that are tangent to arcs as 
well as arcs that are tangent to other arcs. 

 
Figure 9-24: Smartline Segment Type Options 

As we work we are going to be toggling Smartline’s Segment Type back and forth from 
Lines to Arcs. We are not going to be making any changes to Smartline’s Vertex Type. We 
are going to make sure it’s set to Sharp and leave it at that.  

 Something that isn’t going to be obvious at first about drawing with Smartline is that you 
should try to do all of your construction without hitting your Reset key (right mouse button.) 
With Join Elements selected in your Smartline Tool Settings Window, constructing your 
entire baseline without hitting Reset means that the resulting series of lines and arcs is going 
to be joined together as one element (a Complex Chain). Another benefit of constructing the 
Smartline as one element is that AccuDraw is going to be more helpful. It’s going to do this 
by keeping constant tabs on our latest distance and direction of construction.  

A Word About AccuDraw 
AccuDraw is a critical part of this process. There are a couple of things to keep in mind 
when you’re using AccuDraw.  

First off, when you type angles into Accudraw’s Angle field, you have to make sure you’re 
typing in the right Angle Mode. Since we’re going to be entering angles in both Bearing (N 
23° W) and Conventional (113°) we need to be able to toggle back and forth between these 
two Angle Modes quickly.  

We’ve set up Function Keys to accomplish this. F8 will set the Angle Mode to 
Conventional; F9 will set the Angle Mode to Bearing. When you are typing in Angles in 
Bearing mode, make sure to start your angle with either an N or an “S” and end your angle 
with either an “E” or a “W.” In both Bearing and Conventional mode, you need to separate 
Degrees, Minutes, and Seconds with an appropriate symbol. MicroStation uses the ^ 
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character to represent degrees (Shift+6). MicroStation uses the ‘ character for minutes and 
the “ character for seconds. 

 Make sure that when you type a distance or an angle into AccuDraw that you do not 
use the Enter key to “submit” your values to AccuDraw. Enter has a very specific 
function to AccuDraw. It is the Smartlock function. What this does is to lock the 
Angle of whatever you’re constructing to be either horizontal or vertical (relative to 
the AccuDraw Compass.) We will be using the Enter key for Smartlock, but not 
for entering numbers in the window. 

Also, keep your eye on your AccuDraw Window when you’re entering in distances and 
angles to keep from typing angles into the distance field and vice versa. It takes a good long 
time to type an angle in bearing format right down to the nearest tenth of a second. It’s a 
shame to have to type it all over again because you entered it into the distance field instead 
of the angle field. The easiest way to get into the distance field from the angle field is by 
using your Tab key (just to the left of the letter Q). 

AccuDraw Shortcuts 
AccuDraw Shortcuts are single (or occasionally double) key strokes that you type while 
AccuDraw is active. A common example of a shortcut is the Spacebar. When AccuDraw is 
active and you hit the Spacebar, AccuDraw shifts back and forth between Distance/Angle 
and XYZ mode.  

Another shortcut that we’re going to get a lot of mileage out of is the tilde key (~). This is 
the key that’s just to the left of the number 1 at the top of your keyboard. This shortcut is 
called Bump Tool Setting, and we’re going to use it when we swap back and forth between 
drawing arcs and lines as we’re using the Smartline tool. It’s worth noting that you don’t 
have to hold down the Shift key to get this shortcut to work -- even though the “~” character 
is usually typed by holding down the Shift key. 

Conclusions 
These tools are going to be able to do just exactly what we need them to do to help us 
minimize the amount of hand calculations required to lay out a Baseline. However: they’re 
finicky. You’re going to have to keep a constant eye out on your AccuDraw window and 
your Tool Settings Window to make sure that your options are set correctly as you go. 
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BASELINE GEOMETRY 
Step One: Bearing and Distance 
From the Settings Manager select Baseline > Baseline (Figure 9-25).  

 
Figure 9-25: ROW Settings Manager 

This will put you in the correct level, color, style and weight for drawing Baselines, as well 
as activating the Place Smartline command.  

It’s a good idea to start every baseline with a Bearing and Distance if at all possible. Start by 
entering a Data Point to begin your line. Take a look at your AccuDraw Window and make 
sure that you are in Bearing mode (look for an N or an S in the angle field.) If you’re not, 
press F9. This will run a MACRO that sets your active Angle Mode to Bearing. Then enter 
your Bearing and Distance into your AccuDraw Window.  

Note that you can still draw the line either to the left or the right of the origin point, as 
illustrated in Figure 9-26 and Figure 9-27. Make sure that your line on the screen visually 
agrees with the baseline you intend to draw by moving your cursor either to the left, right, 
up, or down to get the direction correct.  

 
Figure 9-26: Drawing to the Right at a Fixed Angle 
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Figure 9-27: Drawing to the Left at the Same Angle 

 Don’t enter a Data Point until you’re satisfied that you’re drawing in the right 
direction. 

Step Two: Troubleshoot and Prepare to Draw a Curve 
You have now successfully entered the first segment of your Baseline. Do not hit your Reset 
button (right mouse button.) MicroStation should now be in the middle of drawing a 
Smartline (Figure 9-28) Your Status Bar (bottom of your screen) should be prompting you 
to “Enter next vertex or Reset to complete.” 

 
Figure 9-28: First Line Complete 

Even if you have screwed up this first portion, do not hit your Reset button -- go to your 
Main Menu and select Edit > Undo Last Data Point. This is important to keep in mind now 
and for the rest of this creation process: if you make a mistake, UNDO. Do not Reset. You 
can also Undo by typing Ctrl+Z.  

If you do (accidentally) hit your Reset at this stage, it’s not the end of the world. All you 
have to do is start drawing again. Snap to the end point of the baseline you just constructed 
and Accept. This will put your AccuDraw Compass at the correct point but it will probably 
not be rotated. 

Tentative Point. Instead, type “RQ.” This will activate Accudraw’s Rotate Quick Shortcut 
and spin the Compass to the proper rotation. 
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 Use the Tilde key (~) to toggle Smartline from Segment Type Lines to Segment 
Type Arcs (Figure 9-29).  

 
Figure 9-29: Swap to Smartline Arcs 

Now type F8 to change your angle mode back to Conventional from Bearing. This is going 
to help us enter in curve deltas (as arc sweep angles.) 

Step Three: Draw a Curve 
Move your mouse around a bit to notice a couple of specific features here. First off, you’re 
going to see a dotted circle moving around the screen. Notice that your cursor is at the center 
of this circle.  

Notice also that the AccuDraw Compass is at the edge of this circle at the point where the 
circle intersects the line you just drew. Move your mouse around until the dotted circle looks 
like it’s perpendicular to the line you just drew. Notice that as you get close to this point, 
AccuDraw is going to tend to “snap” you in along one of its axes. This is going to help us 
lock in our curve to be tangent to our baseline.  

Moving your mouse around, line up the dotted circle so that it is curving in the right 
direction. Also make sure it is at least visually perpendicular to the baseline, then hit Enter. 
This is Accudraw’s Smartlock, and it will nail down the location of the center of the curve. 
Now you’re ready to enter in the Radius of the curve.  

 Make sure that you are typing in Accudraw’s Distance field (if there is a cursor 
blinking in the Angle field, hit your Tab key to put it in the Distance field.), then type 
the radius of the curve.  

What you are entering at this point is the center point of the curve. As you know, the center 
of the curve can be a long way away from the baseline. What this means to us in 
MicroStation is that the point you are about to enter may be way out of your Window. This is 
not a problem. Enter in a Data Point to accept the point you’ve just constrained, and let’s see 
where we are. 

What you’re going to see is probably going to be something like the picture in Figure 9-30. 
As you move your mouse around you’ll notice you’re constructing an arc. You’ll notice a 
couple of dotted lines that are radial to the arc, one of them at the tangent point to the 
baseline, one of them near your cursor.  
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Figure 9-30: Sweep an Arc 

What you need to do here is make sure that you are drawing this curve in the right direction. 
You may have to use the Zoom Out command to get the center of your arc in your view. 
Type F3 and Data Point in your window. 

Zoom Out. You may need to click a few times to Zoom Out a number of times. Reset (just 
once) and MicroStation will drop you out of your Zoom command and back into the Place 
Smartline command and it will show you a more complete picture of the curve you are 
constructing. 

Once you can see the AccuDraw Compass at the center of the arc, move your mouse 
around a bit. Notice that the arc sweeps around with the mouse. To change the direction of 
the arc, sweep your cursor around the Compass point until you see the arc begin to look a 
little bit more like you want it to. Now you’re ready to enter in the Delta of the curve.  

Make sure you are typing in Accudraw’s Angle field. Again, if you are in the Distance field, 
just type Tab to get to the Angle field. Now type the Delta value for the curve into the field. 
Enter a Data Point when you are done. 

Step Four: Troubleshoot and Prepare for Another Curve or 
Tangent 
You have now successfully placed a Curve on to your Baseline.  

 If you made a mistake in this portion of construction, remember NOT TO HIT 
YOUR RESET (Right mouse button.) All you need to do is Undo (Ctrl+Z) to 
gracefully step back in the command and pick up your construction from the last 
correct point. You can Undo more than once, if need be, but take it slow and be sure 
not to Undo too far.  

If you did (Accidentally) hit your Reset key, you can start up again like you did in Step 2 
with one notable exception. You’re going to snap to the end of your baseline and Accept to 
start placing your Smartline again. Then you need to get the AccuDraw Compass rotated 
correctly again. Instead of snapping to the center of the last tangent, you’re going to want to 
snap to the center of the last curve that you placed (use the Center Snap by typing C into 
AccuDraw). Note that this center point is usually far away from the baseline. Once you’ve 
snapped, type RQ to rotate Accudraw’s compass. 
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At this stage of the game you’re totally set up to repeat Step 3 and construct another curve. 
Your AccuDraw Compass should be all set up and your Angle Mode should be correct and 
ready for curve placement. Go back to the beginning of Step 3 if you’re going to lay in 
another curve. 

If, however you are going to construct a tangent from this point, you need to toggle 
Smartline back to its Segment Type Lines mode by typing a Tilde (~) into AccuDraw. 
Check that the change has been made in the Tool Settings Window. 

It is not going to be necessary to enter in the Bearing for this next tangent. If we have 
constructed our curve correctly we can just let AccuDraw get the Bearing right for us. 

Move your mouse around until Smartline looks like it’s going to draw a tangent in the right 
direction (Figure 9-31). Hit the Enter key to activate Accudraw’s Smartlock.  

 
Figure 9-31: Construct Tangent Direction 

Make sure you are in the Distance field by hitting your Tab key and type in the length of 
the Tangent  

Note that this tangent distance is just the distance between the PT and the next PC or end of 
project. Enter a Data Point to accept this point. 

Step Five: Troubleshoot and Prepare for Another Curve or 
Tangent 
Again, make sure not to hit your Reset until you’re done with your whole baseline. If you do 
hit your Reset, check out Step 2 for a method of getting back on track.  

From this point, you now have all the construction tools you need to create any sort of 
baseline. The next step will be to double-check the geometry you have laid out and make 
any necessary corrections. Then we’ll go on to Stationing and Annotating 
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BASELINE CHECKING/CHANGING 
Once you have your baseline constructed you’re going to want to make sure you haven’t 
made any mistakes. If you have, you're going to need to fix it up. 

Drop Complex 
It’s going to seem strange since we went to all that trouble to make sure our alignment was a 
single element, but the first thing we’re going to do when we check our baseline is to drop it 
up into separate elements. We’re going to do this to make it easier to check the length of 
individual elements. 

Pick the Drop Element tool from the Main Tool Frame. Check your Tool Settings 
Window and make sure that Complex is checked off (Figure 9-32). This ensures that 
Complex Chains will be dropped into their individual components.  

 
Figure 9-32: Drop Elements Complex 

Check your Status Bar (at the bottom of your screen) for prompting about what to do next. It 
should tell you to “Identify element.”  

Data Point on the baseline. It will highlight, and your Status Bar will prompt you to 
“Accept/Reject (select next input)”. Data Point to Accept and your baseline will be broken 
up into a series of lines and arcs. If there was an angle point on your baseline, you may have 
constructed a baseline that has two intersecting tangents. When you drop complex status of 
this baseline, this “elbow” is going to be preserved as a Line String. To drop that Line 
String, use Drop Complex again, making sure to have Line Strings/Shapes toggled on in 
your Tool Settings Window.  

Measure Lengths 
From the Measure toolbox, pick the Measure Length tool. This is a great tool for measuring 
the components of a baseline. It will tell us the length of tangents and curves, as well as the 
bearing of tangents. Make sure that you are reading angles in Bearing mode by pressing F9. 
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Figure 9-33: Measure Length 

Your Status Bar will be prompting you to “Identify Element”. It is not going to be necessary 
to snap to the element to pick it here, just Data Point on the element you want to measure. It 
will highlight, and you’ll be prompted to "Accept/Initiate Measurement." Data Point to 
Accept, and MicroStation will display some information for you regarding this element. 
Look to the lower middle of your Status Bar or the Measure Length Dialog for the length of 
lines and arcs, as well as the bearing of lines (Figure 9-33). 

Measure Radius of Curves 
Once you have established the bearing of lines and the length of lines and arcs, you should 
double-check the radii of the curves of the baseline. From the Measure toolbox, choose 
Measure Radius. The Status Bar will prompt you to "Identify Element."  

 
Figure 9-34: Measure Radius 

Data Point on an arc and it will highlight. You'll be prompted to "Accept/Initiate 
Measurement." Data Point again and you will see the Radius being displayed in the lower 
middle of the Status Bar or the Measure Radius Dialog (Figure 9-34).  
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Fix the Problems 
So you've found out that something isn't quite right with the baseline you've just constructed. 
There are a number of tools that we can use to fix it up.  

Modify 
The Modify tool is going to let us change the distance and bearing of lines, as well as the 
sweep angle (delta) and radii of curves. From the Modify toolbox on the Main Tool Frame, 
choose the Modify tool (Figure 9-35).  

 
Figure 9-35: Modify Element 

Rotate 
Say you've made a change to the bearing of a tangent line. That is going to affect the curve 
that you previously constructed from that tangent. You need to use the Rotate tool to 
reorient that curve to align with your modified tangent. 

From the Manipulate toolbox on the Main Tool Frame, choose the Rotate tool (Figure 
9-36). From the Tool Settings Window make sure to set the Method to 3 Points. 

 
Figure 9-36: Rotate Element 

It is also possible that you made a mistake on your initial bearing and need to reorient the 
rest of your baseline. You might have too many segments to want to fix them one at a time. 
You can use the PowerSelector to pick all of the elements that need to be reoriented (Figure 
9-37). That makes it possible to rotate the entire baseline at once. 
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Figure 9-37: Power Selector 

Punt 
If it looks like it's going to be too complicated to modify and manipulate your baseline into 
shape, you can always wipe it out and start again. Practice is good. 

Put It Back Together Again 
Now that we've checked and rechecked and fixed all of the problems in our baseline, we're 
going to want to reassemble it into a Complex Chain. From the Groups toolbox, choose 
Create Complex Chain. In the Tool Settings Window, make sure to set the Method to 
Automatic instead of Manual (Figure 9-38). Your Status Bar is going to be prompting you 
to "Identify Element". Pick the first element in the baseline with a Data Point. The element 
will highlight. Data Point away to Accept.  

 
Figure 9-38: Create Complex Chain 

Now MicroStation will look for another element to attach onto the end of this first element. 
Whatever element it can find at the end of that first element (within a certain distance: the 
"Max Gap") will be highlighted, and MicroStation will prompt you to "Accept Chain 
Element." Data Point to Accept each portion of the baseline as MicroStation finds it. If 
MicroStation cannot find an element, it will finish up the Complex Chain.  

If for some reason MicroStation doesn't find elements that should be part of the baseline, the 
first thing you need to do is Undo the Complex Chain that you just created. If you don't do 
this, you're going to end up with lots of elements on top of each other by the time you're 
through recreating your baseline.  

MicroStation may not have found elements to put on the end of the chain because they were 
too far away from the end of the element preceding them. This could be as simple as a 
missed snap or as complicated as a 3D issue. You should be able to resolve it by using the 
Move command (make sure to PowerSelector if you want to move the entire alignment 
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together) and carefully put the problem elements into place at the end of the baseline. If this 
doesn't work, try flattening the file (Macros>Flatten). Then go back and recreate the 
Complex Chain from the first element again.  
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BASELINE STATIONING 
There are going to be a couple of steps involved in Stationing. First we're going to label the 
PCs and the PTs. Then we'll use those points along with the "Pointalong" macro to find a 
beginning station. From there, we'll use the Settings Manager to place our stations. 

Construct the PCs and PTs 
Choose BASELINE from the Settings Manager to set the element attributes. The way to 
find the PCs and PTs is to snap to the ends of your curves. Place your cursor near the 
intersection of a tangent with a curve but ON the tangent and hit your middle button. You 
should see the tangent highlight and a crosshairs will appear at the end of the tangent (Figure 
9-39). Accept this point with a Data Point to start the PC line.  

 
Figure 9-39: Snap to the End of a Curve 

Choose Center as your Snap Mode and Tentative snap to the curve. Make sure AccuDraw 
is in Distance/Angle mode (the AccuDraw Compass will be a circle if it is). Type "150" (50 
for metric) as your distance (making sure your cursor is in the AccuDraw Distance field.) 
This will lock your line to be pointed at the center of the curve (perpendicular to the 
Baseline) and 150 feet (50m metric) long. Accept by entering a Data Point.  

Repeat this process for all PCs and PTs along the Baseline. 

Double Check Your Baseline Chain 
Step Zero at this phase is to make sure that your Baseline is all one element (Complex 
Chain). From the Primary Tools, pick the Element Information tool. MicroStation will 
prompt you to “Identify Element.” Pick on your Baseline with a Data Point. Data Point 
again to Accept. A dialog box will appear that will tell you (at the top) what kind of an 
element your Baseline is. The top of the dialog should say “Element Information for 
Complex Chain [Type 12]”. If it does, close the dialog and continue. If it doesn't, make it 
into a Complex Chain.  

Generate a Station Marker 
Once the PC’s and PT’s lines are drawn, you're going to use the Station of a PC or PT to 
locate an even 100’ (20m metric) Station on the Baseline. Press the F12 key to run the 
Pointalong macro. 
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Figure 9-40: Point Along Distance 

Data Point to Accept and MicroStation will prompt you to enter in a distance (Figure 9-40). 
Take the station of your PC or PT and calculate the distance to a nearby 100’ (20m for 
metric) station (you do the math.) Enter this distance and push OK. MicroStation will 
prompt you to “Identify Direction for Construction.” Enter a Data Point on the Baseline in 
the direction of the Station you want to place. Finish drawing the line at this point. This will 
serve as a Station Marker Construction Line for placing your Stationing in the next step.  

Place Generic Stations 
Now that we have a marker on an even Station, we can use the Stationing tools in the 
Settings Manager to begin to annotate. From the Settings Manager, choose Baseline > 
Stationing Metric.  
MicroStation is going to prompt you to “Place Cell Along > Identify Element.” We want to 
pick the Baseline, but we want to be certain to pick it at the point where our Station Marker 
Construction Line intersects the Baseline. We’re going to do this by using the Intersection 
snap again. Make sure to snap to the Construction line first, then the Baseline. Data Point to 
Accept and it will show generic station markers at even intervals along your Baseline. At 
this point you will need to Data Point one more time to Accept this configuration.  

Fill in the Station Information 
What you have just placed is a series of tick marks along your Baseline. These tick marks 
are labeled by stations marked 0+00 (0+000 for metric). The next thing we have to do is 
change these stations to the proper values. These Underlined letters are a special kind of 
MicroStation text called Enter-Data Fields. 

We are going to make changes to these Fields by using tools from the Text toolbox from the 
Main Tool Frame (Figure 9-41). 

 
Figure 9-41: Fill in Single Enter Data Field 
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We’re going to start by changing the value of the first Station on our Baseline. From the 
Text toolbox, choose the Fill In Single Enter-Data Field tool. MicroStation will prompt 
you to "Identify Element". Pick on the underlined characters of your first Station with a 
single Data Point. MicroStation will open the Text Editor. Type your Station into the Text 
Editor and hit Enter (Figure 9-42).  

 
Figure 9-42: Pick an Enter Data Field (Metric Example) 

MicroStation will put the text you typed into the Text Editor into the Enter-Data Field 
(Figure 9-43). 

 
Figure 9-43: Data Point to Change the Field (Metric Example) 

Once we have the first Station correct, it's going to be easy to fill in the rest of our Stations. 
We're going to use a tool that will copy our Data from that one field into each Station. For 
each Station we fill, MicroStation is going to add 100 to the value of the previous Station.  

 
Figure 9-44: Copy/Increment Enter Data Fields 

From the Text toolbox, pick the Copy/Increment Enter-Data Fields tool (Figure 9-44). On 
your Tool Settings Window, set your Tag Increment to 100 (20 for metric). MicroStation 
will prompt you to "Select enter data field to copy." Data Point on the field you just entered.  

The Station value should appear in your Status bar. Now Data Point on the next Station. 
MicroStation will change the value of that Station to the next appropriate value.  



mdot MicroStation 
07/01/07 

ROW Sheets 

9-33 

 

Keep picking stations (in order) until you get station 2+100. MicroStation is not smart 
enough to put that hundred marker on the left side of the plus sign. Go back to the Fill In 
Single Enter-Data Field tool and change the station to 3+00. Then use the Copy/Increment 
Enter-Data Fields tool to continue stationing. 
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PTS AND CURVE DATA 
There are only a couple of tricks to labeling the PCs, PTs and Curve Data. 

Text Placement Options 
The first step here is to label the PCs and PTs. MicroStation has a couple of text placement 
features that are going to make this an easy process. When you place text, you have a 
number of options about how that text is going to get stuck into the drawing. By default, 
your text placement method is By Origin. This method hangs the text off the end of your 
cursor and stamps it into the drawing wherever you click.  

The methods that we're going to be using to label the PCs and PTs are Above Element and 
Below Element (Figure 9-45). When you use these methods, you type in the text you'd like 
to place, and then Data Point on an element. MicroStation will then place in the text you've 
typed either Above or Below that element. 

 
Figure 9-45: Text Placement Methods 

We will also be setting the Justification value to either a Right Top or a Left Top 
Justification. If the PC/PT line is on the Right of the Baseline, we'll be using the Right Top 
Justification. If the PC/PT line is on the Left of the Baseline, we'll be using the Left Top 
Justification. To set the Justification, expand by click the arrow in the lower right corner of 
the Place Text Dialog.  

Label the PCs and PTs 
From the Settings Manager choose Baseline > PCPT Text. This will set your active text 
height, width, and font and will launch the Place Text command. Based on the desire to keep 
the PC and PT labels to the INSIDE of the curve, make a decision about whether your 
current PC or PT should be Above or Below the PC/PT line. Select Above or Below from 
the Method section of the Place Text Tool Settings Window. Select a Justification from 
the same Tool Settings Window (Figure 9-46).  
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Figure 9-46: Labeling a PC (Metric Example) 

Type your text into the Text Editor and place it on your PC/PT line by snapping (Keypoint) 
to the end of the line. Data Point to Accept and MicroStation will highlight the line (Figure 
9-46). Data Point again and it will place the text. 

Place PC/PT Circles 
Next we need to place circles (of radius 2.5' (.75m metric) at the PC and PT point on the 
Baseline. From the Settings Manager choose Baseline > PCPTCircle (m) or 
>PCPTCircle ('). This will stick the appropriately sized circle on the end of your cursor. 
Stamp it into place by snapping to the ends of the PC/PT lines. 

Place and Edit Curve Data 
Once you have labeled the PC and PT lines with text and circles, it's time to place Curve 
Data on the Baseline. Our Curve Data is stored in a cell in our ROW cell library. We're 
going to place the cell onto our drawing as many times as necessary to label all of our 
curves. For each one, we're going to want to try to rotate the cell such that it's aligned with 
the radius of the curve at the center of the curve's length. 

From the Settings Manager, choose Baseline > Curve Data (Figure 9-47). This will pick 
our Curve Data cell from our cell library and stick it on the end of your cursor. 

 
Figure 9-47: Choose Baseline>Curve Data 
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When the Cell Tools Dialog appears click on the Place Cell and Rotate Icon (Figure 9-48). 
By adjusting the number of degrees in the Angle field of the Place Cell and Rotate Dialog 
can be placed between the PC and PT of the curve with a Data Point. 

 
Figure 9-48: Placing Curve Data 

Once your Curve Data is in the right place on your drawing, you are going to have to edit it 
to the correct values. Since you can't edit text that is in a cell, we're going to have to start by 
Dropping the cell into its Components.  

 
Figure 9-49: Drop Element Tool Settings 

From the Main Tool Frame, pick Drop Element. Look at your Tool Settings Window and 
make sure that Complex is turned on (Figure 9-49). MicroStation will prompt you to 
"Identify Element." Pick on the Curve Data Cell. It will highlight, and you will Accept with 
a Data Point to complete the Drop. 
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Figure 9-50: Edit Text Button 

Once the Curve Data has been dropped, use your Edit Text tool to change the values to 
reflect your current curve (Figure 9-50). 
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RREESSOOUURRCCEESS  
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ROW FUNCTION KEYS 
 

F1 Flatten Flattens your active file to 0 elevation 

F2 Window in 

F3 Zoom Out 

F4 Update View 

F5 Powerselector 

F6 Fence 

F7 AccuDraw On/Off 

F8 Set Angle Mode to Conventional 

F9 Set Angle Mode to Bearing 

F10 Distance Macro measures along element and gives you options 
on how you can label distances. 

F11 Perpendicular Snap 

F12 Construct Point at Distance and Offset 

Alt+F1 Works similar to a refresh/ clear 

Alt+ F2 Acre/square Feet Macro Automatically changes Square meters 
to feet or acres and places on your pointer.  

Alt+ F3 /actan2 changes your active angle with 2 hit points for placing 
text. 

Alt+ F4 Reserved for Closing Windows/Files 

Alt+ F5 Copy Parallel & Change Attributes (Color, Style, Level, Etc.) 

Alt+ F6  

Alt+ F7  

Alt+ F8  

Alt+ F9  

Alt+ F10  

Alt+ F11  

Alt+ F12 Copy Parallel 

Shift+F1  

Shift+ F2  

Shift+ F3  
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Shift+ F4  

Shift+ F5  

Shift+ F6  

Shift+ F7  

Shift+ F8  

Shift+ F9  

Shift+ F10  

Shift+ F11  

Shift+ F12  

Ctrl+F1  

Ctrl+ F2  

Ctrl+ F3  

Ctrl+ F4  

Ctrl+ F5  

Ctrl+ F6  

Ctrl+ F7  

Ctrl+ F8  

Ctrl+ F9  

Ctrl+ F10  

Ctrl+ F11  

Ctrl+ F12 Move Parallel 
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MMHHPPCC  DDOOCCUUMMEENNTTAATTIIOONN  
Quick Punch List 

• Create a MHPCPlan.dgn using Make Sheetz 
• Copy or Place New Clip Boundaries 
• Create Cut Sheets 
• Run Border Macro 
• Place Legend 
• Edit Sheet Info. (Title Only) 
• Send to Color Plotter 
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VIEWING A PROJECT USING MHPC COLOR 
SCHEME 

Step One: Start MicroStation 
Double-click your MicroStation icon. Click the Project pull-down and pick on your PIN. 
Select EnvPlan.dgn from your list of files and click OK. 

 Picking your project from the pull down should bounce you to your project’s 
Environ\MSTA folder. If it doesn’t, contact CADD Support. 

Step Two: Creating a MHPC File 
Go to File>Make Sheetz. When the dialog opens, select “No Prefix” and pick “Environ” as 
your workgroup (Figure 11-1). Click OK. 

 
Figure 11-1: File Prefix and Workgroup Selected 

From the list of available drawings pick MHPCPlan and click OK (Figure 11-2). This 
creates the new file and opens it. 

 
Figure 11-2: Select MHPCPlan 
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Step Three: Adjust Background to White 
Select Workspace>Preferences from the Main Menu. In the next dialog, select View 
Windows from the left side of the dialog. On the right, place a check in the Black 
Background->White box. Click OK (Figure 11-3). 

 
Figure 11-3: Preference set to White Background 

Check your colors for accuracy. Sometimes you will find that standardization is not 
followed and you will need to adjust the colors of levels in a reference file or two. Do this in 
this file. 

 Please refer to 11-8 for more information on Changing colors Manually. 

 If your color scheme doesn’t appear to be correct, make sure that your view 
attributes (Settings>View Attributes) has Level Symbology checked. It should set 
correctly by default. Contact CADD Support for more assistance. 

 In attempts to stabilize this process, we created a pentable that will not use Symbology. 
Instead, the pentable will adjust colors at plot time only. If the colors do not appear to 
be accurate using Symbology, instead, turn off Symbology and hit the Print Icon. 
Browse to the correct plotter and attach the “MHPC-no Symbology” pentable. Use 
your preview in the print dialog to see if the colors are better represented. 
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CREATING MHPC PLAN SHEETS 
Step One: Temporarily Attach HDPLAN or BDPLAN.dgn 
(Optional) 
As a time saver you can use another programs Clip Boundaries instead of placing your own 
manually. Depending on the type of project Bridge or Highway, use File>Reference 
DOT>Attach and browse to the appropriate groups \MSTA directory and select 
bdplan.dgn or hdplan.dgn. No logical is needed, set the nesting to Copy Attachments and 
depth to “0” (or use No Nesting) and click OK. 

 If there aren’t any clip boundaries in the bdplan.dgn or the hdplan.dgn, you will have 
to place your own boundaries manually.  

Step Two: Copy Clip Boundaries 
Now we need to merge the clip boundaries into the active file. This will produce clip 
boundaries for the MHPC plans that cover the same area as the plans sheets for the project. 
This procedure is assuming that you want a MHPC plan for every plan sheet. If you only 
need a MHPC plan for specific areas on your project, place clip boundaries manually in your 
active file as you would when creating the normal plan drawings. 

 Refer to page 5-5 for the procedure on placing clip boundaries manually. 

In the Reference File dialog, highlight the reference file (**plan.dgn) then select 
Tools>Merge Into Master from the Menu Bar. Now you will be prompted to select a view 
by clicking a data point anywhere on your top view. An informational dialog will open 
telling you that you are about to merge one reference file into the current design file. This is 
what you want to do. Select OK to start the procedure. Refresh your window to update the 
view in order see your clip boundaries in the active file. 

Step Three: Create the Cut Sheets 

Part One: Activate Macro 
From the Settings Manager select Create Plan Sheets > Create Cut Sheets.  

Part Two: Supply Starting Number 
It asks you what number you want to use for the starting number of the MHPC plan sheets 
(Figure 11-4). Use the default “1”. This will appear in your border as your sheet number.  
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Figure 11-4: Start Numbering At? 

Part Three: Sit Back and Watch 
When the program is finished, it will drop you back into MHPCPlan.dgn. Open up the files 
you’ve just created and see how they look! 

Step Four: Troubleshooting 
If you open a MHPC plan sheet drawing and the graphics within the sheet are not correct, it 
could mean that one the drawings that is referenced in is not at the same Global Origin as 
the other drawings. If the graphics aren’t aligned with your border, try and re-cut the sheets 
again. It won’t be necessary to place new boundaries. Normally this will fix the problem. 
See CADD Support for assistance if needed. 
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EDITING MHPC PLAN SHEETS 
Step One: Run the Border Information macro 
The Border contains variables that can be replaced by a macro. It is not necessary to edit 
anything on this drawing that contains a $ or @ (i.e. $TOWNORCITY$). Select 
Macros>Border Information to run the macro. Process all of your sheets.  

 Please refer to PCF Editing on page 1-25 if the variables do not get filled in with the 
proper information. 

Step Two: Place MHPC Legend 
Right click on the Settings Manager and select Category>Scale. Set the scale to 1 in. = 25 
ft. (1:250 for metric) or 1 in. = 50 ft. (1:500 for metric). Select Create Plan Sheets from the 
left hand side of the Settings Manager (Figure 11-5). 

 
Figure 11-5: Create Plan Sheets 

Select MHPC Legend from the right (Figure 11-6). 

 
Figure 11-6: Pick MHPC Legend 

Place the cell down where you want it with a left mouse click. 

Step Three: Edit the Plan Type in the Title Box 
The only text that needs to be edited on the border is the word “PLANS”. Select Text>Edit 
Text from the menu and click on the word PLANS. When it highlights, click again to 
accept. When the Text Editor window opens, type MHPC in front of the words PLAN and 
hit Apply. Right Click to stop editing the text. 

Step Four: Repeat as Necessary 
Repeat Step One and Step Two on all of your ###_MHPCPlan#.dgn drawings. 
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ADJUSTING COLORS MANUALLY IN 
REFERENCE FILES 

Sometimes you will find that standardization is not followed and you will need to adjust the 
colors of levels in a reference file or two.  

 In attempts to stabilize this process, we created a pentable that will not use Symbology. 
Instead, the pentable will adjust colors at plot time only. If the colors do not appear to 
be accurate using Symbology, instead, turn off Symbology and hit the Print Icon. 
Browse to the correct plotter and attach the “MHPC-no Symbology” pentable. Use 
your preview in the print dialog to see if the colors are better represented. 

If you need to adjust the symbology (colors) of a reference files, do this in the 
MHPCPlan.dgn file and the change will reflect on all of your plan sheets. Open your Level 
Manager by selecting Settings>Level Manager from the Main Menu (Ctrl+L). Make sure 
that the Symbology pull down is set to Overrides. 

Use Quality>Analyze Element and click on the element in question to find out what 
reference file the element resides in and the level it is on. 

In the example below (Figure 11-7), the topo.dgn has two levels, UTILS GRND and 
UTILS AERIAL, that are the wrong color. They should be color “14”. Expand the directory 
tree on the left and select topo.dgn. Select a single or multiple levels on the right and click 
on either of the color boxes. A color chart will open (Figure 11-8) allowing you to pick the 
color to change it to. Click on the color to see the number associated to it. Click OK.  

 
Figure 11-7: Example of selecting two levels within the topo reference file 
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Figure 11-8: Example of selecting a new color for a level(s) within a reference file 

Select File>Save Settings to save the adjustment. 
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BATCH PRINTING MHPC PLANS SHEETS 
Step One: Open Batch Print Dialog 
Select File>Batch Print/Plot (DOT) from the dialog Menu. Click Cancel at the Open job 
Set dialog window. 

Step Two: Select a Printer 
Highlight Printer from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose 
US_HPCOLORRoom303 (HPCOLORRoom303 for metric). Click OK. 

Step Three: Select Print Area  
Default Print Area MDOT Standard is correct by default for U.S. Customary projects. 
(Change this to Divisions for metric projects.) 

Step Four: Select a Display (Pentable) 

Pentable that uses Level Symbology 
Highlight Display from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose 
Color_MHPCplans and click OK. This pentable utilizes Level Symbology. 

Pentable without Level Symbology 
 Highlight Display from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose “MHPC-no 
Symbology” and click OK. This pentable does not utilize Level Symbology. Test this using 
method below. 

 In attempts to stabilize this process, we created a pentable that will not use Symbology. 
Instead, the pentable will adjust colors at plot time only. If the colors do not appear to 
be accurate using Symbology, instead, turn off Symbology and hit the Print Icon. 
Browse to the correct plotter and attach the “MHPC-no Symbology” pentable. Use 
your preview in the print dialog to see if the colors are better represented. 

Step Five: Add Design Files 
Select Edit>Add Files from the menu. Select all of your numbered MHPCplan drawings. 
Click the Add button. Click Done. 

Step Six: Send the Plots 
Click the printer icon or select File>Print from the Batch Print dialog menu to send all 
sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 
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WWEETTLLAANNDD  PPLLAANNSS  
Quick Punch List 

• Copy or Place New Clip Boundaries 
• Use Others or Create Cut Sheets 
• Run Border Macro 
• Send to Color Plotter 

Need to Find Wetland Drawings? 
The wetlands should be automatically attached if they were surveyed with the original 
topo.dgn or if the Topoadd and Textadd files have been cleaned up and merged properly. If 
not, they were picked up with other means (GPS) and they may be residing in a Topoadd# 
and Textadd# files sitting in the Survey/MSTA folder. Browse to the Survey/MSTA and 
open the Topoadds to see which one contains the wetland information. There may be an 
OrigWetlands file in the folder. In either case, these files need to be cleaned-up and either 
merged into the topo.dgn or copied into the topo folder. 

 Users should refer to Chapter 3 Survey Clean-up and treat an OrigTopoadd# and 
OrigTextadd# file as “Additional Topo Clean-up” (3-35). 

 Users should refer to Chapter 3 Survey Clean-up and treat an OrigWetlands as 
“Initial Wetlands Clean-up” (3-49). 

For a quick plot use File>Reference (DOT) Attach and attach the files directly from the 
Survey\MSTA folder to your Envplan.dgn or Wetlands-clips.dgn using Coincident World 
method. These files will not stay attached for future plotting as the Survey folder is not 
recognized as a valid path to reference files. Consider cleaning up these files to avoid this 
from happening.  

 In the near future, there will be a separate drawing for wetlands. Cleaning up the 
wetlands.dgn will be the responsibility of the Environmental staff. Details of the 
cleanup will be in Topo Cleanup section of this manual. The wetlands.dgn will be 
attached to Envplan.dgn and Wetlands-clips.dgn by default, however there are many 
old projects that will require the users to attach it manually. The wetlands.dgn will 
exist in the Survey\MSTA folder within your PIN and will be copied into your topo 
folder and cleaned up. Additional wetlands will be handled very similar to the 
Topoadds. 

 Please refer to 3-49 for information on Wetlands cleanup. 
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PLOTTING WETLAND PLANS FOR BIOLOGIST’S 
(USING OTHERS PLAN SHEETS) 

Introduction 
When plotting wetlands for checking purposes, it may be easier to use the plan sheets cut by 
another workgroup as opposed to creating your own. You can open someone else’s plan 
sheets (i.e. 011_hdplan1.dgn or 005_bdplan1.dgn) to check and see if the information you 
need is displayed on them. If topo cleanup is done properly, wetland lines and flags should 
be displayed. If not, you can ask the Program (Urban and Arterial, Bridge or Regional) to go 
through the process of cleaning up the additional topo and text files or consider cleaning 
them up yourself. 

Step One: Start MicroStation 
Double-click your MicroStation icon. Click the Project pull-down and click on your PIN. 

Step Two: Open Any Drawing 
Select any file in your list of files in your workgroups \MSTA folder (i.e. Envplan.dgn). 
Click OK to open it. 

Step Three: Batch Printing - Create a New Batch Job 

Part One: Open Batch Print Dialog 
Select File>Batch Print/Plot (DOT) from the dialog Menu. Click Cancel at the Open job 
Set dialog window. 

Part Two: Select a Printer 
Highlight Printer from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose 
US_OCE9800FULL or US_OCE9400FULL (OCE9800FULL or OCE9400FULL for 
metric). Click OK. 

Part Three: Select Print Area 
Default Print Area MDOT Standard is correct by default for U.S. Customary projects. 
(Change this to OCE for metric projects.) 

Part Four: Select a Display (Pentable) 
Highlight Display from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose 
graysurvey_wetlands and click OK. 

Part Five: Add Design Files 
Select Edit>Add Files from the menu. Depending on the type of project and who has cut 
the plan sheets, browse to the workgroup’s MSTA folder (i.e. highway\MSTA or 
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bridge\MSTA). Select all of the plan sheet drawings (i.e. 011_hdplan1.dgn or 
005_bdplan1.dgn). Click the Add button. Click Done. 

Part Six: Save your Batch Print job 
Select File>Save As… and give you Batch Print a logical name so you can print it again if 
the need arises (i.e. Wetland_ck_OCE9800.job). 

Part Seven: Send the Plots 
Click the printer icon or select File>Print from the Batch Print dialog menu to send all 
sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 
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CREATING WETLAND PLAN SHEETS FOR 
BIOLOGIST’S 

Introduction 
If you are required to create plan sheets for checking Wetlands and are unable to get what 
you need through another workgroups existing plan sheets, you can place your own clip 
boundaries or copy another workgroups clips into the Wetlands-clips.dgn without effecting 
other work to be done in the file (i.e. Army Corps. 8 ½ x 11 sheets).  

Step One: Create a Wetlands-clips Drawing 
It is now necessary to create a Wetlands.dgn within the ENVIRON\MSTA folder to create 
cut sheets for the Wetlands. Use the File>Make Sheetz macro to create a Wetlands-
clips.dgn file. Select “No Prefix” and select “Wetlands-clips” from the list of available 
drawings. Hit Cancel to stop making sheets. 

Step Two: Temporarily Attach HDPLAN or BDPLAN.dgn 
(Optional) 
As a time saver you can use another programs Clip Boundaries instead of placing your own 
manually. Depending on the type of project Bridge or Highway, use File>Reference 
DOT>Attach and browse to the appropriate groups \MSTA directory and select 
bdplan.dgn or hdplan.dgn. No logical is needed, set the nesting to Copy Attachments and 
depth to “0” (or use No Nesting) and click OK. 

 If there aren’t any clip boundaries in the bdplan.dgn or the hdplan.dgn, you will have 
to place your own boundaries manually. 

 Refer to page 5-3 for the procedure on placing clip boundaries manually. 

Step Three: Copy Clip Boundaries 
Now we need to merge the clip boundaries into the active file. This will produce clip 
boundaries for the Wetland plans that cover the same area as the plans sheets for the project. 
This procedure is assuming that you want a Wetland plan for every plan sheet. If you only 
need a Wetland plan for specific areas on your project, place clip boundaries manually in 
your active file as you would when creating the normal plan drawings. 

 Refer to page 5-3 for the procedure on placing clip boundaries manually. 

In the Reference File dialog, highlight the reference file (??plan.dgn) then select 
Tools>Merge Into Master from the Menu Bar. Now you will be prompted to select a view 
by clicking a data point anywhere on your top view. An informational dialog will open 
telling you that you are about to merge one reference file into the current design file. This is 
what you want to do. Select OK to start the procedure. Refresh your window to update the 
view in order see your clip boundaries in the active file. 

Step Four: Create the Cut Sheets 
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Part One: Activate Macro 
From the Settings Manager select Create Plan Sheets > Create Cut Sheets.  

Part Two: Supply Starting Number 
It asks you what number you want to use for the starting number of the Wetland plan sheets. 
Use the default “1” (Figure 11-9). This will appear in your border as your sheet number.  

 
Figure 11-9: Start Numbering At? 

Part Three: Sit back and watch 
When the program has finished, it will drop you back into Wetlands.dgn. Open up the files 
you’ve just created and see how they look! 

Live Nesting 
What is Live Nesting? This is a new method in MicroStation V8 of attaching a file with 
references to another file like our border sheets. By using Live Nesting you no longer need 
to use the old methods of Batch>Attach and Batch>Settings to manipulate the way you 
want your cut sheets to appear for plotting purposes. Now if you want to turn off certain 
levels, adjust displays of reference files or attach/detach additional reference files, you can 
simply do this in your source drawing (i.e. Wetlands-clips, HDPlan, BDPlan, Envplan, etc.) 
and all of your border files will be displayed in the same manner.  

Step Five: Troubleshooting 
If you open a Wetland plan sheet drawing and the graphics within the sheet are not correct, 
it could mean that one the drawings that is referenced in is not at the same Global Origin as 
the other drawings. If the graphics aren’t aligned with your border, try and re-cut the sheets 
again. It won’t be necessary to place new boundaries. Normally this will fix the problem. 
See CADD Support for assistance if needed. 

Step Six: Batch Printing - Create a New Batch Job 

Part One: Open Batch Print Dialog 
Select File>Batch Print/Plot (DOT) from the dialog Menu. Click Cancel at the Open job 
Set dialog window. 
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Part Two: Select a Printer 
Highlight Printer from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose 
US_OCE9800FULL or US_OCE9400FULL (OCE9800FULL or OCE9400FULL for 
metric). Click OK. 

Part Three: Select Print Area 
Default Print Area MDOT Standard is correct by default for U.S. Customary projects. 
(Change this to OCE for metric projects.) 

Part Four: Select a Display (Pentable) 
Highlight Display from the Specifications Controlling Plotting area of the dialog. Select 
Specifications>Select from the menu or click the little green icon. Choose 
graysurvey_wetlands and click OK. 

Part Five: Add Design Files 
Select Edit>Add Files from the menu. Select all of the plan sheet drawings you just created 
(i.e. 001_Wetlands1.dgn). Click the Add button. Click Done. 

Part Six: Save your Batch Print job 
Select File>Save As… and give you Batch Print a logical name so you can print it again if 
the need arises (i.e. Wetland_ck_OCE9800.job). 

Part Seven: Send the Plots 
Click the printer icon or select File>Print from the Batch Print dialog menu to send all 
sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 
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AARRMMYY  CCOORRPP..  DDOOCCUUMMEENNTTAATTIIOONN  
Quick Punch List 

• Cross Hatch Areas 
• Measure Areas/Place Text 
• Place 8 ½ x 11 Clip Boundaries 
• Create Cut Sheets 
• Run Border Macro 
• Send to Color Plotter 
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CROSS HATCHING WETLANDS 
Introduction 
This section is intended to provide assistance with some of the tasks related to the 
production of plans for submittal to the Army Corp. of Engineering. There are many ways to 
do the same thing in MicroStation, however to create standardization and efficiency, we 
encourage you to follow the steps outlined below. 

Step One: Start MicroStation 
Double-click your MicroStation icon. Click the Project pull-down and pick on your PIN. 
Select EnvPlan.dgn from your list of files and click OK. Click your Fit View icon. 

Step Two: Locate the Wetlands 
Check and see if the information you need is displayed on your Envplan.dgn. If topo cleanup 
is done properly, wetland lines and flags should be displayed. If not, you can ask the 
Program (Urban and Arterial, Bridge or Regional) to go through the process of cleaning up 
the additional topo and text files or consider cleaning them up yourself. 

 In the near future, there will be a separate drawing for wetlands. Cleaning up the 
wetlands.dgn will be the responsibility of the Environmental staff. Details of the 
cleanup will be in Topo Cleanup section of this manual. The wetlands.dgn will be 
attached to Envplan.dgn by default, however there are many old projects that will 
require the users to attach it manually. Use File>Reference (DOT) Attach and 
attach them to your Envplan.dgn using Coincident World method. 

Step Three: Lock “Z” to Zero 
From the Main Menu select Macros>Set/Lock Z to force MicroStation to place all elements 
at “0.00” elevation in the file. Click OK for the defaulted “0”. 

 This will prevent MicroStation from jumping to elements at different depths in the 
file. 

Step Four: Set the Category Scale 
Right Click on your Settings Manager and select Category>Scale.  From the list of 
available scales, select the scale that you intend on plotting your sheets. Normally a good 
scale that is still legible on 8 ½ x 11 plan sheets is 1” = 50 ft. for U.S. Customary (1:500 
metric).  

 If you use the Settings Manager for almost any activity, it is required that you set the 
Category Scale first. This has to be set once in every file. 
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Step Five: Cross Hatching Wetlands 

Part One: Select Hatching 
Use the Settings Manager and select Patterning>45^Hatching for “Wetland Impacts” or 
use Patterning>45/135XHatching for “Wetlands of Special Significant Impacts”. (These 
types coincide with the legend on the 8 ½ x 11 plan sheets.) 

Part Two: Set Hatching Method 
The setting in the Hatch Area or Cross Hatch Area dialog should be correct based on the 
Category Scale set in the Settings Manager. Adjust the Method to Points (Figure 11-10). 

 Using Points method instead of Flood will place a bounding element around the area 
you are hatching which will allow you to label the areas all at once. 

 
Figure 11-10: Hatch Area/Cross Hatch Area Dialog Settings 

Part Three: Create Hatch Area 
Using AccuDraw and the available snap methods, hit the intersection and the vertices of the 
elements that bound your area. Right click when you’ve hit them all to finish the command. 

 If you have missed a point and need to add a vertex or want to modify and existing 
vertex, use the tools in the Modify Tool Box to accomplish this. Because we used 
Associative Patterning, the pattern will adjust itself to the new shape.    
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ADDING FILLED SHAPES 
Step One: Set the Shade Type 
Select Patterning>Shade 20% (or another degree of shade). By Default, the settings for 
this tool should be correct. 

Step Two: Create the Shape 
Using AccuDraw and the available snap methods, hit the intersection and the vertices of the 
elements that bound your area. Return to beginning point or hit Close Element to end 
command. 

 If you have missed a point and need to add a vertex or want to modify and existing 
vertex, use the tools in the Modify Tool Box to accomplish this.    

Step Three: Send Fill Back 
From the Main Menu, select Macros>Send Fill Back. This will allow other line work and 
text to be seen in front of the shading. Hit Refresh. 

Step Four: Reset the Fill Type 
If you are finished using the Shape command, you need to tell MicroStation to stop using 
Opaque fill otherwise future areas or hatching that you do will be filled solid. To do this, 
select Qualities>Change>Fill from the Main Menu. 

 
Figure 11-11: Change Fill Type to None 

  In the dialog (Figure 11-11), change Fill Type to None. 
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MEASURING AREAS AND PLACING TEXT 
Step One: Lock “Z” to Zero 
From the Main Menu select Macros>Set/Lock Z to force MicroStation to place all elements 
at “0.00” elevation in the file. Click OK for the defaulted “0”. 

 This will prevent MicroStation from jumping to elements at different depths in the 
file. 

Step Two: Set the Category Scale 
Right Click on your Settings Manager and select Category>Scale.  From the list of 
available scales, select the scale that you intend on plotting your sheets. Normally a good 
scale that is still legible on 8 ½ x 11 plan sheets is 1” = 50 ft. for U.S. Customary (1:500 
metric).  

 If you use the Settings Manager for almost any activity, it is required that you set the 
Category Scale first. This has to be set once in every file. 

Step Three: Set the Text Attributes 
Using the Settings Manager, select Prop. Text and Dims>Text Note. This will set your text 
to the correct height, width, color, level, style and weight. 

Step Four: Open Measure Area Tools 
Select Measure>Area Tools from the Main Menu. A new set of tools should open. 

In the rightmost tool in the Tool Box (Figure 11-12), set some Parameter Settings. 

 
Figure 11-12: Area Parameter Settings 

Part One: Set the Default Text Font 
While in the Text tab, set the Font to 123 dotitalics (Figure 11-13). This is the only setting 
necessary on the tab. 
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Figure 11-13: Adjust Text Font to 123 dotitalics 

Part Two: Set the Default Prefix 
Click on the Prefix tab (Figure 11-14). Add a prefix that you would like to use. (i.e. 
Wetlands = ). You’re limited to ten characters. 

 
Figure 11-14: Add a prefix 

Part Three: Set the Default Suffix 
Click on the Suffix tab (Figure 11-15). Add a suffix that you would like to use. (i.e. s.f. or 
m\178 for metric). You’re limited to ten characters. 

 
Figure 11-15: Add Suffixes 

Step Five: Select by Attributes 
You can select all of your hatched areas, measure and label them all at once with one click 
to the screen. 
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Select Edit>Select By Attributes from the Main Menu. Select Tools>Set Select By from 
Element in the Select by Element dialog box. Click on one of the hatched areas. Click again 
to Accept. Now hit Execute. This should highlight all of the hatched areas. 

 If you want to measure and label shaded area, you will have to select one of those 
areas and hit execute to select them all. 

Step Six: Select Measure Area Tool 
From the Area Tools toolbox (Figure 11-16), select Measure Area. 

 
Figure 11-16: Measure Area Tool 

Configure area tool for the method, prefix and suffix. Select Element from the Method pull 
down and place a check in the Prefix and Suffix boxes and select the corresponding pull 
down and pick one of your preset options. Click in your view to Accept the command.  

This should label all of your areas. The orientation of the text will be horizontal to your 
current view window which means you will have to rotate and possibly move text. Use the 
Rotate Element tool and set method to either 2 points or 3 points. Follow the prompts. 

 If you cannot see the text for your areas, check that you have done all the steps in this 
section. 

Step Seven: Select None 
Select Edit>Select None to unselect your hatching. Close the Select by Attributes dialog 
and click Cancel to tell MicroStation to stop filtering by the hatched attributes. 

Step Eight: Edit the Text (Optional) 
You can use the Edit Text tool to add additional verbiage to your area text. While the text is 
in your Text Editor window, you can click on another type of text placement such as Place 
Note (Figure 11-17). This will allow you to point with an arrow to small areas that cannot be 
labeled clearly.  

 You may have to select a dimension placement from your Settings Manager first in 
order for the arrowhead to be filled in.  

 
Figure 11-17: Place Note tool 

Consider changing the default setting of the tool and selecting Box as a Text Frame (Figure 
11-18). This will make your text stand out and if masking is required, it will make it easy to 
place a fence around your text. 
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Figure 11-18: Using a Box text Frame 

Place the text and delete the old text. 

Step Nine: Masking References (Optional) 
 If the text you placed is obscured by reference files, place a fence around your text and 
select File>Reference (DOT)>Clip>Mask>All if you want to mask all elements in all 
references or File>Reference (DOT)>Clip>Mask>Single and click on the specific 
reference file you want to mask. Click on the view to Accept. 

Or, you can also open your reference file dialog and highlight the specific reference file(s) 
you want to mask and select Tool>Clip Mask. 
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CREATING 8 ½ X 11 CUT SHEETS 
Step One: Set Category Scale 
Right click on the Settings Manager and select Category>Scale. Select the scale you want 
to use for your cut sheets. 1 in. = 50 ft. (1:500 metric) is a good scale to use. This scale will 
still allow the stationing and existing text to be legible. This should be the same scale you 
used to place your text for the areas. 

Step Two: Place 8 ½ x 11 Clip Boundaries 
Select Create Plan Sheets> Place Clip Boundary 8.5x11 from the Main Menu. You will 
have a rectangle on your cursor waiting for placement. You are holding the portrait page by 
the bottom edge of an 8 ½ x 11 piece of paper. With your first click, place the boundary 
along the centerline and move your cursor up-station to rotate the page. Click again to define 
the amount of rotation. Continue placing boundaries for the length of your project. 

 You can stop at any time (by right clicking) and move and/or rotate your boundaries. 
Restart the placement if necessary. 

 You must keep the boundaries in order! This will determine the creation order of the 
cut sheets. 

 Refer to page 5-3 for the procedure on placing clip boundaries manually. 

Step Three: Create the Cut Sheets 

Part One: Activate Macro 
From the Settings Manager select Create Plan Sheets >  Create 8.5x11 Cut Sheets.  

Part Two: Supply Starting Number 
The macro asks you what number you want to use for the starting number of the cut plan 
sheets. Use the default “1” (Figure 11-19). This will appear in your border as your sheet 
number (consider using “2” if you plan on including a Title Sheet, “3” if you plan on having 
a Layout sheet). 

 
Figure 11-19: Start Numbering At? 
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Part Three: Sit back and watch 
When the program has finished, it will drop you back into Envplan.dgn. Open up the files 
you’ve just created and see how they look! 

Step Four: Troubleshooting 
If you open a plan sheet drawing and the graphics within the sheet are not correct, it could 
mean that one the drawings that is referenced in is not at the same Global Origin as the other 
drawings. If the graphics aren’t aligned with your border, try and re-cut the sheets again. It 
won’t be necessary to place new boundaries. Normally this will fix the problem. See CADD 
Support for assistance if needed. 

Step Five: Run the Border Information macro 
The Border contains variables that can be replaced by a macro. It is not necessary to edit 
anything on this drawing that contains a $ or @ (i.e. $TOWNORCITY$). Select 
Macros>Border Information to run the macro. Process all of your sheets.  

 Please refer to PCF Editing on page 1-25 if the variables do not get filled in with the 
proper information. 
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CREATE A TITLE SHEET 
Step One: Create a Title Sheet 
Using File>Make Sheetz, create a title sheet. 

 Refer to page 4-3 for more informtaiton on creating a title sheet. 

Step Two: Create a Location Map 
Select File>Open Location Map, select Macro>Location Map and place the square 
defining the project area. 

 Refer to page 4-4 for more information on creating a Location Map. 

Step Three: Paste Map 
Open the 001_Title.dgn and select Edit>Paste. Adjust the scale to 0.00000789 and place the 
map into the square provided by snapping to the corner. 

 Refer to page 4-5 for more information on pasting a location map into your title sheet 
drawing.  
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CREATE A LAYOUT DRAWING 
Step One: Open EnvPlan 
Open the drawing that contains your Cut Sheets (i.e. EnvPlan.dgn). 

Step Two: Create Saved View 
Create a Saved View called Layout. 

 Refer to page 4-6 for more information on creating a saved view. 

Step Three: Create 002_Layout Drawing 
Using File>Make Sheetz, create a numbered drawing called Layout. 

 Refer to page 1-18  for more information on creating drawings. 

Step Four: Attach Saved View  
Select File>Reference (DOT)>Attach and attach the drawing that contains your saved 
view. Set the scale based on the number of clipe boundaries in combination with the scale in 
which you placed them. In this example, 10 (clip boundaries) x 600 (scale of the clips) = 
6000 (scale of the reference attachment). Set the Nesting to Copy Attachment 1. 

 Refer to page 4-8 for more information on attaching, scaling and rotating your saved 
view.  

Step Five: Adjust Level Display (if necessary) 
Users may want to limit the levels that are displayed and drawings displayed to better 
represent the layout drawing. 
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BATCH PRINTING 8 ½ X 11 CUT SHEETS 
Step One: Open Batch Print Dialog 
Select File>Batch Print/Plot (DOT) from the dialog Menu. Click Cancel at the Open job 
Set dialog window. 

Step Two: Select a Printer 
Highlight Printer from the Specifications Controlling Plotting area of the dialog (Figure 
11-20). Select Specifications>Select from the menu or click the little green icon. Choose 
Standard Details. Click OK. 

Step Three: Select Print Area 
Highlight Print Area from the Specifications Controlling Plotting area of the dialog (Figure 
11-20). Select Specifications>Select from the menu or click the little green icon. Change 
the default Print Area to Standard Details and click OK. 

Step Four: Select a Display (Pentable) 
Highlight Display from the Specifications Controlling Plotting area of the dialog (Figure 
11-20). Select Specifications>Select from the menu or click the little green icon. Choose 
Standard Details and click OK. 

 
Figure 11-20: Batch Print Setup 

Step Five: Add Design Files 
Select Edit>Add Files from the menu. Select all of the plan sheet drawings you just created 
(i.e. 001_EnvPlan1.dgn). Click the Add button. Click Done. 
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Step Six: Save your Batch Print job 
Select File>Save As… and give you Batch Print a logical name so you can print it again if 
the need arises (i.e. EnvPlan_ArmyCorp_printer.job). 

Step Seven: Send the Plots 
Click the printer icon or select File>Print from the Batch Print dialog menu to send all 
sheets to the plotter. 

If you don’t want to send them all, highlight only the files you want to plot. At this point you 
can send just the ones you have selected. Click OK. 

 This printer setting will send your plots to your default Windows printer. 

After you click OK, you can pick which Windows printer to use by selecting Set Up System 
Printer from the Print Batch dialog (Figure 11-21). 

 
Figure 11-21: Select Set Up System Printer 

Select one of your system printers from your list of available printers. Consider using a 
black and white photocopier. Click OK.
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ADJUSTING EXISTING USERS TO REGIONAL 
PREFERENCES 

Overview 
Each MicroStation user has their own User Configuration File (UCF) called normal.ucf, 
which identifies the location where MicroStation will open a file whether on the network 
(y:\PIN) or a user’s local hard drive (d:\PIN). MaineDOT has some Regional Offices with 
poor network connection speed and Surveyors that are working unplugged from the network. 
These users will primarily work on a local copy of the network project. Ocasionally they 
will need to work on files on the network. The following steps are intended for these Region 
Employees who will be primarily working locally.  

The normal.ucf also identifies which workgroup folder the user will be working in (i.e. 
Highway, Bridge, Survey, ROW, etc.). 

Step One: Copy New “.UCF Files” 
Using Windows Explorer, browse to the 
y:\msworksp\!msv8user\!Template_Regional\MSTAUSER\config\users folder. Copy the 
normal.ucf and network.ucf files into your user folder on your local C: drive (i.e. 
C:\!msv8user\Your.Name\MSTAUSER\config\users). Overwrite any existing files. 

Step Two: Adjust the Workgroup (If necessary) 

Part One: Editing “.UCF” Files  
Using Windows Explorer, browse to the 
c:\!msv8user\Your.Name\MSTAUSER\config\users folder. Double click the normal.ucf 
and/or network.ucf file to open it. If the “.ucf” file is not opened directly, Windows may not 
recognize this file extension (Figure 12-1). Pick Select the program from a list and click 
OK.  

 
Figure 12-1 Associate the file type to open with Notepad 

 A new dialog will open (Figure 12-2) asking you to choose a program. Scroll down in the 
list and select Notepad. Place a checkmark in the box to Always use the selected program 
to open this kind of file. Click OK. 
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Figure 12-2 Select Notepad as the preferred program to open this file. 

Part Two: Change Workgroup 
Locate the line in the files that says “WKGROUP =”. Copy and paste from the list of valid 
groups to overwrite the current workgroup (i.e. HIGHWAY).This must be all CAPITOL 
letters and have a space between the “=” and the value as in the examples provided in the file 
(Figure 12-3). This is the only change you should make in this file. Save this file and exit 
Notepad. 

 
Figure 12-3: User Configuration File 

  Step Three: Working Locally or On the Network 
Working locally (D: drive) is now your workflow by default. It utilizes your normal.ucf 
(user configuration file) that points to your PIN briefcase for projects. 

Working Locally 
Entering MicroStation will be the same as usual, by clicking the MicroStation icon on your 
Desktop opening the MicroStation Manager window (Figure 12-4). 
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Figure 12-4: MicroStation Manager 

In the Workspace area of the dialog, it should look like the dialog above. 

The User field always defaults back to “normal”. Normal, for Regional users will point to 
their local PIN briefcase for projects. 

 Working on the Network 
Occasionally you may want to open files on the network to check something. Simply switch 
your user file to Network (Figure 12-5).  

 
Figure 12-5: User: Network 

Pick your project from the “Project” pull down. This should open that project on the network 
(y:) drive. 
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CREATE A BRIEFCASE 
Overview 
The Windows Briefcase software provides a method of comparing project files on the 
network with project files copied locally. A briefcase is simply a folder with intelligence. In 
the event a file is modified, added to a project, or deleted from a project, it is possible to 
know when and possibly by whom. 

 Sometimes Windows thinks that you have a file open if the Explorer window has 
a folder open in the Briefcase. To avoid this, simply close the Explorer window or 
click on another folder. Figure 12-6 is a typical message you will see if you are 
accessing the briefcase through Windows Explorer. 

 
Figure 12-6: Open Briefcase 

Step One: Create D:\PIN folder 
Open Windows Explorer and browse to your D drive. Verify that you have a folder named 
PIN at the root of the D drive. If it does not exist, create one (Right click and select 
New>Folder).  

Step Two: Create a Briefcase 
Click on your D:\PIN folder on the left side of the Explorer window. Right click on the right 
side of Explorer (anywhere except on a file or folder) and select New>Briefcase (Figure 
12-7). 
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Figure 12-7: Creating New Briefcase 

Step Three: Rename the Briefcase 
Right click on the Briefcase and select Rename. Type the PIN number of the project you 
want to work on locally and hit enter (i.e.12745). It’s crucial to stick with the same name as it 
appears on the y: drive. 

Step Four: Open the Briefcase 
Double click on the briefcase. 

 The first time you open the briefcase, the Briefcase Wizard will open giving you 
brief instructions. Click Finish. 



mdot MicroStation 
07/01/07 

Regional Workflow 

12-9 
 

ADDING PROJECTS TO YOUR BRIEFCASE (ALL FILE TYPES) 
Overview 
One way to add files to your briefcase is to add all file types. This will make a full copy of all 
files in the project directory. This is the easiest way of creating a synchronized copy in your 
briefcase. You can also create the briefcase based on individual file types which is described 
later on page 12-14. 

Step One: Adding Network Files To Your Briefcase 
Browse Windows Explorer to the Y:\PIN directory and navigate to your PINs folder. Select 
your project’s decimal folder. Select Edit>Copy To Folder… from the Windows Explorer 
menu (Figure 12-8). 

 
Figure 12-8: Select Copy To Folder… 

In the Copy Items dialog, navigate to the briefcase you just created on your D: drive (i.e. 
D\PIN\12745) Figure 12-9. Select Copy. 
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Figure 12-9: Navigate to your PINs briefcase on your D: drive. 

You will begin Updating Briefcase evident by the dialog (Figure 12-10) and the progress bar. 
When the process is complete, the dialog will disappear.  

 
Figure 12-10: Updating Briefcase dialog while processing. 

 The time it takes to process depends on your network connection and the speed of 
your computer. The initial synchronization will take longer than updates that you 
will do in the future. 

 When there is a database (.mdb) on the network, you may get a few warnings along 
the way. The warnings are intended for reasons described below.  

Step Two: Synchronizing Databases 

Synchronize Your Databases (Read/Write Permissions) 
If the briefcase encounters a database that you have permissions to edit, you will be prompted 
with a few warning dialogs. 

First Warning: Creating a Replica 
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The briefcase will handle synchronizing a database and will create a copy locally (Figure 
12-11). If you intend on working on this database offline, select Yes. If not, select No and 
refer to page 12-12 for instructions on manually updating the briefcase. 

 
Figure 12-11: Creating a replica of the database locally. 

Second Warning: Creating a Backup 
The briefcase will now recommend creating a backup of the original database on the network 
as it prepares it to be the Design Master (Figure 12-12). Only one of the databases will be 
able to modify and save the design of the database (add additional fields, formatting, change 
Queries, etc.). This is referred to as a Design Master. 

 
Figure 12-12: Creating a backup of the database. 

Third Warning: Pick the Design Master 
Select the copy of the database that you want to be the Design Master (Figure 12-13). If most 
of the changes to the design of the database are going to be done locally, select the Briefcase 
Copy. Otherwise, select the Original Copy. 
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Figure 12-13: Select which database has the ability to make design changes. 

Synchronizing Others Databases (No Permissions) 
If the briefcase encounters a database that you do not have permissions to edit, a single 
dialog will open (Figure 12-14) stating that it may be already open by someone else or that 
you do not have permissions to edit it. In this case, the only option is to click OK. Refer to 
page 12-12 for instructions on manually updating the briefcase. 

 
Figure 12-14: Briefcase can't open the database - No permissions. 

Step Three: Remove Database(s) from Synchronize List 
If you told the briefcase not to create a replica or permissions prevented you from having 
access to the database, you will have to finish the original synchronization manually. Now 
you will have the opportunity to skip those databases from being updated in your briefcase.  

Manually Update the Decimal Folder 
In Windows Explorer select your PINs decimal folder. Select Briefcase>Update All from the 
Windows Explorer menu. In the Update dialog (Figure 12-15), scroll and locate any 
databases (.mdb) that you do not want to synchronize. The left portion of the dialog is your 
briefcase location and the rightmost portion is the network file. Right-click near the arrow 
and “Create” text in the center of the dialog between the database and the network location. 
Select Skip from the list. Repeat as necessary. When finished, click Update. 
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Figure 12-15: Update project dialog waiting for input. 
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ADDING PROJECTS TO YOUR BRIEFCASE (BY FILE TYPES) 
Overview 
The second way of making a synchronized copy in your briefcase allows the user to select 
specific file types. In this case, the user will have to manually select up to 20 different file 
types. Experiment with both methods and select the method that you prefer. 

Step One: Adding Network Files To Your Briefcase 
Browse Windows Explorer to the Y:\PIN directory and expand the list of PINs by clicking 
the plus sign on the left panel of the Explorer window. Click on your PIN (Figure 12-16). 

 
Figure 12-16: Browsing your PIN 

Use the scroll bar to display the D:\PIN\## on the left panel of the Explorer window. Right 
click+hold+drag the decimal folder of your project number into your D:\PIN\## Briefcase. 
Release your mouse button and select Make Sync Copy of Type…(Figure 12-17). 
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Figure 12-17: Make Sync Copy of Type 

Step Two: Select the File Types 
From the Add #  to the Briefcase dialog (Figure 12-18), select .csv, .dat, .dgn, .doc, .dwg, 
.dxf, .log, .pdf, .plt, .prj, .prn, .txt, .xml, .zip (and any other MX file types) as your file 
types (it is not necessary to hold CTRL key). Verify that the “Include subfolders of the folder 
#” is checked. Click OK. 

 
Figure 12-18: Select File Types 

 As different files of other types are created or added to the local directory or 
network directory, the briefcase will recognize them; however, inclusion of the 
new file types on the network has to be initiated by the user. 
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SYNCHRONIZE YOUR BRIEFCASE 
Update Briefcase and Network 

Overview 
As you work on your project on your local hard drive, any files that you make changes to 
will be tracked in your briefcase. Likewise, if files are changed on the network, your 
briefcase will identify them. Synchronizing the briefcase with the network will allow the user 
to select which files to update and perform the updating. Users should synchronize their 
briefcase with the network weekly. The network is backed up nightly and is meant to store 
the master copy of all project files. 

Step One: Open Your Briefcase 
Open Windows Explorer. Make sure that Explorer is displaying all details (View>Details). 
Click on your project’s Briefcase on the left side of the Explorer window to display the 
contents on the right. 

Step Two: Update All Files (Recommended) 
From Windows Explorer’s main menu, select Briefcase>Update All. The briefcase will 
compare the files in on your hard drive with the network copies and display the results 
(Figure 12-19). 

 
Figure 12-19: Update dialog with default action. 

The left column displays the file name in question, the next column displays the briefcase 
files information, the next column displays the default action to take in order to update both 
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locations and the right column displays its counterpart’s information on the Y: drive. 

The default action can be adjusted at any time by right clicking the file and selecting a new 
action to be preformed to the file. Below is a breakdown of the actions. 

Replace Option 
When a file has been modified in one or the other location, the briefcase prompts you to 
replace the unmodified file. This is most likely what you want to do.  

However, there may be an instance when the file you were working on was corrupted or 
changes performed are unwanted, you could get a new copy by replacing the file in your 
briefcase. If you right click the file, you get these possible alternatives (Figure 12-20). Notice 
that you also have the option of skipping the update. 

 
Figure 12-20: Update Options 

Skip (both changed) Option 
When the file in the briefcase and the file on the network have both been modified, the 
briefcase prompts you to “skip” updating the file. This is when communication will need to 
take place. Open Windows Explorer and browse to the Y: drive and locate your PIN. Open 
the folders to the location of the common file (i.e. Y:\pin\ 12745\00\Highway\MSTA). Open 
the dgnuse.log file. This file keeps a record of who has opened the files on the network and 
possibly made changes. Look for an entry in the log for the file in question. The log provides 
you with the time, date and name of the person who had opened the file (Figure 12-21). 

 
Figure 12-21: The dgnuse.log file provides valuable information. 

 Find out from this person if any work was done to the file. Once it is determined which file 
takes precedence, you can Right Click the file and change which direction that the file will 
be copied (Figure 12-22). 
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Figure 12-22: Options when both files have been modified. 

 If it is undetermined which file should be preserved, select skip until the files can be 
compared with one another. 

 The “dgnuse.log” can be misleading. The dgnuse.log on the network tells you 
who opened the file on the Y: drive only, it doesn’t tell you if this person has 
made changes to the file. If a person uses the preference “Immediately Save 
Design Changes” this will change the modified date regardless if changes are 
made. When a person synchronizes their briefcase, a dgnuse-local.log gets copied 
to the network, giving a record of who is adding files from a briefcase.  

Delete Option (File Removed) 
The Delete option lets you know when a file was deleted in either of the two locations. If a 
file is no longer needed and is deleted, the briefcase gives you the opportunity to make both 
locations identical (Figure 12-23). 

 
Figure 12-23: Options when a file(s) has been deleted. 

If you Right Click on the file, you get these possible alternative actions (Figure 12-23). The 
briefcase gives you the opportunity to delete the file, create (copy) the file again in the 
location it was deleted from or simply don’t delete the file. The dgnuse.log won’t help you to 
find out who deleted this file, however it may tell you who has been working on this project 
on the network, and that itself may open the lines of communication.  

Create Option 
If a new file was created in either location, the briefcase will give you the option to create the 
file in the other location (Figure 12-24). 

 
Figure 12-24: Create options. 

 It is common that other users may be adding files on the network as well as in you in your 
briefcase. Survey, for example, may have additional topography that you need locally. The 
default action (create) is the normally the one you want. You can right click the file for 
alternative actions. The only other action for create is “skip”.  

Renaming Files in Your Local Briefcase 
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It is recommended that all file renaming (i.e. Sheet Renumbering Utility) be done locally in 
your briefcase. The intelligence of your briefcase allows you to take the renamed files and 
create them on the network and at the same time it will also delete the files that were 
associated to these files from the network. This allows for no confusion or duplication of files 
on the network with different names. 
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ADDING ADDITIONAL FILE TYPES TO BE SYNCHRONIZED 
This section describes how to add additional file types to a briefcase that has already been 
setup. This will allow any “orphan” files of the new type to be synchronized with the 
network. As you work on a project, additional files may be created. General Notes (.doc) 
files, Construction Notes (.xls) files, Estimator (.csv) files, MicroStation Packager files 
(.pzip), Images (.tif, .bmp or .jpg) and MicroStation Backup (.bak) files are some additional 
types that may be created when doing a complete plan set. These file types can be added 
when creating a briefcase or added later. Follow the steps below to add the new types (Figure 
12-25). 

Step One: Right Click Your Project at the decimal folder 

 
Figure 12-25: Changing Properties 

Step Two: Select the Update Info Tab 
Select the Update Info tab (Figure 12-26) and select the new file types you wish to be 
synchronized with the network files. 
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Figure 12-26: Update Info 

Select the new file types (it is not necessary to hold CTRL key). Verify that the “Include 
subfolders of the folder ‘PIN’” is checked. Click OK when done. 

 This process will only work if you are connected to the network location that your 
briefcase is synchronized with. 

Step Three: Synchronize Your Briefcase 
It will be necessary to re-synchronize the briefcase for the new files to be copied to the 
network. This will prompt you to Create the new files on the network. This is the default 
action you want to take. There may be files of this type on the network that will be copied 
down to your briefcase also. If you want a copy of them, the default action is OK, but if you 
don’t need them, you can Skip them by right clicking the file and changing the default action 
to SKIP. 
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REMOVING A PROJECT  FROM THE BRIEFCASE 
Once final plans have been delivered to the Contracts for printing, you can remove it from 
your briefcase. Prior to removing it, do one last synchronization on the PIN and manually 
copy any “orphan” files to the network. Orphan files are additional file types that reside only 
in your briefcase. 

 If you added additional file types or created the briefcase with all file types, there 
may not be any orphan files. 

Step One: Open Briefcase and browse to the MSTA folder 

Step Two: Sort by File Status and copy to Clipboard 
Click on the Status heading in Windows Explorer to group the like files together. Highlight 
the orphan files (Figure 12-27) and select Edit>Copy. 

 
Figure 12-27: Adding Orphan Files 

Step Three: Paste files into the appropriate folder on the Y: 
drive 
Open your Explorer to the Y: drive and browse to the folder that contains the project files 
(i.e. Y:\PIN\9045\00\Highway\MSTA). Select Edit>Paste to copy them to this location. 

Step Four: Delete the Project 
After all project files have been synchronized and orphan files copied to the network, you can 
highlight your briefcase and select File>Delete to delete the PIN and free up space on your 
hard drive.
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DETERMINE THE CONSULTANTS DUTIES 
(PROJECT BY PROJECT BASIS) 

What is their responsibility? 

Consultant Doing Survey 
Aerial Photogrammetric Mapping - Consultants will coordinate through Brian Casey. 
They submit their information back to Brian and no information is necessary from the 
Consultant Coordinator. 

Traditional Surveying - Consultants will coordinate through the Area Survey supervisors 
to get specifications. They submit their information back to the Area Survey supervisors and 
no coordination is necessary. 

Consultant Doing ROW 
Existing ROW - Consultants will coordinate through the Real Estate Manager in the 
Programs. They will require CADD drawings of existing topography and text. 

Proposed ROW - Consultants will coordinate through the Real Estate Manager in the 
Programs. If they are doing the proposed ROW, chances are they are doing existing also. 
They will require CADD drawings of existing topography, text, existing ROW (if 
necessary), alignment, design (highway.dgn or bridge.dgn) and cross sections. 

Consultant Doing Design 
Bridge Projects - Consultants will coordinate through the Consultant Coordinators in the 
Program. They will require CADD drawings (both 2D and 3D) of existing topography, text, 
contours, points, triangles and existing ROW. The agreement may or may not require the 
consultants to “clean-up” topo and text drawings. For all new projects, consultants will 
follow the current General Contract Agreement. 

Highway Projects - Consultants will coordinate through the Consultant Coordinators in the 
Program. They will require CADD drawings (both 2D and 3D) of existing topography, text, 
contours, points, triangles and existing ROW. The agreement may or may not require the 
consultants to “clean-up” topo and text drawings. For all new projects, consultants will 
follow the current General Contract Agreement. 

Multimodal Projects – Similar to the Highway and Bridge projects. 

Traffic Projects - Similar to the Highway and Bridge projects.  

What do they need from us? 

Link to Web page 
All of our CADD customization is available online for consultants to download. This 
includes seed files, linestyle resource files, cell libraries and font resources. The web 
address is as follows: www.maine.gov/mdot/cadd-support/cadd-home.php . We highly 

http://www.maine.gov/mdot/cadd-support/cadd-home.php
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encourage them to use our customization. For more information, have them call ESSG’s 
CADD support personnel. 

Seed Files 
We have quite a few seed files in our configuration. Instruct consultants to use our standard 
seed file called “usMDOT_SEED.dgn” for all U.S. Customary projects (MDOT_SEED for 
metric projects). These can be found on the CADD download page at the following address: 
www.maine.gov/mdot/cadd-support/microstation/downloads.php .  

Our Standard file Structure/File Names 
Consultants should follow our standard naming convention which is laid out on our 
webpage. The address is www.maine.gov/mdot/cadd-support/microstation/std_filename.php 
.  

http://www.maine.gov/mdot/cadd-support/microstation/downloads.php
http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
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SENDING SURVEY FILES TO A CONSULTANT 
MDOT Survey Data 
Most of the consultants will require our survey data with the exception of Survey 
Consultants. When a Survey Editor is done editing MX data and creating MicroStation 
design files, they zip all the pertinent files into a single Zip file and place them in a 
consultant folder under the survey folder on the y:drive (i.e. 
y:\pin\8467\00\Survey\consultant\). The zip file will be named PINTOWN.zip (Figure 
13-1). See breakdown below for explanation of the files included in the zip. 

 
Figure 13-1: Example of zipped Survey Files ready to be sent to a consultant 

Breakdown of files sent to a consultant 
MX files:  
Traverse.inp file(s) contains the adjusted Traverse & generates the Traverse Model. 

Ground01.inp file(s) contains the topographic features from the field survey 

Ground01.out file(s) contains the resulting X, Y, Z coordinates & associated point number 
above data. 

Ground01.inc file(s) generates the topographic features with associated text. 

Ground01.rep file(s) shows the labels X, Y, Z coordinates with associated text. 

Contours.inp generates the Triangles & Contour Models.  
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Points01.str & Points01.txt file(s) generates the Point Numbers as surveyed from the field. 

 MX users may need to process multiple sets of numbered files (i.e. ground01.inp 
through ground10.inp) as opposed to running the highest numbered file.                                                         

MicroStation files: 
Topo.dgn is the Survey (cleaned-up and flattened). This file, if cleaned-up, is located in the 
topo folder of the PIN number.  

Text.dgn is the text associated with Survey data (cleaned-up and flattened). This file, if 
cleaned-up, is located in the topo folder of the PIN number. 

Points.dgn is the field Survey point numbers. 

Contours.dgn is the 3D contours drawing. This file resides in the Survey\MSTA folder. 
There is a contours drawing in the topo folder also, but it has been flattened. 

3Dtopo090902.dgn is the 3D MicroStation design file (.dgn) of the Survey. 

Origtext.dgn is the 3D MicroStation design file (.dgn) of the text associated with Survey 
data. 

Triangles.dgn is the 3D triangulation file (.dgn) for the project. 

Mapping.dgn is the 3D MicroStation design file (.dgn) of the merged Mapping with Survey 
and Traverse (only on Photogrammetric Mapping projects). 

MappingText.dgn is the 3D MicroStation design file (.dgn) of the merged text for Mapping 
and Survey (only on Photogrammetric Mapping projects). 

MappingContours.dgn is the 3D MicroStation design file (.dgn) of the Mapping Contours 
(only on Photogrammetric Mapping projects). 

MappingTriangles.dgn is the 3D MicroStation design file (.dgn) of the Mapping Triangles 
(only on Photogrammetric Mapping projects).  

Step One: Posting files to Outgoing FTP site 
Click your Start button and go to Programs>WS_FTP LE>WS_FTP LE or double click 
the icon (Figure 13-2) on your desktop. 

 
Figure 13-2: FTP Icon 

When the program opens you should see a Session Properties dialog. Press OK (Figure 
13-3) to log into the FTP site. 
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Figure 13-3: Session Properties 

Step Two: Browse and Push Files to FTP 
On the right side (Remote Site), you should see the folder list, (incoming, outgoing, etc.) 
and on the left (Local System), see a list of available drives. These are the drives you 
currently have mapped to your computer. 

We have a folder for all outgoing files and a folder for all incoming files. Open the 
appropriate folder for the action you are taking. 

In the Local System window, browse to the y:drive and folder where the file exists that 
requires transferring (i.e. y:\pin\8467\00\survey\consultant\). When the contents of the folder 
are displayed in the left section of the dialog area, highlight the desired file and click on the 
directional arrow (Figure 13-4) between the two view areas. 
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Figure 13-4: WS_FTP LE ftp.maine.gov 

Step Three: Send Email with Link to File 

Introduction 
We can send a hyperlink in an email document that points directly to the file you posted, 
starting the download on their end automatically.  

Or, we can also notify clients when a file is posted and provide them with the HOST 
(ftp.maine.gov ) with the user (anonymous) and the password (anonymous). Then, by using 
a normal Internet browser or some type of FTP software, they can connect to our site and 
find the file and download it manually. 

Part One: Type address to FTP in email 
Type the complete address path and file name, within the body of an email message area and 
the recipient can click the link and start downloading to a specified location on their 
computer. 

Here is an example: ftp.maine.gov/outgoing/8467topsham.zip. 

 Always test the link by sending this to a coworker or to yourself. It doesn’t always 
work in the draft email that you are preparing. 

 Use forward slashes between folders and never use spaces in the file names. Use 
lowercase for the ftp address and outgoing folder. Match the case of the file name 
you created.  

Part Two: Add Subject Line and Send 
Add the filename in the Subject line of your email. Provide a brief description of files 
attached. Click Send. 

ftp://ftp.maine.gov/
ftp://ftp.state.me.us/outgoing/8467topsham.zip
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SENDING OTHER FILES TO A CONSULTANT 
Step One: Create Consultant “Out” Folder 
Open Windows Explorer and browse to your Workgroup’s folder (i.e. 
Y:\pin\8467\00\HIGHWAY). Right Click and select New>Folder. Name this folder 
Consultant. Open this folder and Right Click and select New>Folder. Name this folder 
OUT. Open this folder. An example is shown in Figure 13-5. 

 
Figure 13-5: An example of a consultant  folder structure 

Step Two: Create a Zip file 
Creating a Zip file is as easy as Right clicking and selecting New>Compressed (zipped) 
Folder in the folder where you want the zip file to exist (i.e. 
Y:\pin\8467\00\HIGHWAY\consultant\OUT). This will create a Compressed (zipped) file 
called “New Compressed (zipped) Folder.zip. Select the file and pick File>Rename. Supply 
a new name by typing the name and hitting enter. Be sure to add the “.zip” extension to the 
file name. 

 Use good judgment when naming files. Rather than dumping random files without 
unique names to the FTP site, always use naming that will make it easy to identify 
your files from someone else’s (i.e. 8467topsham.zip or 8467rwplan.zip). 

Select one or more files in Windows Explorer and drag and drop them onto the Zip file, or 
double click the zip file to open it, then drag and drop files from Windows Explorer into the 
Zip folder. 
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Step Three: Post to Outgoing FTP site 

General Rules of Thumb! 
1) Send a zip (compressed) file when sending more than one file, or files large in size.  

2) Use good judgment when naming zip files. Do not dump random files (i.e. topo.dgn, 
Rwplan.dgn, text.dgn, highway.dgn, etc.) to the FTP site, always try and use unique naming 
that will make it easy to identify your zip file’s from someone else’s. (i.e. 8467topsham.zip) 

3) Do not create a folder. 

4) Clean up you own mess! BIS does house cleaning only when the server is too full to 
function. By then it’s a crisis. Delete incoming files after you have downloaded them.  

Open FTP Site 
Follow steps previously documented in the Sending Survey Files to a Consultant section. 
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RECEIVING PROJECT FILES FROM A 
CONSULTANT 

File Format 
Older project that were started before the current GCA are grand fathered and we will accept 
.dwg or .dxf files. MicroStation can open/attach these files in their native format. If the 
consultant uses AutoCAD, request that they send MODEL SPACE drawings in our State 
Plane Coordinate System. 

Newer contracts that are governed by the current GCA require that consultants send .dgn 
(MicroStation) files. 

Drawings to Receive 
The Department separates drawings by discipline and use referencing to combine all 
drawings necessary to produce a plan set. As previously stated in this document, consultant 
duties vary from project to project. Consultants doing ROW work should send back only the 
existing and/or proposed ROW files. If a consultant is doing proposed design for a project, 
they should be sending back an alignments.dgn and a highway.dgn or bridge.dgn. As the 
project nears completion, they should send all files relative to the project. They may or may 
not use our naming convention. We encourage them to follow our standard naming 
convention which is laid out on our website ( www.maine.gov/mdot/cadd-
support/microstation/std_filename.php ). If they do not, it may be necessary that they 
include a text document that describes their filenames. It’s up to you to rename these files if 
necessary and place them where they belong in the project directory. 

What don’t we want back? 
Because we usually supply the consultant with Survey data, we do not want it back unless 
they have made significant changes to the topo and text files due to field review or 
inspection. If the consultant is required to clean up the topography, we would want the 
cleaned up version back from them and placed on our network. If they have added 
topography, have them send only the things that they have added. These items can be 
merged into our topo.dgn. Someone in-house may have cleaned up our copy of the topo.dgn 
so we may not want to replace it. 

Step One: Create a Consultant Directory 
Now we need to create a folder in the projects PIN structure for the consultants “.zip” file. 
This will be a record of what was received from them and the date of submittal. 

Open Windows Explorer and browse to your Workgroup’s folder (i.e. 
Y:\pin\8467\00\HIGHWAY). Right Click and select New>Folder. Name this folder 
Consultant. Open this folder and Right Click and select New>Folder. Name this folder IN. 
Open this folder.  An example is shown in Figure 13-6. 

http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
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Figure 13-6: Consultant/IN folder in your Workgroup’s folder 

Step Two: Download Files From Incoming FTP Site 

Part One: Open FTP software 
Click your Start button and go to Programs>WS_FTP LE>WS_FTP LE or double click 
the icon (Figure 13-7) on your desktop. 

 
Figure 13-7: FTP Icon 

When the program opens you should see a Session Properties dialog. Press OK (Figure 
13-8) to log into the FTP site. 
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Figure 13-8: Session Properties 

Part Two: Browse and Pull Files From FTP Site 
In the Local System window, browse to the y:drive and to the folder you just created (i.e. 
y:\pin\8467\00\Highway\consultant\IN).  

On the right side (Remote Site), you should see the folder list, (incoming, outgoing, etc.). 
Open the incoming folder. 

Locate the file that the consultant posted for you in the incoming folder and click on the 
directional arrow (Figure 13-9) between the two view areas. You should start to see the 
progress of the download. If you feel confident that the file was copied to the 
Consultant\IN folder, delete the file from the incoming folder. Close the FTP session. 
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Figure 13-9: Incoming folder using WS_FTP LE ftp.maine.gov   

Step Three: Extract Files from the Zip folder 

Part One: Browse to your PIN’s Consultant\IN Folder 
Navigate to the Consultant\IN folder that you created in your project’s PIN number. Locate 
the file that you just copied from the FTP site. Double click this file to display its contents 
(Figure 13-10). 

 
Figure 13-10: Contents of the zipped folder 

Part Two: Extract Files to Consultant directory 
From the Explorer menu, select File>Extract All… . The Extraction Wizard will open. 
Click Next. The next dialog window allows you to either browse to where you want to 

ftp://ftp.maine.gov/
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place the extracted files or simply remove a portion of the path in the “Files will be 
extracted to this directory” window. Trim off the end of the path until you reach the 
Consultant folder (i.e. y:\pin\8467\00\highway\consultant). Click the Next button (Figure 
13-11).  

 
Figure 13-11: Remove part of the path to the desired directory in the Extraction Wizard 

 We want to extract to the consultant directory temporarily. 

Step Four: Rename Consultant files in Consultant\In 
Folder 

Standard Naming Convention 
We have standard names for files. We ask that consultants follow our naming convention, 
but chances are, some won’t. A complete list of acceptable file names is listed on our web 
site. Here is the address: www.maine.gov/mdot/cadd-
support/microstation/std_filename_root.php. It is up to the Consultant Coordinator to 
rename the files if necessary. Common file names are listed below. 

Alignments.dgn - This is the proposed alignment file. It contains all Main Line and Side 
Road alignments including Curve Data and Bearings.  

Highway.dgn - This is the proposed design file for a Highway project. 

Bridge.dgn - This is the proposed design file for a Bridge project. 

Rwplan.dgn - This is the file that will contain both existing and proposed ROW.  
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Renaming the Files 
To rename a file, select the file and pick File>Rename from Windows Explorer’s Main 
Menu. Type the new file name and be sure to include the file extension. Hit enter to 
complete this process. 

Step Five: Move Files to Bridge\MSTA, Highway\MSTA or 
ROW\MSTA 
MicroStation requires that files be in a certain place for them to be viewable to everyone as a 
reference file. Now you will have to move them into the correct location. Highlight the 
design files in the consultant folder. From the Main Menu, select Edit>Cut. On the left side 
of the window, click on the MSTA folder next to the consultant folder to display it’s 
contents on the right. Select Edit>Paste to place the files into the MSTA folder. 

 You may get a warning stating that there are files in the folder with the same names, 
“Do you want to overwrite them?”. Consider moving the files into an “old” folder 
unless you are sure that they are complete replacements. 

 If you receive a Right of Way file, you may not have permissions to move it to the 
correct folder. Have your ROW technician move this file into the ROW\MSTA 
folder. 

 It is important that all MicroStation files relative to the project exist in a MSTA folder. 
This is where MicroStation will look for files to reference. 

Step Six: Compare with our Files (Optional) 
This is an optional step that might save a lot of headaches for someone in the future. If the 
drawing doesn’t follow our standards, it will be apparent immediately when a person views 
it with our standard drawing files. 

Open MicroStation 
Click the MicroStation icon on your desktop. Select your project number from the project 
pull down. 

Select a File to Open 
Open a file that should be referencing the topography files and the proposed design files (i.e. 
hdplan.dgn or bdplan.dgn). Fit view. The files should line up correctly. 

If all looks good… 
If the files line up good, skip to the next step. If it doesn’t, contact ESSG’s CADD support 
for additional troubleshooting. 

Step Seven: Send Message to Team Members 
After the files have been named correctly and placed in the correct directory, it would be a 
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good idea to send a message to team members notifying them that the files are ready to be 
used. 
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RECEIVING UPDATES FROM A CONSULTANT 
Communication 
Communication is the key for receiving updates from a consultant. The update process is 
when a file can be unintentionally overwritten.  

Is this a Complete Replacement? 
Ask the consultant if the file is a replacement of a previous submittal, or if it’s an addition to 
an existing file or simply a file to be added to the project files. It is better to receive a 
complete replacement unless it took a lot of manual editing on our end to get their file to 
meet our standards. In this case, we can reference and merge only the changes into the 
previous submittal.   

Readme file 
A readme.txt file is a good way for a consultant to describe what their intentions are. 
Encourage your consultant to include this in zip files that they submit. 

Step One: Create an OLD folder 
In order to keep a running record of what was submitted by a consultant, create an OLD 
folder under the workgroups MSTA folder (i.e. \Highway\MSTA\OLD). 

Step Two: Move Older file(s) into the OLD folder 
If a file is going to be completely replaced by a new one, move the older file into the old 
folder. In Windows Explorer, find the file to be replaced. Select it and pick Edit>Cut from 
the Main Menu. Click on the OLD folder on the left side of the Explorer window displaying 
the contents on the right. Select Edit>Paste from the Main Menu to paste it into the “old” 
folder. 

  If you have placed files in the “old” folder already, and they have the same name of 
the files you are pasting, Windows may ask you if you to overwrite them. Select 
“OK”(Yes) to overwrite them. Keep only the latest “old” file. 

Step Three: Copy File From FTP to Consultant folder 
Use the same procedures as previously outlined for copying files from the incoming FTP 
site. This was outlined in the “Receiving Project Files from a Consultant” portion of this 
manual.  If the consultant used the same file name as a previous zip, create an old folder 
under the Consultant\IN folder and move the older zip into the “old” folder. If the zip file 
name is different from any previous, leave all zip files in the consultant\IN folder. 
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Step Four: Extract files, Rename Accordingly and move to 
MSTA Folder 
Use the Extracting procedures as outlined previously in this document (“Receiving Project 
Files from a Consultant”). Rename the file if necessary to follow our standard file naming. 

Step Five: Compare with our Files (Optional) 
This is an optional step that might save a lot of headaches for someone in the future. If the 
drawing doesn’t follow our standards, it will be apparent immediately when a person views 
it with our standard drawing files. 

Open MicroStation 
Click the MicroStation icon on your desktop. Select your project number from the project 
pull down. 

Select a File to Open 
Open a file (i.e. hdplan.dgn or bdplan.dgn) that should be referencing the topography files 
and the proposed design files (alignments, highway, bridge and rwplan). Fit view. The files 
should line up correctly. 

If all looks good… 
If the files line up good, skip to the next step. If it doesn’t, contact ESSG’s CADD support 
for additional troubleshooting. 

Step Six: Send Message to Team Members 
Many team members may be using the files received from the consultant. It is a good idea 
that you send a message to them stating a revision has been made. This will keep the project 
flowing smoothly. 
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PROCESS OF SAVING A SINGLE FILE AS A 
DWG 

Introduction 
Occasionally a consultant may require an AutoCAD file. Find out what version of AutoCAD 
they are using. MicroStation can create the drawing using our file standards. It uses the 
active file’s Global Origin, Level Structure, Units and Color table. It is recommended that 
you use the Batch Converter utility to convert multiple files or files that you haven’t got 
permissions to.   

Step One: Open file to be Converted 
Open MicroStation, pick your project from the project pull down and open the file you wish 
to convert. 

Step Two: Select File Save As… 
Choose File>Save As… from the Main Menu. A dialog will open (Figure 13-12) giving you 
the opportunity to change the file type and directory path. From the “Select Format to 
Save” pull down, select AutoCAD drawing file (*.dwg). Browse to your Workgroup’s 
Consultant\OUT directory (i.e. Y:\pin\8467\00\Highway\Consultant\OUT).  

 If you are trying to convert reference files that you do not have permissions to (i.e. 
RWPlan.dgn), you may not be able to convert these files. MicroStation will attempt to 
write them to their original directory. In this case, browse to somewhere on your hard 
drive and all the files will be written there. Consider using the Batch Converter to 
define an Output directory that you have privileges to. 

 
Figure 13-12: Save As dialog (*.dwg File Format) pointing to the Workgroups Consultant/OUT directory 
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 Put the file(s) in the consultant\OUT directory. This is where you will zip up the 
file(s) prior to placing them onto the FTP site. 

Step Three: Adjust Options 
Select the Options button in the Save As… dialog. In the General tab (Figure 13-13), pick 
the version of AutoCAD the consultant is using by clicking on the current value in the row. 
Units should be set to Feet or Meters. In the DWG Seed File area, click the current value to 
browse to MDOT’s standard seed file folder (i.e. c:\!msv2004conf\standards\seed\DWG 
seed\). Depending on the project type, choose either the usMDOT_SEED.dwg or the 
MDOT_SEED.dwg (metric projects). Place a check mark in the Drop Unsupported 
LineStyles box. This will display our linestyles even though the consultant may not have 
them configured or mapped appropriately.  

 
Figure 13-13: General tab with appropriate selections 

Scroll down to the Fonts portion of the dialog (Figure 13-14). Expand the selection. Place a 
check mark in the box to Convert MicroStation fonts to AutoCAD fonts. Adjust the SHX 
Output Directory to point to the c:\temp folder.  
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Figure 13-14: Adjust the Fonts portion of the dialog 

There are many more adjustments possible on the General tab (Figure 13-14), however it’s 
not recommended that you make other changes unless you are advised to do so from the 
consultant or CADD Support personnel. 

The Remap tab is fine by default. Click on the References tab and adjust your options to 
those seen in Figure 13-15. 



mdot MicroStation 

07/01/07 

Consultant CADD 
Coordination 

13-24 

 

 
Figure 13-15: Save As Reference Tab options 

Select the Filter tab and adjust your options to those seen in Figure 13-16. 
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Figure 13-16: Save As Filter Tab options 

Click OK and then OK again. The file(s) will be created in the same folder as the .dgn. 

Step Four: Zip and FTP the File 
MicroStation will also create resource file that AutoCAD can use to display the same Fonts 
and Linestyles in their drawing. Open Windows Explorer and browse to your C:\temp folder 
and copy all of the .shx files to your Workgroup’s Consultant\OUT folder. 

Browse to your Workgroup’s consultant\OUT folder and Right Click and select 
New>Compressed (zipped) Folder. Rename it appropriately copy your .dwg and .shx files 
into it. Post it to the FTP site. Now that you have a record of what you sent in the Zip file, 
delete the single .dwg file and .shx files. 
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BATCH PROCESSING MULTIPLE FILES TO 
DWG 

Introduction 
If you need to create many DWG files it is quicker to setup a Batch job to do this. 
Sometimes you may need to convert and send the survey files as .dwg. You can add files 
from different directories for conversion also. 

Step One: Open a File 
Open MicroStation, pick your project from the project pull down and open any file, 
preferable one that you do not need to convert. 

Step Two: Start Batch Utility 
From the Main Menu, select Utilities>Batch Converter… The Batch Convert dialog will 
open. Select DWG from the Default Output Format pull down (Figure 13-17). 

 
Figure 13-17: Changing the Default Output Format to DWG  

Step Two: Adjust Options 
Adjust the DWG output preferences by selecting Edit>DWG Save Options. These options 
should be set the same as you would for a single file conversion. See figures Figure 13-13, 
Figure 13-14, Figure 13-15 and Figure 13-16. 

Step Three: Adjust Destination 
In the Default Destination field, click the magnifying glass and browse to your Workgroup’s 
consultant\OUT folder. 

 If you change your mind about the destination you must highlight all of the files and 
select Apply to Selection. 
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Step Four: Add Files to Convert 
Select Edit>Add Files from the Batch Convert dialog. A new dialog will open. Browse to 
the directory that contains the files you want to convert. Select them and click the ADD 
button (Figure 13-18). Browse to other directories and add more files if necessary.  

Select a whole directory of files by selecting a folder in the right panel of the dialog and 
placing a check mark in the Include Subdirectories box (Figure 13-18). Click the Add 
button. Click the Done button when you’re finished adding files or directories. 

 
Figure 13-18: Select Files and Directories to Convert dialog 

Step Five: Process Files 
Select File>Process… from the Batch Convert menu. The Files to Convert dialog will open 
(Figure 13-19). Click the Convert button and it will show you the progress as it process the 
files. 

 
Figure 13-19: Files prepared to convert 
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 Occasionally you will receive a message (Figure 13-20) when a file doesn’t get 
converted. Make note of which files fail during the conversion process. This message 
is very common. It may be because you are in a file that is referencing a file you are 
converting. Click OK. 

 
Figure 13-20: Unexpected Error message – Make note of file name 

When the files have all been processed, the dialog (Figure 13-21) will display which files 
that were converted and which ones may have failed. Click DONE. 

 
Figure 13-21: Dialog displaying the results 

Re-process the file(s) that have failed. This time, select only the file or files that failed and 
place a check mark in the Process Selection Only box (Figure 13-22). Select File>Process… 
to start the conversion on the individual file(s). Second time usually works fine. 

 
Figure 13-22: Selecting files and using the Process Selection Only box 
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When you have finished processing all of the files, close the dialog. It is not necessary to 
save the Batch Convert session.  

Step Six: Zip and FTP the File 
MicroStation will create resource files that AutoCAD can use to display the same Fonts and 
Linestyles in their drawing. Open Windows Explorer and browse to your C:\temp folder and 
copy all of the .shx files to your Workgroup’s Consultant\OUT folder. 

In your Workgroup’s consultant\OUT folder and Right Click and select New>Compressed 
(zipped) Folder. Rename it appropriately copy your .dwg and .shx files into it. Post it to the 
FTP site. Now that you have a record of what you sent in the Zip file, delete the single .dwg 
file and .shx files.
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PPAACCKKAAGGIINNGG  AA  MMIICCRROOSSTTAATTIIOONN  
FFIILLEE((SS))  ––  ((VVEERRSSIIOONN  88  AANNDD  

HHIIGGHHEERR))  
This document is intended for the general user as a guideline to creating a “snapshot” of a 
project as it has reached a critical stage that needs to be preserved or as a means to transfer 
design files to a consultant that does not have our resource (linestyles) and cell libraries 
copied into their MicroStation configuration. In a sense, an archive is a zipped up copy of 
your original file or files and all reference attachments. It compacts the files into a single file 
about half the size of all files uncompressed. 

The MicroStation Packager can package a single or multiple design files, with or without all 
of their reference files. A good example is a plan sheet. If you package a plan drawing (i.e. 
011_HDPlan1.dgn), the Package Utility can include all files that need to be packaged to 
reproduce the drawing. You can also include Workspace items like cell libraries, linestyles, 
fonts and more, however, if the files are going to be used in-house, we will always be using 
our configuration so these options do not need to be stored in the package. If the package is 
going to be shared with consultants, these options will display our files with our symbology. 
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PACKAGING SINGLE OR MULTIPLE FILES 
Step One: Open File to Package (Archive) 
Open MicroStation. Pick your project from the project pull down. Open a file.  

 If you are packaging a single file, open that file. If you are packaging multiple files, 
it doesn’t matter which file that you open. 

Step Two: Open Packaging Utility 
From the main menu, select Utilities>Packager… . This opens the Welcome dialog (Figure 
14-1). Select Next. 

 
Figure 14-1: Create Package Welcome dialog 

Step Three: Enter Package Name 
Use a name that will identify the project from others. A good standard to follow is the PIN-
TownName (i.e. 8467-Topsham). Do not use decimals in the file name. It is not necessary to 
enter a description, but it could be helpful to identify at which milestone it was archived. 
Select Next. 

Step Four: Select Design Options 
Select which design options you want to use. Normally, Reference Files is the only box you 
want to check (Figure 14-2). Select Next. 

 
Figure 14-2: Design Options 
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 If you have images in your drawings, you will want to select Raster Reference Files 
also. If the package was going to be shared with consultants, you may want to 
include other options so it will be displayed correctly with our symbology.  

Step Five: Gather Design Data 
In this step (Figure 14-3), it gives you the option to select the Current Design File, Current 
Directory or Browse to select multiple files to Package. Remove the check mark in the 
Recursive box. This will prevent the Packager from digging down from the current directory 
into sub directories for design files. Make your selection, wait for it to finish processing, and 
then select Next. 

 
Figure 14-3: Create Package dialog – Recursive un-checked 

Current Design File – This option will package the current design file with its reference 
files. 

Current Directory – This option will package all MicroStation design files, AutoCAD 
.dwg and .dxf files. 

Browse – This option allows you to select single or multiple design files to package. Use the 
Ctrl key on your keyboard to pick multiple files. 

Refresh – This will refresh the list of files you have selected. If you uncheck a file that you 
do not want to be packaged, you must hit Refresh to remove it from the dialog window. 

Step Six: Select Workspace Options 
Normally we want to uncheck all of the Workspace Options (Figure 14-4). If the file(s) is to 
be shared with a consultant that doesn’t use our configuration, you may want to select all of 
these options. Make your selection and select Next. 
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Figure 14-4: Workspace Options 

Step Seven: Review Selections 
This is the last opportunity to change your selections (Figure 14-5). You can still hit the 
Back button to go back through the steps. A few extra files get generated automatically. Do 
not delete these files. If all looks good, select Next. 

 
Figure 14-5: Review Selections dialog 

Step Eight: Packaging Options 
This step gives you the opportunity to adjust the location of the package file (Figure 14-6). 
The defaults are usually good unless you want to change the path to another folder location. 
Select Next. 
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Figure 14-6: Adjust Path Options 

 The Retain Design History box is to include the Design History of a file. It is 
basically a history of changes that have happened to the files. It is only as good as 
the information typed in by a user. (Full V8 files only).  

Step Nine: Finish 
Select Finish to begin the Packaging process. 
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OOPPEENNIINNGG  AA  MMIICCRROOSSTTAATTIIOONN  VV88  
PPAACCKKAAGGEE  ((..PPZZIIPP))  FFIILLEE  

It is not necessary to have MicroStation open during the extraction process, however it 
won’t matter either way. These files can also be opened with any Zipping utility (i.e. 
WINZip).  
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EXTRACTING A PACKAGE FILE 
Step One: Locate Package File 
Browse to the location of the package file using Windows Explorer. The file has a .pzip file 
extension. 

Step Two: Open the Package File 
Double click the file to open it. The Properties tab (Figure 14-7) gives you a brief rundown 
of the file.  

 
Figure 14-7: properties Tab in the PZIP 

The Entries tab (Figure 14-8) displays the files that have been packaged. 

 
Figure 14-8: Entries Tab 

Step Three: Set the Location for Extraction of Files 
Notice the Extract To Directory portion of the dialog (Figure 14-8). Adjust the path to suit 
your needs by typing the new path or by hitting the Browse button. 

 If you do not change the directory, you will not overwrite any existing files. It 
creates a folder structure of it’s own within the target folder. 

Step Four: Extracting the Package File 
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Click the Extract button (Figure 14-8). When Prompted to “Launch MicroStation?”, say 
NO! (Figure 14-9) 

 
Figure 14-9: Do Not Launce MicroStation – Click NO! 

  If you say yes, MicroStation will be opened, however, it will not use any of our 
configuration files, therefore will not have our symbology. 

Step Six: Finding the Extracted Files 
When the files are extracted, they are placed in the folder you specified in Step Three, 
however, it creates a series of subfolders within the target folder. (i.e. 
Y:\PIN\8467\00\Highway\MSTA\Workspace\projects\Topsham-8467\dgn). In this 
example, the characters in bold type represent the new folders created. 

Step Seven: Opening, Moving or Copying the Extracted 
Files 
Open the extracted files by select No Project from the Project pull down. You will have to 
browse to the files because they are buried in a subfolder. Because all the files live in the 
same folder, they will automatically display all of its reference files.  

Use Windows Explorer to Move or Copy the files to a desired location. One possibility of its 
use is to replace files that have been corrupted, changed unintentionally, etc. 
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MMIICCRROOSSTTAATTIIOONN  AARRCCHHIIVVIINNGG  
PPRROOCCEEDDUURREESS  ((PPRRIIOORR  TTOO  VV88))  
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EXTRACTING AN ARCHIVE 
Prior to Version 8 (V8), MicroStation used a different program for Archiving. V8 does not 
allow you to create an archive, however, it does allow you to access an existing archive and 
extract the files. After identifying the files you wish to restore from the archive file, the 
Archive utility extracts those files from the archive file and copies them to a directory 
specified by the user. 

Step One: Start Utility 
Select Utility>Archive from the main menu.  

Step Two: Open the Archive 
In the Archive dialog box, click the Open Archive icon.  
The Open Archive File dialog box opens. Browse to your PIN’s Archive folder. Select the 
archive file from which files are to be extracted and click OK. 

 The files which constitute the archive file are displayed in the Archive dialog box's 
list box. 

Step Three: Select Files to Extract 

In the list box, select the files to be extracted. Standard list selection techniques can be 
used to select more than one file. To select all files in an archive use the Select All item 
in the Archive Edit menu. 

Step Four: Extract 

Click the Extract Files icon.  The Extract Archive Files dialog box opens (Figure 
14-10), displaying information about the selected files along with destination options. 
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Figure 14-10: Extract Archive Files dialog 

Step Five: Adjust Settings 

Select the Create Stored Directories option. By default, the Archive utility will not use 
any directories stored as part of the archived file's path. By selecting this option, you 
direct the Archive utility to use stored directories as the destination path.  

 If extracting drawings without referenced files attached, do not select this option. 

Do not select the Overwrite Existing Files option unless your intension is to update the 
files on the network, whether the working drawings or an existing extracted archive. 
Destination will depend on which directories to overwrite. Permissions on the files 
should prevent you from overwriting files in another workgroup. 

 Overwrite should be used with extreme caution. Be absolutely positive that you will not 
overwrite someone else’s work on the network 

 When this option is selected, the extracted file will overwrite an existing file with the 
same name. 

Step Six: Preserve Date and Time 

Select the Preserve Date/Time option. If on, the date/time of the extracted file will be 
copied from the compressed file, preserving its original values. 

Step Seven: Set the Destination 

In the Extract To section (Figure 14-10), click the Select button. The Extract To dialog 
box opens (Figure 14-11). Select a new path for the target directory to which the selected 
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design files will be restored and click OK. This path should be to your workgroup’s 
archive folder in the PIN directory. 

 

Figure 14-11: Extract To dialog 

In the Extract Archive Files dialog box, click OK to begin the file extraction process 
(Figure 14-11). 

 

Figure 14-12: Working… 

The working graphic is displayed (Figure 14-12). 
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Figure 14-13: Information dialog 

The information dialog (Figure 14-13) tells you if MicroStation was successful in 
extracting the files. Click OK. 

Step Eight: Close the Archive Window 
Click the “X” or File>Exit from the MicroStation Archive Window.
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USING ESTIMATOR 
Introduction 
This is a description of how to use the Estimator for producing a cost sheet for pricing a 
project. 

Step One: Getting into Estimator 
First you will need to double click on the icon on your desktop. Once in you will need to log 
in. For that you will need to know the user name and password. Those are Beta for the user 
name and User for the password (Figure 15-1).  

 
Figure 15-1: Log In to Estimator 

Note: you must capitalize the first letter of each in order to get in. 

 Contact CADD Support if you do not have an icon. Experienced users: Map any drive 
letter to \dot0dta1fsaug01\$Com-ProgMan\Highest\ folder. Create a shortcut on your 
desktop by right clicking the Highest.exe program and selecting Send To>Desktop 
(create shortcut). 

Step Two: Starting a new Estimator Project 
Once in you will need to open a catalog of items. There are a couple of selections. Select the 
catalog based on the units in your project. To do so simply go to File > Open Catalog and 
select your catalog (Figure 15-2). 
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Figure 15-2: Select your Catalog 

Next you will have to either select an existing file or you will have to create a new file. To 
open an existing file just simple choose File > Open and retrieve the file of interest. If it is a 
new file you will need to do File > New and an Edit Project Header box (Figure 15-3) will 
appear and you will need to supply some information about your project. 

 
Figure 15-3: Edit Project Header 

The type of information need is as follows: 

Project Name ( Town Name ) 

Contract Number ( the Pin # ) 

Letting Date ( Construction Begins) 

Work Type ( SB, LB, etc. ) 

Select County 

Checked By ( can be left blank ) 

Approved By ( can be left blank ) 

Note: You will find a list of work types on the last page of this document. 
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Once you have provided the information, click O.K. and you will see the Project Header 
Box (Figure 15-4) pop up. 

 
Figure 15-4: Project Header 

Step Three: Adding items to the List 
First you will need to double click on the $0.00 and you will see another box pop up (Figure 
15-5).  

 
Figure 15-5: Empty Project Item List 

Next you need to go to the menu at the top and select Edit > Add this will open up another 
box (Figure 15-6) which will allow you to start selecting the items pertaining to the project 
specified. 
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Figure 15-6: Add Project Item 

Once you select an item you will then need to either hit in the Quantity field with your 
mouse or tab to it, in either case you will need to put a quantity there and then hit Add More 
to continue inputting item numbers and quantities.  

When you are done completing your list just hit O.K. and Cancel, this should then bring 
you back to the list of items within the Project Item List as shown in Figure 15-7. 

 
Figure 15-7: Project Item List 

As you might have noticed that the list is not in numerical order. This is not a problem, you 
can easily fix this problem by simply going to the menu on top and selecting Utilities > Sort 
and this will bring up another dialog box that gives you numerous ways of sorting the item 
list. The most common selection would be sorting by Item Code - Ascending Order as 
shown in Figure 15-8. 
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Figure 15-8: Sort Item List 

Step Four: Editing Existing Data 
It is fairly simple to edit existing quantities already in place and Unit Prices ( ? ) that may 
not come out of the history of the item selected. To do this just click on the value you want 
to change and a box will appear to allow you to edit as shown in Figure 15-9 and Figure 
15-10. 

 
Figure 15-9: Project Item List 

 
Figure 15-10: Edit Project Item Quantity 

Step Five: Printing and Saving 
To print go to the menu at the top and select File > Print and you should receive a display 
like Figure 15-11. 
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Figure 15-11: Print Estimator Detailed Estimate 

You should verify your system printer is correct and you will notice that the default range is 
All, hit O.K. and off to the printer it will go.  

You also can use this item list for the front of your Estimate Book by checking off the 
selection for Do Not Include Prices and printing the document. 

When complete always remember to save your document. The preferred naming convention 
is typical to our PIN structure. For example 00567890.he. Also pay attention to the location 
that the file is being saved to. The process should point to the correct directory 
automatically, but on a rare occasion things do get messed up. The proper directory structure 
that the file should be in is :\Highest\00567890.he 

Project Work Type Codes 
I = Interstate Highway Projects 

R = Rural Highway Construction 

U = Urban Highway Construction 

HOV = Hot Bituminous Overlays 

LOV = Light Bituminous Overlays 

LB = Large Bridge Construction ( 15 m or over ) 

SB = Small Bridge Construction ( Incl. Pipes ) 

BH = Bridge Rehabilitation 

SIG = Traffic Signals 

LIT = Lighting and Signing 

L = Landscape 
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Additional Information 
People should be aware that if the have an item that does not appear in the catalog selection 
set that they should notify Eric Erskine so that the item can be established into the program. 

If you are having difficulty getting access to the program then you will need to speak to the 
appropriate support person to correct the problem. 
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GENERAL INFORMATION 
What is an FTP (File Transfer Protocol) site? It’s a secure drive on a computer, protected by 
a firewall, where files are temporarily stored completely accessible by any outside Internet 
connection. This allows consultants to do business with us while exchanging large amounts 
of data directly from computer to computer. Our FTP Internet address is ftp.maine.gov . 
This can be accessed through Internet Explorer if the recipient doesn’t have FTP software. 
At that point, dragging and dropping files works best instead of Edit>Copy and Edit Paste. 
Consider sending a link in an email to files that are place on our FTP site. 

Files over 10 Mb cannot be transferred via email. The State’s email system stops the transfer 
of large files due to their size and the systems restraints. It is recommended that files over 10 
Mb be transfered to outside sources by using this process. 

General Rules of Thumb! 
• Send a zip (compressed) file when sending more than one file, or files large in size.  

• Use good judgment when naming files. Rather than dumping random files without 
explicit names to the FTP site, always use naming that will make it easy to identify 
your files from someone else’s. (i.e. 8467topsham.zip) 

• Do not create folders on the FTP site. Folders can be created within the outgoing 
folder, but are impossible to remove, due to protections that are set by BIS. Only 
they have privileges to remove them, regardless of who created them. 

• Clean up you own mess! OIT does house cleaning only when the server is too full to 
function. Delete incoming files after you have downloaded them. Tell the 
consultant/recipient that they have permissions to delete the files you posted after 
they download them. 

ftp://ftp.maine.gov/
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USING FTP 
Step One: Open FTP Software 
Click your Start button and go to Programs>WS_FTP LE>WS_FTP LE or double click 
the icon (Figure 15-12) on your desktop. 

 
Figure 15-12: FTP Icon 

When the program opens you should see a Session Properties dialog. Press OK (Figure 
15-13) to log into the FTP site. 

 
Figure 15-13: Session Properties 

Step Two: Browse and Push Files to FTP 
On the right side (Remote Site), you should see the folder list, (incoming, outgoing, etc.) 
and on the left (Local System), see a list of available drives. These are the drives you 
currently have mapped to your computer. 

We have a folder for all outgoing files and a folder for all incoming files. Open the 
appropriate folder for the action you are taking. 

Scroll and browse to the drive and folder where the file exists that requires transferring (i.e. 
y:\pin\8467\00\highway\consultant\topsham-design.zip). When the contents of the folder are 
displayed in the left section of the dialog area, highlight the desired file and click on the 
directional arrow (Figure 15-14) between the two view areas. 
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Figure 15-14: WS_FTP LE ftp.state.me.us 

Use the same techniques to copy files from the incoming folder on the FTP site to a drive 
letter on the network or to your local hard drive. 
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SENDING LINKS IN EMAIL MESSAGES 
(OPTIONAL) 

We can send a hyperlink in an email document that points directly to the file you posted, 
starting the download on their end automatically.  

Or, we can also notify clients when a file is posted and provide them with the HOST 
(ftp.maine.gov ) with the user (anonymous) and the password (anonymous). Then, by using 
a normal Internet browser or some type of FTP software, they can connect to our site and 
find the file and download it manually. 

Step One: Type address to FTP in email 
Type the complete address path and file name, within the body of an email message area and 
the recipient can click the link and select Save to start downloading to a specified location 
on their computer. 

Here is an example: ftp.maine.gov/outgoing/8467topsham.zip. 

 Use forward slashes between folders and never use spaces in the file names. Use 
lowercase for the ftp address and outgoing folder. Match the case of the file name 
you created.  

Step Two: Test the Link 
Even though the link shows up in the body of the email message, clicking it will not 
accurately verify that the link works. Send the email to yourself and test the link the emial. If 
it works, send the email to the recipient. 

Step Three: Add Subject Line and Send 
Add the filename in the Subject line of your email. Provide a brief description of files 
attached. Click Send. 

ftp://ftp.maine.gov/
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UUSSIINNGG  AAUUTTOOTTRRAACCKK  ––  TTUURRNNIINNGG  
RRAADDIIUUSS  SSOOFFTTWWAARREE  

AutoTrack is an add-on program for MicroStation, which is used for evaluating a design for 
turning movements of trucks, and any other large vehicles.  We have purchased a 2 user 
network license, which means that only two users can be running AutoTrack at the same 
time on our network.  Depending on the usefulness and demand for the product, we may 
increase the number of licenses in the future.  AutoTrack must be separately installed on the 
PC of each user that is going to run it. 
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AUTOTRACK INSTALLATION 
Introduction 
The AutoTrack licensing system has been set up on the Dot0dta1fscadd1 server.  The 
installation steps below set up a client PC that will look to that server for its license.  To 
avoid problems with our own customized MicroStation interface, we prefer not to let the 
AutoTrack install procedure “configure” the CAD system for us.  Therefore, please follow 
these instructions carefully. 

Step One: Browse to Folder 
Using Windows Explorer, browse to the Y:\msworksp\AutoTrack folder. 

Step Two: Launch Setup 
Double-click on atr###.exe to launch the installation process (i.e. atr700a.exe). These 
numbers will change as new versions become available. Click RUN to bypass the secutity 
warning. If a previous version is found, you will be asked if you want to unstall manually, 
uninstall previous versions without migrating your custom settings or uninstall and migrate 
your custom settings. If you’ve consciously made adjustments, then migrate your settings, 
otherwise, it may be a good time to start with a fresh install. 

You will be asked if you want to install a Full copy.  Choose Yes. 

Click Next to begin the install program and click Yes to agree to the license terms. At the 
Customer Information page, enter State Of Maine as the User Name and enter Department 
Of transportation as the Company Name. Click Next. 

When you get to the Setup Type screen, choose Custom. 

Uncheck the SavoyCAD (Stand alone version) box and hit Next. 

Click Next through to the last of a set of 5-6 pages, where you should see the version of 
MicroStation that we are using checked as an item in the list, with the path to the 
USTATION.EXE file listed to the right. Click Next.   

Click Next to confirm the installation path. 

Click Next again to confirm the selected components, and Next once more to install 
support for earlier versions of vehicle libraries. 

Step Three: Adjust IP Address 
You should now be at the Network License Setup page. Place a checkmark to signify that 
this is a network version.  In the first IP Address line, enter the address of our 
Dot0dta1fscadd1 server, which is 10  10  19  11.  Click Next. 
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Step Four: Update Advise 
Uncheck the top box to prevent users from being able to run updates. All updates will be 
downloaded, tested and approved for use by the CADD Support Staff. Click Next. 

 Do not attempt to upgrade/download a newer version of the software. Our server 
license is relative to the version we are using at any given time. We will notify you in 
the event of an upgrade that affects us. 

Step Five: CADD Configuration 
You should now be at the Configuration of CADD Systems page.  Uncheck both of 
the options on this page and click Next and click Next again to confirm the default program 
folder. 

Step Six: Finishing up 
On the next page, you can skip the Readme file and click OK to the next dialog mentioning 
the USB license install screen. 

You will need to reboot the PC after the procedure completes. 
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USING AUTOTRACK (BASICS) 
Introduction 

We have purchased a 2 user network license. Only two users can be running 
AutoTrack at the same time. We’ve added menu items to load and unload AutoTrack 
during a MicroStation session. Use AutoTrack then unload it to release the license. 
Closing the file unloads it also.     

Open MicroStation 
Always open MicroStation from your desktop icon or from the Start menu. Select your 
project from the Project pull down. Open any file in your list of drawings. 

Create a New Drawing  
Use File>Make Sheetz to create a new drawing with no prefix called Turning Radius. 

 Refer to 1-18 for more information on the Make Sheetz process. 

 Using a new drawing to design your turning movements keeps this information 
separate from the files that another unit references by default. 

Load AutoTrack 
Start AutoTrack by selecting Utilities>AutoTrack>Load AutoTrack.   

The Welcome dialog (Figure 15-15) should open as well as a new tool bar for AutoTrack 
(Figure 15-16) and an additional menu item called Applications.  
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Figure 15-15: AutoTrack Welcome dialog  

 
Figure 15-16: AutoTrack Toolbar for MicroStation 

Set Default Vehicle (Optional) 
It isn’t necessary to select a default vehicle (Figure 15-15). You will be prompted for a 
vehicle when you hit any of the Drive options. If you do set a default, you will have an 
opportunity to change it after selecting a drive option. 

Set Drawing Settings 
You should always verify your Drawing Settings (Figure 15-15) during each session to set 
your units for AutoTrack, especially since we are producing both metric and U.S. 
Customary projects. 

Start AutoTrack Tutor 
Click on the AutoTrack Tutor icon (Figure 15-15) for guidance in using AutoTrack for the 
first time. It will provide a help screen that is relative to the dialog you are on. 
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For More Assistance, Read the Manual 
The manual and tutor will be your best friend through the first few uses. Contact CADD 
Support for assistance. 
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VIEW AN AUTOTRACK DEMO (OPTIONAL) 
Step One: Start Demo 
Click Window’s Start button and browse to the \Programs\AutoTrack#\AutoTrack 
Tutorial Demonstration program. 

Step Two: View at Your Leisure 
The demo is a good rundown of AutoTrack’s functionality and multiple settings. It’s a good 
idea to watch this 40 minute demonstration. 
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USING AUTOTRACK’S MANUAL AND HELP 
AutoTrack On-Line Manual 
An On-line Manual (in PDF format) can be launched independently from MicroStation by 
selecting Start>Programs>AutoTrack #>AutoTrack Manual In PDF Format… 

It also can be launched from within MicroStation by selecting 
Applications>AutoTrack>Help>AutoTrack Help… from the Main Menu.  

 The Table of Contents is linked to the rest of the document. The PDF document is 
fully searchable also. 

 Do not attempt use the PDF installation instructions. Our installation instructions are 
specific to our workflow and licensing. 

AutoTrack’s Webpage Knowledge Base 
Use AutoTrack’s websites (http://www.savoy.co.uk) to provide assistance also. Once you are at this 
site, you can select SUPPORT, then KNOWLEDGE BASE or KNOWN PROBLEMS and even ask for 
email support. 

http://www.savoy.co.uk/
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MMAAPPPPIINNGG  AA  NNEETTWWOORRKK  DDRRIIVVEE  
Step One 
Using Windows Explorer, go to Tools>Map Network Drive. In the Drive field, pick “O” if 
the drive is available. If not, another will do just fine. 

Step Two 
Select “Reconnect at Login”. 

Step Three 
In the Folder field, enter \\DT00DTA1PCFA102\D drive\ocers_q.  

Step Four 
Click Finish and you should see another explorer window of the new mapped drive pop up 
for you. Close this window. Refer to this drive letter in Windows Explorer to check on plots 
that you send to the OCE9800 plotter.
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SETTINGS MANAGER SCALES 
Overview 
The following scales are available through MicroStations Settings Managers. The scales 
described will inform you on what the absolute scale will be when referencing saved views 
to paper space borders. 

1/32”=1’___________________________________________________________1:384 

 

1/16”=1’___________________________________________________________1:192 

 

3/32”=1’___________________________________________________________1:128 

 

1/8”=1’_____________________________________________________________1:96 

 

3/16”=1’____________________________________________________________1:64 

 

1/4”=1’_____________________________________________________________1:48 

 

3/8”=1’_____________________________________________________________1:32 

 

1/2”=1’_____________________________________________________________1:24 

 

3/4”=1’_____________________________________________________________1:16 

 

1” =1’______________________________________________________________1:12 

 

1½”=1’______________________________________________________________1:8 

 

2” =1’_______________________________________________________________1:6 

 

3” =1’_______________________________________________________________1:4 

 

6” =1’______________________________________________________________1:2 
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12” =1’_____________________________________________________________1:1 

 

1”= 4’_______________________________________________________________48 

 

1”= 5’_______________________________________________________________60 

 

1”= 10’_____________________________________________________________120 

 

1”= 20’_____________________________________________________________240 

 

1”= 25’_____________________________________________________________300 

 

1”= 30’_____________________________________________________________360 

 

1”= 40’_____________________________________________________________480 

 

1”= 50’_____________________________________________________________600 

 

1”= 60’_____________________________________________________________720 

 

1”= 100’___________________________________________________________1200 

 

1”= 200’___________________________________________________________2400 

 

1”= 400’___________________________________________________________4800 

 

1”= 500’___________________________________________________________6000 

 

1”= 1000’_________________________________________________________12000 
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ROADWAY LEVEL STRUCTURE 
This level structure is used for all plan related files. 

Level Name Level Number Level Description 

Default 0  

FRAME 1 Mx Boundary 

BRIDGE_TITLE 2 Title Box Information 

BORDER 3 Border Details 

HIGHWAY_TITLE 4 Title Box Information 

MINOR 5 Minor Grid Lines 

MEDIUM 6 Medium Grid Lines 

MAJOR 7 Major Grid Lines 

H_V CONTROLS 8 PI, PT, PC, Curve Data, Etc. 

H_V ANNOTATION 9 Stationing, etc 

TEMPLATE 10 Roadway (in prof, xsc) 

DTM 11 Triangulation (Mx) 

GROUND 12 Ground&Level strings, spot elevs 

POINTS 13 Mx Points 

SUBGRADE 14 Subgrade limits 

CUTFILLCLL 15 Cut, fill, clearing limit 

CENTERLINE 16 Alignment and Stationing 

ROAD 17 Travelway, Shoulder, Turning 

CRB_SDWK_RAIL 18 Curb,Sidewalk,GRail,Indvdl Posts 

SIGNS_TRAFFIC 19 Traff Items,Pvm Mrk,Signs w_Txt 

ANNOTATION 20 Unless otherwise noted 

PCRB_PSW_PRAIL 21 Prop. Curb,Sw,Grail,Indvdl Posts 

DRIVE_FLD_LOT 23 Drives,Entrs,Field&Lot features 

LAWN FEATS 24 Steps,yardlights,Satel dish,etc. 

ROCKS 25 Ledge, Riprap, Boulders 

BLDNGS_FEATS 29 Buildings,Carports,Slabs,etc. 

PRPTY ENVRN 30 Septic,Wells,Graves,Fences,etc. 

RIGHT OF WAY 31 ROW pins, Stonewalls, etc w_Text 

PBSUPER 33 Prop Bridge Superstructure 

PBSUB 34 Proposed Minor_SubStructures 

MINOR STRUCTS 35 MultiPlate,Box culvert,sm bridge 
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Level Name Level Number Level Description 

BRIDGE DECK 36 All Bridge Deck features 

SUPERSTRUCT 37 NonDeck Superstr,Grdrs,Laterals 

RETWAL_SUBSTR 38 Retwalls,Abuts,Piers,Brg Areas 

OBSCURED 39 Undefined Mapping Area 

BANNOTATION 40 Bridge Annotation 

JUNK 41 JUNK LEVEL 

WATER_DAM 42 Dams&Waterways 'cept wetlands 

WTLND_RARE VEG 43 Wetlands and Rare trees_plants 

TREES_BUSHES 44 Nonpay trees, bushes, not hedges 

PAY TREES 45 Lrg Trees for Pay if Removed 

WATR_VEGT TEXT 46 EnviroFeature & Vegetation Text 

PVEGT 47 Proposed Vegetation 

PVEGTTXT 48 Proposed Vegetation Text 

TEXT 49 Complete Original Topo Text 

UNCLASSED 50 Topo items not identifiable 

PATTERNING 51 Hatching, Patterning, Shading 

CLOSED DRNAGE 52 Closed Drainage Systm,CB's, etc. 

OPEN DRNAGE 53 Open Drainage, not MultiPls Boxs 

DRNAGE INVERTS 54 Open & Closed Drainage Inverts 

PRE VERIFICATION 55 Borings, Test Pits 

PDRAIN 56 Proposed Drainage 

PDRAINTXT 57 Proposed Drainage Text 

UTILS GRND 58 Utilities On or In Ground 

UTILS AERIAL 59 Aerial Utilities (wire carrying) 

PLOT BOUNDARY 60 Plotting Area 

PUTIL 61 Proposed Utilities& Text 

UTILITY TEXT 63 Text for All Utilities 
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ROW LEVEL STRUCTURE 
This level structure is for all Right-of-Way files. 

Level Name Level Number Level Description 
Default 0  
BASE LINE 2 Base line 
CURVE DATA 3 Curve Data 
BEARINGS 4 All Bearings, alignment & bridge 
North Arrows 5 Tentative North Arrows ea. Plan 
CHIEF ENG SEAL 6  
H_V CONTROLS 8 Horizontal & Vertical Controls 
Existing ROW 9 All lines for Exst Right of Way 
ROW REFERENCES 10 All refrnces: Old prjs, Cnty,Twn 
EX ROW NOTES 11 Notes re Existing Right of Way 
EX ROW JUNK 12 Workspace for Exist ROW 
Border 13  
PROPERTY LINES 14 Property lines, prvt easemnts,+ 
PROPERTY NOTES 16 Property notes for Final Plans 
PRP OWNER NAMES 17 Property Owner Names 
PROPERTY JUNK 18 WrkSpace for Prpty Owner work 
PRPTY SETUPS 19 Property Owner Set-ups 
POLITICAL BNDRY 22 County,State,Town Lines 
MISCELLN TEXT 23 Miscellaneous Text 
PROPSD ROW LINES 26 Proposed ROW Lines 
PROPSD ROW NOTES 27 Proposed ROW Notes 
PROP ALONG EXIST 28  
TIE LINES 30 Tie Lines 
TIE STATIONS 31 Tie Stations 
TIE DISTANCES 32 Tie Distances 
PERM EASEMENTS 35 Slope Easements 
TEMP RIGHTS 40 Other Permanent Easements 
BASELN DIST_NTES 46 Baseline Distances & Notes 
CONDEMNTN DISTS 47 Condemenation Distances 
PARCEL DISTS 48 Parcel Distances 
CLRLGD2 50 Color Legend Line1 
Patterning 51 Driveway Hatching, etc. 
JUNK 52 Miscellaneous Workspace 
CLRLGD3 53 Color Legend Line2 
CLRLGD4 54 Color Legend Line3 
PLOT BOUNDARY 60 Border layout for plotting areas 
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STRUCTURAL DETAILING LEVELS 
This level structure is used for all structural detailing files. 
Level Name Level Number Level Description 

Default 0  

Exist_ Structure 15 Existing Structure 

Footing 16 Footing 

Abutment 17 Abutment 

Pier 18 Pier 

Superstructure 19 Superstructure 

Fram_Steel 20 Structural Framing/Stee 

F_S Precast 21 Precast Struc Frm/Steel 

Precast 22 Reserved 

Rebar 23 Reinforcing Steel 

Rebar Text 24 Reinforcing Steel Text 

Retaining Wall 25 Retaining Wall Concrete 

Dimensions 28 Dimensions 

Buried Structure 30 Culverts, Pipes, Arches, Etc. 

Approach 31  

Junk 50  

Patterning 51 Hatching / Filled Shapes 
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PUBLIC HEARING LEVELS 
This level structure is used for Public Hearing Plans. 

Level Name Level Number Level Description 
Default 0  
P:TRAVEL:WAY 1 COLOR-6 
P:SHOULDER:PAV 2 COLOR-253 
P:SHOULDER:GRAV 3 COLOR-180 
P:DRIVES:PAVED 4 COLOR-253 
P:DRIVES:GRAV 5 COLOR-180 
P:PAV:APRONS 6 COLOR-253 
P:SIDEWALKS 7 COLOR-19 
P:SLOPE-GRASS 8 COLOR-244 
P:ISLAND:RAISED 9 COLOR-40 
P:ISLAND:FLUSH 10 COLOR-229 
WETLANDS:MITIG 11 COLOR-106 
REMOV_BLD_TREE+ 12 COLOR-2 
CUT:SLOPE:LINE 13 COLOR-38  W-2 
FILL:SLOPE:LINE 14 COLOR-5  W-2 
P:CENTERE:LINE 15 COLOR-2   W-4 
P:R_W:LINES 16 COLOR-30   W-4 
TEXT 17 COLOR-1 &  VAR---  S&W  VARIABLE 
TRAVEL:LANE:LINE 18 COLOR-1   W-4 
DIR_ ARROWS 19 COLOR-1 
P:SUB:GRADE 20 COLOR-27 
P:BRIDGE:STEEL-1 21 COLOR-240 
P:BRIDGE:STEEL-2 22 COLOR-242 
P:BRIDGE:STEEL-3 23 COLOR-244 
P:BRIDGE:WOOD-1 24 COLOR-176 
P:BRIDGE:WOOD-2 25 COLOR-26 
P:BRIDGE:WOOD-3 26 COLOR-25 
P:BRIDGE:CONC-1 27 COLOR-18 
P:BRIDGE:CONC-2 28 COLOR-17 
P:BRIDGE:CONC-3 29 COLOR-16 
PROPOSED:TREES 30 COLOR-136 
P:DETOURS 31 COLOR-133 
E:TRAVELWAY 32 COLOR-115 
E:SHOULDERS 33 COLOR-116 
E:DRIVES:E:LOTS 34 COLOR-117 
E:BUILDINGS 35 COLOR-21 
E:ISLANDS 36 COLOR-118 
E:SIDEWALKS 37 COLOR-22 
E:TREES:CONIF 38 COLOR-109 
E:TREES:DECID 39 COLOR-39 
E:WOODS 40 COLOR-56 
E:BRUSH 41 COLOR-75 
E:BUSH 42 COLOR-243 
WATER-1 43 COLOR-151 
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Level Name Level Number Level Description 
WATER-2 44 COLOR-153 
WATER-3 45 COLOR-155 
WATER-4 46 COLOR-156 
WATER-5 47 COLOR-157 
DEVERTED-WATER 48 WATERWAYS-DEVERTED-ALL 
E:WETLANDS 49 COLOR-77 
E:WOOD:WALLS 50 COLOR-182 
E:GARDENS 51 COLOR-230 
E:CENTER:LINES 52 COLOR-7   W-3 
E:BRIDGE:DECK 53 COLOR-113 
Level 54 54  
Level 55 55  
Level 56 56  
Level 57 57  
Level 58 58  
Level 59 59  
Level 60 60  
Level 61 61  
Level 62 62  
Level 63 63  

 

This level structure is used for Public Hearing Profiles. 

Level Name Level Number Level Description 
Default 0  
P:TRAVEL:WAY 1  
P:SHOULDER:PAV 2  
P:SHOULDER:GRAV 3  
P:DRIVES:PAVED 4  
P:DRIVES:GRAV 5  
P:PAV:APRONS 6  
P:SIDEWALKS 7  
P:SLOPE-GRASS 8 Survey Horiz. & Vert. Controls 
P:ISLAND:RAISED 9 Text for Horiz/Vert Survey Cntrl 
P:ISLAND:FLUSH 10  
WETLANDS:MITIG 11  
REMOV BLD TREE 12 Ground&Level strings, spot elevs 
GROUND TEXT 13 Ground Text only 
Level 14 14  
Level 15 15  
EX CENTERLINE 16 Apparent Existing Centerline 
ROAD FEATURES 17 Road Feats.(Shldr,Pavement,etc.) 
TRAVEL:LANE:LINECOLOR-1 18 Curb,Sidewalk,GRail,Indvdl Posts 
SIGNS_TRAFFIC 19 Traff Items,Pvm Mrk,Signs w/Txt 
P:SUB:GRADE 20 Roadway,Traff,Crb&Rail Text 
Level 21 21  
Level 22 22  
DRIVE_FLD_LOT 23 Drives,Entrs,Field&Lot features 
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Level Name Level Number Level Description 
P:BRIDGE:WOOD-1 24 Steps,yardlights,Satel dish,etc. 
P:BRIDGE:WOOD-2 25 Ledge, Riprap, Boulders 
P:BRIDGE:WOOD-3 26 Text for Features off Roadway 
P:BRIDGE:CONC-1 27  
P:BRIDGE:CONC-2 28  
P:BRIDGE:CONC-3 29 Buildings,Carports,Slabs,etc. 
PROPOSED:TREES 30 Septic,Wells,Graves,Fences,etc. 
P:DETOURS 31 ROW pins, Stonewalls, etc w/Text 
E:TRAVELWAY 32 Text for Buildings,etc. NOT ROW 
E:SHOULDERS 33  
E:DRIVES:E:LOTS 34  
E:BUILDINGS 35 MultiPlate,Box culvert,sm bridge 
E:ISLANDS 36 All Bridge Deck features 
E:SIDEWALKS 37 NonDeck Superstr,Grdrs,Laterals 
E:TREES:CONIF 38 Retwalls,Abuts,Piers,Brg Areas 
E:TREES:DECID 39 Bridge & Retaining Wall Text 
E:WOODS 40  
E:BRUSH 41  
E:BUSH 42 Dams&Waterways 'cept wetlands 
WATER-1 43 Wetlands and Rare trees/plants 
WATER-2 44 Nonpay trees, bushes, not hedges 
WATER-3 45 Lrg Trees for Pay if Removed 
WATER-4 46 EnviroFeature & Vegetation Text 
WATER-5 47  
DEVERTED-WATER 48  
E:WETLANDS 49 Complete Original Topo Text 
E:WOOD:WALLS 50 Topo items not identifiable 
E:GARDENS 51  
CLOSED DRNAGE 52 Closed Drainage Systm,CB's, etc. 
E:BRIDGE:DECK 53 Open Drainage, not MultiPls Boxs 
Level 54 54 Open & Closed Drainage Inverts 
Level 55 55 Text for All Drainage Elements 
Level 56 56  
Level 57 57  
Level 58 58 Utilities On or In Ground 
Level 59 59 Aerial Utilities (wire carrying) 
Level 60 60 Text for All Utilities 
Level 61 61  
Level 62 62  
Level 63 63  

 

This level structure is used for Public Hearing Sections. 

Level Name Level Number Level Description 
Default 0  
P:TRAV:WAY 1 COLOR-6 
P:SHOULDER:PAV_ 2 COLOR-253 
E:WOOD:BRIDGE-1 3 COLOR-180 



mdot MicroStation 
07/01/07 

Standards 

16-13 

 

Level Name Level Number Level Description 
E:WOOD:BRIDGE-2 4 COLOR-181 
E:WOOD:BRIDGE-3 5 COLOR-182 
P:SHOULDER:GRAV_ 6 COLOR-180 
P:SIDE:WALK 7 COLOR-19 
E:STEEL:BRIDGE-1 8 COLOR-244 
E:STEEL:BRIDGE-2 9 COLOR-245 
E:STEEL:BRIDGE-3 10 COLOR-246 
P:ISLAND:RAISED 11 COLOR-40 
P:ISLAND:FLUSH 12 COLOR-229 
P:SLOPE-GRASS 13 COLOR-244 
Level 14 14  
P:CENTER:LINE 15 COLOR-2 
Level 16 16  
TEXT 17 COLOR-1 & VAR. 
P:LANE:LINES 18 COLOR-1 
DIR_ ARROWS 19 COLOR-1 
Level 20 20  
P:STEEL:BRIDGE-1 21 COLOR-240 
P:STEEL:BRIDGE-2 22 COLOR-242 
P:STEEL:BRIDGE-3 23 COLOR-244 
P:WOOD:BRIDGE-1 24 COLOR-176 
P:WOOD:BRIDGE-2 25 COLOR-26 
P:WOOD:BRIDGE-3 26 COLOR-25 
P:CONC:BRIDGE-1 27 COLOR-18 
P:CONC:BRIDGE-2 28 COLOR-17 
P:CONC:BRIDGE-3 29 COLOR-16 
Level 30 30  
Level 31 31  
E:GROUND-1 32 COLOR-115 
E:GROUND-2 33 COLOR-116 
E:GROUND-3 34 COLOR-117 
E:CONC:BRIDGE-1 35 COLOR-20 
E:CONC:BRIDGE-2 36 COLOR-21 
E:CONC:BRIDGE-3 37 COLOR-22 
P:SUB:GRADE-1 38 COLOR-176 
P:SUB:GRADE-2 39 COLOR-179 
P:SUB:GRADE-3 40 COLOR-180 
Level 41 41  
Level 42 42  
E:WATER-1 43 COLOR-151 
E:WATER-2 44 COLOR-153 
E:WATER-3 45 COLOR-155 
E:WATER-4 46 COLOR-156 
E:WATER-5 47 COLOR-157 
Level 48 48  
Level 49 49  
Level 50 50  
Level 51 51  
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Level Name Level Number Level Description 
E:CENTER:LINE 52 COLOR-7 
E:BRIDGE:DECK 53 COLOR-113 
Level 54 54  
Level 55 55  
Level 56 56  
Level 57 57  
Level 58 58  
Level 59 59  
Level 60 60  
Level 61 61  
Level 62 62  
Level 63 63  
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MDOT STANDARD METRIC CUSTOM 
LINESTYLES 

 

 



mdot MicroStation 
07/01/07 

Standards 

16-23 

 

 



mdot MicroStation 
07/01/07 

Standards 

16-24 

 

 



mdot MicroStation 
07/01/07 

Standards 

16-25 

 

 



mdot MicroStation 
07/01/07 

Standards 

16-26 

 

 



mdot MicroStation 
07/01/07 

Standards 

16-27 

 

STRUCTURAL LINESTYLES 
Samples 

 
Figure 16-1: Structural Linestyles 

Using Custom Linestyles 
Linestyles are activated from the Settings Manager, Structural Linestyles group (Figure 
16-2).  

 
Figure 16-2: Structural Linestyle Options 
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Line styles are scale-dependent. Make sure you select the appropriate scale from the 
Settings Manager (by right-clicking and choosing Category > Scale from the Settings 
Manger) before you make a line style selection. 

Tweaking Line style Size 
Sometimes your lines are going to show up either bigger or smaller than you’d like them to 
be. The Break and Cut line styles are most likely going to be the culprits here -- you may 
want to squeeze a break line into a small area.  

Go through the routine outlined above as a starting point. If the Break line is too big for 
example, select Element>Line Style>Custom from the Main Menu. 

This will open up the Line Styles dialog (Figure 16-3). 

 
Figure 16-3: Line Styles Dialog 

Note that there is an on/off switch labeled Scale Factor: followed by a text field. This is the 
scale, as determined by the Settings Manager, to place your line style.  

 If you want your line style, to be smaller, edit the number in the Scale Factor text 
field. If it is currently 48, changing it to 24 will make it smaller (half as big) and 
changing it to 96 will make it bigger (twice as big.) 
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MX STRING LABELS 
BAB = BRIDGE: ABUTMENT (Bottom) 

BB  = BUILDING: BUSINESS/COMMERCIAL 

BCB = BRIDGE: CURB 

BCL = BRIDGE: CENTERLINE 

BCR = BRIDGE: COLUMN (2 shots on diameter) 

BCS = BRIDGE: COLUMN (Square 3 corners) 

BDK = BRIDGE: DECK 

BEJ = BRIDGE: EXPANSION JOINT 

BFA = BRIDGE: FASCHIA 

BFB = BRIDGE: FOOTING (Bottom) 

BFT = BRIDGE: FOOTING (Top) 

BIL = BRIDGE: RAIL 

BLZ = BLAZED LINE 

BM  = BUILDING: MUNICIPAL/GOVERNMENT 

BP  = BUILDING: PORCH/DECK/BULKHEAD, ETC. 

BPA = BRIDGE: PARAPET 

BPI = BRIDGE: PIER (Bottom) 

BR  = BUILDING: RESIDENTIAL 

BST = BRIDGE: SEAT 

BWT = BRIDGE: WINGWALL (Top) 

BX  = CULVERT: BOX CULVERT 

BZ  = BUILDING: RUINS/CELLAR HOLE/FOUND. 

C   = CENTERLINE 

CAP = CULVERT: CORRUGATED ARCH PIPE 

CB  = CURB: BITUMINOUS (Top) 

CC  = CURB: CONCRETE (Top) 

CE  = CURB: GRANITE EDGING (Sloped Curb) 

CEM = CEMETERY 

CG  = CURB: GRANITE (Top) 

CHEK= CHECK SHOT ON TRAV. / BM 

CMT = CULVERT: MULTI-PLATE 
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CO  = CURB: OTHER (Top) 

CP  = CONCRETE PAD/SLAB 

CS  = CURB: BUMPER 

CU  = CENTERLINE OF RUN 

CV  = CULVERT: TOP 

CY  = CANOPY / CARPORT 

DAM = DAM 

DC  = DRIVEWAY: CONCRETE 

DG  = DRIVEWAY: GRAVEL 

DL  = DITCH LINE 

DMG = DAM GATE 

DNS = DOWNSPOUT (Ditch) 

DO  = DRIVEWAY: OTHER (Must be commented) 

DP  = DRIVEWAY: PAVED 

EF  = ENTRANCE: FIELD 

EP  = EDGE: PAVEMENT 

ES  = EDGE: SHOULDER 

EW  = ENTRANCE: WOODS 

F   = FENCE 

FB  = FENCE: BARBED WIRE 

FC  = FENCE: CHAIN LINK 

FE  = FENCE: ELECTRIC 

FG  = FENCE: GATE 

FLY = FLY POINT (a.k.a. TOPO POINT) 

FP  = FENCE: PAGE 

FPI = FENCE: PICKET 

FPR = FENCE: POST AND RAIL 

FS  = FENCE: STOCKADE/POST/PLANK 

FSR = FENCE: SPLIT RAIL 

FW  = FENCE: SMOOTH WIRE (Non-Electric) 

G   = GROUND: ALL GROUND FEATURES 

GB  = GUARDRAIL: BEAM 

GC  = GUARDRAIL: CABLE 
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GJ  = GUARDRAIL: JERSEY BARRIER 

GN  = GARDEN 

GPI = GAS PUMP ISLAND (Top) 

GU  = GUARDRAIL: OTHER 

HE  = HEDGE 

HWT = HEADWALL: TOP 

KB  = STEPS: BRICK (Must be commented) 

KC  = STEPS: CONCRETE (Must be commented) 

KO  = STEPS: OTHER (Must be commented) 

KS  = STEPS: STONE (Must be commented) 

KW  = STEPS: WOOD (Must be commented) 

L   = LEVEL STRING 

LA  = LAWN 

LE  = LEDGE / OUTCROP 

LF  = LEACHFIELD 

LMB = MULTIPLE MAILBOXES (2 SHOTS) 

LP  = PLANTER 

PALM= ALARM BOX ON POST 

PBDN= BRIDGE: DOWNSPOUT 

PBLD= BOULDER / ROCK 

PBMK= BENCH MARK 

PBOR= BORING LOCATIONS 

PBTH= TELEPHONE: PUBLIC 

PBUS= BUSH/SHRUB (Center) 

PCBI= CATCH BASIN: INVERT 

PCBS= CATCH BASIN: SUMP 

PCBT= CATCH BASIN: TOP 

PCLP= CENTERLINE POINT (R/R Spike) 

PCMN= CONCRETE MONUMENT (General) 

PCTL= GEODETIC CONTROL POINT 

PCUI= CULVERT: INVERT 

PDAT= ANTENNA/TOWER/DISH 

PDIN= DROP INLET 
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PDRO= DRAIN OUTLET 

PDTN= TREE: DEAD (Non-Pay Less than 12") 

PDTP= TREE: DEAD (Pay 12" or Larger) 

PELO= ELECTRICAL OUTLET 

PELV= SPOT ELEVATION 

PFLY= SURVEY FLY POINT 

PGBM= GEODETIC BENCH MARK 

PGGT= GAS GATE 

PGPM= GAS PUMPS 

PGRA= GRAVE / GRAVE MARKER 

PGSO= GAS SHUT-OFF 

PHYD= HYDRANT 

PIPP= IRON PIN / PIPE 

PITT= UTILITY ESCAVATION 

PJCT= CONTROL/JUNCTION BOX 

PLED= LEDGE OUTCROP 

PMBX= MAILBOX 

PMHD= MANHOLE: DRAINAGE 

PMHE= MANHOLE: ELECTRIC 

PMHG= MANHOLE: GAS 

PMHS= MANHOLE: SEWER 

PMHT= MANHOLE: TELEPHONE 

PMHU= MANHOLE: UNKNOWN USE 

PMHW= MANHOLE: WATER 

POLB= POLE: BRACE 

POLE= POLE: POWER POLE 

POLF= POLE: FLAGPOLE 

POLG= POLE: GUY WIRE ANCHOR 

POLJ= POLE: JOINT POWER AND TELEPHONE 

POLL= POLE: STREET LIGHT / LAMP POST 

POLS= POLE: SUPPORT 

POLT= POLE: TELEPHONE / TELEGRAPH 

POLU= POLE: STUB 
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PPCN= POST: CONCRETE 

PPJM= PROJECT MARKER 

PPST= POST: STEEL 

PPWD= POST: WOOD 

PRPL= RARE PLANT 

PRRG= RAILROAD: GATE 

PRSL= RAILROAD: SIGNAL 

PRSW= RAILROAD: SWITCH 

PRTR= RARE TREE 

PRWM= R/W MONUMENT 

PSEP= SEPTIC TANK: SINGLE SHOT 

PRSH= RARE SHRUB 

PSGN= SIGN: SINGLE POST 

PSIL= SILL ELEVATION 

PSMN= STONE MONUMENT (General) 

PSSA= SURVEY TRAVERSE STATION 

PSTT= STORAGE TANK FILL CAP 

PSUR= SURVEY MONUMENT 

PTCN= TREE: CONIFER (Non-Pay Less than 12") 

PTCP= TREE: CONIFER (Pay 12" or Larger) 

PTDN= TREE: DECIDUOUS (Non-Pay Less than 12") 

PTDP= TREE: DECIDUOUS (Pay 12" or Larger) 

PTOW= UTILITY TOWER (Center) 

PTRA= SURVEY TRAVERSE POINT 

PTRR= TREE: ROOT 

PTRS= TREE: STUMP 

PTSM= TRAFFIC SIGNAL: POLE W/ MAST ARM 

PTSS= TRAFFIC SIGNAL: SIGNAL POLE 

PUDO= UNDERDRAIN OUTLET 

PVNT= VENT PIPE 

PWGT= WATER GATE 

PWLG= WELL: GROUND ELEVATION 

PWLT= WELL: TOP 
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PWSO= WATER SHUT-OFF 

PYLT= YARD: LIGHT 

PZZZ= MISC. ITEMS (MUST BE COMMENTED) 

QB  = FIREPLACE / BAR-B-QUE 

QP  = POOLS 

RP  = RIPRAP 

RT  = RAILROAD: TRACKS 

RWT = RETAINING WALL: TOP 

SB  = SIDEWALK: BRICK 

SC  = SIDEWALK: CONCRETE 

SGG = STORAGE TANK: LP GAS, PROPANE, ETC 

SGP = STORAGE TANK: GASOLINE, OIL, ETC. 

SGT = STORAGE TANK 

SGW = STORAGE TANK: WATER 

SLW = SLUICEWAY 

SN  = SIGN: BASE 

SND = SIGN: DOUBLE POSTS (2 SHOTS) 

SO  = SIDEWALK: OTHER (Must be commented) 

SP  = SIDEWALK: PAVED 

SPT = SEPTIC TANK: EXPOSED 

SW  = STONE WALL 

TB  = TREE: TREE LINE (BUSHES) 

TI  = TRAVERSE TIES 

TL  = TREE: EDGE WOODS / TREE LINE 

UE  = UNDERGROUND ELECTRIC 

UG  = UNDERGROUND GAS 

UO  = UNDERGROUND OIL MAIN 

US  = UNDERGROUND SEWER 

UT  = UNDERGROUND TELEPHONE 

UW  = UNDERGROUND WATER 

VA  = WETLAND: ESTUARINE UNVEG.SUBSTR. 

VC  = WETLAND: ESTUARINE EMERGENT 

VE  = WETLAND: PALUSTRINE EMERGENT 
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VH  = WETLAND: PALUSTRINE SCRUB-SHRUB 

VK  = WETLAND: PALUSTRINE FORESTED 

VO  = WETLAND: UNCLASSIFIED 

VR  = WETLAND: RIVERINE UNCONS.SUBSTR. 

VU  = WETLAND: LACUSTRINE UNCONS.SUBSTR. 

VW  = WETLAND: VERNAL POOL 

WA  = EDGE: WET AREA 

WC  = WALKWAY: CONCRETE 

WO  = WALKWAY: OTHER (Must be commented) 

WP  = WALKWAY: PAVED 

WR  = EDGE: RIVER/BK./STR./POND/LAKE 

WX  = PAINTED LINES 

X   = EDGE: TRAVELLED WAY 

YG  = YARD: GRAVEL 

YP  = YARD: PAVED 

ZZ  = MISC. FEATURE (MUST BE COMMENTED) 
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TTEEXXTT  
Accessing Custom Symbols 
We have added a number of characters to our fonts. They can be accessed from the text 
editor by typing a “backslash” and then the number corresponding to the character. 

Note that in these tables, the number corresponding to a symbol is the number above the 
symbol. So to type the Centerline symbol, type “\201” 

The Degrees Symbol 
The degrees symbol can be accessed by typing Shift + 6 (the ^ symbol). 

Font 32: DOT_ENG 

 
Figure 16-4: Character Map of Font 32, DOT_ENG 
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Font 123 DOTITALICS 

 
Figure 16-5: Character Map of Font 123, dotitalics 
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Font 229 (Verdana) 

 
Figure 16-6: Character Map of Font 229, Verdana
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PPRROOJJEECCTT  WWRRAAPP  UUPP  
This portion of the MicroStation Manual is intended to provide the general workflow of a 
project once it has been completely designed and detailed in accordance to the MaineDOT 
standards. It makes reference to many topics already described in previous chapters of the 
manual. As opposed to duplicating this information, we briefly describe the steps involved 
and reference the pages where we describe the topic in great detail. The Sheet Re-numbering 
Utility, the Border Information macro, Batch Printing and the MicroStation Packager will 
be used in this chapter. 
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RE-NUMBERING UTILITY 
Overview 
MaineDOT uses a 3 digit prefix followed by an underscore “_” on every .dgn file that is 
going to be placed in a printed plan package. After the underscore is a standard, sheet type 
identifier (i.e. 001_title.dgn). Sometimes this is immediately followed by numbering for 
sheets of similar types (i.e. 011_HDPlan15.dgn). 

 For a complete list of acceptable file names, please refer to the CADD 
Webpage at the following address: http://www.maine.gov/mdot/cadd-
support/microstation/std_filename.php . 

With the MaineDOT configuration, we take the 3 digit prefix and use it as the page number 
that appears in the title block for each sheet. Therefore, each drawing with the 3 digit prefix 
has a border in it. We have a custom program called the Sheet Renumbering Utility to make 
it easier to renumber/rename your sheets to get them in the correct order. All MicroStation 
users should have this program installed at the same time MicroStation is installed. Contact 
CADD Support if this program is not installed. 

 Regional offices that produce projects that are partially a book job and partially a plan 
package should still use this numbering sequence, but only on the sheets that are going 
to be printed for the final contract drawings. All other areas that are covered by the book 
portion of the project should have the 3 digit prefix stripped from the file name. This can 
be accomplished easily by using the Sheet Renumbering Utility.  

 Do not create sub folders to separate the two portions of a Book/Plan Package. All 
final MicroStation drawing should remain in your workgroup’s /MSTA folder.  

Step One: Start Re-numbering Utility Program 
If the Ying-yang icon is not on your Desktop, you can launch the program by selecting 
Start>Programs>MDOT Utilities>MDOT MicroStation Sheet Renumbering Utility. 

 Close all MicroStation files and be sure that no one is accessing files in your 
workgroups MSTA directory. The program needs to rename the files and cannot if 
someone has one open. 

Step Two: Arrange Files 
Arrange the files that are going to be submitted in the correct ascending order that they will 
fall in the plan package. 

Step Three: Renumber Files 
Click on Renumber Plot Files and the program will place or replace the 3 digit prefix with 
the number in which it falls in the list. 

 Please refer to page 1-22 for more detailed instructions on the Sheet 
Renumbering Utility. 

Coordinate ROW Plans or Other Plans 

http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
http://www.maine.gov/mdot/cadd-support/microstation/std_filename.php
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After the last page number of the plan package is known, let the Right of Way team member 
(or other workgroup) know what number to start numbering his or her plan set with. They 
will then run the Renumbering Utility on their plans. It may be necessary for them to 
Remove the prefixes from their plans (not the colored version) and open Windows Explorer 
and manually add the first number and underscore (i.e. 242_) to the first file name in the 
ROW plan set. In the example above, this will add 241 placeholders prior to the first file. 
Adding this manually would be very time consuming.  
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BORDER INFORMATION MACRO 
Overview and Benefits 
The Border Information macro is used to write the page number into the drawing’s title 
boxes. It also handles placement of many other variables. If this macro isn’t run, many of the 
variables will get filled in automatically at plot time, however, without running the macro, 
the border still retains variables (i.e. @SHEET@, $TOWNORCITY$, $PINNUMBER$, 
etc.) and would get archived that way. 

The benefits are many with this macro. All common title box information is entered only 
once and the macro will populate all the title boxes in all of the border drawings in a matter 
of minutes. If a variable needs to be changed, it can be updated just as fast.  

Step One: Launch MicroStation 
Launch MicroStation from the icon on your desktop or from the Start menu. Select your 
project from the Project pull down. 

Step Two: Select a Numbered File 
Select a file in the list with a 3 digit prefix and an underscore. Click OK. 

Step Three: Start Macro 
From the Main Menu select Macros>Border Information. 

 If you get warning stating that you need to “Close MicroStation and choose a project 
(PIN) that is consistent with your file location” (Figure 17-1), it means that you entered 
MicroStation incorrectly. This is a safety measure to insure that the user is going to write 
the correct information into the title boxes. This is all based on the Project pull down 
matching the PIN you are working on. Close MicroStation if you get this error and go 
back to Step One and try again. If you still get an error, contact CADD Support 
personnel.  

 
Figure 17-1: Close MicroStation and pick correct PIN. 

Step Four: Single or All 
If you don’t get an error, you will be asked if you want to Change Current File or Change 
Project Files. This will enable you to process just a single file or process all of the files in 
the directory that meets the 3 digit prefix requirement. Make your selection. 

Step Five: Review List 
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There is an opportunity to review and remove any files from the list of drawing to be 
processed. 

Step Six: Process Drawings 
Click Cancel to process the list of drawings. This usually takes less than 5 minutes even on 
long jobs. 

 Refer to page 1-27 for more information on the Border Information 
Macro. 
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CLEANUP MSTA DIRECTORY 
All Projects (In-house, Regional and Consultant) 
We would like to preserve the drawings that are used in the plan set (Sheet Files) and those 
used to build the plan set (Reference Files). Drawings that were used temporarily, for 
example, the portion of a book job or unused alternatives, should be deleted if not needed. 
The best time to clean up a project directory is immediately after working on the project 
while you’re still familiar with it. According to the General Consultant Agreement (GCA), 
consultants are required to submit electronic files in addition to hard copies. Please treat 
these projects as if they were designed in-house. 

 Please refer to page 13-1 for more information on Consultant 
Coordination of CADD drawings. 

Delete Temporary files 
Throughout the life cycle of a project, additional cross sections are sometimes produced, the 
design may have been sent in two pieces, multiple alignment files are combined into one file 
and a project could be shortened removing a number of drawings. Any drawings, 
spreadsheets, or text files in the MSTA directory that are not needed and are not referenced 
should be deleted or moved into an “old” folder. Any MicroStation files with a .bak, .old, 
.xxx, etc., can be deleted as they are no longer needed. 

Delete Old Folders 
We create a folder named “old” as a temporary storage bin for copies of older versions of 
files until we know the newest version is OK. If you are certain that all files that are needed 
are in the MSTA directory and only junk exists in the old folder, delete the old folder. If you 
are uncertain of the necessity of the contents of the “old” folder, leave it alone or have 
someone more familiar look at it. If space on the server ever becomes an issue, we could 
delete all “old” folders in the whole PIN structure programmatically.  
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FINAL PRINTING 
Send Title Sheet for Signatures 
The title sheet is the only sheet in the plan package that needs hand written signatures. 
Circulate the hardcopy to the appropriate team members. There is a location on every plan 
page for an Engineer to stamp each sheet if necessary.  This will only occur if a certain 
portion of the plan set was approved by an Engineer other than the one approving the 
Highway or Bridge work. Otherwise, the Engineer Stamp on the Title Sheet governs the 
internal plans in the plan package.  

Once all team members have signed the Title Sheet, deliver it to the Chief Engineer’s Office 
for the final stamp and signature. 

Scan the Title Sheet and Others 
Any sheet that has an Engineer stamp and signature will need to be scanned to the project’s 
CONTRACTS folder (i.e. Y:\PIN\12671\00\CONTRACTS) by the Reproduction staff to be 
included in the final plan package as a PDF document and/or .tiff image.  

 If the PIN number doesn’t contain a CONTRACTS folder or if the permissions to the 
folder will not allow you to scan to the folder, contact CADD Support and the 
permissions will be adjusted. 
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CREATE A MULTI-PAGE PDF  
Overview 
We will use MicroStation’s Batch Print utility to create a multi-page PDF file. This will 
provide a viewable plan set to anyone that has a computer and the free Adobe Reader 
software. This also provides a PDF file available for posting on the web for on-line bidding. 

 A .pdf file is only a “snapshot” of the file at its present state. Any changes made to the 
MicroStation file will not be represented in the .pdf without recreating it.  

Batch Printing to a Multi-page PDF 
Step One: Open Batch Print (DOT) 
Select File>Batch Print (DOT) from MicroStation’s main menu. If you have a saved Batch 
Print “job” file of your final plans, select that or select Cancel and create a new one.  

Step Two: Select the Printer 
Highlight the Printer from the Specifications Control Printing portion of the dialog. Select 
Specification>Select… from the Batch Print dialog. Select the pdf_bwFull printer from 
available printers (Figure 17-2). 

 All other Specifications Control Printing should say MDOT Standard for U.S. 
customary projects or OCE for metric projects.  

 
Figure 17-2: Selecting a printer from the Batch Print utility. 

 Step Three: Add Files 
Select Edit>Add Files… and add the files you want to print. The list of files should include 
all drawings with a 3 digit prefix. These are the drawings with a border to be included in the 
final plan set. Browse to the ROW/MSTA folder and select all 3 digit prefix drawings with 
the exception of a plan set used for presentation purposes. These are identified by a higher 
numbering sequence than the plan package set and are followed by the c_RWPlan root 
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file name. If there are other workgroups submitting plans for the plan package, select these 
sheets also (provided that they have been numbered correctly). 

Step Four: Print to Multi-Page PDF 
Select File>Print… from the Batch Print dialog (Figure 17-3). 

 
Figure 17-3: Select File>Print from the Batch Print dialog. 

Step Five: Add PDF File Name 
When the Print Batch dialog opens, select the Browse button in the Document Set Single 
File Output portion of the dialog (Figure 17-4).  

 
Figure 17-4: Browse to the Contracts folder of your PIN. 

Browse to your project’s CONTRACTS folder. Add a file name and .pdf extension (i.e. 
\CONTRACTS\12671-FinalPlans.pdf) in the Files:  portion of the dialog (Figure 17-5). 
Click OK. 
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Figure 17-5 Print Batch dialog. Add the filename with the .pdf extension. 

Once the path has been set, it will be displayed in the Print Batch dialog (Figure 17-6). 
Select OK to start the printing. 

 
Figure 17-6: Batch Print dialog with the path and file name established. 

The multi-page PDF file will be created in the CONTRACTS folder. 

Select File>Save As… and save the job file as PIN- FinalPlans. Close the utility. 
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ADJUST AND PRINT THE MULTI-PAGE PDF 
Overview 
Prior printing the PDF, it will require some editing. This can only be done by someone with 
PDF Writer software. Either the Reproduction staff or someone with this software can 
finalize the PDF for printing. 

Replace Title Sheet and Others 
Any sheets that required stamps and signatures will have to be replaced. Open the PDF 
document and select the Pages tab. Right-click on a page that needs to be replaced and 
select Replace Pages… (Figure 17-7). 

 
Figure 17-7: Right click to replace a page 

Browse to the replacement sheet that was scanned separately, select it and click the Select 
button. A dialog will open allowing the user to replace the single page or multiple pages at 
once. If all replacement sheets were scanned into individual PDF documents and only one 
image was selected to be replaced, then the dialog doesn’t need adjustment. Click OK 
(Figure 17-8). 
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Figure 17-8: Replace Pages dialog 

 A Warning dialog will appear needing confirmation (Figure 17-9). Click OK. 

 
Figure 17-9: Adobe Acrobat warning dialog 

Repeat for other pages if necessary. 

Rotate Vertical Pages 
Vertical Cross Section pages need to be rotated 90 degrees counter-clockwise so that they 
are printed correctly with the binding edges matching all the other pages in the plan set. 

Select the Pages tab and locate the vertical pages (if any exist). Select the first sheet that 
requires rotating. While holding the Shift key, scroll to the last vertical page. Release the 
Shift key. Right-click on the selected pages and select Rotate Pages… (Figure 1-54). 
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Figure 17-10: Right-click and select Rotate Pages 

In the Rotate Pages dialog (Figure 1-55), adjust the Direction to Counterclickwise 90 
degrees. Verify that the Page Range is set to Selection. Click OK. 

 
Figure 17-11: Rotate Pages dialog 

Save the PDF Document 
Select File>Save from the main menu. 

Print to OCETDS800 
Printing the PDF will require that the OCETDS800 has been added as one of your available 
printers. If it isn’t, open Windows Explorer and browse to the \\Dot0dta1psprt02\ folder (or 
click the underlined link in the electronic document). Double click the OceTDS800-Rm126 
printer in the list (Figure 1-56). 
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Figure 17-12: Double click the OceTDS800-Rm126 to add the printer 

Open the PDF document. Select File>Print. Select the printer from the Printer Name pull 
down. Set the Print Range to All. Place a check mark in the Reverse pages box. In the Page 
Handling portion of the dialog, set the number of copies desired (if more than one, place a 
check mark in the collate box), set the Page Scaling to None,  place a check mark in the 
Auto-Rotate and Center box and place a check mark in the Choose Paper Source by PDF 
page size box (Figure 1-57).  

 
Figure 17-13: Print dialog with adjustment made for a Full Size US Customary project 

Select Properties. Depending on whether you want a Full Size or Half size plot or whether 
it’s a metric or U.S. Customary project, will depend on the settings you choose. Select the 
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Refresh button on the Basic tab to refresh the list of page sizes available and make the 
adjustments necessary. 

o Full Size U.S. Customary Project – Set the page size to Oce D 22x34 in. 

o Full Size Metric Project – Set the page size to Oce D+ 24x36 in. 

o Half Size U.S. Customary Project – Set the page size to Oce B 11x17 in. 

o Half Size Metric Project - Set the page size to Oce B+ 12x18 in. 

In addition to these setting, the half size plots will need one more adjustment. 
Select the Layout tab (Figure 1-58). In the Custom Scale portion of the dialog, 
place a check mark in the Keep Aspect Ratio box. Adjust the Custom Scale to 
50%. Click OK. 

 
Figure 17-14: Adjusting the Custom Scale for Half size plots 

 The Preview portion of the Print dialog will not display the correct dimensions for a half 
size plot, however, the 50% scale will happen when it reaches the plotter. 

Select OK to start printing the PDF. A progress bar will appear displaying the printing 
progress. 
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ACTIVATE DESIGN HISTORY 
Overview 
After the PDF is created, we want to activate Design History on all of the files in your 
Workgroups MSTA directory. What this does is it establishes a point in the files that 
MicroStation can restore to. From this point on, anyone that makes a change in the file will 
need to commit their changes and document a description of the change or exit with out 
committing the changes. This will ensure that any unintentional changes made to any of the 
files can restore back to the Contract deliverables. Any changes made to the legally binding 
electronic drawings will need to be more deliberate. 

Activating Design History in the drawing files will allow the use of the same set of drawing 
files for most of the life-cycle of a project from conception to bid letting. Way too often files 
get altered by the time ROW plans are shipped to the registry for recording. 

 Design History will enable users to roll-back any changes made to a file at any point 
during the design process. We are enabling Design History at the time of plan 
submittal to Contracts. In the future, we may enable Design History in every file as a 
PIN is created. 

 For more information on Design History, please refer to MicroStation 
Help.   

Step One: Open Batch Process 
From the Main Menu select Utilities>Batch Process… to open the Batch Process dialog 
(Figure 17-15). 

Step Two: Select Command File 
We created a standard command file for the purpose of activating Design History for all files 
in your workgroup’s directory after a Contract Submittal. This file also sets a description in 
the Design History that describes the milestone. Select the magnifying glass to browse to the 
Set Design History.txt Command File. Select it and click OK. 
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Figure 17-15: Batch Process Dialog. 

Step Three: Add Files 
From the Batch Process dialog menu, select Edit>Add Files… and select all MicroStation 
design files (.dgn’s) in your workgroup’s MSTA folder.  

Step Four: Select All Files 
Select all files in the list. 

Step Five: Process Files 
Select File>Process… from the Batch Process dialog or click the Process Batch Process 
Job button (Figure 17-16). 
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Figure 17-16: Batch Process dialog displaying Process Batch icon. 

Step Six: Review Selection – Click Process 
A new dialog will appear displaying all the files (Figure 17-17). Click Process to start the 
command. Each file will open and run the command specified in the command file. When 
the process is complete, the Process button will change to a Done button. Close the Batch 
Process dialog. 

 
Figure 17-17: Files to process dialog. 

 It is not necessary to Save the Batch Process session. This is easily created again if the 
need arises. 
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MICROSTATION PACKAGER 
Overview 
The MicroStation Packager is a utility used as a means of creating a “snapshot” of a project 
as it reaches a critical stage that needs to be preserved. The Package is a zipped copy of your 
original files and all reference attachments. It will compact the files into a single “.pzip” file 
about half the size of all files uncompressed.  

 The .pzip file extension can be renamed to “.zip” and opened with any zipping software 
(WinZip or Windows XP’s Compressed Folder Utility) if the need arose. 

Step One: Start MicroStation 
Launch MicroStation from the icon on your desktop or from the Start menu. Select your 
project from the Project pull down. Select a file in the list with a 3 digit prefix and an 
underscore. Click OK. 

Step Two: Create New Package 
Select Utilities>Packager… from MicroStation’s main menu. This opens the Create 
Package dialog (Figure 17-18). Click Next. 

 
Figure 17-18: MicroStation Packager's Welcome screen. 
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Step Three: Enter Package Name 
Use a name that will identify the project from others. A good standard to follow is PIN-
SubmittalType (i.e. 12345-FinalPlans). Do not use decimals in the file name. It is not 
necessary to enter a description in the Description field, but it could be helpful to identify at 
which milestone it was archived (Figure 17-19). Click Next.  

 
Figure 17-19: Enter the Package Name and Description 

Step Four: Select Design Options 
Select which design options you want to use (Figure 17-20). Normally, Reference Files is 
the only box you want to check. Click Next. 

 
Figure 17-20: Select Reference Files as the only Design Option 

Step Five: Select Project Files 
The Add Design button allows the user to Browse and select the files you want to package. 
Select all of the 3 digit prefix files in your workgroup’s MSTA directory used for the final 
plan set (Figure 17-21). Select Open. 
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Figure 17-21: Browse and select all 3 digit prefix drawings only 

 Browse to the ROW/MSTA folder and select all 3 digit prefix drawings with the exception 
of a plan set used for presentation purposes. These are identified by a higher numbering 
sequence than the plan package set and are followed by the c_RWPlan root file name. If 
there are other workgroups submitting plans for the plan package, select these sheets also 
(provided that they have been numbered correctly). 

Uncheck the Recursive option so that all files will fall within a single folder instead of 
reproducing the original folder structure. 

Step Six: Unselect Workspace Options 
Uncheck all of the Workspace Options.  

 If the files are to be shared with a consultant that doesn’t use our configuration, you may 
want to select all of these options. Make your selection and click Next. 

Step Seven: Review Selections 
This is the last opportunity to change your selection. You can still select the Back button to 
go back through the steps. A few extra files get generated automatically. Do not delete these 
files. If all looks good, click Next. 

Step Eight: Package Options 
This step gives you the opportunity to adjust the location of the package file. The defaults 
are usually good unless you want to change the path to another folder location. Place a check 
in the Retain Design History box if not already checked. Click Next. 

Step Nine: Finish 
Click Finish to begin the Packaging process. 

 For more detailed instructions on the MicroStation Packager, please 
refer to page 17-22. 

Step Ten: Extract Archive to Contracts Folder 
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Once the Package has been created it needs be extracted to your PIN’s \Contracts folder. 
This will provide Contracts with the drawings that are needed to be archived into Digital 
InterPlot for future document retrieval via the intranet Webpage. Using Windows Explorer, 
locate the MicroStation Package (.pzip) file that should be in your workgroups MSTA folder 
(i.e. 12345-FinalPlans.pzip). Double-click the file and you will see a dialog describing the 
package. Adjust the “Extract To Directory” path by clicking the Browse button. Set the path 
to your PIN’s \Contract folder. Click Extract and you will be prompted to “Launch 
MicroStation?”  Select NO. 

Step Eleven: Notify Contracts 
Once the files are extracted to the Contracts folder, notify someone in that section so they 
can apply proper permissions to the folder to prevent accidental editing of the final contract 
plans. 





mdot MicroStation 

07/01/07 

Changes During 
Advertising 

(Amendments) 

18-1 

 

CChhaapptteerr  1188  CChhaannggeess  
DDuurriinngg  AAddvveerrttiissiinngg  

((AAmmeennddmmeennttss))  



mdot MicroStation 

07/01/07 

Changes During 
Advertising 

(Amendments) 

18-2 

 

WWOORRKKIINNGG  WWIITTHH  AAMMEENNDDMMEENNTTSS  



mdot MicroStation 

07/01/07 

Changes During 
Advertising 

(Amendments) 

18-3 

 

AMENDMENTS OVERVIEW 
Overview 
Occasionally revisions need to be made to the plans after the contract has been advertised. 
Sometimes the problem can be remedied by an Amendment to the contract book, other times 
the change(s) needs to be made on the plans. This portion of the manual will instruct users 
on how to deal with these changes or Addendums which are now being called Amendments. 

Edits 
It is necessary to “cross out” graphics and notes for all items that have changed. New 
features will be entered using the Settings Manager as normal workflow dictates. A revision 
triangle should be added with a revision cloud if necessary so that all changes are apparent 
to those who have the original set of plans. If the compounded changes result in obliteration 
of the sheet, the word VOID should be written across the page and a full replacement sheet 
provided. 

Incrementing Sheets 
All sheets that have been changed will have a new sheet designation. This is done by adding 
a letter suffix to the original sheet number in the bottom right hand corner of the sheet and 
the actual filename. If the original sheet number was 3, then the revised sheet number will 
be 3A. Likewise, if the original filename was 003_Typical02.dgn, then the new filename 
will be 003A_Typical02.dgn.  

Place Copies with Originals 
When the Amendments are complete, only the files adjusted will be copied into the 
CONTRACTS folder with the rest of the Contract Plans for the project.  
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USE FILES IN WORKGROUP’S MSTA FOLDER 
Overview 
Users should always use the “Legally Binding” original set of drawings that were printed for 
the bidding process. Working on the files requires that the original set were unaltered since 
the final printing. The potential of someone editing or adjusting a file since the final printing 
is high. By applying Design History to all files in the workgroup’s MSTA directory, this 
gives users a record of changes to any given file (if any were made) and the opportunity to 
undo those changes resorting back to the original set at time of Final Plans. If a file has been 
altered since it was printed, the user will receive a warning saying that someone else has not 
committed changes to the file, would you like to take over the changes. The user may review 
the Design History to view a description of changes made if someone made a change 
deliberately. The user can determine what changes have been made and visually see and 
undo the changes. Likewise, when a user consciously makes a change considered to be an 
Amendment, they are prompted to enter a short description of the change. 

If the user doesn’t want to rely on these files because too many changes may have been 
made, the .pzip can be re-extracted into the workgroup’s MSTA directory to recover the 
original files. This places all original files needed to re-generate the final plans into a sub 
folder. A restore can also be done from backup tapes if necessary. 

 For more information on Design History, please refer to MicroStation’s 
internal HELP. 

Saving the Files – Commit Design Changes 
When a user exits a file that has been edited, the Commit Changes dialog opens waiting for a 
description of the change (Figure 18-1). It’s a must to enter a brief description. If the user 
plans on making many changes and wants to enter the description later, he or she can select 
Cancel and still save the changes to the file. Remember to return to the file and make a note 
of the overall changes. 

 
Figure 18-1: Add a brief description to the Commit Changes dialog 
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 If  users have their Preference set so that they Save Settings on Exit, they will receive 
this message regardless if a change has been made to the file. Consider removing this 
preference by selecting Workspace>Preferences from the MicroStation main menu and 
adjusting the Operation category by un-checking the Save Settings on Exit option. 

Adding Elements with the Settings Manager 
Make all the changes that are needed as you normally would during the design phase within 
the proposed design files (i.e. Highway, Bridge, Alignment, etc.). 

Some additional cells (Revision Triangles), linestyles (Cross Outs and Revision Clouds) and 
text (Revision Text) have been added to help the changes stand out from original data. These 
items, when printed in color, will be printed green. 

 When editing the sheet files (files beginning with a 3 digit prefix) remember that some 
sheets do not contain any editable graphics besides the border elements. These will be 
the “plan view” Sheets, Geometric Sheets (Curb Layout Sheets) and Structural Detail 
sheets. The “plan area” visible in Plan Sheets actually reside in other files. These 
changes will need to be made in the proposed design file(s) (i.e. Bridge.dgn, 
Highway.dgn, Multimode.dgn, Alignments.dgn, etc.). Structural details usually reside in 
a “z_” file.  

Add Revision Triangles 
Overview 
If changes span a number of plan sheets, each and every sheet affected by the change needs 
to have a revision triangle, date, description and initials. If the change on a “plan view” sheet 
can be handled with a note or additional graphics, then it would be OK to work on the 
individual plan sheet drawings.  

Revision Triangles 
Each collective change that is made needs to be marked with a triangle that is numbered. If a 
new cross pipe is added to a project, the numbered triangle that represents the change in plan 
view is the same number that will be used on the Cross Section, Estimate Sheet and 
Drainage Sheet for that specific change. Each of the respected sheets needs the triangle 
label. If Riprap is also added to the pipe ends, this item will also use the same numbering as 
the plan view drawing. If a ditch, driveway, catch basin is relocated a new number is 
assigned to the triangle. From the Settings Manager select Symbols & Linestyles>Revision 
Triangle (Large) to label the area in the drawing and select Symbols & 
Linestyles>Revision Triangle (Title Block) to place a triangle in the Signature Blocks. 
Select Qualities>Drop>Complex (Cell, Chain, etc.) from the Main Menu and left-click on 
the triangle, and left-click again any where in the view to Accept the command. Use the Edit 
Text tool or select Text>Edit Text from the Main Menu to edit the text within the revision 
triangle. 
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Revision Clouds 
A revision “cloud” can also be used to better display the area that has changed if it isn’t 
completely apparent with just a revision triangle. Place revision clouds from the Settings 
Manager by selecting Symbols & Linestyles>Revision Cloud and left-click to place a 
shape encompassing the area of change. 

Signature Blocks 
Every file in the list with a 3 digit prefix has a border with a signature block. U.S. 
Customary borders have been expanded to accommodate more revisions whether they are 
Amendments or As-builts. There are lines in the signature block dedicated to revisions and a 
single box for Field Changes (Figure 18-2). The Field Changes section is reserved for the 
governing signatures of the revisions. This is where the Project Manager, Asst. Project 
Manager or Resident would sign the plans as final approval of the As-built plans.  

 
Figure 18-2: US Customary signature block with revision triangles 

Metric plan sets may require an expansion to the signature block to cover the revisions 
(Figure 18-3). Use a variety of MicroStation tools to accomplish this. 
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Figure 18-3: Metric signature block - before and after expanding 

Additional Sheets 
When a new sheet needs to be added into the plan package, whether it’s a full replacement 
or a sheet unintentionally left out, it should fall after the sheet that it normally would and 
labeled using the letter “A” as an increment to the sheet number (i.e. 11A). The file name 
will also use the letter “A” as an increment (011A_HDPlan01.dgn). 

Rename and Copy Files to Contracts Folder 

Part One: Rename Sheets That Contain Changes 
Once all the changes to the plan set have been made, and all sheets have been labeled with 
revision triangles and page numbering updated, open Windows Explorer and manually add 
the letter suffix to the filenames of any sheet that has a revision (i.e. 011A_HDPlan01.dgn, 
101A_XSMC10_dr_001.dgn, etc.). Do not change the file extension or rename a file 
without a border, only a 3 digit prefix drawing.  

 Do not rename any other files besides the sheet type drawings. These are the drawings 
that begin with a 3 digit prefix followed by an underscore. Do not rename “z_” files or 
the state plane correct files (i.e. highway.dgn, bridge.dgn, alignments.dgn, etc) as their 
standard file names are important to maintain. 

Copy Files into Contracts Folder 
Notify the Contract Section that the Amendments have been made. They may need to adjust 
permissions to allow you to place the new files into the CONTRACTS folder of the PIN. 
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Select all new sheet files that have changed. They all will have a letter “A” as the suffix on 
the sheet number. Select all the additional drawings that have had changes made to them. 
These additional may be files such as Bridge.dgn, Highway.dgn, Rwplan.dgn, 
Alignments.dgn, etc. Viewing the modified date on the files may help you tell the 
difference.  

Once all the files that have had revisions have been selected, select Edit>Copy from the 
menu. Browse to the CONTRACTS folder within your PIN (i.e. 
CONTRACTS\Workspace\Projects\12671_FinalPlans\dgn). Select Edit>Paste from the 
menu. You will be prompted to overwrite some files. Select Yes. 

Batch Printing to a Multi-page PDF 
All Amendments needs to be mailed out to all original bidders and added to the web page 
for on-line bidding. Using MicroStation’s Batch Print/Plot Utility, select all of the revised 
sheets and print them to a new multi page PDF file. Browse to the CONTRACTS folder 
and supply a standard name that includes the PIN-Amendments01.pdf (i.e. 12345-
Amendments01.pdf) to describe the new document. Notify the Reproduction staff that the 
Amendments are available for printing. 

 Refer to page 17-10 for detailed instructions on creating a multi-page 
PDF. 

Print Amendments 
The Amendment plans can be printed a variety of ways, but are most efficiently printed 
from the PDF document to the OCETDS800 by the Reproduction staff or anyone with 
Adobe writer software. Rotation of the Vertical Cross Sections may be necessary. 

 Refer to page 17-13 for instructions on printing the multi-page PDF.
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OVERVIEW 
Overview 
A Change Order is issued when changes are needed on the plan set during the Construction 
phase of your project. This Change Order may require re-engineering a structure, retaining 
wall or other detail. Because this project has already been awarded, the revisions made to the 
plan set now will be considered As-Built plan work. The work performed on the files will 
be done in the Const/MSTA folder as a standard.  

The electronic As-Built drawings will be printed using the MicroStation drawings directly 
into the Digital InterPlot Archive and will be printed in color. When printed, all As-Built 
elements will be red, any Amendments will be printed green, existing topography will be 
gray, and the design and Right of Way elements will be black.  

Some final “paper As-Builts” may not get transferred into electronic As-Builts, but if they 
are done using the same concepts and written with RED ink or dark RED pencil, they can be 
scanned in color and placed into the Digital InterPlot Archive. The end product of either a 
scanned paper or an electronic As-Built will be nearly identical when view through a web 
browser. 

 Until electronic signatures are accepted by MaineDOT’s Legal Division and the State’s 
Archivist, plan sheets that require an Engineer’s stamp and signature will need to be 
hand editing (using red pen or dark red pencil) and re-scanned to preserve the legal 
binding document. When the multi-page PDF is created from the electronic CADD files, 
the sheets that have been re-scanned can replace the sheets without signatures. 
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RETRIEVE THE LATEST PLAN SET 
Overview 
To work on the plans for a Change Order, we want to start off with the latest plan set. If 
previous steps are followed properly, the CONTRACTS folder should contain the latest plan 
set with the latest revisions (Amendments). These files will be copied into the Const/MSTA 
folder. 

Copy Contracts Folder Contents to Const/MSTA Folder 
Using Windows Explorer, browse to your projects CONTRACTS folder and browse 
internally to the MicroStation files (i.e. 
CONTRACTS\Workspace\Projects\PIN_FinalPlans\dgn). Select all of the files in this 
folder. Select Edit>Copy. Browse to your PIN’s Const/MSTA folder. Select Edit>Paste.  

End Result 
Use the documentation that follows to make the edits for the Change Order. The end result 
will be all contract plans will exist in the CONTRACTS folder and all of the Change 
Orders/As-Built plans will exist in the CONST/MSTA folder for ease of Archiving through 
Digital InterPlot. 
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CHANGE ORDER/AS BUILT GENERAL WORKFLOW 
Overview 
The files adjusted will be considered the start of As-Builts for the project. Each change will 
be labeled with a revision triangle, encompassed with a revision cloud if necessary for 
clarity and the border initialized with a short description of the change, revision number and 
date. 

An As-Built Settings Manager (Settings>DOT Setmgrs>As-Builts>Type) has been created 
to help users standardize the Level in which new elements are placed for symbology 
purposes.  

Launch MicroStation 
Launch MicroStation from the icon on your desktop or from the Start menu. In the 
Workspace portion of the dialog, use the pull-down next to the User and select As-builts. 
This will point you to the Const/MSTA folder of the PIN you pick from the Project pull-
down. Pick your PIN from the Project pull down. Verify that you are now pointing to the 
path to your PIN’s Const/MSTA folder. 

As-Built Settings Manager 
We have an As-Built Settings Manager that will be used when conducting Change 
Order/As-Built mark-ups. This will automatically load based on the User selection being set 
to As-Builts. The As-Built work done on the paper copy of the plan set will be reproduced 
using the Settings Manager and a combination of MicroStation tools. 
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MAKING CORRECTIONS 
Overview 
This section of the manual was interpreted from a Construction Manual dated 2002. We will 
use these guidelines for doing As-Builts on paper or electronically using our CADD 
package. 

An extra set of full size plans will be furnished to the Resident for use as As-Built plans. The 
Resident may request an additional set of plans from the MaineDOT’s reproduction room 
for As-Builts if needed. Preparation of As-Built plans done on paper shall be done using 
RED pen or DARK RED pencil only. The As-Built plans shall be an exact representation of 
the completed work. All revised plan sheets and sheets with no change must be included in 
the complete As-Built plan set. The Estimate Sheet needs to be corrected to show the Final 
Quantities including additional items of work. 

Saving the Files – Commit Design Changes 
When a user exits a file that has been edited, the Commit Changes dialog opens waiting for a 
description of the change (Figure 19-1). It’s a must to enter a brief description. If the user 
plans on making many changes and wants to enter the description later, he or she can select 
Cancel and still save the changes to the file. Remember to return to the file and make a note 
of the overall changes. 

 
Figure 19-1: Add a brief description to the Commit Changes dialog 

 For more information on Design History, please refer to MicroStation’s 
internal HELP. 

 If a user has their Preference set so that they Save Settings on Exit, they will receive this 
message regardless if a change has been made to the file. Consider removing this 
preference by selecting Workspace>Preferences from the MicroStation main menu and 
adjusting the Operation category by un-checking the Save Settings on Exit option. 

Title Sheet/Others 
Updating Sheets with Signatures 
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Some sheets in the plan set may have required signatures and stamps by an Engineer. These 
sheets will require hand written adjustments in either red pen or dark red pencil. 

The title sheet shall bear the following label in some convenient blank space: AS-BUILT 
PLANS. The initial box will also include who the work performed by (Contractor, if more 
than one contract has been let to complete the work, list all prime contractors), the person 
who prepared the As-Builts (listed in the Revisions box) and the approving signature by the 
Project Manager in the FIELD CHANGES section. 

Scan the Sheets 
These sheets will need to be re-scanned by the Reproduction staff directly to individual 
PDFs and placed into the CONST\MSTA folder. They will need to be included in the As-
Built multi-page PDF document. 

 This process will be required until electronic signatures are accepted by the Legal 
department and the State’s Archivist. 

Editing the Proposed Design 
Overview 
Lines, dimensions and notations shown in the original plans which have been eliminated or 
corrected shall be "X ed" (crossed out) and encompassed with a revision cloud. The As-Built 
Settings Manager contains the same tools and settings that a detailer or designer used 
throughout the life cycle of a design with the addition of some Linestyles and Symbols to 
help standardize the look of As-Built drawings. Select Symbols and Linestyles from the left 
side of the Settings Manager and select one of the components needed from the right. 

Adding “As Built” Elements 
In the past, dashed lines were used to indicate any as-built lines, dimensions, or tie points 
which do not conform to the original plans. Now, all As-Built lines will look identical to the 
previous work done with the exception of its Color (red) and the Level (As-Builts). These 
things may not be evident when looking and working on the As-Builts, but they will be 
when they are plotted in color to the web archive. Level Symbology can be used to better 
display the corrected colors when working on the files. 

When correcting a cross pipe for example, a 2' x 65' 8" (600 mm x 20.0 m) pipe culvert was 
constructed at Station 103+50, whereas the plans called for a 2’ x 63’-3” (600 mm x 19.25 
m) pipe culvert at Station 101+50. The culvert line and the notations describing the work at 
Station 101+50 shall be "X ed" (crossed out). In striking out figures and notations, care 
should be used to avoid obliterating the original figures. From the Settings Manager, select 
Symbols and Linestyles>Cross Out Linestyle to place a series of  “X”s over an existing 
element whether lines or text. The new As-Built culvert and corrected description notation 
should be shown at Station 103+50 by using the As-Built Settings Manager for electronic 
As-Builts or red ink (or dark red pencil) for paper As-Builts. A revision triangle will be 
added and possibly a revision cloud to better display the area that has changed. 

Revision Clouds 
A revision “cloud” can be used to better display the area that has changed if it isn’t 
completely apparent with a revision triangle. From the Settings Manager, select Symbols 
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and Linestyles>Revision Cloud to place a cloud around a change to help make it apparent 
to anyone reviewing the plans. 

Revision Triangles 
From the Settings Manager, select Symbols and Linestyles>As-Built Triangle (Large) 
and place a revision triangle in a visible location near the change or the cloud if one is 
necessary. Use Qualities>Drop>Complex from the main menu to drop the triangular cell 
and the Edit Text tool or Text>Edit Text from the main menu to edit the text in the cell to 
the desired number sequence. Each collective change that is made needs to be marked with a 
triangle that is numbered. If a pipe is added to a project, the numbered triangle that 
represents the change in plan view is the same number that will be used on the Cross 
Section, Estimate Sheet and Drainage Sheet. Each of the respected sheets needs the triangle 
label. If Riprap is also added to the pipe ends, this item will also use the same numbering as 
the plan view drawing. If a ditch, driveway or catch basin is relocated, a new number is 
assigned to the triangle. 

Mandatory Inclusion List 

Grading:  
1. All changes in alignment.  

2. All equations in stationing used during construction.  

3. ?All permanent references for control points. Also, all control points required to 
establish centerline shall be perpetuated. Brass caps and pipe are available for this.  

4. All changes in grade lines and elevations.  

5. Locations and elevations of all benchmarks used during construction or permanently 
established in taking final cross sections. Permanent benchmark should be identified 
by the word "Permanent'. Benchmarks shall be established at box culverts, bridges 
and other locations where they may be considered permanent.  

6. Location and number stamped on brass disc of all Government Survey benchmarks. 
The elevation based on the project level datum, if available.  

7. ?Location of all Right-of-Way markers installed.  

8. Location of all land corner witnesses, existing, or installed by the Project Manager. 

9. Location of all farm entrances constructed showing lengths, diameters and type of 
culverts laid or re-laid. 

10. Location of limits of construction of all borrow pits, channel changes, dikes, 
intercepting ditches, etc., outside the Right-of-Way not covered by extended 
roadway cross sections. The stationing and location of the base line with respect to 
the project centerline shall also be shown.  

Culverts:  
1. All changes in location.  

2. All changes in lengths or dimensions.  

3. The type of pipe installed (CMP, RCP, etc.). 
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Bridges and Special Culverts:  
1. All changes in stationing. 

2. All changes in design.  

3. All revised dimensions.  

4. Deck and bridge seat elevation of bridges.  

5. Maximum and minimum length of piling in each footing.  

6. The description, location and elevation of all permanent benchmarks.  

Surfacing:  
1. Beginning and ending stationing of each type and width of surfacing constructed. 

2. Location of all option pits used in connection with the construction of the project. If 
any plan pits are not used, designate by the words "Not Used".  

Initial Borders 
Every file in the list with a 3 digit prefix has a border with an initial box. For U.S. 
Customary projects, the initial box has been expanded to accommodate more revisions 
whether there are Amendments or As-builts. Currently we have lines in the initial box 
dedicated to revisions and a single box for Field Changes (Figure 19-2). The Field Changes 
section is reserved for the governing signatures of the revisions. This is where the Project 
Manager, Asst. Project Manager or Resident would sign the plans as final approval of the 
As-built plans. From the Settings Manager, select Symbols and Linestyles>As-Built 
Triangle (Title Block) to place a triangle in the Signature Block of the plan sheet. Use 
Qualities>Drop>Complex from the main menu to drop the triangular cell and the Edit Text 
tool or Text>Edit Text from the main menu to edit the text in the cell to the desired number 
sequence. Enter your initials and a brief description of the change. 
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Figure 19-2: US Customary signature block 

Metric plan sets may require an expansion to the initial box to cover the revisions (Figure 
19-3). 

 
Figure 19-3: Metric signature block 

Renaming the Drawing Files 
All sheets that have been changed will have a new sheet designation. This is done by adding 
a letter suffix to the original sheet number in the bottom right hand corner of the sheet and 
the actual filename. If the original sheet number was 3, then the revised sheet number will 
be 3A. Likewise, if the original filename was 003_Typical02.dgn, then the new filename 
will be 003A_Typical02.dgn. 

 Do not rename any other files besides the sheet type drawings. These are the drawings 
that begin with a 3 digit prefix followed by an underscore. Do not rename “z_” files or 
the state plane correct files (i.e. highway.dgn, bridge.dgn, alignments.dgn, etc) as their 
standard file names are important to maintain. 

Batch Printing to a Multi-page PDF 
Using MicroStation’s Batch Print/Plot Utility, select all of the sheets (3 digit prefix 
drawings) and print them to a new multi page PDF file using the pdf_ColorFull plot driver 
and the As-Built pentable. Supply a standard name that includes the PIN-As-Builts (i.e. 
12345-As-Builts.pdf) to describe the new document. 

 Refer to page 17-10 for detailed instructions on creating a multi-page 
PDF. Use the settings described above to create the color PDF. 

 Any sheets requiring an Engineer’s stamp and signature will need to replace non-signed 
sheets in the PDF document (i.e. 001_Title, others that require stamp). 
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Stamped and signed sheets will need to be replaced and vertical cross sections rotated by the 
Reproduction staff or someone with the Adobe writer software. 

 Refer to page 17-13 for instructions replacing sheets, rotating vertical 
cross sections, and printing the multi-page PDF. 

Printing As-Builts 
Hand written As-Builts 
These As-Builts can be scanned and re-produced by the Reproduction staff. These can 
eventually be added into the E-Plans Archive through Digital InterPlot and reproduced at a 
later date. 

Printing (No Signatures) 
The As-Builts can be printed directly from MicroStation to a variety of color plotters, 
however the pages will lack the signatures and stamps. The OCETCS500 plotter located in 
the Reproduction room is an available plotter from within MicroStation. 

Official Electronic As-Builts (with Signatures) 
Once the PDF has been adjusted by replacing sheets with stamps and signatures and rotating 
vertical pages, it is ready for reproduction. 

The As-Builts can be most efficiently reproduced from the PDF document to the 
OCETCS500 by the Reproduction staff. The OCETCS500 plotter produces a high quality 
print in less time than any other color plotters we currently have available. Printing the color 
PDF will require that the OCETCS500 has been added as one of your available printers. If it 
isn’t, open Windows Explorer and browse to the \\Dot0dta1psprt02\ folder (or click the 
underlined link in the electronic document). Double click the OceTCS500-Rm126 printer in 
the list. 

Create a MicroStation Package 
Use the MicroStation Packager to create a new package of the As-Built drawings using the 
standard file name PIN-As-Builts (i.e. 12345-As-Builts.pzip). 

 Refer to page 17-22 for detailed instructions on creating a package. 

Final Review 
The final review will be performed. After the final review is completed, the specified sheets 
or complete copies, as requested by the District, will be copied in half-size sets. The copies 
will be returned to the District within three (3) to four (4) weeks after submittal to the 
Project Manager (Is this still done? What District?). Consider sending a Portable plan sets 
from Digital InterPlot. 

Distribution of Plans 
The As Builts will be submitted to the Project Manager with the final records for filing with 
notification of the number of complete copies or specified sheets desired.  

Cities, counties, etc. that have money involved or a special interest in the project will be 
asked by the Project Manager if they need/want a complete copy of the As Builts or only 
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specified sheets. Electronic copies will be available as Portable Plan sets from Digital 
InterPlot once the As-Built archive is complete. 

Submit a copy of the As Builts to the Transportation Planning Division for their use. (Is this 
still done?) Upon completion of their work, the Transportation Planning Division will 
periodically return the full-size As Builts to the District, via truck. 

Lighting and Signals - On all roadway lighting and signal projects, a set of "as-builts" will 
be prepared, pertinent to the wiring alignment, showing the exact location of conduit or 
cable runs, pull boxes, and any other information which would be beneficial in case of 
maintenance problems or construction activities in the area. When "as-builts" are submitted 
to the agency at the time the agency is notified by letter of the acceptance of the installation 
and to assume the maintenance.
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ABOUT THE E-PLANS ARCHIVE 
Overview 
The E-Plans Archive is MaineDOT’s Electronic Plans Archive. It is a web-based, large 
format document management system similar to TEDOCS. The software powering the web 
archive is called Digital InterPlot, which is a product of Bentley Systems, Inc (the owners of 
MicroStation, InRoads and MX). Digital InterPlot (D.I.) is available to all MaineDOT 
employees who have access to the Intranet. Users can search for projects based on over a 
dozen filtering options and print them if necessary. The E-Plans Archive is currently 
organized in categories such as Vault Plans and Property Plans (R/W). There may be 
additional categories in the future. D.I. may also facilitate in producing an electronic set of 
plans for the on-line bidding process available to Contractors on the Internet. You can access 
D.I. by clicking the following hyperlink  http://dot0dta1asiis02/plansweb/dpr.asp. You can 
also access from the MDOT Home page by selecting E-Plans Archive. 

Vault Plans 
The Vault Plans that were once stored in hanging file racks are now available on the Intranet 
through Digital InterPlot electronically. They are viewable, measurable and ready to be 
plotted to scale through a web browser (i.e. Internet Explorer). 

Property Plans 
This Archive will be where Right-of-Way property maps (old hanging files), miscellaneous 
Survey documents, POR documents and tax maps will be stored and made available through 
the E-Plans Archive. 

http://dot0dta1asiis02/plansweb/dpr.asp
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GETTING STARTED 
Accessing the Web Page 
The link to our Electronic Plans system on Digital InterPlot is: 
http://dot0dta1asiis03/plansweb/DPR.asp . We recommend that you save this link as a 
Favorite in your web browser.  

A link to the page can also be found on the MaineDOT Intranet page (MDOTWEB). Figure  

 
Figure 20-1: E-Plans archive via MDOTWEB page 

One Time Installation 
On the "home page" of our Electronic Plans system, you will see a list of available archives. 
You can either Browse or Search these archives. These instructions will cover enough of 
both to get you started, and to help in reviewing the Sample Images.  

http://dot0dta1asiis03/plansweb/DPR.asp
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On your first time in to Digital InterPlot, when selecting a plan sheet to open by clicking on 
its thumbnail image, your PC will need to install the Bentley Web Viewing Control. You 
may get a Security Warning asking if you want to install this control.  If so, click Yes . 

Check Yes, I accept the agreement  

Click OK  

   The above is a one-time procedure. Afterward, you go directly to the plan sheet 
that you select.  
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BROWSING AN ARCHIVE 
Simple Browsing and Viewing 
The archive that we are using for this example is called VaultPlans. This archive contains 
plan sets that were scanned from our Vault. You can use either the Folder icon or the 
Browse tab to get to a page that lists the plot sets within the archive (Figure 20-2). In that 
list, the items in the Plot Set Name column are linked to the corresponding plot sets.   

 
Figure 20-2: Browsing an Archive 

Click on a Plot Set Name to select a plot set.  You are then presented with a list of thumbnail 
images of the sheets in the set.  Click on an image to view the full sheet.    

Note the index data for the plot set is listed at the top of a Table of Contents frame on the 
left of your screen (Figure 20-3).   
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Figure 20-3: Table of Contents Frame 

Viewing a Selected Sheet 
Notice that there is a link titled "Hide Table of Contents Frame" near the top left of the main 
frame (Figure 20-3).  This will provide more room on your screen to browse the sheet you 
have selected.  There are several controls available in a right-click menu to Pan, Zoom, 
Window an Area, Fit View, Rotate, Plot, Measure, etc (Figure 20-4).   

 
Figure 20-4: Right Click menu items 
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Icons are also available at the lower left of the view screen (Figure 20-5) to do some of these 
functions.  These icons will be familiar to MicroStation users. 

 
Figure 20-5: View controls 

Advanced Searching 
Two Stage Search 
If you don't know the specific Project Number or PIN that you are looking for, it will be 
more efficient to do your search in two stages.  In the first stage, you will search for title 
sheets of all the projects that meet your criteria. (A Town would be the most likely.)  When 
you have found the title sheet for the project you are interested in, note the Scan Project ID.  
The second stage will be to search on that number as a Plotset ID.  This results in all the 
sheets archived from the selected project. 

Example: 
Sheet Type:  *Title* 

Town(s):       *Topsham* 

Among the results is project I-95-5(47)74.  The plans for this project have Scan Project ID 
1185.  A second search, on Plotset ID 1185, yields 22 sheets from that project.  If we had 
done a single search for plan sheets in Topsham, we would have had 266 sheets to wade 
through in order to find what we need. 

The advantage of this Two Stage search procedure is that you don't have to browse through a 
huge number of sheets to find your project! 

 Due to the design of the index database, there is a field, shown as Scan Project 
ID, associated with individual sheets, and another field, shown as Plotset ID, 
associated with plot sets.  While these are technically different fields, their 
meaning to us is the same, and they can be used as a key to retrieving the sheets 
from a particular project, as in the above example. 

State Aid Plans 
We have scanned some State Aid plans into the VaultPlans archive, which do not have title 
sheets.  Therefore, you can't find them via the Two Stage Search described above.  However, 
we have Region, Division, and SA designations in the Source File Location field.  Use the 
following example to search for all of the State Aid plans in a particular town 

Example: 
Source File Location:  *SA* 

Town(s):       *Winthrop* 
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You can then use the Sort By pull down in the Results page to help in focusing in on the 
plans you need. 

Right of Way File Numbers 
Right of Way plans are located in the Property Plans archive. Most of the plans have a 
ROW File Number. The file number in Digital InterPlot will consist of a six digit number. 
The ROW File Number contains a hyphen. You will need to substitute a zero “0” in place of 
the hyphen. Add a preceding zero to the number to the left of the hyphen if the number is a 
single digit. Add one or more preceding zeros to the number to the right of the hyphen so that 
the number is a total of 3 digits. 

Example 
ROW File Number: 2-58 

Digital InterPlot #: 020058 

 

In some cases there will be a letter included at the end of a ROW File number. Tack this 
letter to the end of the file number. 

Example 
ROW File Number: 2-129 A 

Digital InterPlot #: 020129A 

 

In some cases there will be a letter included at the beginning of a ROW File number. Tack 
this letter to the front of the file number. Do not use a hyphen. 

Example 
ROW File Number: S-2-179 

Digital InterPlot #: S 020179 

Limit Your Criteria Fields 
Fill in only the fields that are important in defining your search, using wildcards 
appropriately (see below).  Filling in too many fields may limit your search in ways that you 
do not intend. 

Wildcards 
Originally, the % sign was used as the wildcard character in the search criteria, and searches 
were case sensitive. We have modified the programming to allow the asterisk as a wildcard, 
and to make the search insensitive to the case of the entered search criteria. 

It's generally a good idea to use a wildcard on either side of the text in a criteria field.  For 
example, *Brewer* in the Town(s) field would return plan sheets in any plot set where 
"Brewer" is included in the field, including entries like "Bangor, Brewer".  Specifying a town 
name without the wildcards will cause the search to miss records where the specified town is 
one of several in a list. 
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Practice 
As you experiment with searching the archive, you will get a better feel for what works and 
what doesn't.  Maybe you'll even come up with some suggestions we can use in this Hints 
and Tips list! 
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MEASURING A E-PLAN IMAGE 
Overview 
Digital InterPlot assumes a 300 dpi image when it calculates scales.  Our Black and White 
images are 300 dpi.  However, our color images are 200 dpi.  Therefore, when setting scales 
for plotting or for measuring (color images only), there is a "fudge factor" involved.  We, and 
some of the other customers, are urging Bentley to modify their software to automatically 
adjust the calculation, depending on the image resolution, without the need for a fudge 
factor.  Until that is done, there is a ratio of 300/200 (or 150%) that needs to be applied to the 
scale setups for color images.   

If you see shades of gray in the image, especially in the background, it is most likely a color 
image. The black & white images have no gray in them and have a crisp white background. 

Configure Ruler 
Before measuring either distances or areas, you need to complete the settings under 
Configure Ruler in the Measure menu. You first enter this menu system by a Right-Click 
on the image, then choose Configure Ruler (Figure 20-6). 

 
Figure 20-6: Entering the Ruler Configuration 
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Example 25 ft per 1 Inch 
The image below (Figure 20-7) illustrates the setup for a scale of 25 feet per inch.  Note that 
we have indicated that we will measure in Model Units, and that 1.00 inches on the paper 
equals 25.00 feet in the model (or on the ground in our case). For a color image, the settings 
would be 1.00 inches on the paper equals 37.5 feet in the model, due to the "fudge factor" 
discussed above. 

 
Figure 20-7: Setup for 25 feet per Inch 

 We recommend that you do a test measurement on a known distance, such as a 
station interval, to confirm that your ruler setup is correct before you do a series 
of measurements. 

Other Setups 
You need to know the scale of the drawing you are measuring, in order to set the Ruler 
correctly.  It is possible to set up for any scale ratio.  You must remember to add the 150% 
"fudge factor" when measuring on our color images.  Here are some typical setups for plan 
view drawings (Figure 20-8). 

 
Figure 20-8: Typical drawing scale setups 

Measuring Distance 
Choose Measure - Distance from the Right-Click menu.  Click on the first point, then click 
on the second.  You should see the measured distance in the lower-right border of the 
drawing window (Figure 20-9).  You can continue measuring a cumulative distance, from 
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point to point to point.  One tap on the ESC (Reset) key will reset the measurement to zero.   

Two taps on the ESC key will back you out of the Measure Distance command. 

 
Figure 20-9: Distance is displayed in the lower right hand corner 

Measuring Area 
Choose Measure - Area from the Right-Click menu.  Click on the first point, then click on 
the second, and continue to define a polygon to be measured.  You should see the measured 
area in the lower-right border of the drawing window (Figure 20-10).   One tap on the ESC 
(Reset) key will reset the measurement to zero and clear the polygon.    

Two taps on the ESC key will back you out of the Measure Area command. 

 
Figure 20-10: Area measurement displayed in lower right hand corner 
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PLOTTING (PRINTING) A SELECTED SHEET 
Overview 
There are several variations available in methods for printing and plotting.  We'll discuss a 
method here that should be appropriate for most situations.   

Plot to Form 
From the right-click menu, select Plot to Form (Figure 20-11).  You can choose any printer 
or plotter that is set up in Windows on your PC. 

 
Figure 20-11: Right Click, select Plot to Form 

   

 Refer to page 1-32 for a list of available plotters and how to add them as a 
Windows Printer. 

Once you choose a printer or plotter, you should click on the Properties button to select the 
appropriate sheet size (normally D+ or Arch D) and orientation (normally Landscape).   

 To plot only a portion of the sheet, select a different page size such as 8 ½ x 11. 
The shape on your cursor will be adjusted to this size. 

After you click OK on Properties, you need to set up the scaling of the plot. 

Black and White Images 
Digital InterPlot scales correctly with our black & white images, which were scanned at 300 
dpi. If you are printing from a black & white image, select Plot at Original Scale. To get a 
half size plot, use 50.0 in the Scale Percentage field.  

 Color Images 
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However, we have to set a scaling factor to get the proper sizes in our color 200 dpi images.  
To get a plot from a color image at full scale, use 150.0 in the Scale Percentage field. To get 
a half size plot, use 75.0 in the Scale Percentage field. 

Place the shape 
Place the sheet frame on the image with a left-click of the mouse. The original may have 
been wider than the sheet frame. This procedure lets you decide which margins to crop off to 
make the plot fit well. 

Confirm by responding Yes to the Plot Selected Area question (Figure 20-12).  

 
Figure 20-12: Plot selected area? 

 You can answer No at this time if you have changed your mind. 
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USING A DOCUMENT POOL 
Overview 
A Document Pool is a collection of digital plots (DPR files).  The following is a summary of 
the use of the Document Pool for printing: 

Add Single files to the Document Pool 
From the "Plot Set Table of Contents" page or the "Archive Results" page, click the 
check box next to the thumbnail.  Check as many sheets as you want on this page (Figure 
20-13). 

 
Figure 20-13: Place a check in the box next to the image 

Click the "Add to Document Pool" icon (+) next to the check box (Figure 20-14) to add the 
document(s) to the document pool. 

 
Figure 20-14: Click the Plus sign (+) next to the check box of the image 

  You can repeat these first two steps to add sheets from other pages to the 
Document Pool. 

Add Multiple files to the Document Pool 
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Part One: Display all Documents on one Page 
If you have isolated the search to display only the pages you wish to print, you can add them 
all at once to the Document Pool.  

Only five images are displayed in the thumb nail view by default when the results of a search 
are displayed in Digital InterPlot. Towards the top left of the window (Figure 20-15) you 
will notice the Number of Records Found for the search (i.e. 65). The Records per page is 
only displaying 5 at a time. 

 
Figure 20-15: Number of Records Found and the Records per Page 

Part Two: Change the Records Per Page 
Change the Records per page to the Numbers of Records Found. Type in 65 in the Records 
per page box and hit Enter. The page should now display all 65 images (Figure 20-16). 

 
Figure 20-16: Records per page matching the Number of Records 

Part Three: Select all Documents 
Select all the images at once by clicking the check mark in gray bar above all the images 
(Figure 20-17). This will place a check mark next to all the images on the page. 
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Figure 20-17: Select all the images at once 

Part Four: Add to the Document Pool 
Click the Plus Sign (Figure 20-18) next to the Check Mark to add all the images to the 
Document Pool. 

 
Figure 20-18: Click the Add button to add all images to the Document Pool 

 The last icon next to the Check Mark will Clear all of the documents (removes 
the check mark next to all the images).  

Removing Documents from the Pool 
From the Digital InterPlot page, click the "Document Pool" tab. Click the check box next to 
the thumbnail to select the document (Figure 20-19). 

Click the "Remove from Document Pool" icon (-) next to the document name.  
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Figure 20-19: Images in the Document Pool 

Printing Documents in the Document Pool 
If you are satisfied with the documents in the pool, select the Check Mark above all the 
images to select them all (Figure 20-20). 

 
Figure 20-20: Check All button 

 Pick Print Pool towards the top right of the page. This opens the Digital InterPlot Document 
Pool Printing window (Figure 20-21). By right clicking, you have an option of sorting, 
deleting or moving a document to get them in the correct order. 

 
Figure 20-21: Right Click to sort or move a document 

To print all the documents in the Print Pool, click Print. 
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The print dialog box then comes up, where you can make settings, as you do for other 
methods of printing. 

 Refer to page 20-14  for picking a plotter and adjusting the settings. 
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SAVING AN IMAGE TO DISK 
Saving a JPG Copy of Image 
At the very bottom of the view page, there is a link to a JPEG image file of the selected plan 
sheet.  As with many web sites, you can right-click and do a Save As to get your own copy 
of the image to use however you need. 
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DISPLAY FIX 
Overview 
On some PC's, especially some of Maine DOT's laptops, you may see a display problem 
when viewing a sheet through DI, InterPlot Organizer, or the Portable Plan Set viewer. The 
image will appear as if it has been “shredded” (Figure 20-22). The fix for that problem is to 
set the following two variables in Windows at the System level: QV_SWCONTEXT=1 and 
QV_NOPBUFFER=1. 

 
Figure 20-22: Image on a PC that requires the Windows System Variable 

Add Windows System Variable 
Step One: Right Click My Computer 
Right click the My Computer icon and select Properties. 

Step Two: Select Advanced Tab 
Select the Advanced tab and click on Environmental Variables (Figure 20-23). 
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Figure 20-23: select the Environmental Variables button 

Step Three: Add new System Variables 
Select the New button in the System Variables section. Add the two new variables 
(QV_SWCONTEXT=1 and QV_NOPBUFFER=1) and their values as shown in Figure 
20-24. 

 
Figure 20-24: Add the variables and their values 

Once the variables have been added, you should be able to locate them in the list of System 
Variables (Figure 20-25). 
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Figure 20-25: New variables added to the System Variables 
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DATA FIELD DICTIONARY 
Fields in Vault Plans Search Page 
Plot Set Name 
This field comes from the file name of the IPS file used to create the plot set. For our scanned 
Vault Plans, this filed is derived from the Project Number. In the Browse Page, this is the 
field with the attached link to go to the plan sheets in the set. 

Sheet Name 
This field comes from the file name assigned to the image when Smooth Solutions did the 
scanning. It is normally the sheet number, padded to at least 3 places. For example, sheet 2 of 
the plan set becomes 002. When there are sheets added in between, or the scanners found two 
or more of the same sheet number, Sheet Names like “002A” are created. 

Sheet Type 
This is the type of sheet, as interpreted by the scanners, from the following list: 

Title, Typical Sections, Standard Details, Estimate, Drainage, Plan, Profile, Plan_Profile, 
Xsections, Geometry, Highway_Other, RWPlan, Bridge_Abutment, Bridge_Pier, 
Bridge_Superstructure, Bridge_Details, Bridge_Other, Other 

Project ID Number (PIN) 
This field is the PIN that we use on newer projects. Projects started before 1982 did not have 
PINs assigned. 

Source File Location 
In the case of the Vault Plans, this field is used for the “Rack ID” where the plans were 
stored. It can be useful in comparing with the earlier Vault Plans Index. 
In the case of Right of Way Plans, this field is used to indicate where the scanned plan was 
stored. This field, along with the ROW File Number can be used in comparing with the old 
RW Plans Index. 

Project Name 
This field was intended for the name and/or description on the title sheet of the plans. 
However, the process of transferring data from the old Vault Plans Index has resulted in the 
contents of this field usually being the same as the Scope/Description field (which is 
normally the same information). 

Project Number 
This is the Project Number as shown on the Title Sheet. This is likely to be a Federal-Aid 
Project Number with various initials or abbreviations in it. The format of these numbers 
varies widely. The early projects had very cryptic numbers. 

ROW File Number 
This field contains a number assigned by our Right of Way staff to track the RW Plans. It 
will be blank in plot sets that are not RW Plans. 

Year 



mdot MicroStation 
07/01/07 

Digital InterPlot 
 

20-26 
 

Ideally, this is the year that the project was constructed. However, the old index was 
incomplete and lacked this information on many projects. In these cases, we have instructed 
Smooth Solutions to use the latest year they can find on the plans. If they have searched and 
cannot find a date, they are to enter “NONE” to indicate that the search was made and no 
date was found. 

Route Number(s) 
This field contains the route number, from a standard list, for most highway projects. 
Unfortunately, most of our bridge projects do not list a route number on the plans, relying 
only on the bridge number. There can be multiple route numbers listed on a project. 

Route Code 
This field contains an MDOT route code, which has been used by Planning and others, and 
relates directly to the route number. This field will provide more precise search results if you 
know the code for the route you are looking for. 
On projects which did not have a Route Number listed in the old index, we do not have a 
Route Code entered. 

County 
This field can have more than one county in it, when projects cross county lines. 

Bridge Number 
This field can have more than one bridge number in it, when multiple bridges are involved in 
the project. 

Town(s) 
This field can have more than one town in it, when projects cross town lines. 

Scope / Description 
The contents of this field were taken from the old indexes. Many of these entries include four 
letter “scope codes.” We have a list of the scope codes, which will be published with our 
online documentation for the Plans Archive. 

Scan Plotset ID 
This field is essentially a “serial number” for the Plot Set (project) as it is processed into the 
Digital InterPlot system. Each plot set will have only one Scan Plotset ID. This field can be 
useful in doing a two-step search, where you get a list of title sheets meeting your search 
criteria, identify the project you want, then search for all sheets belonging to that plot set. 

Sheet Fields 
Sheet 
This field is a number generated by Digital InterPlot. A “3” in this field means that this is the 
3rd sheet entered. When additional sheets are inserted, such as sheet 3A, or when sheets are 
missing from the set, this number does not match the sheet number on the plans. 

Sheet Name 
This field comes from the file name assigned to the image when Smooth Solutions did the 
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scanning. It is normally the sheet number, padded to at least 3 places. For example, sheet 2 of 
the plan set becomes 002. When there are sheets added in between, or the scanners found two 
or more of the same sheet number, Sheet Names like “002A” are created. 

Scan Project ID 
This field is the “serial number” for the Plot Set, and is the same number as the Scan Plotset 
ID. (Due to the structure of the database, this sheet field has a different name than the 
corresponding field in the plot set. There is a “hidden” field which serves as the index on 
which the relationship between plot sets and sheets is technically established.) 

Scan Image ID 
This field is a “serial number” for the image. Each image has a unique Scan Image ID, which 
can be used for system management purposes. This is required because the image file names 
are not unique. 

Other Fields 
Number of Sheets 
This is the number of sheets in a Plot Set in Digital InterPlot. It is very likely not the same as 
the number of sheets in the original plan set. For most projects, the cross section sheets were 
pulled out and microfilmed years ago. Other sheets may be missing, for whatever reason. 

Sheet __ of __ 
This is based on the sheet numbering generated by Digital InterPlot, and likely does not 
coincide with the original numbering of the plan set. 

DPR 
For a sheet, this is a link to an image file in the DPR format that Digital InterPlot uses. For a 
plot set, this field is a link to the IPS file that defines the makeup of the plot set. 

JPEG 
For a sheet, this is a link to an image file in the JPG format, which is a popular industry 
standard. You can Right-Click and Save As to get your own local copy of the image file, to 
be used with MicroStation, or almost any software that handles images. For a plot set, this 
field is a link to the IPS file that defines the makeup of the plot set. 
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PPOORRTTAABBLLEE  PPLLAANN  SSEETT  
To be documented in the future. 
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IINNDDEEXXIINNGG  AANN  AARRCCHHIIVVEE  
To be documented in the future. 
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PPLLOOTTTTIINNGG  TTOO  AANN  AARRCCHHIIVVEE  
To be documented in the future. 
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